Cisco 827 and ssh access

Discussion in 'Cisco' started by Rightrik, Dec 8, 2003.

  1. Rightrik

    Rightrik Guest

    Hello, i've installed a Cisco IOS with crypto support, but i am having
    problems to connect to the router using ssh...
    I write the hostname and the enable password, but the connection isn't
    accepted.
    How do i have to correctly setup this feature on my 827 ?
    My IOS ver is:
    IOS (tm) C820 Software (C820-K9OSY6-M), Version 12.3(1), RELEASE SOFTWARE
    (fc3)


    Thanks,
    Riccardo
    Rightrik, Dec 8, 2003
    #1
    1. Advertising

  2. "Rightrik" <> wrote in message
    news:br1im5$26ru8n$-berlin.de...
    > Hello, i've installed a Cisco IOS with crypto support, but i am having
    > problems to connect to the router using ssh...
    > I write the hostname and the enable password, but the connection isn't
    > accepted.
    > How do i have to correctly setup this feature on my 827 ?
    > My IOS ver is:
    > IOS (tm) C820 Software (C820-K9OSY6-M), Version 12.3(1), RELEASE SOFTWARE


    You realize the support is currently SSHv1, right? Make sure your client
    allows that.

    Also, by default, connections are not allowed. WHat happens it you telnet?

    Have you canged "transpoprt input" on the VTYs? Added "login local" with a
    "username/secret" combo (SSH requires login)? DO you use AAA?

    You should just need

    username foorbar secret bazquux
    li vty 0 4
    login local
    transport input ssh

    To allow SSH conly connections for user foobar.
    Phillip Remaker, Dec 8, 2003
    #2
    1. Advertising

  3. Rightrik

    Rightrik Guest

    Thanks Phillip, with your suggestions now is everything OK !!!

    I appreciate very much, thanks again.

    Riccardo (ITALY)
    Rightrik, Dec 8, 2003
    #3
  4. Rightrik

    Masud Reza Guest

    "Rightrik" <> wrote in message news:<br1im5$26ru8n$-berlin.de>...
    > Hello, i've installed a Cisco IOS with crypto support, but i am having
    > problems to connect to the router using ssh...
    > I write the hostname and the enable password, but the connection isn't
    > accepted.
    > How do i have to correctly setup this feature on my 827 ?
    > My IOS ver is:
    > IOS (tm) C820 Software (C820-K9OSY6-M), Version 12.3(1), RELEASE SOFTWARE
    > (fc3)



    You need to define a username and password locally on the router in
    order to login. Add a username like this:

    username rightrick password cisco

    You should not use the hostname and enable password combo. That won't
    help.

    I'm using 12.3(4)T on my 827 which supports ssh v2 !.

    Give the 'ip ssh version 2' command in global mode to force the router
    to use ssh v2.

    stargate#show ssh
    Connection Version Mode Encryption Hmac State
    Username
    0 1.99 IN 3des-cbc hmac-sha1 Session started
    masud
    0 1.99 OUT 3des-cbc hmac-sha1 Session started
    masud
    %No SSHv1 server connections running.
    stargate#

    Hope this helps.

    Masud
    Masud Reza, Dec 8, 2003
    #4
  5. Rightrik

    Rightrik Guest

    Thanks Masud :)

    Riccardo
    Rightrik, Dec 8, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Beppe
    Replies:
    0
    Views:
    4,096
    Beppe
    Jul 8, 2003
  2. Gadh
    Replies:
    1
    Views:
    622
    TheRealSlimShady
    Aug 27, 2003
  3. c3dy8911r

    FTP and SSH access question

    c3dy8911r, Nov 30, 2004, in forum: Computer Security
    Replies:
    13
    Views:
    879
    Michael J. Pelletier
    Dec 5, 2004
  4. Simon Gronow

    Cisco 877 & Cisco 827 as backup

    Simon Gronow, Dec 17, 2006, in forum: Cisco
    Replies:
    2
    Views:
    535
    Simon Gronow
    Dec 18, 2006
  5. ppurcell
    Replies:
    0
    Views:
    513
    ppurcell
    Jun 17, 2008
Loading...

Share This Page