Cisco 803: ISDN Dialin (ppp) with W2K-Workstation - login problems

Discussion in 'Cisco' started by Kai Bleek, Jul 13, 2004.

  1. Kai Bleek

    Kai Bleek Guest

    hi out there,

    I'm new to Cisco Configuration and don't know how to solve this
    problem. I want to use the 803 as a dialin gateway to our company, but
    somehow the ppp-Authentication doesn't work. It would be great if
    someone could give me any hints (time is running short...).

    Here's my config:

    Current configuration:
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Cisco803
    !
    aaa new-model
    aaa authentication ppp default local
    enable password test
    !
    username test password 0 test
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    no ip domain-lookup
    isdn switch-type basic-net3
    !
    !
    !
    interface Ethernet0
    description connected to EthernetLAN
    ip address 192.168.0.155 255.255.255.0
    !
    interface BRI0
    description connected to Dial-inPCs(ISDN)
    ip address 192.168.51.91 255.255.255.248
    encapsulation ppp
    no ip split-horizon
    isdn switch-type basic-net3
    isdn answer1 40579967
    isdn send-alerting
    peer default ip address pool Cisco803-Group-1
    no ppp lcp fast-start
    ppp authentication chap
    ppp multilink
    !
    router rip
    version 2
    network 192.168.0.0
    network 192.168.51.0
    no auto-summary
    !
    ip local pool Cisco803-Group-1 192.168.51.92 192.168.51.93
    no ip http server
    ip classless
    ip route 192.168.0.0 255.255.255.0 Ethernet0 permanent
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    exec-timeout 0 0
    password 7 051F031C35
    transport input none
    stopbits 1
    line vty 0 4
    password 7 105A0C0A11
    !
    rcapi server port 2578
    !
    !
    end



    Here's the debugging info (deb ppp auth, deb ppp neg, deb isdn eve):

    20:15:124554092544: ISDN BR0: Incoming call id = 0x002D, dsl 0
    20:15:124554051584: ISDN BR0: LIF_EVENT: ces/callid 1/0x2D
    HOST_INCOMING_CALL
    20:15:124554051584: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data =
    FALSE
    20:15:124561816176: ISDN BR0: RM returned call_type 0 resource type 0
    20:15:29: BRI 0 B1: Set bandwidth to 64Kb

    20:15:29: ISDN BR0: isdn_send_connect(): msg 4, call id 0x2D, ces 1
    bchan 0, call type DATA
    20:15:29: BRI: enable channel B1
    20:15:29: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
    20:15:29: BR0:1 PPP: Treating connection as a callin
    20:15:29: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0
    load]
    20:15:29: BR0:1 LCP: State is Listen
    20:15:29: BR0:1 LCP: I CONFREQ [Listen] id 0 len 13
    20:15:29: BR0:1 LCP: MagicNumber 0x7E4C46F0 (0x05067E4C46F0)
    20:15:29: BR0:1 LCP: Callback 6 (0x0D0306)
    20:15:29: BR0:1 LCP: O CONFREQ [Listen] id 16 len 30
    20:15:29: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    20:15:29: BR0:1 LCP: MagicNumber 0xB51B5EFF (0x0506B51B5EFF)
    20:15:29: BR0:1 LCP: MRRU 1524 (0x110405F4)
    20:15:29: BR0:1 LCP: EndpointDisc 1 Local
    (0x130B01436973636F383033)
    20:15:29: BR0:1 LCP: O CONFREJ [Listen] id 0 len 7
    20:15:29: BR0:1 LCP: Callback 6 (0x0D0306)
    20:15:29: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 94 changed
    to up
    20:15:128849018880: ISDN BR0: LIF_EVENT: ces/callid 1/0x2D
    HOST_DISCONNECT_ACK
    20:15:128856783204: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA
    20:15:128849018880: BRI: disable channel B1
    20:15:128856783230: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
    down
    20:15:128849018912: BR0:1 LCP: State is Closed
    20:15:128856783084: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]
    20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    cid 0x0 cr 0x81 ev 0x7D ces 1 dsl 0
    20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    cid 0x0 cr 0x81 ev 0x7D ces 1 dsl 0
    20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    cid 0x0 cr 0x81 ev 0x5A ces 1 dsl 0
    20:15:30: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 94
    changed to down
    20:15:128849059840: L3: NLCB watch! cid 0x56A068 cr 0x794BEC ev 0x211
    ces 222 dsl 0


    Many thanks in advance!
    Kai
     
    Kai Bleek, Jul 13, 2004
    #1
    1. Advertising

  2. Kai Bleek

    PES Guest

    You may want to try changing "ppp authentication chap" to "ppp
    authentication chap dialin" to keep the router from trying to authenticate
    in the other direction.

    "Kai Bleek" <> wrote in message
    news:...
    > hi out there,
    >
    > I'm new to Cisco Configuration and don't know how to solve this
    > problem. I want to use the 803 as a dialin gateway to our company, but
    > somehow the ppp-Authentication doesn't work. It would be great if
    > someone could give me any hints (time is running short...).
    >
    > Here's my config:
    >
    > Current configuration:
    > !
    > version 12.1
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Cisco803
    > !
    > aaa new-model
    > aaa authentication ppp default local
    > enable password test
    > !
    > username test password 0 test
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > !
    > no ip domain-lookup
    > isdn switch-type basic-net3
    > !
    > !
    > !
    > interface Ethernet0
    > description connected to EthernetLAN
    > ip address 192.168.0.155 255.255.255.0
    > !
    > interface BRI0
    > description connected to Dial-inPCs(ISDN)
    > ip address 192.168.51.91 255.255.255.248
    > encapsulation ppp
    > no ip split-horizon
    > isdn switch-type basic-net3
    > isdn answer1 40579967
    > isdn send-alerting
    > peer default ip address pool Cisco803-Group-1
    > no ppp lcp fast-start
    > ppp authentication chap
    > ppp multilink
    > !
    > router rip
    > version 2
    > network 192.168.0.0
    > network 192.168.51.0
    > no auto-summary
    > !
    > ip local pool Cisco803-Group-1 192.168.51.92 192.168.51.93
    > no ip http server
    > ip classless
    > ip route 192.168.0.0 255.255.255.0 Ethernet0 permanent
    > !
    > dialer-list 1 protocol ip permit
    > !
    > line con 0
    > exec-timeout 0 0
    > password 7 051F031C35
    > transport input none
    > stopbits 1
    > line vty 0 4
    > password 7 105A0C0A11
    > !
    > rcapi server port 2578
    > !
    > !
    > end
    >
    >
    >
    > Here's the debugging info (deb ppp auth, deb ppp neg, deb isdn eve):
    >
    > 20:15:124554092544: ISDN BR0: Incoming call id = 0x002D, dsl 0
    > 20:15:124554051584: ISDN BR0: LIF_EVENT: ces/callid 1/0x2D
    > HOST_INCOMING_CALL
    > 20:15:124554051584: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data =
    > FALSE
    > 20:15:124561816176: ISDN BR0: RM returned call_type 0 resource type 0
    > 20:15:29: BRI 0 B1: Set bandwidth to 64Kb
    >
    > 20:15:29: ISDN BR0: isdn_send_connect(): msg 4, call id 0x2D, ces 1
    > bchan 0, call type DATA
    > 20:15:29: BRI: enable channel B1
    > 20:15:29: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
    > 20:15:29: BR0:1 PPP: Treating connection as a callin
    > 20:15:29: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0
    > load]
    > 20:15:29: BR0:1 LCP: State is Listen
    > 20:15:29: BR0:1 LCP: I CONFREQ [Listen] id 0 len 13
    > 20:15:29: BR0:1 LCP: MagicNumber 0x7E4C46F0 (0x05067E4C46F0)
    > 20:15:29: BR0:1 LCP: Callback 6 (0x0D0306)
    > 20:15:29: BR0:1 LCP: O CONFREQ [Listen] id 16 len 30
    > 20:15:29: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    > 20:15:29: BR0:1 LCP: MagicNumber 0xB51B5EFF (0x0506B51B5EFF)
    > 20:15:29: BR0:1 LCP: MRRU 1524 (0x110405F4)
    > 20:15:29: BR0:1 LCP: EndpointDisc 1 Local
    > (0x130B01436973636F383033)
    > 20:15:29: BR0:1 LCP: O CONFREJ [Listen] id 0 len 7
    > 20:15:29: BR0:1 LCP: Callback 6 (0x0D0306)
    > 20:15:29: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 94 changed
    > to up
    > 20:15:128849018880: ISDN BR0: LIF_EVENT: ces/callid 1/0x2D
    > HOST_DISCONNECT_ACK
    > 20:15:128856783204: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA
    > 20:15:128849018880: BRI: disable channel B1
    > 20:15:128856783230: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
    > down
    > 20:15:128849018912: BR0:1 LCP: State is Closed
    > 20:15:128856783084: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]
    > 20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    > cid 0x0 cr 0x81 ev 0x7D ces 1 dsl 0
    > 20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    > cid 0x0 cr 0x81 ev 0x7D ces 1 dsl 0
    > 20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    > cid 0x0 cr 0x81 ev 0x5A ces 1 dsl 0
    > 20:15:30: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 94
    > changed to down
    > 20:15:128849059840: L3: NLCB watch! cid 0x56A068 cr 0x794BEC ev 0x211
    > ces 222 dsl 0
    >
    >
    > Many thanks in advance!
    > Kai
     
    PES, Jul 14, 2004
    #2
    1. Advertising

  3. Kai Bleek

    Kai Bleek Guest

    Problem solved:
    it was a misconfiguration of some other Cisco Router on the same S0 (I
    don't have access to, so I couldn't check it): the other router seems
    to grap all incoming calls (which it shoud NOT do). So I had infos
    about incoming calls on the D-Channel, but the B-Channel was then
    taken over by the other Cisco. Well, neither LCP nor PPP possible
    without an established ISDN-line, I guess...


    (Kai Bleek) wrote in message news:<>...
    > hi out there,
    >
    > I'm new to Cisco Configuration and don't know how to solve this
    > problem. I want to use the 803 as a dialin gateway to our company, but
    > somehow the ppp-Authentication doesn't work. It would be great if
    > someone could give me any hints (time is running short...).
    >
    > Here's my config:
    >
    > Current configuration:
    > !
    > version 12.1
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Cisco803
    > !
    > aaa new-model
    > aaa authentication ppp default local
    > enable password test
    > !
    > username test password 0 test
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > !
    > no ip domain-lookup
    > isdn switch-type basic-net3
    > !
    > !
    > !
    > interface Ethernet0
    > description connected to EthernetLAN
    > ip address 192.168.0.155 255.255.255.0
    > !
    > interface BRI0
    > description connected to Dial-inPCs(ISDN)
    > ip address 192.168.51.91 255.255.255.248
    > encapsulation ppp
    > no ip split-horizon
    > isdn switch-type basic-net3
    > isdn answer1 40579967
    > isdn send-alerting
    > peer default ip address pool Cisco803-Group-1
    > no ppp lcp fast-start
    > ppp authentication chap
    > ppp multilink
    > !
    > router rip
    > version 2
    > network 192.168.0.0
    > network 192.168.51.0
    > no auto-summary
    > !
    > ip local pool Cisco803-Group-1 192.168.51.92 192.168.51.93
    > no ip http server
    > ip classless
    > ip route 192.168.0.0 255.255.255.0 Ethernet0 permanent
    > !
    > dialer-list 1 protocol ip permit
    > !
    > line con 0
    > exec-timeout 0 0
    > password 7 051F031C35
    > transport input none
    > stopbits 1
    > line vty 0 4
    > password 7 105A0C0A11
    > !
    > rcapi server port 2578
    > !
    > !
    > end
    >
    >
    >
    > Here's the debugging info (deb ppp auth, deb ppp neg, deb isdn eve):
    >
    > 20:15:124554092544: ISDN BR0: Incoming call id = 0x002D, dsl 0
    > 20:15:124554051584: ISDN BR0: LIF_EVENT: ces/callid 1/0x2D
    > HOST_INCOMING_CALL
    > 20:15:124554051584: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data =
    > FALSE
    > 20:15:124561816176: ISDN BR0: RM returned call_type 0 resource type 0
    > 20:15:29: BRI 0 B1: Set bandwidth to 64Kb
    >
    > 20:15:29: ISDN BR0: isdn_send_connect(): msg 4, call id 0x2D, ces 1
    > bchan 0, call type DATA
    > 20:15:29: BRI: enable channel B1
    > 20:15:29: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
    > 20:15:29: BR0:1 PPP: Treating connection as a callin
    > 20:15:29: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0
    > load]
    > 20:15:29: BR0:1 LCP: State is Listen
    > 20:15:29: BR0:1 LCP: I CONFREQ [Listen] id 0 len 13
    > 20:15:29: BR0:1 LCP: MagicNumber 0x7E4C46F0 (0x05067E4C46F0)
    > 20:15:29: BR0:1 LCP: Callback 6 (0x0D0306)
    > 20:15:29: BR0:1 LCP: O CONFREQ [Listen] id 16 len 30
    > 20:15:29: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
    > 20:15:29: BR0:1 LCP: MagicNumber 0xB51B5EFF (0x0506B51B5EFF)
    > 20:15:29: BR0:1 LCP: MRRU 1524 (0x110405F4)
    > 20:15:29: BR0:1 LCP: EndpointDisc 1 Local
    > (0x130B01436973636F383033)
    > 20:15:29: BR0:1 LCP: O CONFREJ [Listen] id 0 len 7
    > 20:15:29: BR0:1 LCP: Callback 6 (0x0D0306)
    > 20:15:29: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 94 changed
    > to up
    > 20:15:128849018880: ISDN BR0: LIF_EVENT: ces/callid 1/0x2D
    > HOST_DISCONNECT_ACK
    > 20:15:128856783204: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA
    > 20:15:128849018880: BRI: disable channel B1
    > 20:15:128856783230: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
    > down
    > 20:15:128849018912: BR0:1 LCP: State is Closed
    > 20:15:128856783084: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]
    > 20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    > cid 0x0 cr 0x81 ev 0x7D ces 1 dsl 0
    > 20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    > cid 0x0 cr 0x81 ev 0x7D ces 1 dsl 0
    > 20:15:128849059840: L3: L3_GetUser_NLCB returned NULL, message ignored
    > cid 0x0 cr 0x81 ev 0x5A ces 1 dsl 0
    > 20:15:30: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 94
    > changed to down
    > 20:15:128849059840: L3: NLCB watch! cid 0x56A068 cr 0x794BEC ev 0x211
    > ces 222 dsl 0
    >
    >
    > Many thanks in advance!
    > Kai
     
    Kai Bleek, Jul 14, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andree Toonk

    Cisco 803 pots and ISDN

    Andree Toonk, Oct 27, 2003, in forum: Cisco
    Replies:
    4
    Views:
    909
    Erik Tamminga
    Oct 28, 2003
  2. Graham Turner

    logging of isdn call history - cisco 803

    Graham Turner, Jan 7, 2004, in forum: Cisco
    Replies:
    1
    Views:
    3,912
    AnyBody43
    Jan 9, 2004
  3. Replies:
    1
    Views:
    5,851
    Jonathan
    May 14, 2006
  4. kazz
    Replies:
    0
    Views:
    760
  5. BE749309
    Replies:
    0
    Views:
    1,221
    BE749309
    Jun 9, 2010
Loading...

Share This Page