cisco 800 series config

Discussion in 'Cisco' started by Jeroen, Aug 1, 2005.

  1. Jeroen

    Jeroen Guest

    Hi,

    I have a cisco 800 series ADSL modem / switch, which is configured with the
    settings described below. This works fine, but i have some questions about
    it and i want to change some settings:

    * how do i enable dhcp for interface Ethernet0 so that computers in my LAN
    get an IP address between 192.168.1.3 - 192.168.1.100 ? I want one computer
    to have a fixed ip address: 192.168.1.2 does that require special
    configuration?
    * where do i specify the ip address of the router (at the LAN side) ?
    * in my current config i have the following lines that map some ports

    ip nat inside source static udp 192.168.1.2 6889 interface Dialer0 6889
    untill ...
    ip nat inside source static udp 192.168.1.2 6881 interface Dialer0 6881

    is there another way to specify this, i mean can i map a range of ports with
    one single line?

    regards and thanks in advance,
    Jeroen


    !
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname *********
    !
    enable secret 5 $**************.
    !
    username ********** password **********
    ip subnet-zero
    no ip domain-lookup
    ip domain-name xs4all.nl
    ip name-server 194.109.6.66
    ip name-server 194.109.9.99
    ip dhcp excluded-address 192.168.1.1 192.168.1.2
    !
    ip dhcp pool XS4all
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 194.109.6.66 194.109.9.99
    !
    !
    !
    !
    interface Ethernet0
    description To interne LAN
    ip address 192.168.1.1 255.255.255.0
    ip access-group 101 in
    ip nat inside
    no ip route-cache
    no keepalive
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    description To xs4all network
    no ip address
    no ip route-cache
    no atm ilmi-keepalive
    pvc 0 8/48
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface Dialer0
    description linked to ATM0
    ip address negotiated
    no ip redirects
    description linked to ATM0
    ip address negotiated
    no ip redirects
    no ip unreachables
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username ********** password 7 ***********
    !
    ip nat inside source list 101 interface Dialer0 overload
    ip nat inside source static udp 192.168.1.2 6889 interface Dialer0 6889
    ip nat inside source static udp 192.168.1.2 6888 interface Dialer0 6888
    ip nat inside source static udp 192.168.1.2 6887 interface Dialer0 6887
    ip nat inside source static udp 192.168.1.2 6886 interface Dialer0 6886
    ip nat inside source static udp 192.168.1.2 6885 interface Dialer0 6885
    ip nat inside source static udp 192.168.1.2 6884 interface Dialer0 6884
    ip nat inside source static udp 192.168.1.2 6883 interface Dialer0 6883
    ip nat inside source static udp 192.168.1.2 6882 interface Dialer0 6882
    ip nat inside source static udp 192.168.1.2 6881 interface Dialer0 6881
    ip nat inside source static tcp 192.168.1.2 6881 interface Dialer0 6881
    ip nat inside source static tcp 192.168.1.2 6882 interface Dialer0 6882
    ip nat inside source static tcp 192.168.1.2 6883 interface Dialer0 6883
    ip nat inside source static tcp 192.168.1.2 6884 interface Dialer0 6884
    ip nat inside source static tcp 192.168.1.2 6885 interface Dialer0 6885
    ip nat inside source static tcp 192.168.1.2 6886 interface Dialer0 6886
    ip nat inside source static tcp 192.168.1.2 6887 interface Dialer0 6887
    ip nat inside source static tcp 192.168.1.2 6888 interface Dialer0 6888
    ip nat inside source static tcp 192.168.1.2 6889 interface Dialer0 6889
    ip nat inside source static tcp 192.168.1.2 8080 interface Dialer0 8080
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0 permanent
    no ip http server
    !
    !
    access-list 1 remark The local LAN.
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 101 permit ip 10.0.0.0 0.255.255.255 any
    access-list 101 permit ip 172.16.0.0 0.15.255.255 any
    access-list 101 permit ip 192.168.0.0 0.0.255.255 any
    access-list 101 deny ip any any
    dialer-list 1 protocol ip permit
    no cdp run
    banner motd ^C
    some fancy banner^C
    !
    line con 0
    exec-timeout 120 0
    stopbits 1
    line vty 0 4
    access-class 1 in
    exec-timeout 120 0
    login local
    !
    scheduler max-task-time 5000
    end
     
    Jeroen, Aug 1, 2005
    #1
    1. Advertising

  2. "Jeroen" <postmaster@localhost> wrote:

    > Hi,
    >
    > I have a cisco 800 series ADSL modem / switch, which is configured with the
    > settings described below. This works fine, but i have some questions about
    > it and i want to change some settings:
    >
    > * how do i enable dhcp for interface Ethernet0 so that computers in my LAN
    > get an IP address between 192.168.1.3 - 192.168.1.100 ? I want one computer
    > to have a fixed ip address: 192.168.1.2 does that require special
    > configuration?



    Hi Jeroen,

    I configured two laptops with a fixed IP address using DHCP this way:

    !
    ip dhcp pool CLIENT
    network 192.168.99.0 255.255.255.0
    default-router 192.168.99.1
    dns-server 192.168.99.202 194.159.73.136 195.64.32.3
    domain-name domain.com
    !
    ip dhcp pool IBOOK-EEN
    host 192.168.99.208 255.255.255.0
    client-identifier 0100.0d93.81b2.d3
    client-name ibook1
    !
    ip dhcp pool IBOOK-TWEE
    host 192.168.99.207 255.255.255.0
    client-identifier 0100.1124.25c3.6e
    client-name ibook2


    So you can use the hardware ethernet address to assign static IPs to
    DHCP clients. (notation: "01xx.xxxx.xxxx.xxxx.xx" where xxxxx is the
    hardware address, prefixed with "01").



    > * where do i specify the ip address of the router (at the LAN side) ?


    You did with the lines:

    interface Ethernet0
    description To interne LAN
    ip address 192.168.1.1 255.255.255.0



    > * in my current config i have the following lines that map some ports
    >
    > ip nat inside source static udp 192.168.1.2 6889 interface Dialer0 6889
    > untill ...
    > ip nat inside source static udp 192.168.1.2 6881 interface Dialer0 6881
    >
    > is there another way to specify this, i mean can i map a range of ports with
    > one single line?
    >


    As far as I know, no... I could be wrong of course...



    > regards and thanks in advance,
    > Jeroen
    >
    >


    Succes,

    Arnoud


    --
    Please use my first and last name in the address & remove '.invalid'
    Mijn voor- en achternaam gebruiken in het adres zonder '.invalid'
     
    Arnoud Helmantel, Aug 1, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Thomas Perl
    Replies:
    4
    Views:
    8,529
    jonathan fernandes
    Jul 16, 2003
  2. Jon Jonsson

    Cisco 800 series port forwarding

    Jon Jonsson, Nov 12, 2003, in forum: Cisco
    Replies:
    4
    Views:
    14,336
    JShepherd
    Nov 14, 2003
  3. Jon Jonsson
    Replies:
    0
    Views:
    1,484
    Jon Jonsson
    Dec 29, 2003
  4. zxcvar
    Replies:
    3
    Views:
    3,840
    Dave Martindale
    Sep 9, 2003
  5. [BnH]
    Replies:
    3
    Views:
    654
    Walter Hofmann
    Sep 24, 2005
Loading...

Share This Page