Cisco 3845 - DSL on interface, how to do PPPOE??

Discussion in 'Cisco' started by ponga, Sep 4, 2009.

  1. ponga

    ponga Guest

    Greetings! I am sticking a DSL modem (ethernet on LAN side) into one
    for the interfaces on this Cisco router. The modem is "bridged" and so
    I want to Cisco to take care of the NAT'ing and have that public
    address on the interface directly...

    This means having to do PPPOE with the Cisco so it can auth-up with
    Qwest, etc... how is that accomplished with this router (commands)? I
    am seeing pppoe sub-commands specific to the interface, but where do I
    enter username / password credentials to be used by the pppoe?

    Any help / examples are GREATLY appreciated?

    -Ponga
     
    ponga, Sep 4, 2009
    #1
    1. Advertising

  2. ponga <> writes:
    >Greetings! I am sticking a DSL modem (ethernet on LAN side) into one
    >for the interfaces on this Cisco router. The modem is "bridged" and so
    >I want to Cisco to take care of the NAT'ing and have that public
    >address on the interface directly...


    >This means having to do PPPOE with the Cisco so it can auth-up with
    >Qwest, etc... how is that accomplished with this router (commands)? I
    >am seeing pppoe sub-commands specific to the interface, but where do I
    >enter username / password credentials to be used by the pppoe?


    I was just going to give you the rude google for it as there's
    zillions of examples, but I don't like the VPDN group setup anyway
    that all comes up.

    !
    bba-group pppoe group1
    !
    interface GigabitEthernet0/0
    description PPPoE interface
    no ip address
    pppoe enable group group1
    pppoe-client dial-pool-number 1
    !
    interface Dialer0
    description PPPoE Dialer
    ip mtu 1492
    ip address negotiated
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp pap sent-username jimbob password woohoo
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
     
    Doug McIntyre, Sep 4, 2009
    #2
    1. Advertising

  3. ponga

    JF Mezei Guest

    Doug McIntyre wrote:

    > interface Dialer0
    > description PPPoE Dialer
    > ip mtu 1492
    > ip address negotiated
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > ppp authentication chap pap callin
    > ppp pap sent-username jimbob password woohoo
    > !



    On a 870 router, I had problems with "dialer-group" and the stuff worked
    when I took that line out.

    dialer pool 1 is what ties the "dialer" interface with fast ethernet
    interfaces in the same group.

    I am no expert on this, just relating my recent experience.
     
    JF Mezei, Sep 4, 2009
    #3
  4. ponga

    ponga Guest

    On Sep 4, 1:01 pm, Doug McIntyre <> wrote:
    > ponga <> writes:
    > >Greetings! I am sticking a DSL modem (ethernet on LAN side) into one
    > >for the interfaces on this Cisco router. The modem is "bridged" and so
    > >I want to Cisco to take care of the NAT'ing and have that public
    > >address on the interface directly...
    > >This means having to do PPPOE with the Cisco so it can auth-up with
    > >Qwest, etc... how is that accomplished with this router (commands)? I
    > >am seeing pppoe sub-commands specific to the interface, but where do I
    > >enter username / password credentials to be used by the pppoe?

    >
    > I was just going to give you the rude google for it as there's
    > zillions of examples, but I don't like the VPDN group setup anyway
    > that all comes up.
    >
    > !
    > bba-group pppoe group1
    > !
    > interface GigabitEthernet0/0
    >  description PPPoE interface
    >  no ip address
    >  pppoe enable group group1
    >  pppoe-client dial-pool-number 1
    > !
    > interface Dialer0
    >  description PPPoE Dialer
    >  ip mtu 1492
    >  ip address negotiated
    >  encapsulation ppp
    >  dialer pool 1
    >  dialer-group 1
    >  ppp authentication chap pap callin
    >  ppp pap sent-username jimbob password woohoo
    > !
    > ip route 0.0.0.0 0.0.0.0 Dialer0
    > !


    Thanks, that's just the trick!
     
    ponga, Sep 11, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Nordien
    Replies:
    0
    Views:
    3,360
    John Nordien
    Nov 22, 2004
  2. Scott Townsend
    Replies:
    0
    Views:
    526
    Scott Townsend
    Mar 26, 2005
  3. Kralizec Craig
    Replies:
    2
    Views:
    968
    Kralizec Craig
    Jun 18, 2007
  4. dodger346
    Replies:
    0
    Views:
    531
    dodger346
    Dec 31, 2007
  5. lga775
    Replies:
    1
    Views:
    2,143
    araishee
    Feb 18, 2010
Loading...

Share This Page