Cisco 3640 NM-4E Westell ADSL Modem & Ambit Cable Modem/Router Half 1/2 Speed

Discussion in 'Cisco' started by Chris, Jun 4, 2006.

  1. Chris

    Chris Guest

    I have a Cisco 3640 connected to a Westell ADSL Modem and an Ambit
    Cable Modem/Router. I recently upgrade to 7.0Mb x 768Kb on each. I
    used to have 3.0Mb x 768K on ADSL and 2.0Mb x 384K on Cable. Both have
    static IP addresses.

    When I connect either modem directly to a PC the speed is fine. This
    worked before I upgraded and after.

    Previously, when I connect the modems to my router through my NM-4E
    (E2/0 and E2/3) card the speed was fine, I gave up about 15%
    throughput based upon my configuration. I can live with that.

    Currently, after the upgrade to 7.0Mb down, my speed is effectively
    cut in half. Approximately 2.7 to 2.8 down, up is fine at 720Kb.

    I understand that my configuration is restrictive, so I configured my
    NM-1FE-TX (F0/0) to be bare bones, least restrictive. When I did this
    my speed improved to almost exactly half.

    I have been to Cisco website for hours, Google, here, all to no avail.

    Any help would be greatly appreciated.

    Below the configuration are my SH Interface and SH IP Interface
    outputs.

    Following is my configuration:

    Building configuration...

    Current configuration: 6437 bytes
    !
    ! Last configuration change at 09:32:49 PDST Sun Jun 4 2006 by
    (redacted)
    ! NVRAM config last updated at 17:30:59 PDST Sat May 27 2006 by
    (redacted)
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service compress-config
    no service dhcp
    !
    hostname CISCO3640
    !
    boot-start-marker
    boot-end-marker
    !
    logging count
    logging buffered 4096 debugging
    enable secret (redacted)
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    !
    aaa session-id common
    !
    resource policy
    !
    clock timezone Pacific -8
    clock summer-time PDST recurring
    ip subnet-zero
    no ip source-route
    !
    ip cef
    ip domain name (redacted)
    ip name-server (redacted)
    ip name-server (redacted)
    ip name-server (redacted)
    ip name-server (redacted)
    no ip dhcp use vrf connected
    !
    no ip bootp server
    no ip ips deny-action ips-interface
    ip ips signature 4050 0 disable
    ip ips name ids-perimeter
    ip scp server enable
    !
    username (redacted) privilege 15 secret (redacted)
    !
    class-map match-any http-hacks
    match protocol http url "*default.ida*"
    match protocol http url "*cmd.exe*"
    match protocol http url "*root.exe*"
    match protocol http url "*readme.eml*"
    !
    policy-map drop-inbound-http-hacks
    class http-hacks
    police cir 1000000 bc 31250 be 31250
    conform-action drop
    exceed-action drop
    violate-action drop
    !
    interface Null0
    no ip unreachables
    !
    interface FastEthernet0/0
    ip address (redacted) test of outside 1&2, not normally used
    ip access-group 1 in
    ip access-group 1 out
    ip nat outside
    ip virtual-reassembly
    shutdown
    duplex auto
    speed auto
    !
    interface Ethernet2/0
    description (redacted) Ambit Cable Modem/Router
    ip address (redacted) outside1
    ip access-group ms-rpc in
    ip access-group ms-rpc out
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip accounting access-violations
    ip nat outside
    ip ips ids-perimeter in
    ip virtual-reassembly
    no ip route-cache cef
    no ip route-cache
    no ip mroute-cache
    half-duplex
    no keepalive
    no cdp enable
    service-policy input drop-inbound-http-hacks
    !
    interface Ethernet2/1
    ip address dhcp (not used)
    shutdown
    full-duplex
    service-policy input drop-inbound-http-hacks
    !
    interface Ethernet2/2
    ip address dhcp (not used)
    shutdown
    full-duplex
    service-policy input drop-inbound-http-hacks
    !
    interface Ethernet2/3
    description (redacted) Westell ADSL Modem
    ip address (redacted) outside2
    ip access-group ms-rpc in
    ip access-group ms-rpc out
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip accounting access-violations
    ip nat outside
    ip ips ids-perimeter in
    ip virtual-reassembly
    no ip route-cache cef
    no ip route-cache
    no ip mroute-cache
    half-duplex
    no keepalive
    no cdp enable
    service-policy input drop-inbound-http-hacks
    !
    interface FastEthernet3/0
    !
    interface FastEthernet3/1
    !
    interface FastEthernet3/2
    !
    interface FastEthernet3/3
    !
    interface FastEthernet3/4
    !
    interface FastEthernet3/5
    !
    interface FastEthernet3/6
    !
    interface FastEthernet3/7
    !
    interface FastEthernet3/8
    !
    interface FastEthernet3/9
    !
    interface FastEthernet3/10
    !
    interface FastEthernet3/11
    !
    interface FastEthernet3/12
    !
    interface FastEthernet3/13
    !
    interface FastEthernet3/14
    !
    interface FastEthernet3/15
    !
    interface Vlan1
    ip address (redacted) inside1
    ip access-group ms-rpc in
    ip access-group ms-rpc out
    no ip proxy-arp
    ip accounting access-violations
    ip nat inside
    ip virtual-reassembly
    !
    no ip http server
    no ip http secure-server
    ip classless
    ip route 0.0.0.0 0.0.0.0 (redacted) name (redacted) outside1
    ip route 0.0.0.0 0.0.0.0 (redacted) name (redacted) outside2
    !
    no ip nat create flow-entries
    ip nat pool (redacted) outside1 (redacted) (redacted) netmask
    (redacted)
    ip nat pool (redacted) outside2 (redacted) (redacted) netmask
    (redacted)
    ip nat inside source route-map (redacted) outside1 pool (redacted)
    outside1 overload
    ip nat inside source route-map (redacted) outside2 pool (redacted)
    outside2 overload
    !
    !
    ip access-list extended ms-rpc
    deny tcp any any eq 135
    deny udp any any eq 135
    deny tcp any any eq 137
    deny udp any any eq netbios-ns
    deny tcp any any eq 138
    deny udp any any eq netbios-dgm
    deny tcp any any eq 139
    deny udp any any eq netbios-ss
    deny tcp any any eq 445
    deny udp any any eq 445
    deny tcp any any eq 593
    deny udp any any eq 593
    deny tcp any any eq 4444
    deny udp any any eq 4444
    deny tcp any any eq 4899
    deny udp any any eq 4899
    permit ip any any
    ip access-list extended ssh
    permit ip host (redacted) any log-input
    permit ip host (redacted) any log-input
    permit ip host (redacted) any log-input
    permit ip host (redacted) any log-input
    deny ip any any log-input
    logging trap debugging
    logging source-interface Vlan1
    logging (redacted)
    access-list 1 permit any
    no cdp run
    !
    route-map (redacted) outside1 permit 10
    match interface Ethernet2/0
    !
    route-map (redacted) outside2 permit 10
    match interface Ethernet2/3
    !
    control-plane
    !
    dial-peer cor custom
    !
    gateway
    timer receive-rtp 1200
    !
    line con 0
    line aux 0
    no exec
    line vty 0 4
    access-class ssh in
    transport input ssh
    transport output ssh
    !
    ntp authenticate
    ntp clock-period 17180450
    ntp max-associations 2
    ntp server 164.67.62.194
    ntp server 131.215.254.2
    !
    end


    CISCO3640#sh ip int e2/0
    Ethernet2/0 is up, line protocol is up
    Internet address is (redacted) outside1
    Broadcast address is 255.255.255.255
    Address determined by non-volatile memory
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is ms-rpc
    Inbound access list is ms-rpc
    Proxy ARP is disabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are never sent
    ICMP unreachables are never sent
    ICMP mask replies are never sent
    IP fast switching is disabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is disabled
    IP Feature Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are No CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is enabled, system threshold is 512
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain outside
    BGP Policy Mapping is disabled
    Inbound IPS rule is ids-perimeter
    CISCO3640#sh int e2/0
    Ethernet2/0 is up, line protocol is up
    Hardware is AmdP2, address is 0008.a397.ace0 (bia 0008.a397.ace0)
    Description: (redacted) outside1
    Internet address is (redacted) outside1
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:01, output 00:00:01, output hang never
    Last clearing of "show interface" counters 02:46:52
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    32456 packets input, 37838100 bytes, 0 no buffer
    Received 370 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    27244 packets output, 2121511 bytes, 0 underruns
    0 output errors, 989 collisions, 1 interface resets
    0 babbles, 0 late collision, 857 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    CISCO3640#sh ip int e2/3
    Ethernet2/3 is up, line protocol is up
    Internet address is (redacted) outside2
    Broadcast address is 255.255.255.255
    Address determined by non-volatile memory
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is ms-rpc
    Inbound access list is ms-rpc
    Proxy ARP is disabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are never sent
    ICMP unreachables are never sent
    ICMP mask replies are never sent
    IP fast switching is disabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is disabled
    IP Feature Fast switching turbo vector
    IP multicast fast switching is disabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are No CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is enabled, system threshold is 512
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain outside
    BGP Policy Mapping is disabled
    Inbound IPS rule is ids-perimeter
    CISCO3640#sh int e2/3
    Ethernet2/3 is up, line protocol is up
    Hardware is AmdP2, address is 0008.a397.ace3 (bia 0008.a397.ace3)
    Description: (redacted) outside2
    Internet address is (redacted) outside2
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive not set
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:07, output 00:00:07, output hang never
    Last clearing of "show interface" counters 02:47:02
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    16861 packets input, 18324718 bytes, 0 no buffer
    Received 26 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    15685 packets output, 1742706 bytes, 0 underruns
    0 output errors, 21 collisions, 4 interface resets
    0 babbles, 0 late collision, 243 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    CISCO3640#sh ip int f0/0
    FastEthernet0/0 is administratively down, line protocol is down
    Internet address is (redacted) outside test stripped config
    Broadcast address is 255.255.255.255
    Address determined by setup command
    MTU is 1500 bytes
    Helper address is not set
    Directed broadcast forwarding is disabled
    Outgoing access list is 1
    Inbound access list is 1
    Proxy ARP is enabled
    Local Proxy ARP is disabled
    Security level is default
    Split horizon is enabled
    ICMP redirects are always sent
    ICMP unreachables are always sent
    ICMP mask replies are never sent
    IP fast switching is enabled
    IP fast switching on the same interface is disabled
    IP Flow switching is disabled
    IP CEF switching is enabled
    IP CEF Feature Fast switching turbo vector
    IP multicast fast switching is enabled
    IP multicast distributed fast switching is disabled
    IP route-cache flags are Fast, CEF
    Router Discovery is disabled
    IP output packet accounting is disabled
    IP access violation accounting is disabled
    TCP/IP header compression is disabled
    RTP/IP header compression is disabled
    Policy routing is disabled
    Network address translation is enabled, interface in domain outside
    BGP Policy Mapping is disabled
    CISCO3640#sh int f0/0
    FastEthernet0/0 is administratively down, line protocol is down
    Hardware is AmdFE, address is 0008.a397.acc0 (bia 0008.a397.acc0)
    Internet address is (redacted) outside test stripped config
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Auto-duplex, Auto Speed, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 2d23h, output 2d23h, output hang never
    Last clearing of "show interface" counters 02:49:45
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops:
    0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
     
    Chris, Jun 4, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. baaa
    Replies:
    2
    Views:
    6,555
    pengulin
    Mar 8, 2005
  2. Chris
    Replies:
    0
    Views:
    768
    Chris
    Jun 6, 2006
  3. LincolnShep
    Replies:
    3
    Views:
    2,822
    Jack \(MVP-Networking\).
    Nov 8, 2006
  4. Stuart
    Replies:
    0
    Views:
    712
    Stuart
    May 11, 2007
  5. Timothy Daniels

    OT: wire rack for Ambit cable modem and Linksys router

    Timothy Daniels, Apr 1, 2008, in forum: Wireless Networking
    Replies:
    1
    Views:
    2,234
    David B.
    Apr 1, 2008
Loading...

Share This Page