cisco 2811 and pppoe connection over ethernet

Discussion in 'Cisco' started by devmustglamour@gmail.com, Apr 22, 2014.

  1. Guest

    Hi @ all, sorry for my bad english...


    My ISP provides me an Internet connection with Ethernet cable with pppoe connection mode. I have pfsense who runs a battery of servers behind this line and everything works fine. The parameters login and password provided arecorrect. From pfsense I wanted to leap and run all through the cisco 2811 I came into possession of a few days. After making some test configuration on the internal network, I decided to try my hand on his pppoe configuration.

    I looked a bit on the internet and in the end I created my own configuration.
    Using 1667 out of 245752 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    !
    no aaa new-model
    !
    dot11 syslog
    ip source-route
    !
    ip cef
    !
    no ipv6 cef
    multilink bundle-name authenticated
    !
    voice-card 0
    !
    archive
    log config
    hidekeys
    !
    controller DSL 0/0/0
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 10
    !
    interface FastEthernet0/1
    ip address 172.16.0.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    !
    interface Vlan1
    no ip address
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    encapsulation ppp
    dialer pool 10
    ppp authentication pap callin
    ppp pap sent-username xxx@yyy password 0 aabbccdd
    ppp ipcp route default
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server

    I have this error:
    *Apr 21 16:31:20.771: Sending PADI: Interface = FastEthernet0/0
    *Apr 21 16:31:20.799: PPPoE 0: I PADO R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    *Apr 21 16:31:22.819: PPPOE: we've got our pado and the pado timer went off
    *Apr 21 16:31:22.819: OUT PADR from PPPoE Session
    *Apr 21 16:31:22.931: PPPoE 21677: I PADS R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    *Apr 21 16:31:22.935: IN PADS from PPPoE Session
    *Apr 21 16:31:22.939: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
    *Apr 21 16:31:22.939: PPPoE: Virtual Access interface obtained.
    *Apr 21 16:31:22.939: PPPoE : encap string prepared
    *Apr 21 16:31:22.939: [0]PPPoE 21677: data path set to Virtual Acess
    *Apr 21 16:31:22.947: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
    *Apr 21 16:31:22.947: Vi2 DDR: Dialer statechange to up
    *Apr 21 16:31:23.439: PPPoE : Shutting down client session
    *Apr 21 16:31:23.439: [0]PPPoE 21677: O PADT R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    *Apr 21 16:31:23.439: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
    *Apr 21 16:31:23.443: Vi2 DDR: disconnecting call
    *Apr 21 16:31:23.443: PPPoE 21677: I PADT R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    *Apr 21 16:31:23.443: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

    But i'm not albe to know why pppoe wan't go up&running :(

    Thanks!!!
     
    , Apr 22, 2014
    #1
    1. Advertising

  2. Nick B. Guest

    wrote:
    > Hi @ all, sorry for my bad english...


    > !
    > interface Dialer1
    > ip address negotiated
    > ip mtu 1492
    > encapsulation ppp
    > dialer pool 10
    > ppp authentication pap callin
    > ppp pap sent-username xxx@yyy password 0 aabbccdd
    > ppp ipcp route default
    > !


    I'd prefer to use CHAP rather than PAP if you can, it avoids sending
    passwords in the clear.

    > I have this error:
    > *Apr 21 16:31:20.771: Sending PADI: Interface = FastEthernet0/0
    > *Apr 21 16:31:20.799: PPPoE 0: I PADO R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    > *Apr 21 16:31:22.819: PPPOE: we've got our pado and the pado timer went off
    > *Apr 21 16:31:22.819: OUT PADR from PPPoE Session
    > *Apr 21 16:31:22.931: PPPoE 21677: I PADS R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    > *Apr 21 16:31:22.935: IN PADS from PPPoE Session
    > *Apr 21 16:31:22.939: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
    > *Apr 21 16:31:22.939: PPPoE: Virtual Access interface obtained.
    > *Apr 21 16:31:22.939: PPPoE : encap string prepared
    > *Apr 21 16:31:22.939: [0]PPPoE 21677: data path set to Virtual Acess
    > *Apr 21 16:31:22.947: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
    > *Apr 21 16:31:22.947: Vi2 DDR: Dialer statechange to up
    > *Apr 21 16:31:23.439: PPPoE : Shutting down client session
    > *Apr 21 16:31:23.439: [0]PPPoE 21677: O PADT R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    > *Apr 21 16:31:23.439: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
    > *Apr 21 16:31:23.443: Vi2 DDR: disconnecting call
    > *Apr 21 16:31:23.443: PPPoE 21677: I PADT R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa0/0
    > *Apr 21 16:31:23.443: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
    >
    > But i'm not albe to know why pppoe wan't go up&running :(
    >
    > Thanks!!!a


    What debugs do you have enabled?
    It may help if you set
    #debug ppp negotiation
    and post any relevant output.

    HTH,
    --
    Nick B.
     
    Nick B., Apr 27, 2014
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Peter
    Replies:
    2
    Views:
    1,077
  2. John Nordien
    Replies:
    0
    Views:
    3,401
    John Nordien
    Nov 22, 2004
  3. RobMarsh
    Replies:
    1
    Views:
    4,917
    RobMarsh
    Sep 18, 2006
  4. Theo Markettos

    VOIP over VPN over TCP over WAP over 3G

    Theo Markettos, Feb 3, 2008, in forum: UK VOIP
    Replies:
    2
    Views:
    986
    Theo Markettos
    Feb 14, 2008
  5. lga775
    Replies:
    1
    Views:
    2,161
    araishee
    Feb 18, 2010
Loading...

Share This Page