Cisco 2621 router config issue

Discussion in 'Cisco' started by BigMike82, Dec 23, 2007.

  1. BigMike82

    BigMike82 Guest

    I've been slamming my head against this for the last few hours, and am
    hoping I can get some help from you guys. :)

    At the moment, I have a Cisco 800 series operating as my main
    router.

    The router in question is a Cisco 2621xm with the ipbasic IOS.
    FastEthernet0/0 is assigned an IP address of 10.0.1.101.
    FastEthernet0/1 is assigned an address of 192.168.0.1.

    FE0/0 is plugged into the 800 series. That router is my home gateway,
    and has an IP of 10.0.0.1.

    From the 2621xm, I am able to ping the main gateway, as well as
    external IP addresses.
    My laptop, which is connected to FE0/1, can not. I assigned it a
    static IP address of 192.168.0.101.

    Any thoughts and hints are much appreciated.

    Thanks!

    Current configuration : 880 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname password
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 password
    enable password password
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    no ftp-server write-enable
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 10.0.1.101 255.255.254.0
    ip nat outside
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface FastEthernet0/1
    ip address 192.168.0.1 255.255.254.0
    ip nat inside
    duplex auto
    speed auto
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.0.0.1
    ip http server
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password password
    login
    !
    !
    !
    end
     
    BigMike82, Dec 23, 2007
    #1
    1. Advertising

  2. On Dec 23, 4:49 am, BigMike82 <> wrote:
    > I've been slamming my head against this for the last few hours, and am
    > hoping I can get some help from you guys. :)
    >
    > At the moment, I have a Cisco 800 series operating as my main
    > router.
    >
    > The router in question is a Cisco 2621xm with the ipbasic IOS.
    > FastEthernet0/0 is assigned an IP address of 10.0.1.101.
    > FastEthernet0/1 is assigned an address of 192.168.0.1.
    >
    > FE0/0 is plugged into the 800 series. That router is my home gateway,
    > and has an IP of 10.0.0.1.
    >
    > From the 2621xm, I am able to ping the main gateway, as well as
    > external IP addresses.
    > My laptop, which is connected to FE0/1, can not. I assigned it a
    > static IP address of 192.168.0.101.
    >
    > Any thoughts and hints are much appreciated.
    >
    > Thanks!
    >
    > Current configuration : 880 bytes
    > !
    > version 12.3
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > no service password-encryption
    > !
    > hostname password
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > enable secret 5 password
    > enable password password
    > !
    > no network-clock-participate slot 1
    > no network-clock-participate wic 0
    > no aaa new-model
    > ip subnet-zero
    > ip cef
    > !
    > !
    > !
    > no ftp-server write-enable
    > !
    > !
    > !
    > !
    > interface FastEthernet0/0
    > ip address 10.0.1.101 255.255.254.0
    > ip nat outside
    > duplex auto
    > speed auto
    > !
    > interface Serial0/0
    > no ip address
    > shutdown
    > !
    > interface FastEthernet0/1
    > ip address 192.168.0.1 255.255.254.0
    > ip nat inside
    > duplex auto
    > speed auto
    > !
    > interface Serial0/1
    > no ip address
    > shutdown
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 10.0.0.1
    > ip http server
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > password password
    > login
    > !
    > !
    > !
    > end


    Just a thought, what subnet is your Laptop running? I see you have a /
    23 as your network for Fe0/1. Can your laptop ping its own gateway?
     
    sCissOrsRsharP, Dec 23, 2007
    #2
    1. Advertising

  3. BigMike82

    Brian V Guest

    "BigMike82" <> wrote in message
    news:...
    > I've been slamming my head against this for the last few hours, and am
    > hoping I can get some help from you guys. :)
    >
    > At the moment, I have a Cisco 800 series operating as my main
    > router.
    >
    > The router in question is a Cisco 2621xm with the ipbasic IOS.
    > FastEthernet0/0 is assigned an IP address of 10.0.1.101.
    > FastEthernet0/1 is assigned an address of 192.168.0.1.
    >
    > FE0/0 is plugged into the 800 series. That router is my home gateway,
    > and has an IP of 10.0.0.1.
    >
    > From the 2621xm, I am able to ping the main gateway, as well as
    > external IP addresses.
    > My laptop, which is connected to FE0/1, can not. I assigned it a
    > static IP address of 192.168.0.101.
    >
    > Any thoughts and hints are much appreciated.
    >
    > Thanks!
    >
    > Current configuration : 880 bytes
    > !
    > version 12.3
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > no service password-encryption
    > !
    > hostname password
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > enable secret 5 password
    > enable password password
    > !
    > no network-clock-participate slot 1
    > no network-clock-participate wic 0
    > no aaa new-model
    > ip subnet-zero
    > ip cef
    > !
    > !
    > !
    > no ftp-server write-enable
    > !
    > !
    > !
    > !
    > interface FastEthernet0/0
    > ip address 10.0.1.101 255.255.254.0
    > ip nat outside
    > duplex auto
    > speed auto
    > !
    > interface Serial0/0
    > no ip address
    > shutdown
    > !
    > interface FastEthernet0/1
    > ip address 192.168.0.1 255.255.254.0
    > ip nat inside
    > duplex auto
    > speed auto
    > !
    > interface Serial0/1
    > no ip address
    > shutdown
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 10.0.0.1
    > ip http server
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > password password
    > login
    > !
    > !
    > !
    > end


    The 800series router needs to know where 192.168.0.0/23 is.
     
    Brian V, Dec 23, 2007
    #3
  4. BigMike82

    Trendkill Guest

    On Dec 23, 7:57 am, "Brian V" <> wrote:
    > "BigMike82" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > I've been slamming my head against this for the last few hours, and am
    > > hoping I can get some help from you guys. :)

    >
    > > At the moment, I have a Cisco 800 series operating as my main
    > > router.

    >
    > > The router in question is a Cisco 2621xm with the ipbasic IOS.
    > > FastEthernet0/0 is assigned an IP address of 10.0.1.101.
    > > FastEthernet0/1 is assigned an address of 192.168.0.1.

    >
    > > FE0/0 is plugged into the 800 series. That router is my home gateway,
    > > and has an IP of 10.0.0.1.

    >
    > > From the 2621xm, I am able to ping the main gateway, as well as
    > > external IP addresses.
    > > My laptop, which is connected to FE0/1, can not. I assigned it a
    > > static IP address of 192.168.0.101.

    >
    > > Any thoughts and hints are much appreciated.

    >
    > > Thanks!

    >
    > > Current configuration : 880 bytes
    > > !
    > > version 12.3
    > > service timestamps debug datetime msec
    > > service timestamps log datetime msec
    > > no service password-encryption
    > > !
    > > hostname password
    > > !
    > > boot-start-marker
    > > boot-end-marker
    > > !
    > > enable secret 5 password
    > > enable password password
    > > !
    > > no network-clock-participate slot 1
    > > no network-clock-participate wic 0
    > > no aaa new-model
    > > ip subnet-zero
    > > ip cef
    > > !
    > > !
    > > !
    > > no ftp-server write-enable
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0/0
    > > ip address 10.0.1.101 255.255.254.0
    > > ip nat outside
    > > duplex auto
    > > speed auto
    > > !
    > > interface Serial0/0
    > > no ip address
    > > shutdown
    > > !
    > > interface FastEthernet0/1
    > > ip address 192.168.0.1 255.255.254.0
    > > ip nat inside
    > > duplex auto
    > > speed auto
    > > !
    > > interface Serial0/1
    > > no ip address
    > > shutdown
    > > !
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 10.0.0.1
    > > ip http server
    > > !
    > > !
    > > line con 0
    > > line aux 0
    > > line vty 0 4
    > > password password
    > > login
    > > !
    > > !
    > > !
    > > end

    >
    > The 800series router needs to know where 192.168.0.0/23 is.


    I agree with the above posters, or you can start NATing on the second
    router as well (which can make things more complicated, but would
    probably fix the immediate issue). Regardless, the internet gateway
    router does not know how to get back to the 192.168s.
     
    Trendkill, Dec 23, 2007
    #4
  5. BigMike82

    Trendkill Guest

    On Dec 23, 7:57 am, "Brian V" <> wrote:
    > "BigMike82" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > I've been slamming my head against this for the last few hours, and am
    > > hoping I can get some help from you guys. :)

    >
    > > At the moment, I have a Cisco 800 series operating as my main
    > > router.

    >
    > > The router in question is a Cisco 2621xm with the ipbasic IOS.
    > > FastEthernet0/0 is assigned an IP address of 10.0.1.101.
    > > FastEthernet0/1 is assigned an address of 192.168.0.1.

    >
    > > FE0/0 is plugged into the 800 series. That router is my home gateway,
    > > and has an IP of 10.0.0.1.

    >
    > > From the 2621xm, I am able to ping the main gateway, as well as
    > > external IP addresses.
    > > My laptop, which is connected to FE0/1, can not. I assigned it a
    > > static IP address of 192.168.0.101.

    >
    > > Any thoughts and hints are much appreciated.

    >
    > > Thanks!

    >
    > > Current configuration : 880 bytes
    > > !
    > > version 12.3
    > > service timestamps debug datetime msec
    > > service timestamps log datetime msec
    > > no service password-encryption
    > > !
    > > hostname password
    > > !
    > > boot-start-marker
    > > boot-end-marker
    > > !
    > > enable secret 5 password
    > > enable password password
    > > !
    > > no network-clock-participate slot 1
    > > no network-clock-participate wic 0
    > > no aaa new-model
    > > ip subnet-zero
    > > ip cef
    > > !
    > > !
    > > !
    > > no ftp-server write-enable
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0/0
    > > ip address 10.0.1.101 255.255.254.0
    > > ip nat outside
    > > duplex auto
    > > speed auto
    > > !
    > > interface Serial0/0
    > > no ip address
    > > shutdown
    > > !
    > > interface FastEthernet0/1
    > > ip address 192.168.0.1 255.255.254.0
    > > ip nat inside
    > > duplex auto
    > > speed auto
    > > !
    > > interface Serial0/1
    > > no ip address
    > > shutdown
    > > !
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 10.0.0.1
    > > ip http server
    > > !
    > > !
    > > line con 0
    > > line aux 0
    > > line vty 0 4
    > > password password
    > > login
    > > !
    > > !
    > > !
    > > end

    >
    > The 800series router needs to know where 192.168.0.0/23 is.


    And a second thought I had. Will the gateway NAT 192.168 to the
    internet, especially since it is probably not in its dhcp/nat pool and
    not directly connected? The OP may need to check the gateway router
    to ensure this would work.
     
    Trendkill, Dec 23, 2007
    #5
  6. BigMike82

    BigMike82 Guest

    Brian was spot on. I needed to add a route to 192.168.0.0 on the 800
    router. That fixed everything.

    Thanks again!
     
    BigMike82, Dec 23, 2007
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bobstar

    Cisco 2621 ISDN router

    bobstar, Jul 1, 2004, in forum: Cisco
    Replies:
    0
    Views:
    542
    bobstar
    Jul 1, 2004
  2. CTEagle

    Cisco 2621 VLAN issue

    CTEagle, Oct 31, 2006, in forum: Hardware
    Replies:
    0
    Views:
    1,170
    CTEagle
    Oct 31, 2006
  3. weston
    Replies:
    8
    Views:
    948
    Aaron Leonard
    Nov 2, 2006
  4. jsmith0012

    Cisco 2621 config problems.

    jsmith0012, Nov 12, 2009, in forum: Cisco
    Replies:
    0
    Views:
    876
    jsmith0012
    Nov 12, 2009
  5. RG
    Replies:
    3
    Views:
    977
Loading...

Share This Page