Cisco 2620 Router IOS Upgrade

Discussion in 'Cisco' started by Corbin O'Reilly, Sep 3, 2007.

  1. Hi everyone. I use a Cisco 2620 router currently running
    c2600-bins-mz.122-11.T.bin.
    I am a Cisco registered user and logged into the site to obtain the lastest
    release of the code. I am really confused about which version I should use.
    Based on my current c2600-bins-mz.122-11.T.bin what correct latest release
    should I upgrade to? I found this one, c2600-bin-mz.123-23.bin, on the
    website but my current release has c2600-bins not c2600-bin in the filename.
    I would appreciate any help. Thanks.
    Corbin O'Reilly, Sep 3, 2007
    #1
    1. Advertising

  2. Corbin O'Reilly

    Merv Guest

    post the output of show version so that responders will know what the
    current feature set is on your router
    Merv, Sep 3, 2007
    #2
    1. Advertising

  3. Here you go. Thanks for the help.

    Cisco Internetwork Operating System Software
    IOS (tm) C2600 Software (C2600-BINS-M), Version 12.2(11)T, RELEASE SOFTWARE
    (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 01-Aug-02 13:10 by ccai
    Image text-base: 0x8000809C, data-base: 0x817475B8

    ROM: System Bootstrap, Version 12.2(6r), RELEASE SOFTWARE (fc1)

    Cisco_Midtown_RTR uptime is 31 weeks, 4 days, 18 hours, 29 minutes
    System returned to ROM by power-on
    System image file is "flash:c2600-bins-mz.122-11.T.bin"

    cisco 2620 (MPC860) processor (revision 0x00) with 61440K/4096K bytes of
    memory.
    Processor board ID JAD06210R1V (520123916)
    M860 processor: part number 0, mask 49
    Bridging software.
    X.25 software, Version 3.0.0.
    1 FastEthernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    32K bytes of non-volatile configuration memory.
    32768K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102

    "Merv" <> wrote in message
    news:...
    >
    > post the output of show version so that responders will know what the
    > current feature set is on your router
    >
    >
    Corbin O'Reilly, Sep 4, 2007
    #3
  4. "Corbin O'Reilly" <> writes:
    >Here you go. Thanks for the help.


    >IOS (tm) C2600 Software (C2600-BINS-M), Version 12.2(11)T, RELEASE SOFTWARE
    >System image file is "flash:c2600-bins-mz.122-11.T.bin"



    It wasn't that useful of a request, because it really only gives back
    all the info encoded in the full filename.

    Usually people say things like they have 12.2.11 which isn't as useful
    as giving the full filename of the image.

    The bulletin at

    http://www.cisco.com/en/US/products/sw/iosswrel/ps5460/prod_bulletin09186a00801af451.html

    has the mapping of the older product series into the newer naming schemes.

    The BINS feature set, which had IP, IPX, Appletalk, and PLUS (s) for IBM
    protocol support is replaced by Enterprise Base (entbase) in newer images.
    Doug McIntyre, Sep 4, 2007
    #4
  5. Hi. Thanks for the information. I logged into the Cisco site to get the
    ENTBASE code but it wasn't there. The following were the available codes
    under 12.3.23 (GD). Please help me select the correct one. Thanks.

    IP/IPX/APPLETALK
    c2600-bin-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP/IPX/APPLETALK
    Size: 8067.84 KB
    Minimum Memory: DRAM:32MB Flash:16MB


    IP/IPX/AT/FW/IDS PLUS BASIC
    c2600-bino3s3-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP/IPX/AT/FW/IDS PLUS BASIC
    Size: 15079.73 KB
    Minimum Memory: DRAM:64MB Flash:16MB


    REMOTE ACCESS SERVER
    c2600-c-mz.123-23.bin
    Release Date: 25/Jul/2007
    REMOTE ACCESS SERVER
    Size: 7301.82 KB
    Minimum Memory: DRAM:32MB Flash:8MB


    IP
    c2600-i-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP
    Size: 7568.01 KB
    Minimum Memory: DRAM:32MB Flash:8MB


    IP/FW/IDS PLUS IPSEC 3DES BASIC
    c2600-ik9o3s3-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP/FW/IDS PLUS IPSEC 3DES BASIC
    Size: 15696.58 KB
    Minimum Memory: DRAM:64MB Flash:16MB


    IP/FW/IDS
    c2600-io3-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP/FW/IDS
    Size: 7902.76 KB
    Minimum Memory: DRAM:32MB Flash:16MB


    IP PLUS
    c2600-is-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP PLUS
    Size: 17638.88 KB
    Minimum Memory: DRAM:64MB Flash:32MB


    IP/H323 PLUS BASIC
    c2600-is3x-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP/H323 PLUS BASIC
    Size: 14678.81 KB
    Minimum Memory: DRAM:64MB Flash:16MB


    IP PLUS BASIC W/O SWITCHING
    c2600-is4-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP PLUS BASIC W/O SWITCHING
    Size: 15852.1 KB
    Minimum Memory: DRAM:64MB Flash:16MB


    IP PLUS BASIC W/O HD ANALOG/AIM ATM/VOICE
    c2600-is5-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP PLUS BASIC W/O HD ANALOG/AIM ATM/VOICE
    Size: 15144.55 KB
    Minimum Memory: DRAM:64MB Flash:16MB


    IP/H323
    c2600-ix-mz.123-23.bin
    Release Date: 25/Jul/2007
    IP/H323
    Size: 8595.04 KB
    Minimum Memory: DRAM:48MB Flash:16MB


    ENTERPRISE BASIC
    c2600-j1s3-mz.123-23.bin
    Release Date: 25/Jul/2007
    ENTERPRISE BASIC
    Size: 15698.34 KB
    Minimum Memory: DRAM:64MB Flash:16MB


    TELCO FEATURE SET
    c2600-telco-mz.123-23.bin
    Release Date: 25/Jul/2007
    TELCO FEATURE SET
    Size: 10687.33 KB
    Minimum Memory: DRAM:48MB Flash:16MB




    "Doug McIntyre" <> wrote in message
    news:46dcd804$0$79256$...
    > "Corbin O'Reilly" <> writes:
    >>Here you go. Thanks for the help.

    >
    >>IOS (tm) C2600 Software (C2600-BINS-M), Version 12.2(11)T, RELEASE
    >>SOFTWARE
    >>System image file is "flash:c2600-bins-mz.122-11.T.bin"

    >
    >
    > It wasn't that useful of a request, because it really only gives back
    > all the info encoded in the full filename.
    >
    > Usually people say things like they have 12.2.11 which isn't as useful
    > as giving the full filename of the image.
    >
    > The bulletin at
    >
    > http://www.cisco.com/en/US/products/sw/iosswrel/ps5460/prod_bulletin09186a00801af451.html
    >
    > has the mapping of the older product series into the newer naming schemes.
    >
    > The BINS feature set, which had IP, IPX, Appletalk, and PLUS (s) for IBM
    > protocol support is replaced by Enterprise Base (entbase) in newer images.
    >
    >
    Corbin O'Reilly, Sep 4, 2007
    #5
  6. Corbin O'Reilly

    Merv Guest

    One of the reason for asking for the show version output was to see
    how much memory is in your router.

    This has an obvious impact on trying to load some of the larger images
    associated with some features set

    Since your router has 64M of DRAM and 32 M of flash, you can loaded
    any of the above images.

    If you do not know which image to use, then you need to indicate what
    the routers is used for.
    For example IP only ? VPN tunnels , IOS firewall, etc, etc

    If you post your router config, then responders could tell what
    feature set is required to support the current working config.
    Merv, Sep 4, 2007
    #6
  7. Corbin O'Reilly schrieb:
    > Hi. Thanks for the information. I logged into the Cisco site to get the
    > ENTBASE code but it wasn't there. The following were the available codes
    > under 12.3.23 (GD). Please help me select the correct one. Thanks.

    [...]
    > ENTERPRISE BASIC
    > c2600-j1s3-mz.123-23.bin


    Hmmm, looks like it was there after all.

    > "Doug McIntyre" <> wrote in message
    > news:46dcd804$0$79256$...

    [...]
    >> The BINS feature set, which had IP, IPX, Appletalk, and PLUS (s) for IBM
    >> protocol support is replaced by Enterprise Base (entbase) in newer images.

    ~~~~~~~~~~~~~~~
    HTH

    --
    Please excuse my bad English/German/French/Greek/Cantonese/Klingon/...
    Tilman Schmidt, Sep 4, 2007
    #7
  8. Here is a "sanitized" copy of my running configuration. I would really
    appreciate it if someone could tell me which version of the 12.3.23 (GD)
    code I should upgrade the router to. Thanks.

    show run
    Building configuration...



    Current configuration : 3059 bytes
    !
    version 12.2
    no parser cache
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Cisco_Midtown_RTR
    !
    boot system flash:c2600-bins-mz.122-11.T.bin
    enable password
    !
    ip subnet-zero
    ip cef
    !
    !
    !
    ip multicast-routing
    ipx routing 00e0.1e60.6a2d
    !
    class-map match-all voice
    match access-group 101
    !
    !
    policy-map Frame_QoS
    class voice
    priority percent 90
    class class-default
    bandwidth remaining percent 10
    policy-map Lan_QoS
    class voice
    priority 90000
    class class-default
    bandwidth 10000
    !
    !
    !
    voice call carrier capacity active
    !
    !
    !
    !
    !
    !
    !
    !
    !
    mta receive maximum-recipients 0
    !
    !
    source-bridge ring-group 4
    source-bridge transparent 4 5 1 1
    dlsw local-peer peer-id 11.1.2.1
    dlsw remote-peer 0 tcp 11.1.1.1
    dlsw bridge-group 1
    !
    !
    interface Loopback0
    ip address 11.1.2.1 255.255.255.0
    !
    interface FastEthernet0/0
    mac-address 00e0.1e60.6a2d
    ip address 218.x.y.z 255.255.255.224 secondary
    ip address 10.1.3.1 255.255.255.0
    ip pim dense-mode
    duplex auto
    speed auto
    ipx network 5
    ipx type-20-propagation
    max-reserved-bandwidth 100
    service-policy output Lan_QoS
    no mop enabled
    bridge-group 1
    !
    interface Serial0/0
    ip address 10.250.1.1 255.255.255.252
    ip pim dense-mode
    encapsulation frame-relay IETF
    ipx network 4
    ipx type-20-propagation
    no fair-queue
    frame-relay traffic-shaping
    frame-relay interface-dlci 100
    class ABC_NY
    frame-relay lmi-type ansi
    !
    router eigrp 10
    network 10.0.0.0
    network 11.0.0.0
    no auto-summary
    no eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.1.3.220
    ip route 10.1.1.0 255.255.255.0 10.250.1.2
    ip route 10.1.2.0 255.255.255.0 10.250.1.2
    ip route 10.1.4.0 255.255.255.0 10.250.1.2
    ip route 10.1.5.0 255.255.255.0 10.250.1.2
    ip route 10.1.10.0 255.255.255.0 10.250.1.2
    ip route 11.1.1.0 255.255.255.0 10.250.1.2
    ip route 174.x.0.0 255.255.0.0 10.1.3.149
    ip route 218.x.y.z 255.255.255.255 10.250.1.2
    ip route 218.x.y.z 255.255.255.255 10.250.1.2
    ip route 218.x.y.z 255.255.255.255 10.250.1.2
    ip route 218.x.y.z 255.255.255.255 10.250.1.2
    ip http server
    !
    !
    !
    map-class frame-relay ABC_NY
    frame-relay cir 1544000
    frame-relay bc 15440
    frame-relay mincir 1544000
    service-policy output Frame_QoS
    access-list 101 permit udp any any range 2093 2096
    access-list 101 permit ip host 10.1.3.100 any
    access-list 101 permit ip host 10.1.3.101 any
    access-list 101 permit ip host 10.1.3.102 any
    access-list 101 permit ip host 10.1.3.103 any
    access-list 101 permit ip host 10.1.3.104 any
    access-list 101 permit ip host 10.1.3.105 any
    access-list 101 permit ip host 10.1.3.106 any
    access-list 101 permit ip host 10.1.3.107 any
    access-list 101 permit ip host 10.1.3.108 any
    access-list 101 permit ip host 10.1.3.109 any
    !
    !
    !
    ipx router eigrp 10
    network 4
    !
    !
    ipx router rip
    no network 4
    !
    !
    !
    bridge 1 protocol ieee
    call rsvp-sync
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password password
    login
    line vty 5 15
    login
    !
    !
    end



    "Tilman Schmidt" <> wrote in message
    news:fbjnd8$2rd$-ndh.com...
    > Corbin O'Reilly schrieb:
    >> Hi. Thanks for the information. I logged into the Cisco site to get the
    >> ENTBASE code but it wasn't there. The following were the available codes
    >> under 12.3.23 (GD). Please help me select the correct one. Thanks.

    > [...]
    >> ENTERPRISE BASIC
    >> c2600-j1s3-mz.123-23.bin

    >
    > Hmmm, looks like it was there after all.
    >
    >> "Doug McIntyre" <> wrote in message
    >> news:46dcd804$0$79256$...

    > [...]
    >>> The BINS feature set, which had IP, IPX, Appletalk, and PLUS (s) for IBM
    >>> protocol support is replaced by Enterprise Base (entbase) in newer
    >>> images.

    > ~~~~~~~~~~~~~~~
    > HTH
    >
    > --
    > Please excuse my bad English/German/French/Greek/Cantonese/Klingon/...
    Corbin O'Reilly, Sep 5, 2007
    #8
  9. Corbin O'Reilly

    Merv Guest

    The config shows that IP,IPX, DLSW and PIM multicast are being used.


    Doug McIntrye's post has already indicated to use Enterprise Base:

    " The BINS feature set, which had IP, IPX, Appletalk, and PLUS (s) for
    IBM
    protocol support is replaced by Enterprise Base (entbase) in newer
    images"


    The 12.2(23) Enterprise Base image name is c2600-j1s3-mz.123-23.bin
    Merv, Sep 5, 2007
    #9
  10. Great. Thanks everyone for all the help.

    "Merv" <> wrote in message
    news:...
    >
    > The config shows that IP,IPX, DLSW and PIM multicast are being used.
    >
    >
    > Doug McIntrye's post has already indicated to use Enterprise Base:
    >
    > " The BINS feature set, which had IP, IPX, Appletalk, and PLUS (s) for
    > IBM
    > protocol support is replaced by Enterprise Base (entbase) in newer
    > images"
    >
    >
    > The 12.2(23) Enterprise Base image name is c2600-j1s3-mz.123-23.bin
    >
    Corbin O'Reilly, Sep 5, 2007
    #10
  11. Corbin O'Reilly

    gascan.jyy4

    Joined:
    Sep 4, 2007
    Messages:
    5
    you feature is as bellow, keep the same feature, and go for latest ver, look at the requirement for ram and flash:



    Image Name Release Platform Feature Set
    c2600-bins-mz.122-11.T.bin 12.2(11)T 2610-2613 IP/IPX/APPLETALK PLUS
    c2600-bins-mz.122-11.T.bin 12.2(11)T 2610XM-2611XM IP/IPX/APPLETALK PLUS
    c2600-bins-mz.122-11.T.bin 12.2(11)T 2620-2621 IP/IPX/APPLETALK PLUS
    c2600-bins-mz.122-11.T.bin 12.2(11)T 2620XM-2621XM IP/IPX/APPLETALK PLUS
    c2600-bins-mz.122-11.T.bin 12.2(11)T 2650-2651 IP/IPX/APPLETALK PLUS
    c2600-bins-mz.122-11.T.bin 12.2(11)T 2650XM-2651XM IP/IPX/APPLETALK PLUS
    gascan.jyy4, Sep 5, 2007
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Watt
    Replies:
    0
    Views:
    540
  2. D Watt

    2620 IOS query for ADSL WIC

    D Watt, Nov 10, 2005, in forum: Cisco
    Replies:
    2
    Views:
    583
    Doug McIntyre
    Nov 10, 2005
  3. cisconewbie

    Cisco 837 upgrade IOS upgrade gone wrong

    cisconewbie, Sep 22, 2006, in forum: Hardware
    Replies:
    5
    Views:
    3,315
    kuruvi
    Oct 5, 2008
  4. Mike Rahl
    Replies:
    1
    Views:
    1,176
    Trendkill
    May 30, 2007
  5. Mike Rahl
    Replies:
    1
    Views:
    941
    Doug McIntyre
    Jun 14, 2007
Loading...

Share This Page