Cisco 2600 E1 ISDN PRI Voice Problem . Dial tone does not stop after DTMF

Discussion in 'Cisco' started by Reza, Apr 22, 2004.

  1. Reza

    Reza Guest

    Hello
    please help me to solve this problem :

    I have setup a E1 PRI on a cisco 2600 with NM-HDV with 30 voice ports.
    the E1 is up and also ISDN layer 1 , 2 are up.
    when I dial into the router I hear the dial-tone and I see the voice
    port goes into DIGIT_COLLECT state. but when I try to dial a number
    (DTMF) the dial tone does not stop and in few seconds the router hangs
    up the call.
    I see "Invalid number format" as disconnect cause .

    here is the DEBUG ISDN Q931 messages



    *Mar 1 15:53:00 UTC: ISDN Se1/0:15: RX <- SETUP pd = 8 callref =
    0x0001
    *Mar 1 15:53:00 UTC: Sending Complete
    *Mar 1 15:53:00 UTC: Bearer Capability i = 0x8090A3
    *Mar 1 15:53:00 UTC: Channel ID i = 0xA98381
    *Mar 1 15:53:00 UTC: Progress Ind i = 0x8483 - Origination
    address is non-ISDN
    *Mar 1 15:53:00 UTC: Called Party Number i = 0x81, '225113',
    Plan:ISDN, Type:Unknown
    *Mar 1 15:53:00 UTC: ISDN Se1/0:15: TX -> CALL_PROC pd = 8 callref =
    0x8001
    *Mar 1 15:53:00 UTC: Channel ID i = 0xA98381
    *Mar 1 15:53:00 UTC: ISDN Se1/0:15: TX -> CONNECT pd = 8 callref =
    0x8001
    *Mar 1 15:53:00 UTC: ISDN Se1/0:15: RX <- CONNECT_ACK pd = 8 callref
    = 0x0001
    *Mar 1 15:53:00 UTC: ISDN Se1/0:15: CALL_PROGRESS: CALL_CONNECTED
    call id 0x6, bchan 0, dsl 0


    *Mar 1 15:53:10 UTC: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref
    = 0x8001
    *Mar 1 15:53:10 UTC: Cause i = 0x809C - Invalid number format
    (incomplete number)
    *Mar 1 15:53:10 UTC: Progress Ind i = 0x8483 - Origination
    address is non-ISDN
    *Mar 1 15:53:10 UTC: Called Party Number i = 0x81, '225113',
    Plan:ISDN, Type:Unknown
    *Mar 1 15:53:10 UTC: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref =
    0x0001
    *Mar 1 15:53:10 UTC: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8
    callref = 0x8001





    !
    version 12.2
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !

    !
    no logging buffered
    !
    !
    voice-card 1
    dspfarm
    !
    ip subnet-zero
    !
    !
    no ip domain-lookup
    !
    isdn switch-type primary-net5
    isdn voice-call-failure 0
    !
    !
    voice service voip
    !
    controller E1 1/0
    clock source line primary
    pri-group timeslots 1-16
    description 1Mbps E1 for incoming Voice
    !
    controller E1 1/1
    shutdown
    !
    gw-accounting h323
    gw-accounting h323 vsa
    gw-accounting voip
    bridge irb
    !
    !
    !
    interface Ethernet0/0
    ip address 192.168.65.3 255.255.255.0
    no ip redirects
    half-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    fair-queue
    !
    interface Ethernet0/1
    no ip address
    shutdown
    half-duplex
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    interface Serial1/0:15
    no ip address
    no logging event link-status
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    !
    ip classless
    no ip forward-protocol udp netbios-ns
    no ip forward-protocol udp netbios-dgm
    ip route 0.0.0.0 0.0.0.0 192.168.65.1
    no ip http server
    ip pim bidir-enable
    !
    dialer-list 1 protocol ip permit
    dialer-list 1 protocol ipx permit
    !
    call rsvp-sync
    !
    voice-port 1/0:15
    echo-cancel coverage 32
    playout-delay mode adaptive
    timeouts interdigit 2
    bearer-cap Speech
    !
    !
    mgcp profile default
    !
    dial-peer cor custom
    !
    !
    dial-peer cor list name
    !
    !
    dial-peer voice 100 pots
    port 1/0:15
    !
    dial-peer voice 10 voip
    huntstop
    destination-pattern ....T
    session target ipv4:192.168.3.2
    !
    gateway
    !
    !
    line con 0
    login
    line aux 0
    login
    line vty 0 4
    login
    !
    !
    end





    sh isdn sta
    Global ISDN Switchtype = primary-net5
    ISDN Serial1/0:15 interface
    dsl 0, interface ISDN Switchtype = primary-net5
    Layer 1 Status:
    ACTIVE
    Layer 2 Status:
    TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
    0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask: 0x80007FFF
    Number of L2 Discards = 0, L2 Session ID = 1
    Total Allocated ISDN CCBs = 0
     
    Reza, Apr 22, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jamal
    Replies:
    1
    Views:
    868
  2. Ada
    Replies:
    2
    Views:
    1,562
  3. Victor Cappuccio

    AS5350, TCL and DTMF Tone.

    Victor Cappuccio, Apr 15, 2005, in forum: Cisco
    Replies:
    0
    Views:
    467
    Victor Cappuccio
    Apr 15, 2005
  4. jdsal

    Voice T1, ISDN PRI

    jdsal, Oct 21, 2005, in forum: Cisco
    Replies:
    2
    Views:
    3,708
    Sir_Routes_Alot
    Oct 24, 2005
  5. Replies:
    2
    Views:
    5,078
    thrill5
    Jan 28, 2006
Loading...

Share This Page