Cisco 2500 - modem dialin via aux port

Discussion in 'Cisco' started by Syn, Jun 23, 2004.

  1. Syn

    Syn Guest

    Hello,

    I am trying in vain to make my Cisco 2500 allow us to dialin into our
    Cisco 2500 access server. What we did is simply plug an USR Robotics
    Courier V.Everything to the AUX port of our Cisco 2500. Then I
    configured the Cisco 2500 as in the docs from Cisco. Everything looks
    fine when I try to dialin the modem answers but then nothing happens,
    there is no username password prompt... We simply would like to be able
    to login into our cisco 2500 like that in case of emergency so it's
    quite important for us. So far I really have no more clue what is going
    wrong... Does anyone have suggestions ?

    Here is the configuration of the cisco 2500:

    Current configuration : 1284 bytes
    !
    ! Last configuration change at 07:52:06 UTC Wed Apr 21 2004
    ! NVRAM config last updated at 07:52:16 UTC Wed Apr 21 2004
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug datetime
    service timestamps log datetime
    service password-encryption
    !
    hostname c2500
    !
    enable secret 5 <censored>
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip routing
    no ip domain-lookup
    ip host modem 2017 192.168.100.100
    ip host test 2001 192.168.100.100
    !
    !
    !
    !
    interface Loopback0
    ip address 192.168.100.100 255.255.255.255
    interface Ethernet0
    ip address 192.168.10.3 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    !
    interface Serial0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    !
    interface Serial1
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    !
    ip default-gateway 192.168.10.1
    ip classless
    no ip http server
    !
    snmp-server community public RO
    !
    line con 0
    line 1 8
    session-timeout 20
    exec-timeout 0 0
    no exec
    transport input telnet
    line 9 16
    line aux 0
    password 7 <censored>
    login
    modem Dialin
    modem autoconfigure discovery
    transport input all
    stopbits 1
    speed 38400
    flowcontrol hardware
    line vty 0 4
    password 7 <censored>
    login
    !
    end


    Thank you very much in advance for your help

    Regards
     
    Syn, Jun 23, 2004
    #1
    1. Advertising

  2. line aux 0
    session-timeout 30
    exec-timeout 30 0
    password 7 <blink>
    login
    modem InOut

    ....works for me. what does show line aux 0 say?

    --Jerome


    Syn <> wrote in message news:<>...
    > Hello,
    >
    > I am trying in vain to make my Cisco 2500 allow us to dialin into our
    > Cisco 2500 access server. What we did is simply plug an USR Robotics
    > Courier V.Everything to the AUX port of our Cisco 2500. Then I
    > configured the Cisco 2500 as in the docs from Cisco. Everything looks
    > fine when I try to dialin the modem answers but then nothing happens,
    > there is no username password prompt... We simply would like to be able
    > to login into our cisco 2500 like that in case of emergency so it's
    > quite important for us. So far I really have no more clue what is going
    > wrong... Does anyone have suggestions ?
    >
    > Here is the configuration of the cisco 2500:
    >
    > Current configuration : 1284 bytes
    > !
    > ! Last configuration change at 07:52:06 UTC Wed Apr 21 2004
    > ! NVRAM config last updated at 07:52:16 UTC Wed Apr 21 2004
    > !
    > version 12.1
    > no service single-slot-reload-enable
    > service timestamps debug datetime
    > service timestamps log datetime
    > service password-encryption
    > !
    > hostname c2500
    > !
    > enable secret 5 <censored>
    > !
    > !
    > !
    > !
    > !
    > ip subnet-zero
    > no ip routing
    > no ip domain-lookup
    > ip host modem 2017 192.168.100.100
    > ip host test 2001 192.168.100.100
    > !
    > !
    > !
    > !
    > interface Loopback0
    > ip address 192.168.100.100 255.255.255.255
    > interface Ethernet0
    > ip address 192.168.10.3 255.255.255.0
    > no ip route-cache
    > no ip mroute-cache
    > !
    > interface Serial0
    > no ip address
    > no ip route-cache
    > no ip mroute-cache
    > shutdown
    > !
    > interface Serial1
    > no ip address
    > no ip route-cache
    > no ip mroute-cache
    > shutdown
    > !
    > ip default-gateway 192.168.10.1
    > ip classless
    > no ip http server
    > !
    > snmp-server community public RO
    > !
    > line con 0
    > line 1 8
    > session-timeout 20
    > exec-timeout 0 0
    > no exec
    > transport input telnet
    > line 9 16
    > line aux 0
    > password 7 <censored>
    > login
    > modem Dialin
    > modem autoconfigure discovery
    > transport input all
    > stopbits 1
    > speed 38400
    > flowcontrol hardware
    > line vty 0 4
    > password 7 <censored>
    > login
    > !
    > end
    >
    >
    > Thank you very much in advance for your help
    >
    > Regards
     
    jerome benton, Jun 23, 2004
    #2
    1. Advertising

  3. Syn

    Syn Guest

    jerome benton wrote:
    > line aux 0
    > session-timeout 30
    > exec-timeout 30 0
    > password 7 <blink>
    > login
    > modem InOut
    >
    > ...works for me. what does show line aux 0 say?


    First many thanks for your answer ;-) Here is the output of a show line
    aux 0:

    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise
    Overruns Int
    17 AUX 38400/38400 - DialIn - - - 8 1 14/0
    -

    Line 17, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 1 stopbits, 8 databits
    Status: No Exit Banner, Modem Detected, CTS Raised, Modem Signals Polled
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
    Modem RI is CD, Modem Discovery
    Modem state: Idle
    Modem hardware state: CTS* noDSR DTR RTS, Modem Configured
    Special Chars: Escape Hold Stop Start Disconnect Activation
    ^^x none - - none
    Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch
    00:10:00 never none
    not set
    Idle Session Disconnect Warning
    never
    Login-sequence User Response
    00:00:30
    Autoselect Initial Wait
    not set
    Modem type is usr_courier.
    Session limit is not set.
    Time since activation: never
    Editing is enabled.
    History is enabled, history size is 10.
    DNS resolution in show commands is enabled
    Full user help is disabled
    Allowed input transports are pad v120 telnet rlogin udptn.
    Allowed output transports are pad v120 telnet rlogin.
    Preferred transport is telnet.
    No output characters are padded
    No special data dispatching characters



    Does that help you ? Do you see something wrong ?

    Thanks
    Regards
     
    Syn, Jun 24, 2004
    #3
  4. The show line aux 0 indicates data overruns on the aux port. I believe
    this is caused by flow control errors. Try using software (Xon/Xoff)
    or no flow control instead of hardware (RTS/CTS). If that doesn't give
    you joy, it may be time to revisit show modemcap usr_courier and modem
    autoconfigure discovery to re-initialize the modem.

    You can also rapidly initialize the modem by reverse telnet, e.g:

    c2500#telnet 192.168.100.100 2017

    Trying 192.168.100.100, 2017 ... Open
    at&fs0=1

    OK

    Then disconnect the session by using shift-ctrl-6 x to escape async
    mode, and disconnect 1 to disconnect the session. I used a USR Courier
    init string in the above example, but I haven't touched modem init
    strings in 10 years, so you may want to refer to
    http://www.56k.com/inits/ for more init strings.

    --Jerome
     
    jerome benton, Jun 29, 2004
    #4
  5. Syn

    Syn Guest

    jerome benton wrote:
    > The show line aux 0 indicates data overruns on the aux port. I believe
    > this is caused by flow control errors. Try using software (Xon/Xoff)
    > or no flow control instead of hardware (RTS/CTS). If that doesn't give
    > you joy, it may be time to revisit show modemcap usr_courier and modem
    > autoconfigure discovery to re-initialize the modem.
    >
    > You can also rapidly initialize the modem by reverse telnet, e.g:
    >
    > c2500#telnet 192.168.100.100 2017
    >
    > Trying 192.168.100.100, 2017 ... Open
    > at&fs0=1
    >
    > OK
    >
    > Then disconnect the session by using shift-ctrl-6 x to escape async
    > mode, and disconnect 1 to disconnect the session. I used a USR Courier
    > init string in the above example, but I haven't touched modem init
    > strings in 10 years, so you may want to refer to
    > http://www.56k.com/inits/ for more init strings.
    >
    > --Jerome


    Hi Jerome,

    Well I tryed what you told me then called but it didn't make any
    differences unfortunately :(

    I also had a look at the "SHOW LOG" and here is the last log entries,
    maybe this helps you:


    Jun 30 08:36:10: TTY17: Modem command: --AT&F&C1&D2&H1&R2&M4&K1&B1S0=1H0--
    Jun 30 08:36:11: TTY17: Modem configuration succeeded
    Jun 30 08:36:12: TTY17: detection speed (38400) response ---OK---
    Jun 30 08:36:12: TTY17: Done with modem configuration

    There you can see the init string which is used, I checked it looks
    quite correct, or what do you think ? Should I use another init string
    by manually specifying one ? If yes how can I do that ?

    Many thanks
    Regards
     
    Syn, Jun 30, 2004
    #5
  6. On Wed, 30 Jun 2004 10:43:33 +0200, Syn <> wrote:

    Syn,

    Your debug output indicates that modem autoconfigure successfully runs
    on your AUX and communicates OK with the Courier at 38400 bps, so we
    can infer that the data path between the 2500 and the Courier is good.

    Next step is to reverse telnet to the Courier and verify that your
    AT gets an OK (it should). Now, while reverse telnetted in, dial in
    from another modem. Verify that the modems train and the answer side
    gets a CONNECT and that in your Courier window you can type "hi mom"
    and that is seen in the originate modem window and vice versa.

    Next step is to configure this:

    interface async 16
    encapsulation ppp
    no shutdown
    async mode interactive

    line aux 0
    autoselect ppp
    autoselect during login

    service timestamp debug date msec

    In a telnet or console exec session on the 2500, have
    terminal monitor
    debug modem
    in effect. Now dial into the Courier and let's see what happens.

    If the autoselect debugs show garbage characters and the originate
    modem also sees garbage, then I fear that what's happening is something
    that USR external modems have lately been strangely susceptible to -
    forgetting their DTE rate when answering a call. Regrettably USR
    does not provide a way directly to configure the DTE rate; &B1 is
    supposed to do the trick, but it seems that USRs can be flaky in
    this regard.

    If your modem is flaky like this, then the only reliable workaround
    is to configure the answer modem for a fixed DCE rate (like say 19200
    bps V.34 with data compression disabled) and configured to have DTE
    rate follow DCE rate (&B0). Of course this will impair your throughput.

    Aaron

    ---

    ~ jerome benton wrote:
    ~ > The show line aux 0 indicates data overruns on the aux port. I believe
    ~ > this is caused by flow control errors. Try using software (Xon/Xoff)
    ~ > or no flow control instead of hardware (RTS/CTS). If that doesn't give
    ~ > you joy, it may be time to revisit show modemcap usr_courier and modem
    ~ > autoconfigure discovery to re-initialize the modem.
    ~ >
    ~ > You can also rapidly initialize the modem by reverse telnet, e.g:
    ~ >
    ~ > c2500#telnet 192.168.100.100 2017
    ~ >
    ~ > Trying 192.168.100.100, 2017 ... Open
    ~ > at&fs0=1
    ~ >
    ~ > OK
    ~ >
    ~ > Then disconnect the session by using shift-ctrl-6 x to escape async
    ~ > mode, and disconnect 1 to disconnect the session. I used a USR Courier
    ~ > init string in the above example, but I haven't touched modem init
    ~ > strings in 10 years, so you may want to refer to
    ~ > http://www.56k.com/inits/ for more init strings.
    ~ >
    ~ > --Jerome
    ~
    ~ Hi Jerome,
    ~
    ~ Well I tryed what you told me then called but it didn't make any
    ~ differences unfortunately :(
    ~
    ~ I also had a look at the "SHOW LOG" and here is the last log entries,
    ~ maybe this helps you:
    ~
    ~
    ~ Jun 30 08:36:10: TTY17: Modem command: --AT&F&C1&D2&H1&R2&M4&K1&B1S0=1H0--
    ~ Jun 30 08:36:11: TTY17: Modem configuration succeeded
    ~ Jun 30 08:36:12: TTY17: detection speed (38400) response ---OK---
    ~ Jun 30 08:36:12: TTY17: Done with modem configuration
    ~
    ~ There you can see the init string which is used, I checked it looks
    ~ quite correct, or what do you think ? Should I use another init string
    ~ by manually specifying one ? If yes how can I do that ?
    ~
    ~ Many thanks
    ~ Regards
     
    Aaron Leonard, Jun 30, 2004
    #6
  7. Syn

    Syn Guest

    Aaron Leonard wrote:

    ....

    > If your modem is flaky like this, then the only reliable workaround
    > is to configure the answer modem for a fixed DCE rate (like say 19200
    > bps V.34 with data compression disabled) and configured to have DTE
    > rate follow DCE rate (&B0). Of course this will impair your throughput.


    Well it's a miracle, I've tested again and it works now, many many
    thanks to all of you replying me and helping me! You've all been of a
    great help.

    Now I wanted to ask this list, what are the parameters I need to add to
    line aux 0, to allow also for the PPP protocol and give a static IP
    address to the remote dial-in user ?

    Regards
     
    Syn, Jul 2, 2004
    #7
  8. On Fri, 02 Jul 2004 10:46:37 +0200, Syn <> wrote:

    ~ Aaron Leonard wrote:
    ~
    ~ ...
    ~
    ~ > If your modem is flaky like this, then the only reliable workaround
    ~ > is to configure the answer modem for a fixed DCE rate (like say 19200
    ~ > bps V.34 with data compression disabled) and configured to have DTE
    ~ > rate follow DCE rate (&B0). Of course this will impair your throughput.
    ~
    ~ Well it's a miracle, I've tested again and it works now, many many
    ~ thanks to all of you replying me and helping me! You've all been of a
    ~ great help.
    ~
    ~ Now I wanted to ask this list, what are the parameters I need to add to
    ~ line aux 0, to allow also for the PPP protocol and give a static IP
    ~ address to the remote dial-in user ?
    ~
    ~ Regards

    the basics:

    interface async 17 ! or whatever line # your aux is
    encapsulation ppp
    ip unnumbered ether0
    ppp authentication pap chap callin
    peer default ip address 1.2.3.4
    async mode interactive

    line aux 0
    autoselect during-login
    autoselect ppp

    the debugs:

    debug modem
    debug ppp negotiation

    Aaron
     
    Aaron Leonard, Jul 2, 2004
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. erike
    Replies:
    2
    Views:
    1,366
    Guest
    Dec 31, 2003
  2. Beppe
    Replies:
    1
    Views:
    3,808
  3. asda
    Replies:
    0
    Views:
    414
  4. asad
    Replies:
    0
    Views:
    660
  5. philbo30
    Replies:
    1
    Views:
    459
    philbo30
    Apr 26, 2007
Loading...

Share This Page