Cisco 2500 help/Newbie, thanks for the help in advance

Discussion in 'Cisco' started by chrisadatl, Mar 15, 2006.

  1. chrisadatl

    chrisadatl Guest

    Here is what I got,

    Cisco 2500
    Cisco Catalyst 2900 series switch

    Currently at the house I have and in the order I have it connected.

    BROADBAND CONNECTION
    \
    Linux Smoothwall firewall (192.168.1.1)
    \
    Switch ( 192.168.1.2)
    \
    Rest of the network.(Clients are DHCP from
    firewall)


    I have 1.3 reserved for a server.

    what I am wanting to do is implament a cisco 2500 series router into
    the mix. My first idea was to break the switch up (16 ports) 8 going to
    1 subnet and 2 going to another (2 Vlans)

    I wanted to see if the Cisco could break these broadcast domains up and
    make them talk...

    the router has 1 ethernet interface and I heard that I could create a
    subinterface and assign it an ip address, and direct one subnet towards
    that sub interface.. as their default gateway.

    hopefull, both subnets will use 1.1 as a gateway to get outbound but
    have 2 subnets, 2 vlans and so forth so on..

    if you guys could please give me a couple of hints on what kind of
    powers this 2500 series possess also where I might be able to go and
    get some information that will help me actually use this thing at home.
    what ever i may help you guys out with in the future I will research
    and put in if I got the knowledge...


    I hope you guys have a good one... thanks for the help.
     
    chrisadatl, Mar 15, 2006
    #1
    1. Advertising

  2. chrisadatl

    Merv Guest

    What you are trying to do is to implement what is called
    "router-on-stick"

    Try configuring something like:



    ! Cisco 2500 config for VLAN trunk to 2900 switch

    ip subnet-zero

    int eth 0/0
    o shut
    exit


    int eth 0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    exit


    int eth 0/0.20
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    exit


    !+++++++++++++++++++++++++++++++++++++++++


    ! Cisco Catalyst 2900 switch config

    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    mode trunk
    exit

    interface FastEthernet0/2
    description switch port in VLAN 10
    switchport access vlan 10
    spanning-tree portfast
    exit


    interface FastEthernet0/3
    description switch port in VLAN 20
    switchport access vlan 20
    spanning-tree portfast
    exit

    int vlan 10
    ip address 192.168.10.2 255.255.255.0
    exit

    ip default-gateway 192.168.10.1
     
    Merv, Mar 16, 2006
    #2
    1. Advertising

  3. chrisadatl

    chrisadatl Guest

    Thanks! I see what your doing.. you are putting 1 vlan on 1 port and 1
    on the other.. using FA01 as the router port to the switch for
    trunking....

    AWSOME!!

    i know that this is not the ideal setup, but what would you do with
    this equipment other then throw it away cuz it is way outdated..

    If you had a broad band connection, router, switch, and a firewall....
    is there anything in particular you would do with it to gain knowledge
    on the cyntax and IOS?

    Does this router have DHCP services? NAT? Firewall services? I really
    dont know.

    Thanks for any answers that anyone can help out with
     
    chrisadatl, Mar 16, 2006
    #3
  4. chrisadatl

    Merv Guest

    Post the output of "show version" command for both devices.
     
    Merv, Mar 16, 2006
    #4
  5. chrisadatl

    Charlie Root Guest

    "chrisadatl" <> wrote in message
    news:...
    > if you guys could please give me a couple of hints on what kind of
    > powers this 2500 series possess also where I might be able to go and
    > get some information that will help me actually use this thing at home.
    > what ever i may help you guys out with in the future I will research
    > and put in if I got the knowledge...
    >

    For experiments 2500 is fine, but you will be very disappointed that this
    router doesn't perform above 2.25Mbps. Meaning your LAN communication will
    be definetely penalized, and if your broadband connection is above 2Mbps
    than you won't get full speed there (don't blame ISP after that). 2900
    series switch is find on the other hand.

    I'd suggest you to build your network in way that you can quickly insert
    2500 when you want to experiment and have it off when you need performance
    of your network.

    Kind regards,
    iLya
     
    Charlie Root, Mar 19, 2006
    #5
  6. chrisadatl

    chrisadatl Guest

    Thank you for all the replies so far, I will post the version files
    on for both pieces of hardware soon.

    I really want to get to know this equipment and are really interested
    in it...

    Thanks alot for all the help..
     
    chrisadatl, Mar 20, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. aligurhan
    Replies:
    3
    Views:
    444
    Yddap
    Feb 13, 2004
  2. Rick

    Thanks, thanks a lot

    Rick, May 5, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    509
  3. Niall
    Replies:
    2
    Views:
    592
    Parko
    Nov 26, 2004
  4. blind
    Replies:
    2
    Views:
    402
    Pug Fugley
    Dec 11, 2004
  5. Giuen
    Replies:
    0
    Views:
    1,017
    Giuen
    Sep 12, 2008
Loading...

Share This Page