Cisco 1811 Router VLAN Question

Discussion in 'Cisco' started by Tom, May 23, 2008.

  1. Tom

    Tom Guest

    Hello,

    I have a Cisco 1811 IOS 12.4(6)T11. It has two L3 ports and eight L2
    ports. Is it possible to use the L2 ports for separate networks?
    For example,
    int f0 is 10.1.4.22
    int f1 is 10.10.2.1

    Is it possible to assign IP's (networks) to the other
    interfaces...example:

    int f2 10.10.3.1
    int f3 10.10.4.1
    int f4 10.10.5.1

    I'm hoping this can somehow be done via VLAN's. If you can please
    recommend an example that I can look at or if it's even possible
    please let me know.

    Thanks in advance:)

    BTW This is my current config...but secondary IP's will not work with
    my application:
    ========================================================
    Using 2349 out of 196600 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname lab_ospf
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool sdm-pool
    import all
    network 10.10.10.0 255.255.255.248
    default-router 10.10.10.1
    lease 0 2
    !
    no ip domain lookup
    ip domain name yourdomain.com
    !
    crypto pki trustpoint TP-self-signed-2176816363
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2176816363
    revocation-check none
    rsakeypair TP-self-signed-2176816363
    !
    crypto pki certificate chain TP-self-signed-2176816363
    certificate self-signed 01 nvram:IOS-Self-Sig#3301.cer
    username cisco privilege 15 secret 5 $1$4NMd$SQ.k0cQsa5kaqCt3bNXOO0
    username it privilege 15 secret 5 $1$9q36$O.XeN1qwbCJE9zvkm1v5w.
    !
    interface FastEthernet0
    ip address 10.1.4.22 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet1
    ip address 10.10.3.1 255.255.255.0 secondary
    ip address 10.10.4.1 255.255.255.0 secondary
    ip address 10.10.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    !
    interface FastEthernet5
    !
    interface FastEthernet6
    !
    interface FastEthernet7
    !
    interface FastEthernet8
    !
    interface FastEthernet9
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
    no ip address
    ip tcp adjust-mss 1452
    !
    interface Async1
    no ip address
    encapsulation slip
    !
    router ospf 100
    log-adjacency-changes
    network 10.10.2.0 0.0.0.255 area 0
    network 10.10.3.0 0.0.0.255 area 0
    network 10.10.4.0 0.0.0.255 area 0
    !
    ip route 172.20.1.0 255.255.255.0 10.1.4.1
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    no cdp run
    !
    control-plane
    !
    line con 0
    login local
    line 1
    modem InOut
    stopbits 1
    speed 115200
    flowcontrol hardware
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    line vty 5 15
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    !
    !
    webvpn context Default_context
    ssl authenticate verify all
    !
    no inservice
    end
    Tom, May 23, 2008
    #1
    1. Advertising

  2. Tom

    Scott Guest

    The 1811 supports up to 8 VLANS.

    switch(config)#vlan 2
    switch(config-vlan)#name VLAN2
    switch(config-vlan)#int fa 2
    switch(config-if)#switchport access vlan 2
    switch(config-if)#ip address 10.10.3.1 255.255.255.0

    Verify which ports are assigned to which vlan
    switch#sh vlan
    Scott, May 23, 2008
    #2
    1. Advertising

  3. Tom

    Tom Guest

    On May 23, 3:49 pm, Scott <> wrote:
    > The 1811 supports up to 8 VLANS.
    >
    > switch(config)#vlan 2
    > switch(config-vlan)#name VLAN2
    > switch(config-vlan)#int fa 2
    > switch(config-if)#switchport access vlan 2
    > switch(config-if)#ip address 10.10.3.1 255.255.255.0
    >
    > Verify which ports are assigned to which vlan
    > switch#sh vlan


    Interesting...I had tried this before, but it seem not to work
    properly. Also the command "show vlan" fails with ambigous command,
    but I can go to vlan database and type show and see the vlans.

    How do I know which port vlan 2 is assigned??? For example, will it
    be assigned to f2, f3?...I would think f2 would need to somehow be
    associated with vlan 2??? For example, if I want to assign 10.10.4.1
    to f3 using vlan 3, how does the router associate that port with
    vlan3...etc...

    Thanks:)
    Tom, May 23, 2008
    #3
  4. Tom

    Trendkill Guest

    On May 23, 6:57 pm, Tom <> wrote:
    > On May 23, 3:49 pm, Scott <> wrote:
    >
    > > The 1811 supports up to 8 VLANS.

    >
    > > switch(config)#vlan 2
    > > switch(config-vlan)#name VLAN2
    > > switch(config-vlan)#int fa 2
    > > switch(config-if)#switchport access vlan 2
    > > switch(config-if)#ip address 10.10.3.1 255.255.255.0

    >
    > > Verify which ports are assigned to which vlan
    > > switch#sh vlan

    >
    > Interesting...I had tried this before, but it seem not to work
    > properly.  Also the command "show vlan" fails with ambigous command,
    > but I can go to vlan database and type show and see the vlans.
    >
    > How do I know which port vlan 2 is assigned???  For example, will it
    > be assigned to f2, f3?...I would think f2 would need to somehow be
    > associated with vlan 2???  For example, if I want to assign 10.10.4.1
    > to f3 using vlan 3, how does the router associate that port with
    > vlan3...etc...
    >
    > Thanks:)


    Two very different things. Putting a port as an access port in vlan 3
    immediately makes it a switched port. Which means that whatever you
    connect to that router must be addressed in vlan 3's subnet, but the
    router will not have an IP on that port. On a l3 switch, show vlan
    will tell you what ports are in what vlans, you just need to find the
    proper command for this router. Now, if you want to create vlans and
    then assign them to layer 2 ports, this kind of eliminates the need to
    have a routed port in the same vlan. The SVI is the gateway for the
    subnet, and your routed ports are used for building a neighbor/
    relationship with another router to advertise whatever subnets or
    vlans are off the 1811. Either way, you should not have a case where
    you are assigning an IP to a switched port. You are assigning an IP
    to a SVI and putting ports in that vlan so that nodes connected to it
    can use that subnet/gateway.

    'Show int f0/2 switchport' or one of those might work perhaps for your
    show vlan question? I have never used the smaller cisco routers, but
    that is a command string on a l3 switch that shows a lot of
    information about trunks, etc.
    Trendkill, May 24, 2008
    #4
  5. Tom

    Guest

    On 24 May, 14:45, Trendkill <> wrote:
    > On May 23, 6:57 pm, Tom <> wrote:
    >
    >
    >
    >
    >
    > > On May 23, 3:49 pm, Scott <> wrote:

    >
    > > > The 1811 supports up to 8 VLANS.

    >
    > > > switch(config)#vlan 2
    > > > switch(config-vlan)#name VLAN2
    > > > switch(config-vlan)#int fa 2
    > > > switch(config-if)#switchport access vlan 2
    > > > switch(config-if)#ip address 10.10.3.1 255.255.255.0

    >
    > > > Verify which ports are assigned to which vlan
    > > > switch#sh vlan

    >
    > > Interesting...I had tried this before, but it seem not to work
    > > properly.  Also the command "show vlan" fails with ambigous command,
    > > but I can go to vlan database and type show and see the vlans.

    >
    > > How do I know which port vlan 2 is assigned???  For example, will it
    > > be assigned to f2, f3?...I would think f2 would need to somehow be
    > > associated with vlan 2???  For example, if I want to assign 10.10.4.1
    > > to f3 using vlan 3, how does the router associate that port with
    > > vlan3...etc...

    >
    > > Thanks:)

    >
    > Two very different things.  Putting a port as an access port in vlan 3
    > immediately makes it a switched port.  Which means that whatever you
    > connect to that router must be addressed in vlan 3's subnet, but the
    > router will not have an IP on that port.  On a l3 switch, show vlan
    > will tell you what ports are in what vlans, you just need to find the
    > proper command for this router.  Now, if you want to create vlans and
    > then assign them to layer 2 ports, this kind of eliminates the need to
    > have a routed port in the same vlan.  The SVI is the gateway for the
    > subnet, and your routed ports are used for building a neighbor/
    > relationship with another router to advertise whatever subnets or
    > vlans are off the 1811.  Either way, you should not have a case where
    > you are assigning an IP to a switched port.  You are assigning an IP
    > to a SVI and putting ports in that vlan so that nodes connected to it
    > can use that subnet/gateway.
    >
    > 'Show int f0/2 switchport' or one of those might work perhaps for your
    > show vlan question?  I have never used the smaller cisco routers, but
    > that is a command string on a l3 switch that shows a lot of
    > information about trunks, etc.- Hide quoted text -
    >


    The "switch modules in routers" vary a bit. I would guess that
    yours might be like a one or two port router with a 9 port HWIC
    ethernet module in it.

    If it is you can do something like

    create vlans 3, 4, 5, 6, 7, 8

    interface FastEthernet2
    sw mode access ! may or may not be needed
    sw access vl 2

    interface FastEthernet3
    sw mode access ! may or may not be needed
    sw access vl 3

    int vl 2
    ip address x.x.x.x
    no shut

    int vl 3
    ip address y.y.y.y
    no shut

    You create vlans either with

    conf t
    vlan 2
    vlan 3
    end

    or

    vlan dat
    vl 2
    vl 3
    exit
    Latter roughly; may have forgotten.
    You have to make a point of saving it anyway.
    Think it may prompt.

    On the 9 port HWIC it is not possible to
    assign an IP address directly to a port.

    Good luck.
    , May 26, 2008
    #5
  6. Tom

    Tom Guest

    On May 26, 1:48 pm, wrote:
    > On 24 May, 14:45, Trendkill <> wrote:
    >
    >
    >
    > > On May 23, 6:57 pm, Tom <> wrote:

    >
    > > > On May 23, 3:49 pm, Scott <> wrote:

    >
    > > > > The 1811 supports up to 8 VLANS.

    >
    > > > > switch(config)#vlan 2
    > > > > switch(config-vlan)#name VLAN2
    > > > > switch(config-vlan)#int fa 2
    > > > > switch(config-if)#switchport access vlan 2
    > > > > switch(config-if)#ip address 10.10.3.1 255.255.255.0

    >
    > > > > Verify which ports are assigned to which vlan
    > > > > switch#sh vlan

    >
    > > > Interesting...I had tried this before, but it seem not to work
    > > > properly.  Also the command "show vlan" fails with ambigous command,
    > > > but I can go to vlan database and type show and see the vlans.

    >
    > > > How do I know which port vlan 2 is assigned???  For example, will it
    > > > be assigned to f2, f3?...I would think f2 would need to somehow be
    > > > associated with vlan 2???  For example, if I want to assign 10.10.4.1
    > > > to f3 using vlan 3, how does the router associate that port with
    > > > vlan3...etc...

    >
    > > > Thanks:)

    >
    > > Two very different things.  Putting a port as an access port in vlan 3
    > > immediately makes it a switched port.  Which means that whatever you
    > > connect to that router must be addressed in vlan 3's subnet, but the
    > > router will not have an IP on that port.  On a l3 switch, show vlan
    > > will tell you what ports are in what vlans, you just need to find the
    > > proper command for this router.  Now, if you want to create vlans and
    > > then assign them to layer 2 ports, this kind of eliminates the need to
    > > have a routed port in the same vlan.  The SVI is the gateway for the
    > > subnet, and your routed ports are used for building a neighbor/
    > > relationship with another router to advertise whatever subnets or
    > > vlans are off the 1811.  Either way, you should not have a case where
    > > you are assigning an IP to a switched port.  You are assigning an IP
    > > to a SVI and putting ports in that vlan so that nodes connected to it
    > > can use that subnet/gateway.

    >
    > > 'Show int f0/2 switchport' or one of those might work perhaps for your
    > > show vlan question?  I have never used the smaller cisco routers, but
    > > that is a command string on a l3 switch that shows a lot of
    > > information about trunks, etc.- Hide quoted text -

    >
    > The "switch modules in routers" vary a bit. I would guess that
    > yours might be like a one or two port router with a 9 port HWIC
    > ethernet module in it.
    >
    > If it is you can do something like
    >
    > create vlans 3, 4, 5, 6, 7, 8
    >
    > interface FastEthernet2
    > sw mode access  ! may or may not be needed
    > sw access vl 2
    >
    > interface FastEthernet3
    > sw mode access  ! may or may not be needed
    > sw access vl 3
    >
    > int vl 2
    > ip address x.x.x.x
    > no shut
    >
    > int vl 3
    > ip address y.y.y.y
    > no shut
    >
    > You create vlans either with
    >
    > conf t
    > vlan 2
    > vlan 3
    > end
    >
    > or
    >
    > vlan dat
    > vl 2
    > vl 3
    > exit
    > Latter roughly; may have forgotten.
    > You have to make a point of saving it anyway.
    > Think it may prompt.
    >
    > On the 9 port HWIC it is not possible to
    > assign an IP address directly to a port.
    >
    > Good luck.


    Thank everyone for the great feedback and comments!! Really
    appreciated!
    Tom, May 27, 2008
    #6
  7. Tom

    Tom Guest

    On May 26, 1:48 pm, wrote:
    > On 24 May, 14:45, Trendkill <> wrote:
    >
    >
    >
    > > On May 23, 6:57 pm, Tom <> wrote:

    >
    > > > On May 23, 3:49 pm, Scott <> wrote:

    >
    > > > > The 1811 supports up to 8 VLANS.

    >
    > > > > switch(config)#vlan 2
    > > > > switch(config-vlan)#name VLAN2
    > > > > switch(config-vlan)#int fa 2
    > > > > switch(config-if)#switchport access vlan 2
    > > > > switch(config-if)#ip address 10.10.3.1 255.255.255.0

    >
    > > > > Verify which ports are assigned to which vlan
    > > > > switch#sh vlan

    >
    > > > Interesting...I had tried this before, but it seem not to work
    > > > properly.  Also the command "show vlan" fails with ambigous command,
    > > > but I can go to vlan database and type show and see the vlans.

    >
    > > > How do I know which port vlan 2 is assigned???  For example, will it
    > > > be assigned to f2, f3?...I would think f2 would need to somehow be
    > > > associated with vlan 2???  For example, if I want to assign 10.10.4.1
    > > > to f3 using vlan 3, how does the router associate that port with
    > > > vlan3...etc...

    >
    > > > Thanks:)

    >
    > > Two very different things.  Putting a port as an access port in vlan 3
    > > immediately makes it a switched port.  Which means that whatever you
    > > connect to that router must be addressed in vlan 3's subnet, but the
    > > router will not have an IP on that port.  On a l3 switch, show vlan
    > > will tell you what ports are in what vlans, you just need to find the
    > > proper command for this router.  Now, if you want to create vlans and
    > > then assign them to layer 2 ports, this kind of eliminates the need to
    > > have a routed port in the same vlan.  The SVI is the gateway for the
    > > subnet, and your routed ports are used for building a neighbor/
    > > relationship with another router to advertise whatever subnets or
    > > vlans are off the 1811.  Either way, you should not have a case where
    > > you are assigning an IP to a switched port.  You are assigning an IP
    > > to a SVI and putting ports in that vlan so that nodes connected to it
    > > can use that subnet/gateway.

    >
    > > 'Show int f0/2 switchport' or one of those might work perhaps for your
    > > show vlan question?  I have never used the smaller cisco routers, but
    > > that is a command string on a l3 switch that shows a lot of
    > > information about trunks, etc.- Hide quoted text -

    >
    > The "switch modules in routers" vary a bit. I would guess that
    > yours might be like a one or two port router with a 9 port HWIC
    > ethernet module in it.
    >
    > If it is you can do something like
    >
    > create vlans 3, 4, 5, 6, 7, 8
    >
    > interface FastEthernet2
    > sw mode access  ! may or may not be needed
    > sw access vl 2
    >
    > interface FastEthernet3
    > sw mode access  ! may or may not be needed
    > sw access vl 3
    >
    > int vl 2
    > ip address x.x.x.x
    > no shut
    >
    > int vl 3
    > ip address y.y.y.y
    > no shut
    >
    > You create vlans either with
    >
    > conf t
    > vlan 2
    > vlan 3
    > end
    >
    > or
    >
    > vlan dat
    > vl 2
    > vl 3
    > exit
    > Latter roughly; may have forgotten.
    > You have to make a point of saving it anyway.
    > Think it may prompt.
    >
    > On the 9 port HWIC it is not possible to
    > assign an IP address directly to a port.
    >
    > Good luck.


    Wow! This worked! Thanks Trendkill!!!
    Tom, May 27, 2008
    #7
  8. Tom

    Tippmann

    Joined:
    May 25, 2012
    Messages:
    1
    Ok this worked perfect on the switch but however i will no be able to create sub interfaces on my layer 3 ports because the ups are going to overlap. can i get any help with this?? thank you in advance
    Tippmann, May 25, 2012
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MdV
    Replies:
    0
    Views:
    3,672
  2. Joel
    Replies:
    0
    Views:
    3,217
  3. James Coldwind

    Switch ports on a 1811 router

    James Coldwind, Oct 24, 2006, in forum: Cisco
    Replies:
    0
    Views:
    394
    James Coldwind
    Oct 24, 2006
  4. giligan
    Replies:
    1
    Views:
    1,204
    Charles N Wyble
    Jun 5, 2008
  5. Replies:
    0
    Views:
    5,236
Loading...

Share This Page