CISCO 1801 DNS problem

Discussion in 'Hardware' started by marsav, Jun 14, 2009.

  1. marsav

    marsav

    Joined:
    Jun 14, 2009
    Messages:
    1
    Hi, Apolgies first:

    1) I am totally new to Cisco set-up! - but think I have done ok to get this far!
    2) Sorry if this is the wrong board.

    My problem is as follows

    I have set up the router to connect to the ISP.
    1) From the CLI I can ping any internet address and get a valid response.
    2) I cannot ping a domain name from the windows command propmt but can ping an Internet IP Address
    3) IE and firefox cannot resolve domain names but can access the websites direct through IP Address.

    My ISP is BTIreland formally esatclear

    So I think I have my connection setup ok, but for some reason I just cannot resolve through the DNS servers from windows. My running config is as follows:

    show running-config
    Building configuration...

    Current configuration : 5189 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname becadmin
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 51200 warnings
    enable secret 5 $1$e7cu$dIl2pjVjEDMpClCI7gteS0
    !
    no aaa new-model
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    !
    crypto pki trustpoint TP-self-signed-952721997
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-952721997
    revocation-check none
    rsakeypair TP-self-signed-952721997
    !
    !
    crypto pki certificate chain TP-self-signed-952721997
    certificate self-signed 01
    3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 39353237 32313939 37301E17 0D303930 36313431 39323535
    375A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
    532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3935 32373231
    39393730 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
    A6DDB3D9 5D85A81A 07C9C865 B831A0F4 09A3C0D3 C65899C2 6EF3D031 C1750FDE
    2D779295 40336EE4 2661400E 151138F5 5FBBBDEF F199DC2D 96342005 A7C2CC43
    CF03BA9C 2DD8A160 E53A8A7E 0D962539 0AF6DC1D 68A357A6 3D5A2C8B 49C83EC6
    645E51AC D58BE417 A6783684 BD313EE7 990AAA5D 8B6071EC 1EDD31FA 939EB39D
    02030100 01A36830 66300F06 03551D13 0101FF04 05300301 01FF3013 0603551D
    11040C30 0A820862 65636164 6D696E30 1F060355 1D230418 30168014 703695AF
    8668646E 2DAB1FE4 E010857B CE560152 301D0603 551D0E04 16041470 3695AF86
    68646E2D AB1FE4E0 10857BCE 56015230 0D06092A 864886F7 0D010104 05000381
    81003C42 ACE01ED1 19891DFB 61A7506F 2C5E3A9E E1070A34 357E7D48 1EC6D6E6
    232DAA0A 112D07C4 C477DE69 594C7113 D936D82E C9137C8B 8FAF15A5 587850F8
    EC67B51F 83C87E0A 8715F584 92BB331C 99D3EBAB FC76EEE9 51B99EB6 06D32445
    105BA16B 79B643E7 71A9EDD9 E456351B 9F68A9D7 43F6A0A1 C6A2394C 4EF0C746 33CC
    quit
    dot11 syslog
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.2.1 192.168.2.49
    ip dhcp excluded-address 192.168.2.100 192.168.2.254
    !
    ip dhcp pool sdm-pool1
    import all
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.1
    !
    !
    ip domain name ieunet.ie
    ip name-server 192.111.39.1
    ip name-server 192.111.39.4
    !
    multilink bundle-name authenticated
    !
    !
    username XXXXXXXX privilege 15 secret 5 XXXXXXXX
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0
    no ip address
    duplex auto
    speed auto
    !
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    !
    interface FastEthernet5
    !
    interface FastEthernet6
    !
    interface FastEthernet7
    !
    interface FastEthernet8
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    description $ES_WAN$
    pvc 8/35
    pppoe-client dial-pool-number 1
    !
    !
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-FE 1$$ES_LAN$
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1412
    !
    interface Dialer0
    ip address negotiated
    ip mtu 1452
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname xxxxxx@btbb
    ppp chap password 0 XXXXXXXX
    ppp multilink
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0 permanent
    !
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat pool Internet 192.168.2.1 192.168.2.254 netmask 255.255.255.0
    ip nat inside source list 1 interface Dialer0 overload
    ip nat outside source list 1 pool Internet
    !
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.2.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    !
    !
    !
    !
    control-plane
    !
    banner exec ^C
    % Password expiration warning.
    -----------------------------------------------------------------------

    Cisco Router and Security Device Manager (SDM) is installed on this device and
    it provides the default username "cisco" for one-time use. If you have already

    used the username "cisco" to login to the router and your IOS image supports the

    "one-time" user option, then this username has already expired. You will not be

    able to login to the router with this username after you exit this session.

    It is strongly suggested that you create a new username with a privilege level
    of 15 using the following command.

    username <myuser> privilege 15 secret 0 <mypassword>

    Replace <myuser> and <mypassword> with the username and password you want to
    use.

    -----------------------------------------------------------------------
    ^C
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    line vty 5 15
    privilege level 15
    login local
    transport input telnet ssh
    !
    end


    Interfaces are as follows:

    show interface atm0
    ATM0 is down, line protocol is down
    Hardware is MPC ATMSAR (with Alcatel ADSL Module)
    MTU 4470 bytes, sub MTU 4470, BW 672 Kbit/sec, DLY 540 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ATM, loopback not set
    Encapsulation(s): AAL5 AAL2, PVC mode
    23 maximum active VCs, 1024 VCs per VP, 0 current VCCs
    VC Auto Creation Disabled.
    VC idle disconnect time: 300 seconds
    Last input 00:12:04, output 00:09:26, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: Per VC Queueing
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    825 packets input, 613261 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    836 packets output, 108595 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    show interface atm0.1
    ATM0.1 is down, line protocol is down
    Hardware is MPC ATMSAR (with Alcatel ADSL Module)
    Description: $ES_WAN$
    MTU 4470 bytes, BW 672 Kbit/sec, DLY 540 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ATM
    834 packets input, 619393 bytes
    836 packets output, 108595 bytes
    0 OAM cells input, 0 OAM cells output
    AAL5 CRC errors : 0
    AAL5 SAR Timeouts : 0
    AAL5 Oversized SDUs : 0
    Last clearing of "show interface" counters never

    ATM is down at the moment while I type this using a different router!!!

    show interface dialer0
    Dialer0 is up, line protocol is up (spoofing)
    Hardware is Unknown
    Internet address will be negotiated using IPCP
    MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    DTR is pulsed for 1 seconds on reset
    Last input never, output never, output hang never
    Last clearing of "show interface" counters 01:06:35
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    792 packets input, 584485 bytes
    816 packets output, 76791 bytes

    Hope I have provided enough info. Any help greatly appreciated.
    marsav, Jun 14, 2009
    #1
    1. Advertising

  2. marsav

    adeelasher

    Joined:
    Jun 29, 2009
    Messages:
    19
    You need to add dns-server addresses to your DHCP pool which you have configured for your machines.

    ip dhcp pool sdm-pool1
    import all
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.1
    dns-server 192.111.39.1
    dns-server 192.111.39.4

    Then your machines will also show these DNS addresses in ipconfig /all output.
    If it resolve your issue please let me know.
    Regards,
    Adeel Asher
    adeelasher, Jun 29, 2009
    #2
    1. Advertising

  3. marsav

    adeelasher

    Joined:
    Jun 29, 2009
    Messages:
    19
    Re:

    Your router is not assigning dns server ip addresses to your machine because it is not configured to do so..your dhcp configuration need to more entries..

    !
    ip dhcp pool sdm-pool1
    import all
    network 192.168.2.0 255.255.255.0
    default-router 192.168.2.1
    dns-server 192.111.39.1
    dns-server 192.111.39.4
    !
    adeelasher, Jul 5, 2009
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. kokba@menara.ma

    ADSL ET RNIS SUR CISCO 1801

    kokba@menara.ma, Oct 10, 2005, in forum: Cisco
    Replies:
    0
    Views:
    559
    kokba@menara.ma
    Oct 10, 2005
  2. kokba@menara.ma

    ADSL ET RNIS SUR CISCO 1801

    kokba@menara.ma, Oct 10, 2005, in forum: Cisco
    Replies:
    0
    Views:
    516
    kokba@menara.ma
    Oct 10, 2005
  3. kokba@menara.ma

    ADSL ET RNIS SUR CISCO 1801

    kokba@menara.ma, Oct 10, 2005, in forum: Cisco
    Replies:
    1
    Views:
    1,465
    anybody43@hotmail.com
    Oct 10, 2005
  4. Masterx81
    Replies:
    0
    Views:
    824
    Masterx81
    Mar 5, 2007
  5. Masterx81

    Cisco 1801 VPN Problem

    Masterx81, Mar 9, 2007, in forum: Cisco
    Replies:
    2
    Views:
    2,803
    Masterx81
    Mar 9, 2007
Loading...

Share This Page