Cisco 1721 ATM nightmare

Discussion in 'Cisco' started by andrew@millenniumstaff.co.uk, Sep 8, 2006.

  1. Guest

    Hi
    I am trying to get a 1721 atm interface to work with BT and I am not
    having much luck....... all I am getting is the Vi3 protocol not coming
    up and a continuous debug about "PPP: Authorization NOT required"

    Here's the relavant bits of config any help gratfully received:

    Current configuration : 4378 bytes
    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname hostname
    !
    logging queue-limit 100
    enable secret 5 password
    !
    username root password 7 password
    aaa new-model
    !
    !
    aaa authentication login VTY local-case
    aaa session-id common
    ip subnet-zero
    no ip source-route
    !
    !
    ip domain name .com
    !
    no ip bootp server
    ip inspect max-incomplete low 200
    ip inspect max-incomplete high 400
    ip inspect one-minute low 50
    ip inspect one-minute high 100
    ip inspect name OUTBOUNDTRAFFIC tcp
    ip inspect name OUTBOUNDTRAFFIC udp
    ip inspect name OUTBOUNDTRAFFIC ftp
    ip inspect name OUTBOUNDTRAFFIC icmp
    ip audit notify log
    ip audit po max-events 100
    !
    !
    !!
    interface ATM0
    ip address dhcp
    ip mtu 1500
    no atm ilmi-keepalive
    pvc 0/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface Ethernet0
    no ip address
    shutdown
    !
    interface FastEthernet0
    ip address 10.x.x.x 255.255.255.0
    ip nat inside
    speed auto
    !
    interface Dialer1
    ip address 217.x.x.x 255.255.255.248
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callout
    ppp chap hostname hostname
    ppp chap password 7 password
    !
    !
    ip nat inside source list NAT2 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    dialer-list 1 protocol ip permit
    !

    line con 0
    line aux 0
    line vty 0 4
    access-class TELNETSSH in
    login authentication VTY
    transport input telnet ssh
    !
    no scheduler allocate
    end

    Interface IP-Address OK? Method Status Protocol

    Virtual-Access3 unassigned YES unset up down
    ATM0 unassigned YES manual up up
    ATM0.1 unassigned YES unset up up
    Dialer0 217.x.x.x YES manual up up
     
    , Sep 8, 2006
    #1
    1. Advertising

  2. Guest

    wrote:
    > Hi
    > I am trying to get a 1721 atm interface to work with BT and I am not
    > having much luck....... all I am getting is the Vi3 protocol not coming
    > up and a continuous debug about "PPP: Authorization NOT required"
    >
    > Here's the relavant bits of config any help gratfully received:
    >
    > Current configuration : 4378 bytes
    > !
    > version 12.2
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > service password-encryption
    > !
    > hostname hostname
    > !
    > logging queue-limit 100
    > enable secret 5 password
    > !
    > username root password 7 password
    > aaa new-model
    > !
    > !
    > aaa authentication login VTY local-case
    > aaa session-id common
    > ip subnet-zero
    > no ip source-route
    > !
    > !
    > ip domain name .com
    > !
    > no ip bootp server
    > ip inspect max-incomplete low 200
    > ip inspect max-incomplete high 400
    > ip inspect one-minute low 50
    > ip inspect one-minute high 100
    > ip inspect name OUTBOUNDTRAFFIC tcp
    > ip inspect name OUTBOUNDTRAFFIC udp
    > ip inspect name OUTBOUNDTRAFFIC ftp
    > ip inspect name OUTBOUNDTRAFFIC icmp
    > ip audit notify log
    > ip audit po max-events 100
    > !
    > !
    > !!
    > interface ATM0
    > ip address dhcp
    > ip mtu 1500
    > no atm ilmi-keepalive
    > pvc 0/35
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > dsl operating-mode auto
    > !
    > interface Ethernet0
    > no ip address
    > shutdown
    > !
    > interface FastEthernet0
    > ip address 10.x.x.x 255.255.255.0
    > ip nat inside
    > speed auto
    > !
    > interface Dialer1
    > ip address 217.x.x.x 255.255.255.248
    > ip nat outside
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > ppp authentication chap callout
    > ppp chap hostname hostname
    > ppp chap password 7 password
    > !
    > !
    > ip nat inside source list NAT2 interface Dialer1 overload
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1
    > no ip http server
    > no ip http secure-server
    > !
    > !
    > !
    > !
    > dialer-list 1 protocol ip permit
    > !
    >
    > line con 0
    > line aux 0
    > line vty 0 4
    > access-class TELNETSSH in
    > login authentication VTY
    > transport input telnet ssh
    > !
    > no scheduler allocate
    > end
    >
    > Interface IP-Address OK? Method Status Protocol
    >
    > Virtual-Access3 unassigned YES unset up down
    > ATM0 unassigned YES manual up up
    > ATM0.1 unassigned YES unset up up
    > Dialer0 217.x.x.x YES manual up up


    Well for starters you seem to have the wrong VPI/VCI.


    You want something like these on the
    ATM/dialer

    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    dsl operating-mode auto
    !
    !

    interface Dialer1
    description we.keep.note.of.address.here
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname hostname
    ppp chap password 7 password


    Even with a static IP we let it negotiate.

    Obviously you need to define the ACL for NAT
    or maybe you cut it out?
     
    , Sep 8, 2006
    #2
    1. Advertising

  3. podzol

    Joined:
    Sep 7, 2006
    Messages:
    2
    Thanks

    Thanks for the help, you were spot on with the VPI/VCI but I can't understand why on a 2wire router/modem it was set to 0/35?????

    Thanks again
     
    podzol, Sep 10, 2006
    #3
  4. Guest

    wrote:
    > wrote:
    > > Hi
    > > I am trying to get a 1721 atm interface to work with BT and I am not
    > > having much luck....... all I am getting is the Vi3 protocol not coming
    > > up and a continuous debug about "PPP: Authorization NOT required"
    > >
    > > Here's the relavant bits of config any help gratfully received:
    > >
    > > Current configuration : 4378 bytes
    > > !
    > > version 12.2
    > > service timestamps debug datetime msec
    > > service timestamps log datetime msec
    > > service password-encryption
    > > !
    > > hostname hostname
    > > !
    > > logging queue-limit 100
    > > enable secret 5 password
    > > !
    > > username root password 7 password
    > > aaa new-model
    > > !
    > > !
    > > aaa authentication login VTY local-case
    > > aaa session-id common
    > > ip subnet-zero
    > > no ip source-route
    > > !
    > > !
    > > ip domain name .com
    > > !
    > > no ip bootp server
    > > ip inspect max-incomplete low 200
    > > ip inspect max-incomplete high 400
    > > ip inspect one-minute low 50
    > > ip inspect one-minute high 100
    > > ip inspect name OUTBOUNDTRAFFIC tcp
    > > ip inspect name OUTBOUNDTRAFFIC udp
    > > ip inspect name OUTBOUNDTRAFFIC ftp
    > > ip inspect name OUTBOUNDTRAFFIC icmp
    > > ip audit notify log
    > > ip audit po max-events 100
    > > !
    > > !
    > > !!
    > > interface ATM0
    > > ip address dhcp
    > > ip mtu 1500
    > > no atm ilmi-keepalive
    > > pvc 0/35
    > > encapsulation aal5mux ppp dialer
    > > dialer pool-member 1
    > > !
    > > dsl operating-mode auto
    > > !
    > > interface Ethernet0
    > > no ip address
    > > shutdown
    > > !
    > > interface FastEthernet0
    > > ip address 10.x.x.x 255.255.255.0
    > > ip nat inside
    > > speed auto
    > > !
    > > interface Dialer1
    > > ip address 217.x.x.x 255.255.255.248
    > > ip nat outside
    > > encapsulation ppp
    > > dialer pool 1
    > > dialer-group 1
    > > ppp authentication chap callout
    > > ppp chap hostname hostname
    > > ppp chap password 7 password
    > > !
    > > !
    > > ip nat inside source list NAT2 interface Dialer1 overload
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 Dialer1
    > > no ip http server
    > > no ip http secure-server
    > > !
    > > !
    > > !
    > > !
    > > dialer-list 1 protocol ip permit
    > > !
    > >
    > > line con 0
    > > line aux 0
    > > line vty 0 4
    > > access-class TELNETSSH in
    > > login authentication VTY
    > > transport input telnet ssh
    > > !
    > > no scheduler allocate
    > > end
    > >
    > > Interface IP-Address OK? Method Status Protocol
    > >
    > > Virtual-Access3 unassigned YES unset up down
    > > ATM0 unassigned YES manual up up
    > > ATM0.1 unassigned YES unset up up
    > > Dialer0 217.x.x.x YES manual up up

    >
    > Well for starters you seem to have the wrong VPI/VCI.
    >
    >
    > You want something like these on the
    > ATM/dialer
    >
    > interface ATM0
    > no ip address
    > no ip mroute-cache
    > no atm ilmi-keepalive
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > dsl operating-mode auto
    > !
    > !
    >
    > interface Dialer1
    > description we.keep.note.of.address.here
    > ip address negotiated
    > ip nat outside
    > ip virtual-reassembly
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > no cdp enable
    > ppp authentication chap callin
    > ppp chap hostname hostname
    > ppp chap password 7 password
    >
    >
    > Even with a static IP we let it negotiate.
    >
    > Obviously you need to define the ACL for NAT
    > or maybe you cut it out?


    Thanks for help it was the VPI/VCI
     
    , Sep 11, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Iskander
    Replies:
    13
    Views:
    4,987
    Iskander
    Feb 23, 2005
  2. AM
    Replies:
    0
    Views:
    464
  3. hlep
    Replies:
    0
    Views:
    2,893
  4. podzol

    Cisco 1721 ATM nightmare

    podzol, Sep 7, 2006, in forum: Cisco
    Replies:
    0
    Views:
    470
    podzol
    Sep 7, 2006
  5. Replies:
    0
    Views:
    415
Loading...

Share This Page