Cisco 1721 and routing not working correctly

Discussion in 'Cisco' started by Brian, Oct 24, 2003.

  1. Brian

    Brian Guest

    We have a cisco 1721 router on a customers end. For some reason the
    following statement does not work

    ip route 0.0.0.0 0.0.0.0 gateway

    We've had to put it in this way and it works fine.

    ip route 0.0.0.0 128.0.0.0 gateway
    ip route 128.0.0.0 128.0.0.0 gateway

    Anyone know why this is?
     
    Brian, Oct 24, 2003
    #1
    1. Advertising

  2. On Fri, 24 Oct 2003 15:49:46 -0400, Brian wrote:
    > We have a cisco 1721 router on a customers end. For some reason the
    > following statement does not work
    >
    > ip route 0.0.0.0 0.0.0.0 gateway
    >
    > We've had to put it in this way and it works fine.
    >
    > ip route 0.0.0.0 128.0.0.0 gateway
    > ip route 128.0.0.0 128.0.0.0 gateway
    >
    > Anyone know why this is?


    There was already a default route ?

    Please provide the full configuration.

    --
    Jesper Skriver, CCIE #5456, FreeBSD committer
     
    Jesper Skriver, Oct 24, 2003
    #2
    1. Advertising

  3. Brian

    Brian Guest

    This config will NOT WORK: (see below for working config)
    --------------------------------------------------
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname xxxxxxxxx
    !
    security authentication failure rate 10 log
    security passwords min-length 6
    logging buffered 4096 debugging
    enable secret xxxxxxxxxxxxxxx
    enable password xxxxxxxxxx
    !
    username xxxxxx password xxxxxxxxxxxx
    aaa new-model
    !
    !
    aaa authentication login local_auth local
    aaa session-id common
    ip subnet-zero
    no ip source-route
    no ip gratuitous-arps
    !
    !
    !
    no ip bootp server
    ip cef
    !
    !
    !
    !
    interface FastEthernet0
    ip address xxxxxxxxxxx
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    speed auto
    half-duplex
    no cdp enable
    !
    interface Serial0
    ip address xxxxxxxxxxxxxxxxxxx
    ip access-group autosec_complete_bogon in
    ip verify unicast source reachable-via rx 100
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation ppp
    service-module t1 timeslots 1-6
    !
    ip default-gateway xxxxxxxxxxx
    ip classless
    ip route 0.0.0.0 0.0.0.0 xxxxxxxxxx
    no ip http server
    !
    !
    ip access-list extended autosec_complete_bogon

    <<<<snip>>>>

    logging trap debugging
    logging facility local2
    access-list 100 permit udp any any eq bootpc
    dialer-list 1 protocol ip permit
    no cdp run
    radius-server authorization permit missing Service-Type
    !
    line con 0
    login authentication local_auth
    transport output telnet
    line aux 0
    login authentication local_auth
    transport output telnet
    line vty 0 4
    password xxxxxxxxxxxxxxx
    login authentication local_auth
    transport input telnet
    !
    no scheduler allocate
    !
    end
    -------------------------------------------------------
    This config WILL WORK:

    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname xxxxxxxxx
    !
    security authentication failure rate 10 log
    security passwords min-length 6
    logging buffered 4096 debugging
    enable secret xxxxxxxxxxxxxxx
    enable password xxxxxxxxxx
    !
    username xxxxxx password xxxxxxxxxxxx
    aaa new-model
    !
    !
    aaa authentication login local_auth local
    aaa session-id common
    ip subnet-zero
    no ip source-route
    no ip gratuitous-arps
    !
    !
    !
    no ip bootp server
    ip cef
    !
    !
    !
    !
    interface FastEthernet0
    ip address xxxxxxxxxxx
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    speed auto
    half-duplex
    no cdp enable
    !
    interface Serial0
    ip address xxxxxxxxxxxxxxxxxxx
    ip access-group autosec_complete_bogon in
    ip verify unicast source reachable-via rx 100
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation ppp
    service-module t1 timeslots 1-6
    !
    ip default-gateway xxxxxxxxxxx
    ip classless
    ip route 0.0.0.0 128.0.0.0 xxxxxxxxxx
    ip route 128.0.0.0 128.0.0.0 xxxxxxxxxxxxxx
    no ip http server
    !
    !
    ip access-list extended autosec_complete_bogon

    <<<<snip>>>>

    logging trap debugging
    logging facility local2
    access-list 100 permit udp any any eq bootpc
    dialer-list 1 protocol ip permit
    no cdp run
    radius-server authorization permit missing Service-Type
    !
    line con 0
    login authentication local_auth
    transport output telnet
    line aux 0
    login authentication local_auth
    transport output telnet
    line vty 0 4
    password xxxxxxxxxxxxxxx
    login authentication local_auth
    transport input telnet
    !
    no scheduler allocate
    !
    end
     
    Brian, Oct 24, 2003
    #3
  4. On Fri, 24 Oct 2003 17:21:07 -0400, Brian wrote:
    > This config will NOT WORK: (see below for working config)
    > --------------------------------------------------
    > no service pad
    > service tcp-keepalives-in
    > service tcp-keepalives-out
    > service timestamps debug datetime msec localtime show-timezone
    > service timestamps log datetime msec localtime show-timezone
    > service password-encryption
    > service sequence-numbers
    > !
    > hostname xxxxxxxxx
    > !
    > security authentication failure rate 10 log
    > security passwords min-length 6
    > logging buffered 4096 debugging
    > enable secret xxxxxxxxxxxxxxx
    > enable password xxxxxxxxxx
    > !
    > username xxxxxx password xxxxxxxxxxxx
    > aaa new-model
    > !
    > !
    > aaa authentication login local_auth local
    > aaa session-id common
    > ip subnet-zero
    > no ip source-route
    > no ip gratuitous-arps
    > !
    > !
    > !
    > no ip bootp server
    > ip cef
    > !
    > !
    > !
    > !
    > interface FastEthernet0
    > ip address xxxxxxxxxxx
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > speed auto
    > half-duplex
    > no cdp enable
    > !
    > interface Serial0
    > ip address xxxxxxxxxxxxxxxxxxx
    > ip access-group autosec_complete_bogon in
    > ip verify unicast source reachable-via rx 100


    For it to consider the default route, you need to use
    ip verify unicast source reachable-via rx allow-default 100

    --
    Jesper Skriver, CCIE #5456, FreeBSD committer
     
    Jesper Skriver, Oct 24, 2003
    #4
  5. Brian

    Brian Guest

    Thanks that worked.

    "Jesper Skriver" <> wrote in message
    news:...
    > On Fri, 24 Oct 2003 17:21:07 -0400, Brian wrote:
    > > This config will NOT WORK: (see below for working config)
    > > --------------------------------------------------
    > > no service pad
    > > service tcp-keepalives-in
    > > service tcp-keepalives-out
    > > service timestamps debug datetime msec localtime show-timezone
    > > service timestamps log datetime msec localtime show-timezone
    > > service password-encryption
    > > service sequence-numbers
    > > !
    > > hostname xxxxxxxxx
    > > !
    > > security authentication failure rate 10 log
    > > security passwords min-length 6
    > > logging buffered 4096 debugging
    > > enable secret xxxxxxxxxxxxxxx
    > > enable password xxxxxxxxxx
    > > !
    > > username xxxxxx password xxxxxxxxxxxx
    > > aaa new-model
    > > !
    > > !
    > > aaa authentication login local_auth local
    > > aaa session-id common
    > > ip subnet-zero
    > > no ip source-route
    > > no ip gratuitous-arps
    > > !
    > > !
    > > !
    > > no ip bootp server
    > > ip cef
    > > !
    > > !
    > > !
    > > !
    > > interface FastEthernet0
    > > ip address xxxxxxxxxxx
    > > no ip redirects
    > > no ip unreachables
    > > no ip proxy-arp
    > > speed auto
    > > half-duplex
    > > no cdp enable
    > > !
    > > interface Serial0
    > > ip address xxxxxxxxxxxxxxxxxxx
    > > ip access-group autosec_complete_bogon in
    > > ip verify unicast source reachable-via rx 100

    >
    > For it to consider the default route, you need to use
    > ip verify unicast source reachable-via rx allow-default 100
    >
    > --
    > Jesper Skriver, CCIE #5456, FreeBSD committer
     
    Brian, Oct 24, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Skybird
    Replies:
    1
    Views:
    4,155
    Skybird
    Apr 12, 2004
  2. Scooter
    Replies:
    1
    Views:
    900
    BradReeseCom
    Feb 25, 2005
  3. opietexas
    Replies:
    0
    Views:
    4,125
    opietexas
    Jul 6, 2006
  4. opietexas
    Replies:
    0
    Views:
    467
    opietexas
    Jul 6, 2006
  5. Ajar
    Replies:
    0
    Views:
    824
Loading...

Share This Page