Cisco 1721 ADSL (dynamic) + ISDN failover (is it possibile ??)

Discussion in 'Cisco' started by Marcus, Oct 11, 2004.

  1. Marcus

    Marcus Guest

    Hello

    I am struggling to set up an automatic ISDN failover on a 1721 router
    with a dynamic ADSL connection. The only workaround we have found,
    it's with a couple of scripts that manually bring up/down the related
    dialer interfaces. I wonder whether it is possible or not to manage
    this case. I post my configuration, any help is really appreciated.

    version 12.3
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname NTLONRTR01
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200 debugging
    logging console critical
    enable secret xxxxxxx
    !
    username xxxxxxx
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    no ip source-route
    !
    !
    ip tcp synwait-time 10
    ip domain name natorcapital.local
    !
    no ip bootp server
    ip cef
    !
    isdn switch-type basic-net3
    !
    !
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation ppp
    ip route-cache flow
    dialer pool-member 2
    isdn switch-type basic-net3
    !
    interface FastEthernet0
    description $FW_INSIDE$$ETH-LAN$$INTF-INFO-10/100 Ethernet$
    ip address 92.70.22.22 255.255.255.248
    ip access-group 100 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    ip tcp adjust-mss 1452
    speed 100
    full-duplex
    no cdp enable
    !
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxx
    ppp chap password yyyy
    !
    interface Dialer2
    ip address negotiated
    encapsulation ppp
    dialer pool 2
    dialer string 08456000444
    dialer-group 2
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxxx password yyyy
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http access-class 1
    ip http authentication local
    !
    !
    logging trap debugging
    access-list 1 remark Auto generated by SDM Management Access feature
    access-list 1 remark SDM_ACL Category=1
    access-list 1 permit 10.2.88.0 0.0.1.255
    access-list 1 permit 92.70.22.16 0.0.0.7
    access-list 100 remark Auto generated by SDM Management Access feature
    access-list 100 remark SDM_ACL Category=1
    access-list 100 permit tcp 10.2.88.0 0.0.1.255 host 92.70.22.22 eq
    telnet
    access-list 100 permit tcp 92.70.22.16 0.0.0.7 host 92.70.22.22 eq
    telnet
    access-list 100 permit tcp 10.2.88.0 0.0.1.255 host 92.70.22.22 eq 22
    access-list 100 permit tcp 92.70.22.16 0.0.0.7 host 92.70.22.22 eq 22
    access-list 100 permit tcp 10.2.88.0 0.0.1.255 host 92.70.22.22 eq www
    access-list 100 permit tcp 92.70.22.16 0.0.0.7 host 92.70.22.22 eq www
    access-list 100 permit tcp 10.2.88.0 0.0.1.255 host 92.70.22.22 eq cmd
    access-list 100 permit tcp 92.70.22.16 0.0.0.7 host 92.70.22.22 eq cmd
    access-list 100 deny tcp any host 92.70.22.22 eq telnet
    access-list 100 deny tcp any host 92.70.22.22 eq 22
    access-list 100 deny tcp any host 92.70.22.22 eq www
    access-list 100 deny tcp any host 92.70.22.22 eq 443
    access-list 100 deny tcp any host 92.70.22.22 eq cmd
    access-list 100 deny udp any host 92.70.22.22 eq snmp
    access-list 100 permit ip any any
    access-list 101 remark Auto generated by SDM Management Access feature
    access-list 101 remark SDM_ACL Category=1
    access-list 101 permit ip 10.2.88.0 0.0.1.255 any
    access-list 101 permit ip 92.70.22.16 0.0.0.7 any
    access-list 102 remark Auto generated by SDM Management Access feature
    access-list 102 remark SDM_ACL Category=1
    access-list 102 permit ip 10.2.88.0 0.0.1.255 any
    access-list 102 permit ip 92.70.22.16 0.0.0.7 any
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip permit
    no cdp run
    !
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    !
    line con 0
    login local
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    access-class 101 in
    privilege level 15
    login local
    transport input telnet
    line vty 5 15
    access-class 102 in
    privilege level 15
    login local
    transport input telnet
    !
    scheduler allocate 4000 1000
    scheduler interval 500
    end
    Marcus, Oct 11, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. BobCov
    Replies:
    3
    Views:
    570
    Andre Beck
    Nov 21, 2003
  2. Hans-Peter Walter
    Replies:
    3
    Views:
    1,132
    Joe Bloggs
    Jan 21, 2004
  3. Blar

    1721 with ADSL & ISDN WIC's

    Blar, Feb 2, 2004, in forum: Cisco
    Replies:
    2
    Views:
    709
    end user too
    Feb 2, 2004
  4. sync
    Replies:
    0
    Views:
    545
  5. Fabio

    Possibile/ It's possibile?

    Fabio, Oct 21, 2005, in forum: MCDST
    Replies:
    0
    Views:
    289
    Fabio
    Oct 21, 2005
Loading...

Share This Page