Cisco 1721 ADSL configuration Advice

Discussion in 'Cisco' started by martin.stenner@gmail.com, Dec 8, 2006.

  1. Guest

    Hi there,

    I'm relatively new to Cisco, and have been trying to configure a Cisco
    1721 router for PPPoA ADSL with static settings.
    The config that I've pieced together (see below) connects to the ADSL
    service, and allows me to ping internet addresses by IP and hostname.
    As you can see from the setting, the router allocates clients an IP
    address from a DHCP pool, but a connected client cannot ping any
    internet addresses. I'm wondering if this is something to do with an
    access-list or routing issue. I'd really appreciate any help with this.

    Thanks,

    Martin

    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname MyRouter
    !
    ip cef
    ip name-server w.x.y.z
    ip name-server w.x.y.z
    !
    enable password password
    !
    ip subnet-zero
    no shutdown
    !
    ip dhcp excluded-address 10.112.4.254
    !
    ip dhcp pool MyDHCPPool
    network 10.112.4.0 255.255.255.0
    default-router 10.112.4.254
    dns-server 10.112.4.254
    !
    ip audit notify log
    ip audit po max-events 100
    !
    interface ATM0
    no shutdown
    no ip address
    atm ilmi-keepalive
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface BRI0
    no ip address
    shutdown
    !
    interface FastEthernet0
    no shutdown
    ip address 10.112.4.254 255.255.255.0
    no ip redirects
    no ip proxy-arp
    ip nat inside
    speed auto
    !
    interface Dialer1
    ip address w.x.y.z 255.255.255.0 <--IP Address and subnet allocated by
    ISP (static)
    ip nat outside
    encapsulation ppp
    dialer pool 1
    ppp chap hostname
    ppp chap password 0 password
    ppp pap sent-username password 0 password
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    ip nat inside source list 1 interface Dialer1 overload
    ip pim bidir-enable
    !
    ip access-list extended nat-out
    permit ip 10.112.4.0 0.0.0.255 any
    !
    !
    line con 0
    exec-timeout 0 0
    stopbits 1
    line aux 0
    line vty 0 4
    exec-timeout 5 0
    password password
    login
    !
    no scheduler allocate
    end
    , Dec 8, 2006
    #1
    1. Advertising

  2. Hi Martin
    If you have " ip nat inside source list 1 interface Dialer1 overload" in
    your configuration, you should have an
    "access-list 1 permit 10.112.4.0 0.0.0.255 " and not
    "ip access-list extended nat-out
    permit ip 10.112.4.0 0.0.0.255 any"

    because the access-list "nat-out" is not defined in your NAT rule but the
    "source list 1" which refers to an access-list 1

    HTH

    Bye

    Carlo


    <> ha scritto nel messaggio
    news:...
    > Hi there,
    >
    > I'm relatively new to Cisco, and have been trying to configure a Cisco
    > 1721 router for PPPoA ADSL with static settings.
    > The config that I've pieced together (see below) connects to the ADSL
    > service, and allows me to ping internet addresses by IP and hostname.
    > As you can see from the setting, the router allocates clients an IP
    > address from a DHCP pool, but a connected client cannot ping any
    > internet addresses. I'm wondering if this is something to do with an
    > access-list or routing issue. I'd really appreciate any help with this.
    >
    > Thanks,
    >
    > Martin
    >
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > no service password-encryption
    > !
    > hostname MyRouter
    > !
    > ip cef
    > ip name-server w.x.y.z
    > ip name-server w.x.y.z
    > !
    > enable password password
    > !
    > ip subnet-zero
    > no shutdown
    > !
    > ip dhcp excluded-address 10.112.4.254
    > !
    > ip dhcp pool MyDHCPPool
    > network 10.112.4.0 255.255.255.0
    > default-router 10.112.4.254
    > dns-server 10.112.4.254
    > !
    > ip audit notify log
    > ip audit po max-events 100
    > !
    > interface ATM0
    > no shutdown
    > no ip address
    > atm ilmi-keepalive
    > pvc 0/38
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > dsl operating-mode auto
    > !
    > interface BRI0
    > no ip address
    > shutdown
    > !
    > interface FastEthernet0
    > no shutdown
    > ip address 10.112.4.254 255.255.255.0
    > no ip redirects
    > no ip proxy-arp
    > ip nat inside
    > speed auto
    > !
    > interface Dialer1
    > ip address w.x.y.z 255.255.255.0 <--IP Address and subnet allocated by
    > ISP (static)
    > ip nat outside
    > encapsulation ppp
    > dialer pool 1
    > ppp chap hostname
    > ppp chap password 0 password
    > ppp pap sent-username password 0 password
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1
    > no ip http server
    > ip nat inside source list 1 interface Dialer1 overload
    > ip pim bidir-enable
    > !
    > ip access-list extended nat-out
    > permit ip 10.112.4.0 0.0.0.255 any
    > !
    > !
    > line con 0
    > exec-timeout 0 0
    > stopbits 1
    > line aux 0
    > line vty 0 4
    > exec-timeout 5 0
    > password password
    > login
    > !
    > no scheduler allocate
    > end
    >
    >
    Carlo Poggiarelli, Dec 9, 2006
    #2
    1. Advertising

  3. Guest

    Carlo - Thanks for the advice. I'll give it a try.

    Cheers,
    Martin

    > Carlo Poggiarelli wrote:


    > Hi Martin
    > If you have " ip nat inside source list 1 interface Dialer1 overload" in
    > your configuration, you should have an
    > "access-list 1 permit 10.112.4.0 0.0.0.255 " and not
    > "ip access-list extended nat-out
    > permit ip 10.112.4.0 0.0.0.255 any"
    >
    > because the access-list "nat-out" is not defined in your NAT rule but the
    > "source list 1" which refers to an access-list 1
    >
    > HTH
    >
    > Bye
    >
    > Carlo
    , Dec 11, 2006
    #3
  4. Guest

    Carlo - Yes, this worked! Thanks very much for the help. I don't
    suppose you would have any pointers, or reference for configuring VPN
    on this device? We have the necessary module in the router.

    Thanks again for the help.

    >Carlo Poggiarelli wrote:


    > Hi Martin
    > If you have " ip nat inside source list 1 interface Dialer1 overload" in
    > your configuration, you should have an
    > "access-list 1 permit 10.112.4.0 0.0.0.255 " and not
    > "ip access-list extended nat-out
    > permit ip 10.112.4.0 0.0.0.255 any"
    >
    > because the access-list "nat-out" is not defined in your NAT rule but the
    > "source list 1" which refers to an access-list 1
    >
    > HTH
    >
    > Bye
    >
    > Carlo
    >
    >
    > <> ha scritto nel messaggio
    > news:...
    > > Hi there,
    > >
    > > I'm relatively new to Cisco, and have been trying to configure a Cisco
    > > 1721 router for PPPoA ADSL with static settings.
    > > The config that I've pieced together (see below) connects to the ADSL
    > > service, and allows me to ping internet addresses by IP and hostname.
    > > As you can see from the setting, the router allocates clients an IP
    > > address from a DHCP pool, but a connected client cannot ping any
    > > internet addresses. I'm wondering if this is something to do with an
    > > access-list or routing issue. I'd really appreciate any help with this.
    > >
    > > Thanks,
    > >
    > > Martin
    > >
    > > service timestamps debug datetime msec
    > > service timestamps log datetime msec
    > > no service password-encryption
    > > !
    > > hostname MyRouter
    > > !
    > > ip cef
    > > ip name-server w.x.y.z
    > > ip name-server w.x.y.z
    > > !
    > > enable password password
    > > !
    > > ip subnet-zero
    > > no shutdown
    > > !
    > > ip dhcp excluded-address 10.112.4.254
    > > !
    > > ip dhcp pool MyDHCPPool
    > > network 10.112.4.0 255.255.255.0
    > > default-router 10.112.4.254
    > > dns-server 10.112.4.254
    > > !
    > > ip audit notify log
    > > ip audit po max-events 100
    > > !
    > > interface ATM0
    > > no shutdown
    > > no ip address
    > > atm ilmi-keepalive
    > > pvc 0/38
    > > encapsulation aal5mux ppp dialer
    > > dialer pool-member 1
    > > !
    > > dsl operating-mode auto
    > > !
    > > interface BRI0
    > > no ip address
    > > shutdown
    > > !
    > > interface FastEthernet0
    > > no shutdown
    > > ip address 10.112.4.254 255.255.255.0
    > > no ip redirects
    > > no ip proxy-arp
    > > ip nat inside
    > > speed auto
    > > !
    > > interface Dialer1
    > > ip address w.x.y.z 255.255.255.0 <--IP Address and subnet allocated by
    > > ISP (static)
    > > ip nat outside
    > > encapsulation ppp
    > > dialer pool 1
    > > ppp chap hostname
    > > ppp chap password 0 password
    > > ppp pap sent-username password 0 password
    > > !
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 Dialer1
    > > no ip http server
    > > ip nat inside source list 1 interface Dialer1 overload
    > > ip pim bidir-enable
    > > !
    > > ip access-list extended nat-out
    > > permit ip 10.112.4.0 0.0.0.255 any
    > > !
    > > !
    > > line con 0
    > > exec-timeout 0 0
    > > stopbits 1
    > > line aux 0
    > > line vty 0 4
    > > exec-timeout 5 0
    > > password password
    > > login
    > > !
    > > no scheduler allocate
    > > end
    > >
    > >
    , Dec 11, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Said SIM

    Cisco 1721 lost configuration

    Said SIM, Apr 28, 2004, in forum: Cisco
    Replies:
    4
    Views:
    8,227
    Said SIM
    Apr 28, 2004
  2. Marcus
    Replies:
    0
    Views:
    1,093
    Marcus
    Oct 11, 2004
  3. dr_rockstar66
    Replies:
    2
    Views:
    6,482
    Hansang Bae
    Feb 5, 2005
  4. Scooter
    Replies:
    1
    Views:
    855
    BradReeseCom
    Feb 25, 2005
  5. gooker

    Cisco configuration 1721

    gooker, Jul 8, 2006, in forum: Cisco
    Replies:
    5
    Views:
    681
    gooker
    Jul 14, 2006
Loading...

Share This Page