Cisco 1605R PPPoE ADSL Troubles

Discussion in 'Cisco' started by Hugh William Collier-Byrd, Jul 17, 2003.

  1. I have been working on a particular bothersome problem for about a month now
    and I don't think I have come any closer to solving the problem...

    My 1605R is the standard Eth0 / Eth1 setup, no wic in the expansion slot, I
    have it setup per Cisco's site (and by every other example I have ever seen)
    to connect the correct way. I know the config works because the router ran
    for 80 days before I moved and had my ADSL service setup at my new house.

    Since moving the router will not setup a PPPoE connection to my ISP
    (Earthlink, in Greenville, SC) - their tech support will not support
    anything out of the bounds of have you rebooted your modem, etc. so I do not
    know what else to try, here is my current running config :

    gnvlsc-01-gw001#sh conf
    Using 2594 out of 7506 bytes
    !
    version 12.2
    no parser cache
    no service single-slot-reload-enable
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    no service dhcp
    !
    hostname gnvlsc-01-gw001
    !
    logging rate-limit console 10 except errors
    enable secret OMITTED
    !
    clock timezone EST -5
    clock summer-time EDT recurring
    ip subnet-zero
    ip name-server 207.217.126.81
    ip name-server 207.217.77.82
    ip name-server 207.217.120.83
    ip name-server 64.89.70.2
    ip name-server 64.89.74.2
    !
    ip cef
    no ip dhcp-client network-discovery
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    !
    !
    !
    interface Ethernet0
    description OMITTED
    no ip address
    no ip mroute-cache
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Ethernet1
    description OMITTED
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    no ip mroute-cache
    !
    interface Dialer1
    description Earthlink.net ADSL
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    ppp pap sent-username OMITTED password OMITTED
    !
    ip nat inside source list 10 interface Dialer1 overload
    ip nat inside source static udp 10.0.0.10 4000 interface Dialer1 4000
    ip nat inside source static tcp 10.0.0.10 4000 interface Dialer1 4000
    ip nat inside source static udp 10.0.0.10 7777 interface Dialer1 7777
    ip nat inside source static udp 10.0.0.10 7778 interface Dialer1 7778
    ip nat inside source static udp 10.0.0.10 7779 interface Dialer1 7779
    ip nat inside source static udp 10.0.0.10 7780 interface Dialer1 7780
    ip nat inside source static udp 10.0.0.10 7781 interface Dialer1 7781
    ip nat inside source static udp 10.0.0.10 27500 interface Dialer1 27500
    ip nat inside source static udp 10.0.0.10 27900 interface Dialer1 27900
    ip nat inside source static tcp 10.0.0.10 5800 interface Dialer1 5800
    ip nat inside source static udp 10.0.0.10 5800 interface Dialer1 5800
    ip nat inside source static udp 10.0.0.10 5900 interface Dialer1 5900
    ip nat inside source static tcp 10.0.0.10 5900 interface Dialer1 5900
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    access-list 10 permit 10.0.0.0 0.255.255.255
    !
    line con 0
    password OMITTED
    login
    line vty 0 4
    password OMITTED
    login
    !
    ntp clock-period 17042334
    ntp server 64.89.70.2 prefer
    ntp server 64.89.74.2
    end

    I have run IOS 12.1(3)XG6 which worked but crashed every 3 - 4 days so I
    ended up settling on 12.2(2)T4 which ran for 80 days before I packed up and
    moved on...

    The Cisco has not yet come up at the new house, ELNK says I am connection
    through a new kind of DSLAM but the Linksys BEFSR41 router and my Windows XP
    box can establish the PPPoE connection no problem, ELNK recommends I install
    the newest IOS...

    I have now tried as of this evening 12.3(1a), 12.3(1), and 12.2(15)T5, all
    of which give me the same result... I have tried running both the IP PLUS
    and IP/FW PLUS IPSEC 56 feature sets if this matters...

    I have tried PPPoE debugging but I'm not 100% sure what kind of failures I'm
    supposed to be looking for, since everything worked fine until the move I
    don't think its going to help for me to just keep randomly changing things
    so I figure its worth asking to see if anyone else has had a similar
    experience...

    Thanks!

    --
    Hugh William Collier-Byrd
    --
    Amethyst Networks
    Websites, Networking, Design, & More!
    http://amninc.net/
     
    Hugh William Collier-Byrd, Jul 17, 2003
    #1
    1. Advertising

  2. Hugh William Collier-Byrd

    hktco Guest

    Everything looks okay to me except I have the following under my int
    d1.

    "ppp authentication pap callin"

    AND I have this in the global config mode. Try permitting IP traffic
    and see how it goes.

    "dialer-list 1 protocol ip permit"

    hktco

    "Hugh William Collier-Byrd" <> wrote in message news:<1hrRa.36$>...
    > I have been working on a particular bothersome problem for about a month now
    > and I don't think I have come any closer to solving the problem...
    >
    > My 1605R is the standard Eth0 / Eth1 setup, no wic in the expansion slot, I
    > have it setup per Cisco's site (and by every other example I have ever seen)
    > to connect the correct way. I know the config works because the router ran
    > for 80 days before I moved and had my ADSL service setup at my new house.
    >
    > Since moving the router will not setup a PPPoE connection to my ISP
    > (Earthlink, in Greenville, SC) - their tech support will not support
    > anything out of the bounds of have you rebooted your modem, etc. so I do not
    > know what else to try, here is my current running config :
    >
    > gnvlsc-01-gw001#sh conf
    > Using 2594 out of 7506 bytes
    > !
    > version 12.2
    > no parser cache
    > no service single-slot-reload-enable
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > no service dhcp
    > !
    > hostname gnvlsc-01-gw001
    > !
    > logging rate-limit console 10 except errors
    > enable secret OMITTED
    > !
    > clock timezone EST -5
    > clock summer-time EDT recurring
    > ip subnet-zero
    > ip name-server 207.217.126.81
    > ip name-server 207.217.77.82
    > ip name-server 207.217.120.83
    > ip name-server 64.89.70.2
    > ip name-server 64.89.74.2
    > !
    > ip cef
    > no ip dhcp-client network-discovery
    > vpdn enable
    > !
    > vpdn-group 1
    > request-dialin
    > protocol pppoe
    > !
    > !
    > !
    > !
    > interface Ethernet0
    > description OMITTED
    > no ip address
    > no ip mroute-cache
    > pppoe enable
    > pppoe-client dial-pool-number 1
    > !
    > interface Ethernet1
    > description OMITTED
    > ip address 10.0.0.1 255.255.255.0
    > ip nat inside
    > no ip mroute-cache
    > !
    > interface Dialer1
    > description Earthlink.net ADSL
    > ip address negotiated
    > ip mtu 1492
    > ip nat outside
    > encapsulation ppp
    > no ip mroute-cache
    > dialer pool 1
    > dialer-group 1
    > ppp pap sent-username OMITTED password OMITTED
    > !
    > ip nat inside source list 10 interface Dialer1 overload
    > ip nat inside source static udp 10.0.0.10 4000 interface Dialer1 4000
    > ip nat inside source static tcp 10.0.0.10 4000 interface Dialer1 4000
    > ip nat inside source static udp 10.0.0.10 7777 interface Dialer1 7777
    > ip nat inside source static udp 10.0.0.10 7778 interface Dialer1 7778
    > ip nat inside source static udp 10.0.0.10 7779 interface Dialer1 7779
    > ip nat inside source static udp 10.0.0.10 7780 interface Dialer1 7780
    > ip nat inside source static udp 10.0.0.10 7781 interface Dialer1 7781
    > ip nat inside source static udp 10.0.0.10 27500 interface Dialer1 27500
    > ip nat inside source static udp 10.0.0.10 27900 interface Dialer1 27900
    > ip nat inside source static tcp 10.0.0.10 5800 interface Dialer1 5800
    > ip nat inside source static udp 10.0.0.10 5800 interface Dialer1 5800
    > ip nat inside source static udp 10.0.0.10 5900 interface Dialer1 5900
    > ip nat inside source static tcp 10.0.0.10 5900 interface Dialer1 5900
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1
    > no ip http server
    > !
    > access-list 10 permit 10.0.0.0 0.255.255.255
    > !
    > line con 0
    > password OMITTED
    > login
    > line vty 0 4
    > password OMITTED
    > login
    > !
    > ntp clock-period 17042334
    > ntp server 64.89.70.2 prefer
    > ntp server 64.89.74.2
    > end
    >
    > I have run IOS 12.1(3)XG6 which worked but crashed every 3 - 4 days so I
    > ended up settling on 12.2(2)T4 which ran for 80 days before I packed up and
    > moved on...
    >
    > The Cisco has not yet come up at the new house, ELNK says I am connection
    > through a new kind of DSLAM but the Linksys BEFSR41 router and my Windows XP
    > box can establish the PPPoE connection no problem, ELNK recommends I install
    > the newest IOS...
    >
    > I have now tried as of this evening 12.3(1a), 12.3(1), and 12.2(15)T5, all
    > of which give me the same result... I have tried running both the IP PLUS
    > and IP/FW PLUS IPSEC 56 feature sets if this matters...
    >
    > I have tried PPPoE debugging but I'm not 100% sure what kind of failures I'm
    > supposed to be looking for, since everything worked fine until the move I
    > don't think its going to help for me to just keep randomly changing things
    > so I figure its worth asking to see if anyone else has had a similar
    > experience...
    >
    > Thanks!
    >
    > --
    > Hugh William Collier-Byrd
     
    hktco, Jul 17, 2003
    #2
    1. Advertising

  3. Did not work...:-(

    I did capture some PPPoE debugging information, here are the packets :

    00:03:49: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
    00:03:49: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
    00:04:09: PPPoE 0: I PADO R:0003.4be3.9482 L:00d0.58a4.4480 Et0
    00 D0 58 A4 44 80 00 03 4B E3 94 82 88 63 11 07
    00 00 00 1B 01 01 00 00 01 02 00 0B 67 6E 76 6C ...
    00:04:11: PPPoE 1999: I PADS R:0003.4be3.9482 L:00d0.58a4.4480 Et0
    00 D0 58 A4 44 80 00 03 4B E3 94 82 88 63 11 65
    07 CF 00 1B 01 01 00 00 01 02 00 0B 67 6E 76 6C ...
    00:04:12: IN PADS from PPPoE Session
    00:04:12: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
    00:04:12: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
    00:04:12: PPPoE 1999: I PADT R:0003.4be3.9482 L:00d0.58a4.4480 Et0
    00 D0 58 A4 44 80 00 03 4B E3 94 82 88 63 11 A7
    07 CF 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ...
    00:04:12: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
    00:04:12: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
    00:04:32: PPPoE 0: I PADO R:0003.4be3.9482 L:00d0.58a4.4480 Et0
    00 D0 58 A4 44 80 00 03 4B E3 94 82 88 63 11 07
    00 00 00 1B 01 01 00 00 01 02 00 0B 67 6E 76 6C ...
    00:04:34: PPPoE 2000: I PADS R:0003.4be3.9482 L:00d0.58a4.4480 Et0
    00 D0 58 A4 44 80 00 03 4B E3 94 82 88 63 11 65
    07 D0 00 1B 01 01 00 00 01 02 00 0B 67 6E 76 6C ...
    00:04:34: IN PADS from PPPoE Session
    00:04:34: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
    00:04:34: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
    00:04:34: PPPoE 2000: I PADT R:0003.4be3.9482 L:00d0.58a4.4480 Et0
    00 D0 58 A4 44 80 00 03 4B E3 94 82 88 63 11 A7
    07 D0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ...

    --
    Hugh William Collier-Byrd
    --
    Amethyst Networks
    Websites, Networking, Design, & More!
    http://amninc.net/

    "hktco" <> wrote in message
    news:...
    > Everything looks okay to me except I have the following under my int
    > d1.
    >
    > "ppp authentication pap callin"
    >
    > AND I have this in the global config mode. Try permitting IP traffic
    > and see how it goes.
    >
    > "dialer-list 1 protocol ip permit"
     
    Hugh William Collier-Byrd, Jul 21, 2003
    #3
  4. I just figured it out...

    NEW CONFIG :

    gnvlsc-hh-gw001#sh run
    Building configuration...

    Current configuration : 2595 bytes
    !
    version 12.3
    no parser cache
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    no service dhcp
    !
    hostname gnvlsc-hh-gw001
    !
    enable secret 5 OMITTED
    !
    clock timezone EST -5
    clock summer-time EDT recurring
    ip subnet-zero
    ip name-server 207.217.126.81
    ip name-server 207.217.77.82
    ip name-server 207.217.120.83
    ip name-server 64.89.70.2
    ip name-server 64.89.74.2
    !
    ip cef
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    !
    !
    !
    !
    interface Ethernet0
    description OMITTED
    no ip address
    no ip mroute-cache
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    interface Ethernet1
    description OMITTED
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    no ip mroute-cache
    !
    interface Dialer1
    description Earthlink.net ADSL
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    no ip mroute-cache
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname
    ppp chap password OMITTED
    ppp pap sent-username password OMITTED
    !
    ip nat inside source list 10 interface Dialer1 overload
    ip nat inside source static tcp 10.0.0.10 5900 interface Dialer1 5900
    ip nat inside source static udp 10.0.0.10 5900 interface Dialer1 5900
    ip nat inside source static udp 10.0.0.10 5800 interface Dialer1 5800
    ip nat inside source static tcp 10.0.0.10 5800 interface Dialer1 5800
    ip nat inside source static udp 10.0.0.10 27900 interface Dialer1 27900
    ip nat inside source static udp 10.0.0.10 27500 interface Dialer1 27500
    ip nat inside source static udp 10.0.0.10 7781 interface Dialer1 7781
    ip nat inside source static udp 10.0.0.10 7780 interface Dialer1 7780
    ip nat inside source static udp 10.0.0.10 7779 interface Dialer1 7779
    ip nat inside source static udp 10.0.0.10 7778 interface Dialer1 7778
    ip nat inside source static udp 10.0.0.10 7777 interface Dialer1 7777
    ip nat inside source static tcp 10.0.0.10 4000 interface Dialer1 4000
    ip nat inside source static udp 10.0.0.10 4000 interface Dialer1 4000
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    !
    access-list 10 permit 10.0.0.0 0.255.255.255
    !
    line con 0
    password OMITTED
    login
    line vty 0 4
    password OMITTED
    login
    !
    ntp clock-period 17042334
    ntp server 64.89.70.2 prefer
    ntp server 64.89.74.2
    !
    end

    Anyhow, what I finally did was ?'ed in debug long enough until I saw I could
    turn on low level packet debugging for PPP and see everything that was going
    back on forth from my router and the access concentrator...

    Even though ELNK says they use PAP authentication it looks like on these new
    loops we have a little PAP and CHAP. Check out my pre-fix logging :

    01:05:16: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
    01:05:16: Vi1 EVT: Cstate 0 0x00000000
    01:05:16: Vi1 EVT: Free PPP 0 0x00000000
    01:05:40: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
    01:05:40: EVT: Setup 0 0x00000000
    01:05:40: Vi1 EVT: Setup 0 0x00000000
    01:05:40: Vi1 PPP: Using dialer call direction
    01:05:40: Vi1 PPP: Treating connection as a callout
    01:05:40: Vi1 PPP: Authorization required
    01:05:40: Vi1 PPP: No remote authentication for call-out
    01:05:40: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
    01:05:40: Vi1 LCP: MagicNumber 0xD094C373 (0x0506D094C373)
    01:05:40: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
    01:05:40: Vi1 EVT: Cstate 4 0x00000000
    01:05:40: Vi1 PPP: I pkt type 0xC021, datagramsize 21 link[ppp]
    01:05:40: Vi1 PPP: I pkt type 0xC021, datagramsize 12 link[ppp]
    01:05:40: Vi1 EVT: Packet 0 0x02DC930C
    01:05:40: Vi1 LCP: I CONFREQ [REQsent] id 74 len 19
    01:05:40: Vi1 LCP: MagicNumber 0x7AD49965 (0x05067AD49965)
    01:05:40: Vi1 LCP: MRU 1500 (0x010405DC)
    01:05:40: Vi1 LCP: AuthProto CHAP (0x0305C22305)
    01:05:40: Vi1 LCP: O CONFACK [REQsent] id 74 len 19
    01:05:40: Vi1 LCP: MagicNumber 0x7AD49965 (0x05067AD49965)
    01:05:40: Vi1 LCP: MRU 1500 (0x010405DC)
    01:05:40: Vi1 LCP: AuthProto CHAP (0x0305C22305)
    01:05:40: Vi1 EVT: Packet 0 0x02DCAA4C
    01:05:40: Vi1 LCP: I CONFACK [ACKsent] id 1 len 10
    01:05:40: Vi1 LCP: MagicNumber 0xD094C373 (0x0506D094C373)
    01:05:40: Vi1 PPP: No authorization without authentication
    01:05:40: Vi1 PPP: I pkt type 0xC223, datagramsize 34 link[ppp]
    01:05:40: Vi1 EVT: Auth Packet 0 0x02DCC18C
    01:05:40: Vi1 CHAP: I CHALLENGE id 1 len 32 from "gnvlscdt72w"
    01:05:40: Vi1 CHAP: Unable to authenticate for peer
    01:05:40: Vi1 LCP: O TERMREQ [Open] id 2 len 4
    01:05:40: Vi1 PPP: I pkt type 0xC021, datagramsize 6 link[ppp]
    01:05:40: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
    01:05:40: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

    ---

    Anyhow if you look through you will see the Access Concentrator at
    gnvlscdt72w, Greenville, SC Dial & Toll CO, request CHAP authentication
    which per ELNK it should not request at all.. Well I turned on CHAP and then
    the debug logs showed something was trying to authenticate me for PAP so I
    turned on CHAP and PAP and it worked fine and the problem was with
    authentication believe it or not, I suppose my Linksys router and Windows XP
    box are smart enough to reply for both without explicitly being told to do
    so...

    --
    Hugh William Collier-Byrd
    --
    Amethyst Networks
    Websites, Networking, Design, & More!
    http://amninc.net/
     
    Hugh William Collier-Byrd, Jul 21, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Nordien
    Replies:
    0
    Views:
    3,430
    John Nordien
    Nov 22, 2004
  2. Jaap Hubert
    Replies:
    3
    Views:
    3,057
    Walter Roberson
    Jan 18, 2005
  3. Michael Thomsen

    Need help with Cisco 1605R

    Michael Thomsen, Mar 16, 2005, in forum: Cisco
    Replies:
    2
    Views:
    2,662
    michael thomsen
    Mar 16, 2005
  4. Replies:
    2
    Views:
    675
    aservin
    Jul 4, 2005
  5. lga775
    Replies:
    1
    Views:
    2,166
    araishee
    Feb 18, 2010
Loading...

Share This Page