Cisco 1603 ISDN & Nat

Discussion in 'Cisco' started by Garry Argrave, Dec 1, 2003.

  1. Can anyone help???

    We have been provided with a Cisco 1603 router by one of our suppliers
    (configuration supplied below), this router was configured by them but it
    doesn't work as I would expect it. I believe that it should raise the ISDN
    link if we attempt to connect to the address 195.11.208.210 (which it
    appears to NAT), this is not however the case. The only way for us to raise
    the link is to start pinging the address (195.11.208.210) and then issue the
    "clear ip nat translation *" command on the router. Is this right or is
    there something we can change to resolve this.

    Any help much appreciated.

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname SAD_REMOTE
    !
    enable password 7 OMITTED
    !
    username SAD_REMOTE password 7 OMITTED
    username SAD_ACCESS password 7 OMITTED
    username OMITTED password 7 OMITTED
    ip subnet-zero
    no ip domain-lookup
    isdn switch-type basic-net3
    !
    !
    !
    interface Ethernet0
    ip address 195.11.208.206 255.255.255.252
    no ip directed-broadcast
    ip nat inside
    !
    interface BRI0
    description RAS Alison OMITTED
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    no ip route-cache
    dialer pool-member 1
    isdn switch-type basic-net3
    ppp authentication chap callin
    !
    interface Dialer1
    description RAS fuer
    ip address negotiated
    no ip directed-broadcast
    ip nat outside
    encapsulation ppp
    dialer remote-name *
    dialer string OMITTED
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname OMITTED
    ppp chap password 7 OMITTED
    !
    ip nat inside source list intern interface Dialer1 overload
    ip nat outside source static 172.16.100.111 195.11.208.210
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    !
    !
    ip access-list standard intern
    permit 195.11.208.204 0.0.0.3
    dialer-list 1 protocol ip permit
    !
    line con 0
    transport input none
    line vty 0 4
    password 7 OMITTED
    login
    !
    end
     
    Garry Argrave, Dec 1, 2003
    #1
    1. Advertising

  2. Garry Argrave

    ERP Guest

    This is the statement that triggers the dial:
    dialer-list 1 protocol ip permit
    it means any ip protocol will trigger it but, you need a route first out the
    dialer inorder for the router to send the traffic. Here is your route:
    ip route 0.0.0.0 0.0.0.0 Dialer1
    It looks to me like this should be ok, you are correct in that the address
    you are connecting to is getting NAT'ed. The only thing I can think of that
    might give you a problem is that the router must dial, negotiate an IP
    address and CHAP before it can start sending any of your traffic and NAT'ing
    your source. By that time I am reasonably sure your connection has timed out
    and you may have an invalid NAT entry you need to clear. You may be stuck
    having to genertae some other traffic to bring up the call before you
    initiate your connection. It would be better if you had an ip address on
    your dialer and didn't have to negotiate that first.

    "Garry Argrave" <> wrote in message
    news:bqfdg5$njd$1$...
    > Can anyone help???
    >
    > We have been provided with a Cisco 1603 router by one of our suppliers
    > (configuration supplied below), this router was configured by them but it
    > doesn't work as I would expect it. I believe that it should raise the

    ISDN
    > link if we attempt to connect to the address 195.11.208.210 (which it
    > appears to NAT), this is not however the case. The only way for us to

    raise
    > the link is to start pinging the address (195.11.208.210) and then issue

    the
    > "clear ip nat translation *" command on the router. Is this right or is
    > there something we can change to resolve this.
    >
    > Any help much appreciated.
    >
    > Current configuration:
    > !
    > version 12.0
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > service udp-small-servers
    > service tcp-small-servers
    > !
    > hostname SAD_REMOTE
    > !
    > enable password 7 OMITTED
    > !
    > username SAD_REMOTE password 7 OMITTED
    > username SAD_ACCESS password 7 OMITTED
    > username OMITTED password 7 OMITTED
    > ip subnet-zero
    > no ip domain-lookup
    > isdn switch-type basic-net3
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 195.11.208.206 255.255.255.252
    > no ip directed-broadcast
    > ip nat inside
    > !
    > interface BRI0
    > description RAS Alison OMITTED
    > no ip address
    > no ip directed-broadcast
    > encapsulation ppp
    > no ip route-cache
    > dialer pool-member 1
    > isdn switch-type basic-net3
    > ppp authentication chap callin
    > !
    > interface Dialer1
    > description RAS fuer
    > ip address negotiated
    > no ip directed-broadcast
    > ip nat outside
    > encapsulation ppp
    > dialer remote-name *
    > dialer string OMITTED
    > dialer pool 1
    > dialer-group 1
    > ppp authentication chap callin
    > ppp chap hostname OMITTED
    > ppp chap password 7 OMITTED
    > !
    > ip nat inside source list intern interface Dialer1 overload
    > ip nat outside source static 172.16.100.111 195.11.208.210
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Dialer1
    > ip http server
    > !
    > !
    > ip access-list standard intern
    > permit 195.11.208.204 0.0.0.3
    > dialer-list 1 protocol ip permit
    > !
    > line con 0
    > transport input none
    > line vty 0 4
    > password 7 OMITTED
    > login
    > !
    > end
    >
    >
     
    ERP, Dec 1, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jon Cox
    Replies:
    3
    Views:
    1,450
    Jon Cox
    Jan 9, 2004
  2. TonyB

    Cisco 1603 ISDN Router

    TonyB, Jun 3, 2004, in forum: Cisco
    Replies:
    1
    Views:
    1,828
    Aaron Leonard
    Jun 8, 2004
  3. Enrico

    NAT and Cisco 1603

    Enrico, Jul 15, 2005, in forum: Cisco
    Replies:
    2
    Views:
    614
    Masterx81
    Jul 18, 2005
  4. Masterx81

    Nat and Cisco 1603

    Masterx81, Jul 19, 2005, in forum: Cisco
    Replies:
    1
    Views:
    530
  5. sync
    Replies:
    0
    Views:
    621
Loading...

Share This Page