changing search engines

Discussion in 'Firefox' started by vicsage@yahoo.canada, Nov 22, 2004.

  1. Guest

    For starters, I'll apologize if this has been asked before. I've read
    through a number of older posts, and while I see similar questions, I
    don't see this specific one.

    Secondly, while I'm perfectly capable of using a computer, I'm not
    really comfortable digging into code. I'm willing to try, but I need
    to be walked through it very carefully and slowly.

    I've just downloaded the latest build (as far as I can tell) of
    Firefox -- specifically Mozilla/5.0 (Windows; U; Win98; en-GB;
    rv:1.7.5) Gecko/20041110 Firefox/1.0.

    I had the choice of downloading either the British or American
    versions. I tossed a coin and picked the British one, figuring the
    language would be closest to Canadian English. After downloading the
    browser, I saw the option to use Canuck speak as the default, so I'm
    happy there.

    Finding that solution, however, hasn't helped me solve my main
    question, which is about the searchbar. If I'm going to have one
    there, I might as well have search engines that I actually use. Is
    there a way I can change the default google.co.uk and Yahoo U.K. to
    google.ca and yahoo.ca, etc.? I know that if I uninstalled the British
    version and reinstalled the American one, I'd still end up wanting to
    change the default American-based search engines to Canadian based
    ones, so switching to the U.S. version isn't going to be any help.

    I tried the "add search engine" option (under the pull down menu), but
    that took me to mozdev.org site. I looked around those pages, but I
    didn't see any obvious links to get me the answer I'm looking for
    since I don't want to randomly install complex plug-ins. I've also
    looked through the help section in the browser but I didn't find
    anything useful in there either.

    So what's my next step?

    Thanks for what I'm sure will be helpful answers.
    Vic
    , Nov 22, 2004
    #1
    1. Advertising

  2. :: BRIAN :: Guest

    (On 11/22/2004 12:21 AM) da wrote:

    [snip]

    > I had the choice of downloading either the British or American
    > versions. I tossed a coin and picked the British one, figuring the
    > language would be closest to Canadian English. After downloading the
    > browser, I saw the option to use Canuck speak as the default, so I'm
    > happy there.
    >
    > Finding that solution, however, hasn't helped me solve my main
    > question, which is about the searchbar. If I'm going to have one
    > there, I might as well have search engines that I actually use. Is
    > there a way I can change the default google.co.uk and Yahoo U.K. to
    > google.ca and yahoo.ca, etc.? I know that if I uninstalled the British
    > version and reinstalled the American one, I'd still end up wanting to
    > change the default American-based search engines to Canadian based
    > ones, so switching to the U.S. version isn't going to be any help.


    [snip]

    > So what's my next step?


    Open the ../Mozilla Firefox/searchplugins folder. Then open google.src
    in a text editor and change the "action" address from .co.uk to .ca --
    or whatever you want it to be. Do the same thing with the yahoo.src file.

    > Thanks for what I'm sure will be helpful answers.


    I don't know if that's the proper answer, but it works none the less.
    The files might change back if you update...

    > Vic


    --
    Brian

    Email Info -
    http://68.1.17.8/p0nykiller/email.htm
    :: BRIAN ::, Nov 22, 2004
    #2
    1. Advertising

  3. Guest

    On Mon, 22 Nov 2004 03:49:01 -0500, :: BRIAN :: <user@127.0.1.1>
    wrote:

    >> So what's my next step?

    >
    >Open the ../Mozilla Firefox/searchplugins folder. Then open google.src
    >in a text editor and change the "action" address from .co.uk to .ca --
    >or whatever you want it to be. Do the same thing with the yahoo.src file.
    >
    >> Thanks for what I'm sure will be helpful answers.

    >
    >I don't know if that's the proper answer, but it works none the less.
    >The files might change back if you update...
    >
    >> Vic

    >
    >--
    >Brian
    >
    >Email Info -
    >http://68.1.17.8/p0nykiller/email.htm



    Thanks for the response Brian.

    I think I probably missed something or goofed in some other way (but
    that doesn't surprise me).

    I opened up the .src file file and changed all the "google.co.uk"
    references to google.ca. I saved the file, rebooted Firefox and ran a
    couple of test queries. For each of them I received the 404 no found
    error reproduced below.

    /?q=test&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-GB:eek:fficial

    I queried the word "test" for this demonstration.

    I tried going back into the file and changing everything back to
    co.uk but the damage seems to be done. I'm still getting 404 errors
    when I search.

    I'm getting the feeling that wiping the program and reloading it is my
    next step.
    --Vic
    , Nov 22, 2004
    #3
  4. MLC Guest

    da_, lunedì 22/nov/2004:

    > On Mon, 22 Nov 2004 03:49:01 -0500, :: BRIAN :: <user@127.0.1.1>
    > wrote:
    >
    >>> So what's my next step?

    >>
    >>Open the ../Mozilla Firefox/searchplugins folder. Then open google.src
    >>in a text editor and change the "action" address from .co.uk to .ca --
    >>or whatever you want it to be. Do the same thing with the yahoo.src file.
    >>
    >>> Thanks for what I'm sure will be helpful answers.

    >>
    >>I don't know if that's the proper answer, but it works none the less.
    >>The files might change back if you update...
    >>
    >>> Vic

    >>
    >>--
    >>Brian
    >>
    >>Email Info -
    >>http://68.1.17.8/p0nykiller/email.htm

    >
    > Thanks for the response Brian.
    >
    > I think I probably missed something or goofed in some other way (but
    > that doesn't surprise me).
    >
    > I opened up the .src file file and changed all the "google.co.uk"
    > references to google.ca. I saved the file, rebooted Firefox and ran a
    > couple of test queries. For each of them I received the 404 no found
    > error reproduced below.
    >
    > /?q=test&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-GB:eek:fficial
    >
    > I queried the word "test" for this demonstration.
    >
    > I tried going back into the file and changing everything back to
    > .co.uk but the damage seems to be done. I'm still getting 404 errors
    > when I search.
    >
    > I'm getting the feeling that wiping the program and reloading it is my
    > next step.
    > --Vic


    It worked for me. I changed google.com to google.it and typing "test" the
    address bar became:
    http://www.google.it/search?q=test&...ient=firefox-a&rls=org.mozilla:en-US:official
    showing well the page.

    The problem is that this change doesn't stick: another search gives again
    google.com, and the google.src file has again the row
    action="http://www.google.com/search"

    --
    Maria Luisa C - 22/11/2004 17.53.33
    MLC, Nov 22, 2004
    #4
  5. da wrote:
    > On Mon, 22 Nov 2004 03:49:01 -0500, :: BRIAN :: <user@127.0.1.1>
    > wrote:
    >
    >
    >>>So what's my next step?

    >>
    >>Open the ../Mozilla Firefox/searchplugins folder. Then open google.src
    >>in a text editor and change the "action" address from .co.uk to .ca --
    >>or whatever you want it to be. Do the same thing with the yahoo.src file.
    >>
    >>
    >>>Thanks for what I'm sure will be helpful answers.

    >>
    >>I don't know if that's the proper answer, but it works none the less.
    >>The files might change back if you update...
    >>
    >>
    >>>Vic

    >>
    >>--
    >>Brian
    >>
    >>Email Info -
    >>http://68.1.17.8/p0nykiller/email.htm

    >
    >
    >
    > Thanks for the response Brian.
    >
    > I think I probably missed something or goofed in some other way (but
    > that doesn't surprise me).
    >
    > I opened up the .src file file and changed all the "google.co.uk"
    > references to google.ca. I saved the file, rebooted Firefox and ran a
    > couple of test queries. For each of them I received the 404 no found
    > error reproduced below.
    >
    > /?q=test&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-GB:eek:fficial
    >
    > I queried the word "test" for this demonstration.
    >
    > I tried going back into the file and changing everything back to
    > co.uk but the damage seems to be done. I'm still getting 404 errors
    > when I search.
    >
    > I'm getting the feeling that wiping the program and reloading it is my
    > next step.
    > --Vic
    >
    >


    Use Mycroft to install the proper searchplugins:

    http://mycroft.mozdev.org/quick/google.html

    Scroll down to google.ca, and click on it, should pop it right in.

    Lee
    Leonidas Jones, Nov 22, 2004
    #5
  6. Guest

    On Mon, 22 Nov 2004 17:27:08 GMT, Leonidas Jones <>
    wrote:


    >
    >Use Mycroft to install the proper searchplugins:
    >
    >http://mycroft.mozdev.org/quick/google.html
    >
    >Scroll down to google.ca, and click on it, should pop it right in.
    >
    >Lee


    Thanks Lee.

    I was worried about installing plug-ins because I am not too sure how
    they are tested/approved/etc. but I've done it and they seem to be
    working fine. I've added yahoo.ca as well as google, and I'll probably
    be adding more in the future. Thanks for the good advice.
    --Vic
    , Nov 22, 2004
    #6
  7. da wrote:
    > On Mon, 22 Nov 2004 17:27:08 GMT, Leonidas Jones <>
    > wrote:
    >
    >
    >
    >>Use Mycroft to install the proper searchplugins:
    >>
    >>http://mycroft.mozdev.org/quick/google.html
    >>
    >>Scroll down to google.ca, and click on it, should pop it right in.
    >>
    >>Lee

    >
    >
    > Thanks Lee.
    >
    > I was worried about installing plug-ins because I am not too sure how
    > they are tested/approved/etc. but I've done it and they seem to be
    > working fine. I've added yahoo.ca as well as google, and I'll probably
    > be adding more in the future. Thanks for the good advice.
    > --Vic
    >


    Mozdev projects are pretty safe. Mycroft is a great tool for adding
    search plugins.

    Lee
    Leonidas Jones, Nov 22, 2004
    #7
  8. :: BRIAN :: Guest

    (On 11/22/2004 12:27 PM) Leonidas Jones wrote:
    > da wrote:
    >
    >> On Mon, 22 Nov 2004 03:49:01 -0500, :: BRIAN :: <user@127.0.1.1>
    >> wrote:
    >>
    >>
    >>>> So what's my next step?
    >>>
    >>>
    >>> Open the ../Mozilla Firefox/searchplugins folder. Then open
    >>> google.src in a text editor and change the "action" address from
    >>> .co.uk to .ca -- or whatever you want it to be. Do the same thing
    >>> with the yahoo.src file.
    >>>
    >>>
    >>>> Thanks for what I'm sure will be helpful answers.
    >>>
    >>>
    >>> I don't know if that's the proper answer, but it works none the less.
    >>> The files might change back if you update...
    >>>
    >>>
    >>>> Vic
    >>>
    >>>
    >>> --
    >>> Brian
    >>>
    >>> Email Info -
    >>> http://68.1.17.8/p0nykiller/email.htm

    >>
    >>
    >>
    >>
    >> Thanks for the response Brian.
    >> I think I probably missed something or goofed in some other way (but
    >> that doesn't surprise me).
    >>
    >> I opened up the .src file file and changed all the "google.co.uk"
    >> references to google.ca. I saved the file, rebooted Firefox and ran a
    >> couple of test queries. For each of them I received the 404 no found
    >> error reproduced below.
    >>
    >> /?q=test&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-GB:eek:fficial
    >>
    >>
    >> I queried the word "test" for this demonstration.
    >> I tried going back into the file and changing everything back to
    >> co.uk but the damage seems to be done. I'm still getting 404 errors
    >> when I search.
    >> I'm getting the feeling that wiping the program and reloading it is my
    >> next step.
    >> --Vic
    >>
    >>

    >
    > Use Mycroft to install the proper searchplugins:
    >
    > http://mycroft.mozdev.org/quick/google.html
    >
    > Scroll down to google.ca, and click on it, should pop it right in.
    >
    > Lee


    That's the easy way ;-)

    --
    Brian

    Email Info -
    http://68.1.17.8/p0nykiller/email.htm
    :: BRIAN ::, Nov 22, 2004
    #8
  9. :: BRIAN :: wrote:
    > (On 11/22/2004 12:27 PM) Leonidas Jones wrote:
    >
    >> da wrote:
    >>
    >>> On Mon, 22 Nov 2004 03:49:01 -0500, :: BRIAN :: <user@127.0.1.1>
    >>> wrote:
    >>>
    >>>
    >>>>> So what's my next step?
    >>>>
    >>>>
    >>>>
    >>>> Open the ../Mozilla Firefox/searchplugins folder. Then open
    >>>> google.src in a text editor and change the "action" address from
    >>>> .co.uk to .ca -- or whatever you want it to be. Do the same thing
    >>>> with the yahoo.src file.
    >>>>
    >>>>
    >>>>> Thanks for what I'm sure will be helpful answers.
    >>>>
    >>>>
    >>>>
    >>>> I don't know if that's the proper answer, but it works none the
    >>>> less. The files might change back if you update...
    >>>>
    >>>>
    >>>>> Vic
    >>>>
    >>>>
    >>>>
    >>>> --
    >>>> Brian
    >>>>
    >>>> Email Info -
    >>>> http://68.1.17.8/p0nykiller/email.htm
    >>>
    >>>
    >>>
    >>>
    >>>
    >>> Thanks for the response Brian.
    >>> I think I probably missed something or goofed in some other way (but
    >>> that doesn't surprise me).
    >>>
    >>> I opened up the .src file file and changed all the "google.co.uk"
    >>> references to google.ca. I saved the file, rebooted Firefox and ran a
    >>> couple of test queries. For each of them I received the 404 no found
    >>> error reproduced below.
    >>>
    >>> /?q=test&sourceid=mozilla-search&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:en-GB:eek:fficial
    >>>
    >>>
    >>> I queried the word "test" for this demonstration.
    >>> I tried going back into the file and changing everything back to
    >>> co.uk but the damage seems to be done. I'm still getting 404 errors
    >>> when I search.
    >>> I'm getting the feeling that wiping the program and reloading it is my
    >>> next step.
    >>> --Vic
    >>>
    >>>

    >>
    >> Use Mycroft to install the proper searchplugins:
    >>
    >> http://mycroft.mozdev.org/quick/google.html
    >>
    >> Scroll down to google.ca, and click on it, should pop it right in.
    >>
    >> Lee

    >
    >
    > That's the easy way ;-)
    >


    So sue me for being lazy!! ;)

    Lee
    Leonidas Jones, Nov 22, 2004
    #9
  10. MLC Guest

    _Leonidas Jones_, lunedì 22/nov/2004:

    > da wrote:
    >> [50 righe citate nascoste]

    >
    > Use Mycroft to install the proper searchplugins:
    >
    > http://mycroft.mozdev.org/quick/google.html
    >
    > Scroll down to google.ca, and click on it, should pop it right in.
    >


    Hi Lee,
    could you please teach to me how I can change the google.it plugin icon?
    Because it is identical to that for google.com, and now I can't distinguish
    in the search bar which is selected (to be sure I have to select it again
    from the drop down list).

    Thanks,
    --
    Maria Luisa C - 22/11/2004 23.26.48
    MLC, Nov 22, 2004
    #10
  11. MLC wrote:
    > _Leonidas Jones_, lunedì 22/nov/2004:
    >
    >
    >> wrote:
    >>
    >>>[50 righe citate nascoste]

    >>
    >>Use Mycroft to install the proper searchplugins:
    >>
    >>http://mycroft.mozdev.org/quick/google.html
    >>
    >>Scroll down to google.ca, and click on it, should pop it right in.
    >>

    >
    >
    > Hi Lee,
    > could you please teach to me how I can change the google.it plugin icon?
    > Because it is identical to that for google.com, and now I can't distinguish
    > in the search bar which is selected (to be sure I have to select it again
    > from the drop down list).
    >
    > Thanks,


    In your program folder (not profile) there is a folder called
    searchplugins. In there you will find googleIT.src and googleIT.gif.

    Rename the latter, which is identical to google.gif, with a gif file of
    your choice.

    Lee
    Leonidas Jones, Nov 23, 2004
    #11
  12. MLC Guest

    _Leonidas Jones_, martedì 23/nov/2004:

    > MLC wrote:
    >> _Leonidas Jones_, lunedì 22/nov/2004:
    >>
    >>> wrote:
    >>>
    >>>>[50 righe citate nascoste]
    >>>
    >>>Use Mycroft to install the proper searchplugins:
    >>>
    >>>http://mycroft.mozdev.org/quick/google.html
    >>>
    >>>Scroll down to google.ca, and click on it, should pop it right in.
    >>>

    >>
    >> Hi Lee,
    >> could you please teach to me how I can change the google.it plugin icon?
    >> Because it is identical to that for google.com, and now I can't distinguish
    >> in the search bar which is selected (to be sure I have to select it again
    >> from the drop down list).
    >>
    >> Thanks,

    >
    > In your program folder (not profile) there is a folder called
    > searchplugins. In there you will find googleIT.src and googleIT.gif.
    >
    > Rename the latter, which is identical to google.gif, with a gif file of
    > your choice.
    >

    Easy! Now I have a Google icon with the Italian flag. Thank you.
    --
    Maria Luisa C - 23/11/2004 8.53.14
    MLC, Nov 23, 2004
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jude Barnes
    Replies:
    4
    Views:
    893
    David Harrison
    Aug 20, 2004
  2. Chuck

    Search Engines

    Chuck, Oct 17, 2004, in forum: Firefox
    Replies:
    4
    Views:
    478
    Alvaro G. Vicario
    Oct 18, 2004
  3. Zimran Douglas

    Search Bar not displaying search Engines

    Zimran Douglas, Jan 6, 2005, in forum: Firefox
    Replies:
    1
    Views:
    638
    Splibbilla
    Jan 7, 2005
  4. Jim

    Firefox Search Engines

    Jim, Feb 6, 2005, in forum: Firefox
    Replies:
    1
    Views:
    542
    Leonidas Jones
    Feb 6, 2005
  5. Replies:
    1
    Views:
    506
    Moz Champion
    Feb 17, 2005
Loading...

Share This Page