CEF load balancing 2 T1 with a 2621

Discussion in 'Cisco' started by Mirco, Jul 7, 2004.

  1. Mirco

    Mirco Guest

    We have 2 full T1 lines which, individually connected to the router,
    work just fine. However, when both are up at the same time, they are
    not working, or at least it seems like packets take a long time to get
    out.
    Each T1 is routing 16 IPs and the 2 blocks are consecutive:

    T1 #1 WAN: A.B.C.245/24
    LAN: A.B.D.96/28
    T1 #2 WAN: A.B.C.246/24
    LAN: A.B.D.112/28

    The following is the configuration file we are using. Could anybody
    tell me what's wrong with it.

    TIA,

    ---Mirco.

    ! =======================================================================
    !
    no ip name-server
    !
    ip subnet-zero
    no ip domain-lookup
    ip routing
    ip cef
    !
    interface FastEthernet 0/0
    no shutdown
    ip address A.B.D.97 255.255.255.224
    keepalive 10
    !
    interface FastEthernet 0/1
    no ip address
    shutdown
    !
    interface Serial 0/0
    no shutdown
    no ip address
    encapsulation frame-relay
    !
    interface Serial 0/0.1 point-to-point
    no shutdown
    ip address A.B.C.245 255.255.255.0
    frame-relay interface-dlci 16 ietf
    !
    interface Serial 0/1
    no shutdown
    no ip address
    encapsulation frame-relay
    !
    interface Serial 0/1.1 point-to-point
    no shutdown
    ip address A.B.C.246 255.255.255.0
    frame-relay interface-dlci 16 ietf
    !
    router rip
    version 2
    network A.0.0.0
    passive-interface Serial 0/0.1
    passive-interface Serial 0/1.1
    no auto-summary
    !
    !
    ip classless
    !
    ! IP Static Routes
    ip route 0.0.0.0 0.0.0.0 Serial 0/0.1
    ip route 0.0.0.0 0.0.0.0 Serial 0/1.1
    no ip http server
    snmp-server community public RO
    no snmp-server location
    no snmp-server contact
    !
    ! =======================================================================
    Mirco, Jul 7, 2004
    #1
    1. Advertising

  2. (Mirco) wrote some stuff in message
    >news:<>...


    cisco.com has a detailed troubleshooting guide for load sharing on
    parallel links using CEF:

    http://www.cisco.com/en/US/customer/tech/tk827/tk831/technologies_tech_note09186a0080094806.shtml

    It covers both per-packet and per-destination load sharing. There's
    even a comparison of the two methods so you can select the method you
    want based on your goals.

    From your post, I can't tell if you meet the pre-requisite for CEF
    load sharing. Like dancing the Tango, and as the name implies, load
    sharing requires a pair of devices connecting 2 or more links from
    source to destination, in parallel. That is, the source device (CPE
    router, e.g.) and destination device (ISP edge router, e.g.) must both
    support CEF and be configured for the same method on all shared
    interfaces. Does your ISP have CEF and static routes configured for
    each interface?

    Also, from the config stub posted, you need to configure load-sharing
    on the parallel link interfaces. Choose either per-packet or
    per-destination to suit your needs. Use "show cef interface
    [interface]" to verify CEF load-sharing.

    Below is a working stub config, with IPs changed to protect the
    innocent. The ISP edge router is a 7206VXR NPE300, and the CPE router
    is a 2610.

    ISP Edge:

    interface Serial4/0/0:1
    ip address 1.1.1.9 255.255.255.252
    no ip directed-broadcast
    no ip proxy-arp
    ip load-sharing per-packet
    no ip route-cache distributed
    down-when-looped
    no cdp enable

    interface Serial4/0/0:16
    ip address 1.1.1.13 255.255.255.252
    no ip directed-broadcast
    no ip proxy-arp
    ip load-sharing per-packet
    no ip route-cache distributed
    down-when-looped
    no cdp enable


    ip route 1.1.1.224 255.255.255.240 Serial4/0/0:1
    ip route 1.1.1.224 255.255.255.240 Serial4/0/0:16


    CPE router:

    interface Ethernet0/0
    ip address 1.1.1.225 255.255.255.240
    no ip directed-broadcast
    !
    interface Serial0/0
    ip address 1.1.1.10 255.255.255.252
    ip access-group 100 in
    no ip directed-broadcast
    ip load-sharing per-packet
    no ip mroute-cache
    service-module t1 timeslots 1-24
    !
    interface Serial0/1
    ip address 1.1.1.14 255.255.255.252
    ip access-group 100 in
    no ip directed-broadcast
    ip load-sharing per-packet
    no ip mroute-cache
    service-module t1 timeslots 1-24

    ip route 0.0.0.0 0.0.0.0 Serial0/0
    ip route 0.0.0.0 0.0.0.0 Serial0/1

    ....and below are the show cef interface results.

    ISP edge:

    Serial4/0/0:1 is up (if_number 46)
    Corresponding hwidb fast_if_number 46
    Corresponding hwidb firstsw->if_number 46
    Internet address is 1.1.1.9/30
    ICMP redirects are always sent
    Per packet load-sharing is enabled
    IP unicast RPF check is disabled
    Inbound access list is not set
    Outbound access list is not set
    IP policy routing is disabled
    BGP based policy accounting is disabled
    Interface is marked as point to point interface
    Hardware idb is Serial4/0/0:1
    Fast switching type 4, interface type 22
    IP CEF switching enabled
    IP Feature Fast switching turbo vector
    IP Feature CEF switching turbo vector
    Input fast flags 0x0, Output fast flags 0x0, Flags 0xC1
    ifindex 45(45)
    Slot 4 Slot unit 0 VC 1
    Transmit limit accumulator 0x4800022A (0x4800022A)
    IP MTU 1500


    Serial4/0/0:16 is up (if_number 42)
    Corresponding hwidb fast_if_number 42
    Corresponding hwidb firstsw->if_number 42
    Internet address is 1.1.1.13/30
    ICMP redirects are always sent
    Per packet load-sharing is enabled
    IP unicast RPF check is disabled
    Inbound access list is not set
    Outbound access list is not set
    IP policy routing is disabled
    BGP based policy accounting is disabled
    Interface is marked as point to point interface
    Hardware idb is Serial4/0/0:16
    Fast switching type 4, interface type 22
    IP CEF switching enabled
    IP Feature Fast switching turbo vector
    IP Feature CEF switching turbo vector
    Input fast flags 0x0, Output fast flags 0x0, Flags 0xC1
    ifindex 41(41)
    Slot 4 Slot unit 0 VC 16
    Transmit limit accumulator 0x48000232 (0x48000232)
    IP MTU 1500


    CPE router:

    Serial0/0 is up (if_number 3)
    Internet address is 1.1.1.10/30
    ICMP redirects are always sent
    Per packet loadbalancing is enabled
    IP unicast RPF check is disabled
    Inbound access list is 100
    Outbound access list is not set
    Interface is marked as point to point interface
    Hardware idb is Serial0/0
    Fast switching type 4, interface type 43
    IP CEF switching enabled
    IP CEF Feature Fast switching turbo vector
    Input fast flags 0x1, Output fast flags 0x0
    ifindex 2(2)
    Slot 0 Slot unit 0 VC -1
    Transmit limit accumulator 0x0 (0x0)
    IP MTU 1500


    Serial0/1 is up (if_number 4)
    Internet address is 1.1.1.14/30
    ICMP redirects are always sent
    Per packet loadbalancing is enabled
    IP unicast RPF check is disabled
    Inbound access list is 100
    Outbound access list is not set
    Interface is marked as point to point interface
    Hardware idb is Serial0/1
    Fast switching type 4, interface type 43
    IP CEF switching enabled
    IP CEF Feature Fast switching turbo vector
    Input fast flags 0x1, Output fast flags 0x0
    ifindex 3(3)
    Slot 0 Slot unit 1 VC -1
    Transmit limit accumulator 0x0 (0x0)
    IP MTU 1500

    HTH

    --Jerome
    jerome benton, Jul 9, 2004
    #2
    1. Advertising

  3. Mirco

    AnyBody43 Guest

    (jerome benton) wrote
    > From your post, I can't tell if you meet the pre-requisite for CEF
    > load sharing. Like dancing the Tango, and as the name implies, load
    > sharing requires a pair of devices connecting 2 or more links from
    > source to destination, in parallel.
    >
    > That is, the source device (CPE
    > router, e.g.) and destination device (ISP edge router, e.g.) must both
    > support CEF and be configured for the same method on all shared
    > interfaces. Does your ISP have CEF and static routes configured for
    > each interface?


    I don't believe that all of this is quite correct.

    " the source device (CPE > router, e.g.) and destination device
    (ISP edge router, e.g.) must both support CEF"
    Sorry, not correct.

    The mechanism that a single device uses to route an IP packet
    is independent of all other devices. The IP routing protocols
    of which I have any understanding (most Interior GP's) know
    nothing of load sharing other than that they may be prepared to put
    more than one route into the routing table. Once a routing table
    is established THEN the end device may choose for example
    to do equal-cost-path load balancing, using for example per packet,
    per flow, or some other algorithm.

    It can be a critical part of IP troubleshooting to appreciate
    that packets do not take the same outbound and return path.
    A tracert for example only tells you the *outbound* path of
    the particular set ot test packets. Note that it does not tell
    you the path of any single packet. There is NO requirement for
    any two packets to take the same path.
    AnyBody43, Jul 12, 2004
    #3
  4. (AnyBody43) wrote in message news:<>...
    > (jerome benton) wrote
    > > From your post, I can't tell if you meet the pre-requisite for CEF
    > > load sharing. Like dancing the Tango, and as the name implies, load
    > > sharing requires a pair of devices connecting 2 or more links from
    > > source to destination, in parallel.
    > >
    > > That is, the source device (CPE
    > > router, e.g.) and destination device (ISP edge router, e.g.) must both
    > > support CEF and be configured for the same method on all shared
    > > interfaces. Does your ISP have CEF and static routes configured for
    > > each interface?

    >
    > I don't believe that all of this is quite correct.
    >
    > " the source device (CPE > router, e.g.) and destination device
    > (ISP edge router, e.g.) must both support CEF"
    > Sorry, not correct.
    >
    > The mechanism that a single device uses to route an IP packet
    > is independent of all other devices. The IP routing protocols
    > of which I have any understanding (most Interior GP's) know
    > nothing of load sharing other than that they may be prepared to put
    > more than one route into the routing table. Once a routing table
    > is established THEN the end device may choose for example
    > to do equal-cost-path load balancing, using for example per packet,
    > per flow, or some other algorithm.
    >
    > It can be a critical part of IP troubleshooting to appreciate
    > that packets do not take the same outbound and return path.
    > A tracert for example only tells you the *outbound* path of
    > the particular set ot test packets. Note that it does not tell
    > you the path of any single packet. There is NO requirement for
    > any two packets to take the same path.


    I beleive we are both correct. IP paths are not necessarily symmetric.
    However, the subject of the post is "CEF load balancing 2 T1 with a
    2621" which I interpret to mean that the poster requires CEF load
    balancing. The Cisco IOS, referred to by the poster, uses 4 mechanisms
    to switch IP packets; namely, process switching, fast switching, Cisco
    Express Forwarding, and distributed CEF. CEF uses FIB to make
    destination switching decisions, and adjacency tables to maintain
    layer 2 next hop information. This is all very clearly defined in the
    document I referenced, and which I urge anyone with CEF curiosity to
    read.

    If the subject or question had been "How do I load balance multiple
    links," for example, I would have responded "Choose your favorite
    IGP." Perhaps the poster can clarify if they truly meant CEF load
    balancing, or simply IP routing.

    --Jerome
    jerome benton, Jul 13, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ETLALAR
    Replies:
    2
    Views:
    819
    Jesper Skriver
    Jan 19, 2004
  2. Replies:
    1
    Views:
    2,311
    Vincent C Jones
    Nov 21, 2005
  3. comp.dcom.sys.cisco

    HARDWARE cef or SOFTWARE cef ?

    comp.dcom.sys.cisco, Mar 22, 2006, in forum: Cisco
    Replies:
    2
    Views:
    3,244
    comp.dcom.sys.cisco
    Mar 23, 2006
  4. tmcgov05
    Replies:
    6
    Views:
    1,262
    Thrill5
    Feb 10, 2009
  5. palas_123
    Replies:
    1
    Views:
    2,077
    donjohnston
    Dec 28, 2009
Loading...

Share This Page