CEF and EIGRP

Discussion in 'Cisco' started by t0100980@hotmail.com, Apr 4, 2005.

  1. Guest

    Hello all!

    Sorry about my english. I'm trying to get CEF per-packet balancing to
    work with EIGRP in a lab network. I have two unequal routes I want to
    share packets (same source and destination). I have understood that CEF
    makes its decisions based on routing table and EIGRP only keeps
    successors in its routing table. It started to work when I added two
    static routes.

    I see both routes in topology table. So is it possible to get CEF
    per-packet to work with EIGRP or should I do with static routes? The
    network I want to load balance to is 172.16.5.0.
    ------------------------------------------------------------------------------
    interface Ethernet0
    description connected to SW1
    ip address 172.16.4.1 255.255.255.0
    no ip directed-broadcast
    ip load-sharing per-packet
    no ip mroute-cache
    !
    interface Serial0
    description connected to LABA
    ip address 172.16.1.1 255.255.255.0
    no ip directed-broadcast
    --More--   ip load-sharing per-packet
    encapsulation ppp
    no ip mroute-cache
    !
    interface Serial1
    description connected to LABD
    ip address 172.16.2.1 255.255.255.
    no ip directed-broadcast
    ip load-sharing per-packet
    encapsulation ppp
    no ip mroute-cache
    clockrate 4000000
    !
    router eigrp 1
    variance 10
    redistribute connected
    network 172.16.0.0

    routing table:
    ----------------------------------------------------------------------------
    172.16.0.0/16 is variably subnetted, 14 subnets, 2 masks
    D 172.16.6.2/32 [90/2323456] via 172.16.1.2, 01:25:04, Serial0
    [90/2809856] via 172.16.2.2, 01:25:04, Serial1
    C 172.16.4.0/24 is directly connected, Ethernet0
    D 172.16.5.0/24 [90/2195456] via 172.16.2.2, 01:25:04, Serial1
    C 172.16.6.3/32 is directly connected, Loopback0
    D 172.16.6.1/32 [90/2297856] via 172.16.1.2, 01:25:04, Serial0
    C 172.16.2.2/32 is directly connected, Serial1
    D 172.16.0.0/24 [90/2195456] via 172.16.1.2, 01:25:04, Serial0
    D 172.16.3.2/32 [90/2681856] via 172.16.2.2, 01:25:04, Serial1
    C 172.16.1.0/24 is directly connected, Serial0
    C 172.16.2.0/24 is directly connected, Serial1
    D 172.16.6.4/32 [90/2297856] via 172.16.2.2, 01:25:05, Serial1
    ------------------------------------------------------------------------------
    topology table:

    P 172.16.5.0/24, 1 successors, FD is 2195456, serno 168
    via 172.16.2.2 (2195456/281600), Serial1
    via 172.16.1.2 (2733056/2221056), Serial0
    , Apr 4, 2005
    #1
    1. Advertising

  2. Hello, !
    You wrote on 4 Apr 2005 07:03:59 -0700:

    t> Sorry about my english. I'm trying to get CEF per-packet balancing
    t> to work with EIGRP in a lab network. I have two unequal routes I
    t> want to share packets (same source and destination). I have
    t> understood that CEF makes its decisions based on routing table and
    t> EIGRP only keeps successors in its routing table. It started to
    t> work when I added two static routes.

    t> topology table:

    t> P 172.16.5.0/24, 1 successors, FD is 2195456, serno 168
    t> via 172.16.2.2 (2195456/281600), Serial1
    t> via 172.16.1.2 (2733056/2221056), Serial0

    I don't think it's going to work. 2221056 (reported distance through Serial 0)
    is more than 2195456 (feasible distance). From EIGRP point of view path through
    Serial 0 might be a loop. You have to have reported distance to be lower than
    feasible distance for both interfaces. Than you can play with variance to put
    both paths into routing table even if they have different cost.

    With best regards,
    Andrey.
    Andrey Tarasov, Apr 4, 2005
    #2
    1. Advertising

  3. On 4 Apr 2005 07:03:59 -0700, wrote:
    > Hello all!
    >
    > Sorry about my english. I'm trying to get CEF per-packet balancing to
    > work with EIGRP in a lab network. I have two unequal routes I want to
    > share packets (same source and destination). I have understood that CEF
    > makes its decisions based on routing table and EIGRP only keeps
    > successors in its routing table. It started to work when I added two
    > static routes.


    If the routing table present multiple paths to CEF with the same
    or different share weights, CEF will build loadbalance objects in
    accordance with these weights, and use that for both per-packet
    and per-destination load balancing.

    /Jesper

    --
    Jesper Skriver, CCIE #5456, FreeBSD committer
    Jesper Skriver, Apr 4, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chris Ames-Farrow

    CEF and Dynamic Routing

    Chris Ames-Farrow, Oct 17, 2003, in forum: Cisco
    Replies:
    0
    Views:
    363
    Chris Ames-Farrow
    Oct 17, 2003
  2. Chris Ames-Farrow

    CEF and Dynamic Routing

    Chris Ames-Farrow, Oct 17, 2003, in forum: Cisco
    Replies:
    2
    Views:
    2,419
    Harri Suomalainen
    Oct 20, 2003
  3. ETLALAR
    Replies:
    2
    Views:
    794
    Jesper Skriver
    Jan 19, 2004
  4. BG
    Replies:
    3
    Views:
    6,565
  5. comp.dcom.sys.cisco

    HARDWARE cef or SOFTWARE cef ?

    comp.dcom.sys.cisco, Mar 22, 2006, in forum: Cisco
    Replies:
    2
    Views:
    3,224
    comp.dcom.sys.cisco
    Mar 23, 2006
Loading...

Share This Page