Catalyst 3200/LS1010 Vlan trunking problem

Discussion in 'Cisco' started by Hkz, Dec 22, 2007.

  1. Hkz

    Hkz Guest

    Hi,
    i've got catalyst 3200 with some VLANs i need to trunk using the WS-X3006
    ATM module and a Cisco LS1010.
    The LS1010 is doing LECS,LES and BUS, the cat3200 only LEC.
    From what i have read (i'm not an ATM/LANE expert) i need to configure
    an ELAN for every VLAN i need to trunk on the switch, with the same name,
    and the cat3200 should automatically join as a LEC every elan corresponding
    to its vlans with ports assigned.
    On the cat3200 the following VLANs are configured: "default", with no ports
    assigned, "labnet" with 10 ports, "privatenet" with the remaining ports,
    and the ATM configuration is done through ILMI...
    alas on the ELAN table on the 3200 i get only this:
    STATE/
    ELAN NAME LES ADDRESS/BUS ADDRESS/LEC ADDRESS LECID TIME
    1 default 00.000000000000000000000000.000000000000.00 0 Down
    00.000000000000000000000000.000000000000.00 0:00:00
    47.00918100000000603E5A4501.0080240B8B10.00

    This is the LS1010 configuration
    !
    version 11.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service compress-config
    !
    hostname LS1010
    !
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxx
    enable password 7 xxxxxxxxxxxxxxxxxxxxxxxxxx
    !
    username router password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
    no ip routing
    ip domain-name hkzlab.net
    ip name-server 192.168.2.20
    !
    atm lecs-address-default 47.0091.8100.0000.0060.3e5a.4501.0010.0739.b105.00 1
    atm address 47.0091.8100.0000.0060.3e5a.4501.0060.3e5a.4501.00
    atm router pnni
    no aesa embedded-number left-justified
    node 1 level 56 lowest
    redistribute atm-static
    !
    !
    lane database LANE_DATABASE
    name default server-atm-address 47.00918100000000603E5A4501.00100739B103.00
    name default elan-id 1
    name privatenet server-atm-address 47.00918100000000603E5A4501.00100739B103.02
    name privatenet elan-id 11
    name labnet server-atm-address 47.00918100000000603E5A4501.00100739B103.01
    name labnet elan-id 10
    default-name default
    clock timezone GMT+1 1
    clock summer-time ORA_LEGALE recurring last Sun Mar 2:00 last Sun Oct 2:00
    !
    !
    interface ATM0/0/0
    description connection to cat3200
    no ip address
    no ip route-cache
    no ip mroute-cache
    no atm ilmi-keepalive
    !
    interface ATM0/0/1
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/0/2
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/0/3
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/1
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/2
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/3
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM1/0/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM1/1/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM2/0/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    atm maxvp-number 0
    lane config auto-config-atm-address
    lane config database LANE_DATABASE
    !
    !
    interface ATM2/0/0.1 multipoint
    no ip route-cache
    no ip mroute-cache
    lane server-bus ethernet default elan-id 1
    !
    interface ATM2/0/0.2 multipoint
    no ip route-cache
    no ip mroute-cache
    lane server-bus ethernet labnet elan-id 10
    !
    interface ATM2/0/0.3 multipoint
    no ip route-cache
    no ip mroute-cache
    lane server-bus ethernet privatenet elan-id 11
    !
    interface Ethernet2/0/0
    ip address 192.168.1.230 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    !
    interface ATM3/0/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM3/1/0
    no ip address
    no ip route-cache
    no ip mroute-cache
    shutdown
    no atm ilmi-keepalive
    !
    ip default-gateway 192.168.1.1
    ip classless
    !
    banner motd ^C LS1010 HKZlab ATM switch ^C
    !
    !
    line con 0
    login local
    line aux 0
    line vty 0 4
    password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    login local
    !
    ntp clock-period 17180483
    ntp server 192.168.1.160
    end

    This is a "show lane server" output:
    LS1010#show lane server
    LE Server ATM2/0/0.1, Elan name: default, Admin: up, State: operational
    Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516
    locally set elan-id: 1
    elan-id obtained from LECS: not set
    ATM address: 47.00918100000000603E5A4501.00100739B103.01
    LECS used: 47.00918100000000603E5A4501.00100739B105.00 connected, vcd 226

    LE Server ATM2/0/0.2, Elan name: labnet, Admin: up, State: operational
    Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516
    locally set elan-id: 10
    elan-id obtained from LECS: not set
    ATM address: 47.00918100000000603E5A4501.00100739B103.02
    LECS used: 47.00918100000000603E5A4501.00100739B105.00 connected, vcd 285

    LE Server ATM2/0/0.3, Elan name: privatenet, Admin: up, State: operational
    Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516
    locally set elan-id: 11
    elan-id obtained from LECS: not set
    ATM address: 47.00918100000000603E5A4501.00100739B103.03
    LECS used: 47.00918100000000603E5A4501.00100739B105.00 connected, vcd 195

    If i run a "debug lane config all" i get these messages.
    11:54:56 : LECS EVENT ATM2/0/0: placed register address 0x60F5C6E8 (47.00918100000000603E5A4501.00100739B105.00) request with ILMI
    11:54:56 : LECS EVENT ATM2/0/0: 47.00918100000000603E5A4501.00100739B105.00: ilmi registered
    11:55:00 : LECS EVENT ATM2/0/0: ATM_SETUP received: callid 0x6103C1BC
    11:55:00 : LECS EVENT ATM2/0/0: calling party addr 47.00918100000000603E5A4501.0080240B8B10.00 (type=16 len=20)
    11:55:00 : LECS EVENT ATM2/0/0: calling party is probably an LEC
    11:55:00 : LECS EVENT ATM2/0/0: call ACCEPTED and sent a CONNECT to 0x6103C1BC
    11:55:00 : LECS EVENT ATM2/0/0: ATM_CONNECT_ACK received: callid 0x6103C1BC
    11:55:00 : LECS PACKET ATM2/0/0: packet received and enqueued
    11:55:00 : LECS PACKET ATM2/0/0: a packet is received from a LEC
    11:55:00 : --- LECS PACKET ATM2/0/0: dump of input packet ---
    opcode: 0x1
    transaction_id: 2284
    src_lan_dest: 0080.240b.8b10
    11:55:00 : lan_type: 1
    max_frame_size: 1
    num_tlvs: 0
    src_atm_addr: 47.00918100000000603E5A4501.0080240B8B10.00
    name_size: 7
    elan_name: default
    11:55:00 : ------------------------------------------
    11:55:00 : LECS PACKET ATM2/0/0: found elan 'default' by name
    11:55:00 : LECS PACKET ATM2/0/0: config request for elan 'default' succeeded
    11:55:00 : LECS PACKET ATM2/0/0: added the elan-id (1) tlv to config response; num_tlvs = 1
    11:55:00 : LECS PACKET ATM2/0/0: packet transmitted
    11:55:00 : LECS PACKET: time units used: 4, total requests: 2478, total time units: 1244
    11:55:00 : LECS EVENT ATM2/0/0: ATM_RELEASE received: callid 0x6103C1BC cause 31
    11:55:00 : LECS EVENT ATM2/0/0: sending RELEASE_COMPLETE for call 0x6103C1BC cause 31
    11:55:00 : LECS EVENT ATM2/0/0: final removal of connection obj for callid 0x6103C1BC
    11:55:00 : LECS EVENT ATM2/0/0: call 0x6103C1BC cleaned up


    I think the problem is in my LS1010 config, anyone got an idea?
    Thanks,
    Hkz

    P.S.
    sorry for my english: i'm not a native speaker.

    --
    "La profonda attrazione esercitata da (...) sentirsi parte di una
    potente Elite tecnologica non dovrebbe mai essere sottovalutata."
    -Bruce Sterling
    HKZlab Network: http://hkzlab.spatof.org
    INTERnet ->
    Retro DECnet -> 1126::HKZ
     
    Hkz, Dec 22, 2007
    #1
    1. Advertising

  2. Hkz

    Hkz Guest

    Problem solved:
    i forgot to add the vlan to the atm trunk port on the catalyst 3200.
    Here's an ls1010 working config:
    Current configuration:
    !
    ! Last configuration change at 01:29:00 GMT+1 Tue Dec 25 2007 by router
    ! NVRAM config last updated at 01:31:38 GMT+1 Tue Dec 25 2007 by router
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service compress-config
    !
    hostname LS1010
    !
    enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
    enable password 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXx
    !
    username router password 7 04480A0D01345F5D0C14
    ip subnet-zero
    no ip routing
    ip domain-name hkzlab.net
    ip name-server 192.168.2.20
    !
    atm qos default cbr max-cell-loss-ratio clp0 255
    atm qos default cbr max-cell-loss-ratio clp1plus0 255
    atm qos default vbr-rt max-cell-loss-ratio clp0 255
    atm qos default vbr-rt max-cell-loss-ratio clp1plus0 255
    atm qos default vbr-nrt max-cell-loss-ratio clp0 255
    atm qos default vbr-nrt max-cell-loss-ratio clp1plus0 255
    atm lecs-address-default 47.0091.8100.0000.0060.3e5a.4501.0010.0739.b105.00 1
    atm address 47.0091.8100.0000.0060.3e5a.4501.0060.3e5a.4501.00
    atm router pnni
    no aesa embedded-number left-justified
    node 1 level 56 lowest
    redistribute atm-static
    !
    !
    lane database LANE_DATABASE
    name default server-atm-address 47.00918100000000603E5A4501.00100739B103.01
    name labvlan server-atm-address 47.00918100000000603E5A4501.00100739B103.02
    name privlan server-atm-address 47.00918100000000603E5A4501.00100739B103.03
    default-name default
    clock timezone GMT+1 1
    clock summer-time ORA_LEGALE recurring last Sun Mar 2:00 last Sun Oct 2:00
    !
    !
    interface ATM0/0/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    no atm ilmi-keepalive
    !
    interface ATM0/0/1
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/0/2
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/0/3
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/1
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/2
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM0/1/3
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM1/0/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM1/1/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM2/0/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    atm maxvp-number 0
    lane config auto-config-atm-address
    lane config database LANE_DATABASE
    !
    interface ATM2/0/0.1 multipoint
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    lane server-bus ethernet default
    !
    interface ATM2/0/0.2 multipoint
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    lane server-bus ethernet labvlan
    !
    interface ATM2/0/0.3 multipoint
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    lane server-bus ethernet privlan
    !
    interface Ethernet2/0/0
    ip address 192.168.1.230 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    !
    interface ATM3/0/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    interface ATM3/1/0
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    logging event subif-link-status
    shutdown
    no atm ilmi-keepalive
    !
    ip default-gateway 192.168.1.1
    ip classless
    !
    line con 0
    login local
    transport input none
    line aux 0
    line vty 0 4
    password 7 0017120D0A4E18150A2C
    login local
    !
    ntp clock-period 17180182
    ntp server 192.168.1.160
    end

    Oh, and Merry Christmas to everyone!
    Hkz


    --
    "La profonda attrazione esercitata da (...) sentirsi parte di una
    potente Elite tecnologica non dovrebbe mai essere sottovalutata."
    -Bruce Sterling
    HKZlab Network: http://hkzlab.spatof.org
    INTERnet ->
    Retro DECnet -> 1126::HKZ
     
    Hkz, Dec 25, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jarek Jarzebowski
    Replies:
    1
    Views:
    1,191
  2. LS1010 show version

    , Jul 13, 2005, in forum: Cisco
    Replies:
    0
    Views:
    470
  3. brownie
    Replies:
    1
    Views:
    904
  4. mnkyb0i

    VLAN Trunking/Routing Problem

    mnkyb0i, Jun 26, 2007, in forum: Cisco
    Replies:
    0
    Views:
    504
    mnkyb0i
    Jun 26, 2007
  5. Neddy
    Replies:
    8
    Views:
    1,712
    Doug McIntyre
    May 27, 2009
Loading...

Share This Page