Can't View Website from within LAN

Discussion in 'Cisco' started by wisccal@googlemail.com, Mar 1, 2007.

  1. Guest

    Hi,

    For some reason, I'm unable to access my website from within my
    network. It works just fine from any computer outside the LAN, though.
    I can also view my website if I type the local IP address or localhost
    on the server, but not on any other machine in the network. What
    happened instead is that I got to the router's login page. I disabled
    this by using "no ip http server", but to no avail. Now, when I try
    it, the browser just can't find any webpage.

    The reason that I believe it is a router issue is that I updated the
    firmware, and as far as I remember, it worked before that. Also, I
    know for sure that I did not change any settings on my server that
    could cause this. The router is a Cisco 850 and the firmware version
    is IOS 12.3.

    I don't really know much about networks, so if there is any other
    relevant information that you need, please let me know.

    Thanks,
    Stefan
    --------------------------
    www.stkomp.com
    , Mar 1, 2007
    #1
    1. Advertising

  2. Trendkill Guest

    On Mar 1, 7:24 am, wrote:
    > Hi,
    >
    > For some reason, I'm unable to access my website from within my
    > network. It works just fine from any computer outside the LAN, though.
    > I can also view my website if I type the local IP address or localhost
    > on the server, but not on any other machine in the network. What
    > happened instead is that I got to the router's login page. I disabled
    > this by using "no ip http server", but to no avail. Now, when I try
    > it, the browser just can't find any webpage.
    >
    > The reason that I believe it is a router issue is that I updated the
    > firmware, and as far as I remember, it worked before that. Also, I
    > know for sure that I did not change any settings on my server that
    > could cause this. The router is a Cisco 850 and the firmware version
    > is IOS 12.3.
    >
    > I don't really know much about networks, so if there is any other
    > relevant information that you need, please let me know.
    >
    > Thanks,
    > Stefan
    > --------------------------www.stkomp.com


    If you can access the page on the server itself by going to localhost,
    then you should be able to get to it by typing http:\\<internalIP>:80
    from any other computer on the same network segment (ie, in the same
    subnet).

    Second, I would make sure that whatever port forwarding you setup on
    the router is still there. Do you have internal vs external IP
    addressing? (192.168.x.x internal?)

    Lastly, do you have a domain name that is pointed correctly?
    Trendkill, Mar 1, 2007
    #2
    1. Advertising

  3. Guest

    Thanks for your answer.

    Yes, I can actually access the website from within the network using
    192.168.xxx.xxx. Sorry about this, must have typed the wrong IP or
    something when I was trying it before.

    Yes, the router is set up to use NAT. "ip nat translation" shows me
    among others this entry, which to me, looks correct:

    Pro Inside global Inside Local Outside local Outside global
    tcp 213.xxx.xxx.xxx:80 192.168.xxx.xxx:80 --- ---

    Yes, the domain name points to the right address. As I said, I can
    access the website from any one machine outside the network using the
    domain name. It's only on machines hooked up to this network where
    this doesn't work.

    Thanks again,
    Stefan

    Trendkill wrote:
    > On Mar 1, 7:24 am, wrote:
    > > Hi,
    > >
    > > For some reason, I'm unable to access my website from within my
    > > network. It works just fine from any computer outside the LAN, though.
    > > I can also view my website if I type the local IP address or localhost
    > > on the server, but not on any other machine in the network. What
    > > happened instead is that I got to the router's login page. I disabled
    > > this by using "no ip http server", but to no avail. Now, when I try
    > > it, the browser just can't find any webpage.
    > >
    > > The reason that I believe it is a router issue is that I updated the
    > > firmware, and as far as I remember, it worked before that. Also, I
    > > know for sure that I did not change any settings on my server that
    > > could cause this. The router is a Cisco 850 and the firmware version
    > > is IOS 12.3.
    > >
    > > I don't really know much about networks, so if there is any other
    > > relevant information that you need, please let me know.
    > >
    > > Thanks,
    > > Stefan
    > > --------------------------www.stkomp.com

    >
    > If you can access the page on the server itself by going to localhost,
    > then you should be able to get to it by typing http:\\<internalIP>:80
    > from any other computer on the same network segment (ie, in the same
    > subnet).
    >
    > Second, I would make sure that whatever port forwarding you setup on
    > the router is still there. Do you have internal vs external IP
    > addressing? (192.168.x.x internal?)
    >
    > Lastly, do you have a domain name that is pointed correctly?
    , Mar 1, 2007
    #3
  4. Guest

    I should have clarified that both domain name & external IP
    (213.XXX.XXX.XXX) do not work inside the LAN. And both work outside.

    On Mar 1, 4:00 pm, wrote:
    > Thanks for your answer.
    >
    > Yes, I can actuallyaccessthewebsitefromwithinthe network using
    > 192.168.xxx.xxx. Sorry about this, must have typed the wrong IP or
    > something when I was trying it before.
    >
    > Yes, the router is set up to use NAT. "ip nat translation" shows me
    > among others this entry, which to me, looks correct:
    >
    > Pro Inside global Inside Local Outside local Outside global
    > tcp 213.xxx.xxx.xxx:80 192.168.xxx.xxx:80 --- ---
    >
    > Yes, the domain name points to the right address. As I said, I canaccessthewebsitefrom any one machine outside the network using the
    > domain name. It's only on machines hooked up to this network where
    > this doesn't work.
    >
    > Thanks again,
    > Stefan
    >
    > Trendkill wrote:
    > > On Mar 1, 7:24 am, wrote:
    > > > Hi,

    >
    > > > For some reason, I'm unable toaccessmywebsitefromwithinmy
    > > > network. It works just fine from any computer outside theLAN, though.
    > > > I can also view mywebsiteif I type the local IP address or localhost
    > > > on the server, but not on any other machine in the network. What
    > > > happened instead is that I got to the router's login page. I disabled
    > > > this by using "no ip http server", but to no avail. Now, when I try
    > > > it, the browser justcan'tfind any webpage.

    >
    > > > The reason that I believe it is a router issue is that I updated the
    > > > firmware, and as far as I remember, it worked before that. Also, I
    > > > know for sure that I did not change any settings on my server that
    > > > could cause this. The router is a Cisco 850 and the firmware version
    > > > is IOS 12.3.

    >
    > > > I don't really know much about networks, so if there is any other
    > > > relevant information that you need, please let me know.

    >
    > > > Thanks,
    > > > Stefan
    > > > --------------------------www.stkomp.com

    >
    > > If you canaccessthe page on the server itself by going to localhost,
    > > then you should be able to get to it by typing http:\\<internalIP>:80
    > > from any other computer on the same network segment (ie, in the same
    > > subnet).

    >
    > > Second, I would make sure that whatever port forwarding you setup on
    > > the router is still there. Do you have internal vs external IP
    > > addressing? (192.168.x.x internal?)

    >
    > > Lastly, do you have a domain name that is pointed correctly?
    , Mar 1, 2007
    #4
  5. Trendkill Guest

    On Mar 1, 10:03 am, wrote:
    > I should have clarified that both domain name & external IP
    > (213.XXX.XXX.XXX) do not work inside the LAN. And both work outside.
    >
    > On Mar 1, 4:00 pm, wrote:
    >
    > > Thanks for your answer.

    >
    > > Yes, I can actuallyaccessthewebsitefromwithinthe network using
    > > 192.168.xxx.xxx. Sorry about this, must have typed the wrong IP or
    > > something when I was trying it before.

    >
    > > Yes, the router is set up to use NAT. "ip nat translation" shows me
    > > among others this entry, which to me, looks correct:

    >
    > > Pro Inside global Inside Local Outside local Outside global
    > > tcp 213.xxx.xxx.xxx:80 192.168.xxx.xxx:80 --- ---

    >
    > > Yes, the domain name points to the right address. As I said, I canaccessthewebsitefrom any one machine outside the network using the
    > > domain name. It's only on machines hooked up to this network where
    > > this doesn't work.

    >
    > > Thanks again,
    > > Stefan

    >
    > > Trendkill wrote:
    > > > On Mar 1, 7:24 am, wrote:
    > > > > Hi,

    >
    > > > > For some reason, I'm unable toaccessmywebsitefromwithinmy
    > > > > network. It works just fine from any computer outside theLAN, though.
    > > > > I can also view mywebsiteif I type the local IP address or localhost
    > > > > on the server, but not on any other machine in the network. What
    > > > > happened instead is that I got to the router's login page. I disabled
    > > > > this by using "no ip http server", but to no avail. Now, when I try
    > > > > it, the browser justcan'tfind any webpage.

    >
    > > > > The reason that I believe it is a router issue is that I updated the
    > > > > firmware, and as far as I remember, it worked before that. Also, I
    > > > > know for sure that I did not change any settings on my server that
    > > > > could cause this. The router is a Cisco 850 and the firmware version
    > > > > is IOS 12.3.

    >
    > > > > I don't really know much about networks, so if there is any other
    > > > > relevant information that you need, please let me know.

    >
    > > > > Thanks,
    > > > > Stefan
    > > > > --------------------------www.stkomp.com

    >
    > > > If you canaccessthe page on the server itself by going to localhost,
    > > > then you should be able to get to it by typing http:\\<internalIP>:80
    > > > from any other computer on the same network segment (ie, in the same
    > > > subnet).

    >
    > > > Second, I would make sure that whatever port forwarding you setup on
    > > > the router is still there. Do you have internal vs external IP
    > > > addressing? (192.168.x.x internal?)

    >
    > > > Lastly, do you have a domain name that is pointed correctly?


    Sounds to me like your router is not allowing traffic out and back
    in. Are you using an internal DNS server or one from the ISP? If
    internal, I'd consider putting in a static entry for the web-server to
    the internal IP address. If externally, something in your router
    config is preventing traffic from going out and coming back in. You
    may want to paste your config (just relevant parts of config
    obviously, and may want to mask IPs)
    Trendkill, Mar 1, 2007
    #5
  6. AM Guest

    wrote:
    > Hi,
    >



    > I don't really know much about networks, so if there is any other
    > relevant information that you need, please let me know.
    >


    Do you have a NAT for the entire IP protocol or have just translated the TCP port 80?

    Alex.
    AM, Mar 1, 2007
    #6
  7. Egghead Guest

    Is it the alias problem?

    cheers,
    RL
    <> wrote in message
    news:...
    > Hi,
    >
    > For some reason, I'm unable to access my website from within my
    > network. It works just fine from any computer outside the LAN, though.
    > I can also view my website if I type the local IP address or localhost
    > on the server, but not on any other machine in the network. What
    > happened instead is that I got to the router's login page. I disabled
    > this by using "no ip http server", but to no avail. Now, when I try
    > it, the browser just can't find any webpage.
    >
    > The reason that I believe it is a router issue is that I updated the
    > firmware, and as far as I remember, it worked before that. Also, I
    > know for sure that I did not change any settings on my server that
    > could cause this. The router is a Cisco 850 and the firmware version
    > is IOS 12.3.
    >
    > I don't really know much about networks, so if there is any other
    > relevant information that you need, please let me know.
    >
    > Thanks,
    > Stefan
    > --------------------------
    > www.stkomp.com
    >
    Egghead, Mar 1, 2007
    #7
  8. Guest

    OK, below is the part of the config file that, I hope, is relevant.
    No, there is no internal DNS server, I'm using my ISP's. And yes, I
    have NAT for the entire protocol (as far as I know). Lastly, I don't
    know what the alias problem is. Can you please explain?

    Thanks for your help,

    Stefan

    ---------------------------------------

    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 5 life 86400 requests 10000
    ip nat inside source list 1 interface FastEthernet4 overload
    ip nat inside source static tcp 192.168.1.123 21 interface
    FastEthernet4 21
    ip nat inside source static tcp 192.168.1.123 50000 interface
    FastEthernet4 50000
    ip nat inside source static tcp 192.168.1.123 80 interface
    FastEthernet4 80
    ip nat inside source static tcp 192.168.1.123 1433 interface
    FastEthernet4 1433
    ip nat inside source static tcp 192.168.1.123 443 interface
    FastEthernet4 443
    ip nat inside source static tcp 192.168.1.123 3389 interface
    FastEthernet4 3389
    !
    ip access-list extended Inside_Out
    permit ip any any
    ip access-list extended Outside_In
    permit tcp any host 213.XXX.XXX.XXX eq 22
    permit tcp any host 213.XXX.XXX.XXX eq telnet
    permit tcp host 216.204.141.92 host 213.XXX.XXX.XXX eq 3389
    permit tcp host 216.204.141.91 host 213.XXX.XXX.XXX eq 3389
    permit tcp host 64.102.253.96 host 213.XXX.XXX.XXX eq 3389
    permit tcp host 216.204.141.90 host 213.XXX.XXX.XXX eq 3389
    permit tcp any host 213.XXX.XXX.XXX eq 3389
    permit esp any any
    permit ahp any any
    permit udp any any eq non500-isakmp
    permit udp any any eq isakmp
    permit tcp any host 213.XXX.XXX.XXX eq 443
    permit tcp host 216.204.141.90 host 213.XXX.XXX.XXX eq 1433
    permit tcp host 216.204.141.91 host 213.XXX.XXX.XXX eq 1433
    permit tcp host 216.204.141.92 host 213.XXX.XXX.XXX eq 1433
    permit tcp host 64.102.253.96 host 213.XXX.XXX.XXX eq 1433
    permit tcp any host 213.XXX.XXX.XXX eq www
    permit tcp any host 213.XXX.XXX.XXX eq ftp
    permit tcp any host 213.XXX.XXX.XXX eq 50000
    , Mar 2, 2007
    #8
  9. Egghead Guest

    Nothing to do with DNS here

    You need to add an alias in your box which match the website's REAL address
    to your lan address. I will do that to my box:

    "alias (inside) LAN_ADDRESS WEB_REAL_IP_ADDRESS"

    So that "smart" box will not try to route package to the device with the
    same security level.

    You need to read your router manual on how to add alias.

    cheers,
    RL
    <> wrote in message
    news:...
    > OK, below is the part of the config file that, I hope, is relevant.
    > No, there is no internal DNS server, I'm using my ISP's. And yes, I
    > have NAT for the entire protocol (as far as I know). Lastly, I don't
    > know what the alias problem is. Can you please explain?
    >
    > Thanks for your help,
    >
    > Stefan
    >
    > ---------------------------------------
    >
    > ip http server
    > ip http authentication local
    > ip http secure-server
    > ip http timeout-policy idle 5 life 86400 requests 10000
    > ip nat inside source list 1 interface FastEthernet4 overload
    > ip nat inside source static tcp 192.168.1.123 21 interface
    > FastEthernet4 21
    > ip nat inside source static tcp 192.168.1.123 50000 interface
    > FastEthernet4 50000
    > ip nat inside source static tcp 192.168.1.123 80 interface
    > FastEthernet4 80
    > ip nat inside source static tcp 192.168.1.123 1433 interface
    > FastEthernet4 1433
    > ip nat inside source static tcp 192.168.1.123 443 interface
    > FastEthernet4 443
    > ip nat inside source static tcp 192.168.1.123 3389 interface
    > FastEthernet4 3389
    > !
    > ip access-list extended Inside_Out
    > permit ip any any
    > ip access-list extended Outside_In
    > permit tcp any host 213.XXX.XXX.XXX eq 22
    > permit tcp any host 213.XXX.XXX.XXX eq telnet
    > permit tcp host 216.204.141.92 host 213.XXX.XXX.XXX eq 3389
    > permit tcp host 216.204.141.91 host 213.XXX.XXX.XXX eq 3389
    > permit tcp host 64.102.253.96 host 213.XXX.XXX.XXX eq 3389
    > permit tcp host 216.204.141.90 host 213.XXX.XXX.XXX eq 3389
    > permit tcp any host 213.XXX.XXX.XXX eq 3389
    > permit esp any any
    > permit ahp any any
    > permit udp any any eq non500-isakmp
    > permit udp any any eq isakmp
    > permit tcp any host 213.XXX.XXX.XXX eq 443
    > permit tcp host 216.204.141.90 host 213.XXX.XXX.XXX eq 1433
    > permit tcp host 216.204.141.91 host 213.XXX.XXX.XXX eq 1433
    > permit tcp host 216.204.141.92 host 213.XXX.XXX.XXX eq 1433
    > permit tcp host 64.102.253.96 host 213.XXX.XXX.XXX eq 1433
    > permit tcp any host 213.XXX.XXX.XXX eq www
    > permit tcp any host 213.XXX.XXX.XXX eq ftp
    > permit tcp any host 213.XXX.XXX.XXX eq 50000
    >
    Egghead, Mar 2, 2007
    #9
  10. Smokey Guest

    wrote:
    > OK, below is the part of the config file that, I hope, is relevant.
    > No, there is no internal DNS server, I'm using my ISP's. And yes, I
    > have NAT for the entire protocol (as far as I know). Lastly, I don't
    > know what the alias problem is. Can you please explain?
    >
    > Thanks for your help,
    >
    > Stefan
    >
    > ---------------------------------------


    Basically you can not send a request out the same interface you are to
    receive the request on. I would try the alias command, what this does is
    rewrites the internal IP for request to that external IP.

    So if you had this scenario:

    Web: 192.168.0.2
    Client: 192.168.0.3
    Router Inside: 192.168.0.1
    Router Outside: 2.2.2.2

    When the client requests you website from the LAN it can not be directed
    to 2.2.2.2 instead it must use the internal IP of 192.168.0.2, the alias
    command will rewrite that for you so when the clients request hits the
    router it rewrites the destination IP as 192.168.0.2.


    HTH
    Smokey, Mar 2, 2007
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?bWFza2Fs?=

    wireless lan for three computers within a large corporate network

    =?Utf-8?B?bWFza2Fs?=, Feb 4, 2005, in forum: Wireless Networking
    Replies:
    7
    Views:
    579
    =?Utf-8?B?bWFza2Fs?=
    Feb 4, 2005
  2. congoclash
    Replies:
    4
    Views:
    15,469
    cisco_user
    Nov 23, 2008
  3. =?Utf-8?B?U05DTFRV?=

    Reading within folders on a wireless LAN

    =?Utf-8?B?U05DTFRV?=, Jan 22, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    530
  4. Mirsky

    Best website for sharing photos within a group?

    Mirsky, Sep 25, 2006, in forum: Digital Photography
    Replies:
    3
    Views:
    340
    Bruce Lewis
    Sep 26, 2006
  5. Replies:
    0
    Views:
    389
Loading...

Share This Page