can't take off the read-only attrib for XP

Discussion in 'MCSE' started by Bay, Oct 16, 2003.

  1. Bay

    Bay Guest

    Hi,

    I am trying to replace the laptop hard drive but I don't want to reinstall
    everything over again, so I plan to create an image by using the ghost. I
    don't have a adaptor to allow myself cloning the hard drive, so I am
    creating the image to a shared folder within the domain. The shared folder
    is located in the client machine within the domain. The shared folder has a
    "read only" attribute for some reason I don't know why, everytime I checked
    it off and it will be checked on again when I checked its properties again.
    So now even I have the mapped drive floppy disk created by the ghost, I am
    still not able to connect to the shared folder. The message said the file
    is marked as read-only and request me to change the attribute. Why can't I
    change the attribute permanently? What should I do?

    Thanks

    Billy
    Bay, Oct 16, 2003
    #1
    1. Advertising

  2. Bay

    Ken Briscoe Guest

    "Bay" <> wrote in message
    news:zVDjb.789139$Ho3.211525@sccrnsc03...
    > Hi,
    >
    > I am trying to replace the laptop hard drive but I don't want to reinstall
    > everything over again, so I plan to create an image by using the ghost. I
    > don't have a adaptor to allow myself cloning the hard drive, so I am
    > creating the image to a shared folder within the domain. The shared

    folder
    > is located in the client machine within the domain. The shared folder has

    a
    > "read only" attribute for some reason I don't know why, everytime I

    checked
    > it off and it will be checked on again when I checked its properties

    again.
    > So now even I have the mapped drive floppy disk created by the ghost, I am
    > still not able to connect to the shared folder. The message said the file
    > is marked as read-only and request me to change the attribute. Why can't I
    > change the attribute permanently? What should I do?
    >
    > Thanks
    >
    > Billy
    >
    >


    Have you tried doing it from a command line? try the command "attrib"
    syntax is: attrib <path\filename> -r
    or attrib /? for more help

    KB
    Ken Briscoe, Oct 17, 2003
    #2
    1. Advertising

  3. Bay

    Roger Abell Guest

    Wake up. On a folder that checkbox is only a switch used
    to set/unset the attribute on contained files. Did you not get
    a prompt to that effect when you used it ?

    If you want to view/change the read-only attibute on folders
    in XP or W2k3 you need to use the attrib command.

    --
    Roger Abell
    Microsoft MVP (Windows Server System: Security)
    MCSE (W2k3,W2k,Nt4) MCDBA
    "Bay" <> wrote in message
    news:zVDjb.789139$Ho3.211525@sccrnsc03...
    > Hi,
    >
    > I am trying to replace the laptop hard drive but I don't want to reinstall
    > everything over again, so I plan to create an image by using the ghost. I
    > don't have a adaptor to allow myself cloning the hard drive, so I am
    > creating the image to a shared folder within the domain. The shared

    folder
    > is located in the client machine within the domain. The shared folder has

    a
    > "read only" attribute for some reason I don't know why, everytime I

    checked
    > it off and it will be checked on again when I checked its properties

    again.
    > So now even I have the mapped drive floppy disk created by the ghost, I am
    > still not able to connect to the shared folder. The message said the file
    > is marked as read-only and request me to change the attribute. Why can't I
    > change the attribute permanently? What should I do?
    >
    > Thanks
    >
    > Billy
    >
    >
    Roger Abell, Oct 18, 2003
    #3
  4. Bay

    Nerka

    Joined:
    Oct 18, 2006
    Messages:
    1
    Hi there,

    I'm currently having the same problem. My folder was shared from one computer to another as we're shifting around terminals at the lab I work in. However, in its new location, I am unable to remove the read-only attribute from my folder or any of its sub-folders or files. The same thing described here occurs - the box in the properties window is unchecked, but is re-checked as soon as the window is re-opened. I tried removing the attribute from the command prompt, as suggested here (attrib <path/filename> -r) but the same pattern occurs

    Randy
    Nerka, Oct 18, 2006
    #4
  5. Bay

    Robbap

    Joined:
    Jun 15, 2007
    Messages:
    1
    How to remove read-only attrib in XP

    This might not be the best solution, or the only one, but it is by far the easiest. In my experience the problem you're having is caused by the desktop.ini file in the folder being deleted or corrupted.

    Do a search for the desktop.ini file, and copy a version of it from any other folder where you are NOT having this problem. That should take care of the issue, and allow you to actually change the folder settings.

    The reason you aren't being allowed to right now, is that desktop.ini is XP's file where configuration settings are kept for folders (viewing options, etc). If this file is erased or corrupted, XP will bug out, not 'knowing' how to treat the folder.

    ~Rob
    Robbap, Jun 15, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ashjas
    Replies:
    4
    Views:
    561
  2. larya
    Replies:
    7
    Views:
    496
    thanatoid
    Sep 11, 2006
  3. crgbut147

    attrib command in DOS for XP windows

    crgbut147, Apr 8, 2007, in forum: General Computer Support
    Replies:
    0
    Views:
    1,499
    crgbut147
    Apr 8, 2007
  4. Giuen
    Replies:
    0
    Views:
    692
    Giuen
    Sep 12, 2008
  5. Bay
    Replies:
    3
    Views:
    379
    Roger Abell
    Oct 18, 2003
Loading...

Share This Page