Can't ping my routers in my home network.

Discussion in 'Cisco' started by group user, Feb 14, 2004.

  1. group user

    group user Guest

    Hi all,

    I have a 3550 switch SMI with three Vlans configured that I can ping, telnet
    and configure from my home network. The switch can ping and access the home
    network and the 'net.

    I have a 3620 router that is connected to each of two vlans. The Routers
    can ping the switch but not the home network nor the 'net. I'd like to be
    able to telnet directly to the router from my home network without having to
    either console to it or telnet from the Switch. I can telnet and ping
    between the switch and router. I have a static route setup on the router to
    the switch as well as RIP to the network they share.

    Can anyone take a look at my configs below to see what I might need to add
    in order for me to reach the routers directly?

    Do I need to enable a RIP or static routing protocol on the switch as well?
    (I thought about this as I was making this post.)

    Tell me I figured it out on my own!

    Thanks.

    --
    hostname RouterB
    !
    boot system flash c3620-ik9s-mz.122-7c.bin
    logging buffered 4096 debugging
    enable password 7 xx
    !
    clock timezone NewJersey -5
    ip subnet-zero
    !
    ip host Switch 192.168.2.2
    ip host RouterA 10.168.1.1
    ip name-server x.x.x.x
    ip name-server x.x.x.x
    no ip dhcp conflict logging
    !
    ip ssh time-out 120
    ip ssh authentication-retries 3
    !
    call rsvp-sync
    !
    interface Ethernet0/0
    ip address 192.168.2.1 255.255.255.0
    full-duplex
    !
    interface Ethernet0/1 <=directly connected with xover to another router
    ip address 10.168.1.2 255.255.255.252
    full-duplex
    !
    router rip
    network 10.0.0.0 <=network to directly connected router
    network 192.168.2.0 <network to Switch
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.2.2 <=switch ip address
    no ip http server
    no ip pim bidir-enable
    !
    dial-peer cor custom
    !
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 5 0
    password 7 xx
    login
    length 25
    !
    ntp clock-period 17179920
    ntp server 192.168.2.2
    end
    --
    Switch config follows

    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Switch
    !
    enable password cisco
    !
    clock timezone NewJersey -5
    ip subnet-zero
    ip routing
    ip host RouterB 192.168.2.1
    ip host RouterA 192.168.1.1
    ip name-server x.x.x.x
    ip name-server x.x.x.x
    !
    mls qos
    !
    spanning-tree extend system-id
    !
    interface FastEthernet0/1
    description connection to RouterA
    switchport access vlan 10
    switchport mode access
    no ip address
    duplex full
    !
    interface FastEthernet0/12
    description connection to RouterB
    switchport access vlan 20
    switchport mode access
    no ip address
    duplex full
    !
    interface FastEthernet0/47
    description connection to home network
    switchport access vlan 1
    switchport mode access
    no ip address
    duplex full
    speed 100
    !
    interface GigabitEthernet0/1
    no ip address
    !
    interface GigabitEthernet0/2
    no ip address
    !
    interface Vlan1
    ip address 192.168.0.20 255.255.255.0 <=connected to my Dlink home router
    !
    interface Vlan10
    ip address 192.168.1.2 255.255.255.0 <=connected to RouterA
    !
    interface Vlan20
    ip address 192.168.2.2 255.255.255.0 <=connected to RouterB
    !
    ip default-gateway 192.168.0.1 <=my Dlink home router
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.0.1 <=my Dlink home router
    ip http server
    !
    access-list 1 permit any
    !
    line con 0
    password cisco
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    ntp clock-period 17180545
    ntp access-group peer 1
    ntp max-associations 3
    ntp peer 192.168.1.1
    ntp peer 192.168.2.1
    ntp server 65.211.109.11
    ntp server 65.211.109.1
    end
    group user, Feb 14, 2004
    #1
    1. Advertising

  2. group user

    PES Guest

    "group user" <> wrote in message
    news:c0lnvu$...
    > Hi all,
    >
    > I have a 3550 switch SMI with three Vlans configured that I can ping,

    telnet
    > and configure from my home network. The switch can ping and access the

    home
    > network and the 'net.
    >
    > I have a 3620 router that is connected to each of two vlans. The Routers
    > can ping the switch but not the home network nor the 'net. I'd like to be
    > able to telnet directly to the router from my home network without having

    to
    > either console to it or telnet from the Switch. I can telnet and ping
    > between the switch and router. I have a static route setup on the router

    to
    > the switch as well as RIP to the network they share.
    >
    > Can anyone take a look at my configs below to see what I might need to add
    > in order for me to reach the routers directly?
    >
    > Do I need to enable a RIP or static routing protocol on the switch as

    well?
    > (I thought about this as I was making this post.)
    >
    > Tell me I figured it out on my own!
    >
    > Thanks.
    >
    > --
    > hostname RouterB
    > !
    > boot system flash c3620-ik9s-mz.122-7c.bin
    > logging buffered 4096 debugging
    > enable password 7 xx
    > !
    > clock timezone NewJersey -5
    > ip subnet-zero
    > !
    > ip host Switch 192.168.2.2
    > ip host RouterA 10.168.1.1
    > ip name-server x.x.x.x
    > ip name-server x.x.x.x
    > no ip dhcp conflict logging
    > !
    > ip ssh time-out 120
    > ip ssh authentication-retries 3
    > !
    > call rsvp-sync
    > !
    > interface Ethernet0/0
    > ip address 192.168.2.1 255.255.255.0
    > full-duplex
    > !
    > interface Ethernet0/1 <=directly connected with xover to another router
    > ip address 10.168.1.2 255.255.255.252
    > full-duplex
    > !
    > router rip
    > network 10.0.0.0 <=network to directly connected router
    > network 192.168.2.0 <network to Switch
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.2.2 <=switch ip address
    > no ip http server
    > no ip pim bidir-enable
    > !
    > dial-peer cor custom
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > exec-timeout 5 0
    > password 7 xx
    > login
    > length 25
    > !
    > ntp clock-period 17179920
    > ntp server 192.168.2.2
    > end
    > --
    > Switch config follows
    >
    > version 12.1
    > no service pad
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Switch
    > !
    > enable password cisco
    > !
    > clock timezone NewJersey -5
    > ip subnet-zero
    > ip routing
    > ip host RouterB 192.168.2.1
    > ip host RouterA 192.168.1.1
    > ip name-server x.x.x.x
    > ip name-server x.x.x.x
    > !
    > mls qos
    > !
    > spanning-tree extend system-id
    > !
    > interface FastEthernet0/1
    > description connection to RouterA
    > switchport access vlan 10
    > switchport mode access
    > no ip address
    > duplex full
    > !
    > interface FastEthernet0/12
    > description connection to RouterB
    > switchport access vlan 20
    > switchport mode access
    > no ip address
    > duplex full
    > !
    > interface FastEthernet0/47
    > description connection to home network
    > switchport access vlan 1
    > switchport mode access
    > no ip address
    > duplex full
    > speed 100
    > !
    > interface GigabitEthernet0/1
    > no ip address
    > !
    > interface GigabitEthernet0/2
    > no ip address
    > !
    > interface Vlan1
    > ip address 192.168.0.20 255.255.255.0 <=connected to my Dlink home router
    > !
    > interface Vlan10
    > ip address 192.168.1.2 255.255.255.0 <=connected to RouterA
    > !
    > interface Vlan20
    > ip address 192.168.2.2 255.255.255.0 <=connected to RouterB
    > !
    > ip default-gateway 192.168.0.1 <=my Dlink home router
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.0.1 <=my Dlink home router
    > ip http server
    > !
    > access-list 1 permit any
    > !
    > line con 0
    > password cisco
    > line vty 0 4
    > password cisco
    > login
    > line vty 5 15
    > password cisco
    > login
    > !
    > ntp clock-period 17180545
    > ntp access-group peer 1
    > ntp max-associations 3
    > ntp peer 192.168.1.1
    > ntp peer 192.168.2.1
    > ntp server 65.211.109.11
    > ntp server 65.211.109.1
    > end
    >
    >

    Is the default gateway of the host pointed to an ip address on the 3550. If
    not, the device it is pointed at (possibly the dlink router) needs a static
    route to the 192.168.2.0 255.255.255.0 network.
    PES, Feb 14, 2004
    #2
    1. Advertising

  3. group user

    ^V^ Guest

    "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in message news:<402e7f5f$>...
    > "group user" <> wrote in message
    > news:c0lnvu$...
    > > Hi all,
    > >
    > > I have a 3550 switch SMI with three Vlans configured that I can ping,

    > telnet
    > > and configure from my home network. The switch can ping and access the

    > home
    > > network and the 'net.
    > >
    > > I have a 3620 router that is connected to each of two vlans. The Routers
    > > can ping the switch but not the home network nor the 'net. I'd like to be
    > > able to telnet directly to the router from my home network without having

    > to
    > > either console to it or telnet from the Switch. I can telnet and ping
    > > between the switch and router. I have a static route setup on the router

    > to
    > > the switch as well as RIP to the network they share.
    > >
    > > Can anyone take a look at my configs below to see what I might need to add
    > > in order for me to reach the routers directly?
    > >
    > > Do I need to enable a RIP or static routing protocol on the switch as

    > well?
    > > (I thought about this as I was making this post.)
    > >
    > > Tell me I figured it out on my own!
    > >
    > > Thanks.
    > >


    <snip>

    > >
    > >

    > Is the default gateway of the host pointed to an ip address on the 3550. If
    > not, the device it is pointed at (possibly the dlink router) needs a static
    > route to the 192.168.2.0 255.255.255.0 network.


    Thanks for your suggestion.

    The Dlink router that I have doesn't allow static routes. I can only
    allow or deny ip's or ports. I've allowed the IP of the switch and
    the router, but the Cisco router still cannot ping beyond the switch
    towards the Dlink (nor vice versa).

    I've added static routes in the switch's config for the path to the
    Dlink and to the Cisco routers. The pings still are not advertised
    outside of the switch in either direction from either router.

    Added the below to switch but it still doesn't help any.

    ip route 192.168.2.0 255.255.255.0 Vlan20
    ip route 192.168.2.0 255.255.255.0 192.168.2.1

    I did a traceroute from my computer and I can only see the vlan1 ip
    address 192.168.0.20. That is the directly connected interface to the
    Dlink and my home network. The switch apparently isn't routing to the
    different networks.

    Even though I have declared 'ip routing' on the switch, it seems not
    to be happening. Could that be the issue?

    Keep the suggestions coming please!
    ^V^, Feb 15, 2004
    #3
  4. group user

    PES Guest

    "^V^" <> wrote in message
    news:...
    > "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in

    message news:<402e7f5f$>...
    > > "group user" <> wrote in message
    > > news:c0lnvu$...
    > > > Hi all,
    > > >
    > > > I have a 3550 switch SMI with three Vlans configured that I can ping,

    > > telnet
    > > > and configure from my home network. The switch can ping and access

    the
    > > home
    > > > network and the 'net.
    > > >
    > > > I have a 3620 router that is connected to each of two vlans. The

    Routers
    > > > can ping the switch but not the home network nor the 'net. I'd like

    to be
    > > > able to telnet directly to the router from my home network without

    having
    > > to
    > > > either console to it or telnet from the Switch. I can telnet and ping
    > > > between the switch and router. I have a static route setup on the

    router
    > > to
    > > > the switch as well as RIP to the network they share.
    > > >
    > > > Can anyone take a look at my configs below to see what I might need to

    add
    > > > in order for me to reach the routers directly?
    > > >
    > > > Do I need to enable a RIP or static routing protocol on the switch as

    > > well?
    > > > (I thought about this as I was making this post.)
    > > >
    > > > Tell me I figured it out on my own!
    > > >
    > > > Thanks.
    > > >

    >
    > <snip>
    >
    > > >
    > > >

    > > Is the default gateway of the host pointed to an ip address on the 3550.

    If
    > > not, the device it is pointed at (possibly the dlink router) needs a

    static
    > > route to the 192.168.2.0 255.255.255.0 network.

    >
    > Thanks for your suggestion.
    >
    > The Dlink router that I have doesn't allow static routes. I can only
    > allow or deny ip's or ports. I've allowed the IP of the switch and
    > the router, but the Cisco router still cannot ping beyond the switch
    > towards the Dlink (nor vice versa).


    If the dlink will not allow the routing table to be adjusted by some means,
    it will not work with multiple internal subnets. A ping is an echo, and the
    client doing the pinging will only report success if it sees an associated
    echo reply. If you are pinging from a cisco box, you would get a U if it
    does not know the route to destination (or if you did a "no ip unreachables"
    on the interface. Most likely, based on what you have explained, your
    echo's are reaching the destination. The echo-replies don't know how to get
    back to the ip that the echo came from. Fire up a sniffer on the last hop
    the echo would take and you will see that the echo gets to the host, the
    host responds to the originating ip and the dest mac address will be that of
    the hosts default gateway. If that gateway does not have a route back to
    the ip address of the originating echo, it will deliver it to its default
    gateway. In the case of the d-link, it would go to the internet.


    >
    > I've added static routes in the switch's config for the path to the
    > Dlink and to the Cisco routers. The pings still are not advertised
    > outside of the switch in either direction from either router.


    Are you sure of this, from a controled environment, you could do a debug ip
    packet. Or you could write an acl to log to syslog or buffer.

    > Added the below to switch but it still doesn't help any.
    >
    > ip route 192.168.2.0 255.255.255.0 Vlan20
    > ip route 192.168.2.0 255.255.255.0 192.168.2.1


    Not necessary. This is a locally/direct connect to that interface.

    >
    > I did a traceroute from my computer and I can only see the vlan1 ip
    > address 192.168.0.20. That is the directly connected interface to the
    > Dlink and my home network. The switch apparently isn't routing to the
    > different networks.


    Set your default gateway on your computer to 192.168.0.20, and you can ping
    further.

    > Even though I have declared 'ip routing' on the switch, it seems not
    > to be happening. Could that be the issue?


    Not likely.

    >
    > Keep the suggestions coming please!
    PES, Feb 15, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?V0pQQw==?=

    Can not ping myself, but can ping others

    =?Utf-8?B?V0pQQw==?=, Dec 25, 2004, in forum: Wireless Networking
    Replies:
    6
    Views:
    5,947
    Chuck
    Dec 26, 2004
  2. Bob Simon
    Replies:
    8
    Views:
    7,111
    John Lamar
    Jan 19, 2005
  3. Jack \(MVP-Networking\).

    Re: Can't Ping Computers on Home Network

    Jack \(MVP-Networking\)., Jan 22, 2007, in forum: Wireless Networking
    Replies:
    0
    Views:
    562
    Jack \(MVP-Networking\).
    Jan 22, 2007
  4. David Hettel

    Re: Can't Ping Computers on Home Network

    David Hettel, Jan 22, 2007, in forum: Wireless Networking
    Replies:
    1
    Views:
    432
    =?Utf-8?B?VG9ueSBW?=
    Jan 29, 2007
  5. superkingkong
    Replies:
    2
    Views:
    1,797
    superkingkong
    Apr 17, 2010
Loading...

Share This Page