cant ping another interface on the same router ...

Discussion in 'Cisco' started by J Bard, Dec 30, 2003.

  1. J Bard

    J Bard Guest

    I'm getting this error

    Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
    %Invalid next hop address (it's this router)

    and when I simply try to ping 192.168.4.1, I get a time out. Though I'm new
    to this, I must say I'm puzzled by the behavior. Why should I not be able to
    ping another interface on the router ?


    Current configuration:
    !
    version 11.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable password ah
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.3.1 255.255.255.0
    !
    interface Serial0
    no ip address
    no ip mroute-cache
    shutdown
    no fair-queue
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface Async1
    ip address 192.168.4.1 255.255.255.0
    encapsulation ppp
    async dynamic routing
    async mode dedicated
    !
    router rip
    network 1.0.0.0
    network 169.254.0.0
    network 192.0.0.0
    !
    ip classless
    !
    !
    line con 0
    session-timeout 3000
    absolute-timeout 10000
    line aux 0

    modem InOut
    transport input all
    speed 38400
    flowcontrol hardware
    line vty 0 4
    password ah
    login
    !
    end
    J Bard, Dec 30, 2003
    #1
    1. Advertising

  2. what are the results of "show ip arp interface async1" ?

    Your default route should point to the next hop routing device.

    Claude

    "J Bard" <> wrote in message
    news:dtiIb.15429$...
    >
    > I'm getting this error
    >
    > Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
    > %Invalid next hop address (it's this router)
    >
    > and when I simply try to ping 192.168.4.1, I get a time out. Though I'm

    new
    > to this, I must say I'm puzzled by the behavior. Why should I not be able

    to
    > ping another interface on the router ?
    >
    >
    > Current configuration:
    > !
    > version 11.3
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router
    > !
    > enable password ah
    > !
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.3.1 255.255.255.0
    > !
    > interface Serial0
    > no ip address
    > no ip mroute-cache
    > shutdown
    > no fair-queue
    > !
    > interface Serial1
    > no ip address
    > shutdown
    > !
    > interface Async1
    > ip address 192.168.4.1 255.255.255.0
    > encapsulation ppp
    > async dynamic routing
    > async mode dedicated
    > !
    > router rip
    > network 1.0.0.0
    > network 169.254.0.0
    > network 192.0.0.0
    > !
    > ip classless
    > !
    > !
    > line con 0
    > session-timeout 3000
    > absolute-timeout 10000
    > line aux 0
    >
    > modem InOut
    > transport input all
    > speed 38400
    > flowcontrol hardware
    > line vty 0 4
    > password ah
    > login
    > !
    > end
    >
    >
    Claude LeFort, Dec 30, 2003
    #2
    1. Advertising

  3. In article <dtiIb.15429$>,
    "J Bard" <> wrote:

    > I'm getting this error
    >
    > Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
    > %Invalid next hop address (it's this router)


    It makes no sense to set a next hop to the router's own address. It
    means that the packets will just cycle forever on the router. You
    should use the address of the device at the other end, or the interface
    name:

    ip route 0.0.0.0 0.0.0.0 Async1

    > and when I simply try to ping 192.168.4.1, I get a time out. Though I'm new
    > to this, I must say I'm puzzled by the behavior. Why should I not be able to
    > ping another interface on the router ?


    When you ping a serial interface from the router itself, Cisco sends the
    packet out the interface and expects it to be forwarded back by the
    device at the other end. This allows you to use ping to confirm that
    the serial line is functioning properly.

    If the ping is failing, it may be a configuration problem with the
    remote router. Perhaps it doesn't have the correct address or mask on
    its Async interface.

    >
    > Current configuration:
    > !
    > version 11.3
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router
    > !
    > enable password ah
    > !
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.3.1 255.255.255.0
    > !
    > interface Serial0
    > no ip address
    > no ip mroute-cache
    > shutdown
    > no fair-queue
    > !
    > interface Serial1
    > no ip address
    > shutdown
    > !
    > interface Async1
    > ip address 192.168.4.1 255.255.255.0
    > encapsulation ppp
    > async dynamic routing
    > async mode dedicated
    > !
    > router rip
    > network 1.0.0.0
    > network 169.254.0.0
    > network 192.0.0.0
    > !
    > ip classless
    > !
    > !
    > line con 0
    > session-timeout 3000
    > absolute-timeout 10000
    > line aux 0
    >
    > modem InOut
    > transport input all
    > speed 38400
    > flowcontrol hardware
    > line vty 0 4
    > password ah
    > login
    > !
    > end
    >
    >


    --
    Barry Margolin,
    Arlington, MA
    Barry Margolin, Dec 30, 2003
    #3
  4. J Bard

    PES Guest

    Barry is correct. Don't route to yourself, route to the next hop. Also the
    statement
    network 192.0.0.0 is not 192.x.x.x it is 192.0.x.x. I doubt that is what
    you want.

    "J Bard" <> wrote in message
    news:dtiIb.15429$...
    >
    > I'm getting this error
    >
    > Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.1
    > %Invalid next hop address (it's this router)
    >
    > and when I simply try to ping 192.168.4.1, I get a time out. Though I'm

    new
    > to this, I must say I'm puzzled by the behavior. Why should I not be able

    to
    > ping another interface on the router ?
    >
    >
    > Current configuration:
    > !
    > version 11.3
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname Router
    > !
    > enable password ah
    > !
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.3.1 255.255.255.0
    > !
    > interface Serial0
    > no ip address
    > no ip mroute-cache
    > shutdown
    > no fair-queue
    > !
    > interface Serial1
    > no ip address
    > shutdown
    > !
    > interface Async1
    > ip address 192.168.4.1 255.255.255.0
    > encapsulation ppp
    > async dynamic routing
    > async mode dedicated
    > !
    > router rip
    > network 1.0.0.0
    > network 169.254.0.0
    > network 192.0.0.0
    > !
    > ip classless
    > !
    > !
    > line con 0
    > session-timeout 3000
    > absolute-timeout 10000
    > line aux 0
    >
    > modem InOut
    > transport input all
    > speed 38400
    > flowcontrol hardware
    > line vty 0 4
    > password ah
    > login
    > !
    > end
    >
    >
    PES, Dec 30, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page