Can't echo to router /dev/ttyS0 after reload/quit!

Discussion in 'Cisco' started by BOK, Jul 27, 2003.

  1. BOK

    BOK Guest

    I have this shell script, that runs:
    1. write erase
    2. reload
    3. answers "no" for the configuration dialog question
    4. enable
    5 some more commands..

    All the writings to the router are echo $1 > /dev/ttyS0.
    After step 3, the script commands no longer reach the router!
    I have to enter minicom, press Enter, and quit minicom (without "quit"
    command. only CTRL-A-q).
    It seems as if i enter minicom, type "quit" (and get the "press return
    to get started" print), and exit minicom without hitting enter, I
    encounter the same problem.
    btw, echo-ing "enters" doesn't do the job either.

    Does anyone have a clue?!

    i'm using a cisco 26xx with ios 12.2.
     
    BOK, Jul 27, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?Y2JrYXR5?=

    After bluescreen and reload Wireless will not work

    =?Utf-8?B?Y2JrYXR5?=, Sep 11, 2004, in forum: Wireless Networking
    Replies:
    0
    Views:
    488
    =?Utf-8?B?Y2JrYXR5?=
    Sep 11, 2004
  2. craig judd

    echo echo echo

    craig judd, Sep 23, 2003, in forum: Computer Support
    Replies:
    1
    Views:
    539
    Miggsee
    Sep 23, 2003
  3. Replies:
    5
    Views:
    1,049
  4. Podzol

    Static IP lost after reload

    Podzol, Dec 29, 2007, in forum: Cisco
    Replies:
    4
    Views:
    603
    headsetadapter.com
    Dec 30, 2007
  5. Andercovny

    Connecting to Other Wireless Networks After System Reload

    Andercovny, Dec 2, 2008, in forum: Wireless Networking
    Replies:
    0
    Views:
    900
    Andercovny
    Dec 2, 2008
Loading...

Share This Page