Canon S410 Problem

Discussion in 'Digital Photography' started by Tom in PA, Mar 24, 2010.

  1. Tom in PA

    Tom in PA Guest

    I just pulled my Canon S410, which I haven't used since '08, out of
    the drawer to make sure it was working OK, as I wanted to take it as a
    backup camera on an upcoming trip. It was fine when last used. It
    now has a strange problem: all normal functions (such as changing
    settings using Function, Menu,etc.) are working and the screen will
    display photos taken back in '08 from the CF card. But in picture-
    taking mode, the screen is black (except for all the usual icons):
    there is no image of what the camera is pointed at. Also, it will
    snap photos (and fire the flash) that, when viewed on either the
    camera screen or my PC, are there but are totally black.

    No, I didn't leave the lens cap on! Doesn't have one. Lens extends
    as usual, zooms in and out, etc. No odd behavior there.

    I'm guessing I'm screwed with respect to using the camera, but am at
    least curious. Any ideas regarding what has gone wrong here?

    Thanks in advance!
    Tom in PA, Mar 24, 2010
    #1
    1. Advertising

  2. Tom in PA

    DanP Guest

    On 24 Mar, 22:16, Tom in PA <> wrote:
    > I just pulled my Canon S410, which I haven't used since '08, out of
    > the drawer to make sure it was working OK, as I wanted to take it as a
    > backup camera on an upcoming trip.  It was fine when last used.  It
    > now has a strange problem:  all normal functions (such as changing
    > settings using Function, Menu,etc.) are working and the screen will
    > display photos taken back in '08 from the CF card.  But in picture-
    > taking mode, the screen is black (except for all the usual icons):
    > there is no image of what the camera is pointed at.  Also, it will
    > snap photos (and fire the flash) that, when viewed on either the
    > camera screen or my PC, are there but are totally black.
    >
    > No, I didn't leave the lens cap on!  Doesn't have one.  Lens extends
    > as usual, zooms in and out, etc.  No odd behavior there.
    >
    > I'm guessing I'm screwed with respect to using the camera, but am at
    > least curious.  Any ideas regarding what has gone wrong here?
    >
    > Thanks in advance!


    Could be a connector came lose.
    Worth opening the camera and see what's inside.


    DanP
    DanP, Mar 25, 2010
    #2
    1. Advertising

  3. In article
    <>,
    Tom in PA <> wrote:

    > I just pulled my Canon S410, which I haven't used since '08, out of
    > the drawer to make sure it was working OK, as I wanted to take it as a
    > backup camera on an upcoming trip. It was fine when last used. It
    > now has a strange problem: all normal functions (such as changing
    > settings using Function, Menu,etc.) are working and the screen will
    > display photos taken back in '08 from the CF card. But in picture-
    > taking mode, the screen is black (except for all the usual icons):
    > there is no image of what the camera is pointed at. Also, it will
    > snap photos (and fire the flash) that, when viewed on either the
    > camera screen or my PC, are there but are totally black.
    >
    > No, I didn't leave the lens cap on! Doesn't have one. Lens extends
    > as usual, zooms in and out, etc. No odd behavior there.
    >
    > I'm guessing I'm screwed with respect to using the camera, but am at
    > least curious. Any ideas regarding what has gone wrong here?


    Tom-

    Suppose the battery was nearly discharged at some point, and you turned
    the camera on. Its RAM memory might have gotten corrupted and never
    recovered. Even if the battery was subsequently charged.

    If there is no master reset, try leaving the battery out of the camera
    over night. Then, with a fully charged battery, the CPU should load a
    fresh copy of its firmware into memory, and everything should work
    correctly again.

    If the memory card still has the last photo taken, the camera will read
    its number and continue from there. Otherwise, it will start over at
    number one.

    Fred
    Fred McKenzie, Mar 25, 2010
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. peter

    Canon S410 no improvement in red eye?

    peter, Feb 10, 2004, in forum: Digital Photography
    Replies:
    0
    Views:
    336
    peter
    Feb 10, 2004
  2. Anthony Martin

    Canon S410 Vs Sony DSC-P72

    Anthony Martin, Apr 21, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    410
    David Sommers
    Apr 22, 2004
  3. Steve Lee
    Replies:
    3
    Views:
    417
    Chicha
    Jun 29, 2004
  4. John F

    CANON A80 vs CANON S410

    John F, Oct 22, 2004, in forum: Digital Photography
    Replies:
    5
    Views:
    346
    Dave Martindale
    Oct 23, 2004
  5. Fia

    Oly D590 Zoom, Canon SD300, or Canon S410?

    Fia, Nov 15, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    387
Loading...

Share This Page