Canon PowerShot A70 problem

Discussion in 'Digital Photography' started by omm@netvision.net.il, Apr 21, 2005.

  1. Guest

    Hi,

    I have a Canon PowerShot A70, and I usually connect it to a Win XP Home
    edition.
    Everything was working fine until about a week ago.

    Since then, whenever I connect it to the computer (via USB) I get the
    little sound saying the camera WinXP recognized a device, but nothing
    else happens. I look in the "remove devices" window, and there's no
    camera there. I open "my computer" and under "imaging devices" or
    whatever, it's there. But when I try to view it's properties, or get
    the pictures, it opens the "connecting to device" message, and just
    hangs there until it says "imaging device is busy."

    The "autoplay" window which uses to pop up comes up sometimes, but with
    no options with which to view the pictures. Canon software doesn't get
    the pics either.

    I checked my camera with another computer, and another camera on my
    computer, all other combinations work fine. It's just my camera with my
    computer.

    Any suggestions??

    Thanx,
    Omer.
     
    , Apr 21, 2005
    #1
    1. Advertisements

  2. Marc Guest

    I set up my mothers new XP computer with the same camera. Try going to "My
    Computer" and scrolling all the way to the bottom of the window.

    Marc


    <> wrote in message
    news:...
    > Hi,
    >
    > I have a Canon PowerShot A70, and I usually connect it to a Win XP Home
    > edition.
    > Everything was working fine until about a week ago.
    >
    > Since then, whenever I connect it to the computer (via USB) I get the
    > little sound saying the camera WinXP recognized a device, but nothing
    > else happens. I look in the "remove devices" window, and there's no
    > camera there. I open "my computer" and under "imaging devices" or
    > whatever, it's there. But when I try to view it's properties, or get
    > the pictures, it opens the "connecting to device" message, and just
    > hangs there until it says "imaging device is busy."
    >
    > The "autoplay" window which uses to pop up comes up sometimes, but with
    > no options with which to view the pictures. Canon software doesn't get
    > the pics either.
    >
    > I checked my camera with another computer, and another camera on my
    > computer, all other combinations work fine. It's just my camera with my
    > computer.
    >
    > Any suggestions??
    >
    > Thanx,
    > Omer.
    >
     
    Marc, Apr 21, 2005
    #2
    1. Advertisements

  3. Guest

    I did it,
    the camera is there, but when I try to do anything with it (get the
    pictures, view the properties) it thinks some, then says "imaging
    device is busy" and suggests it's being used by another application
    blah blah blah
     
    , Apr 22, 2005
    #3
  4. Cutter Guest

    wrote in news:1114175793.558662.170990
    @g14g2000cwa.googlegroups.com:

    > I did it,
    > the camera is there, but when I try to do anything with it (get the
    > pictures, view the properties) it thinks some, then says "imaging
    > device is busy" and suggests it's being used by another application
    > blah blah blah
    >
    >


    Windows is a complex operating system and can be down right stupid at
    times.

    Do other USB devices work on your computer? If they don't, windows needs
    to be reminded that you have a USB controller. In Device Manager, remove
    the USB controller and unplugg all USB devices, reboot. Windows will
    (_should_) rediscover the USB controller on your machine and reinstall
    it. Plug in your USB devices one at a time and wait until Windows has
    installed the device before moving to the next one.

    If other devices work on your computer, then Windows is very messed up.
    Do the same thing that I mentioned above.

    As a last resort, reinstall Windows ;)
     
    Cutter, May 9, 2005
    #4
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sexy Susan

    Re: Canon Powershot A60 vs. Canon Powershot A70

    Sexy Susan, Sep 18, 2003, in forum: Digital Photography
    Replies:
    2
    Views:
    691
    Browntimdc
    Sep 22, 2003
  2. KOS
    Replies:
    3
    Views:
    850
    Darius Alexander
    Sep 25, 2003
  3. Andrys Basten

    Re: Canon Powershot A60 vs. Canon Powershot A70

    Andrys Basten, Oct 15, 2003, in forum: Digital Photography
    Replies:
    3
    Views:
    656
    Timothy Lange
    Oct 15, 2003
  4. John F

    CANON POWERSHOT A80 or CANON POWERSHOT S1 IS ?

    John F, Oct 26, 2004, in forum: Digital Photography
    Replies:
    11
    Views:
    675
    Hans-Georg Michna
    Oct 29, 2004
  5. Bill Lukic Duke

    Canon PowerShot S1 IS vs. Canon PowerShot S2 IS

    Bill Lukic Duke, Jul 12, 2005, in forum: Digital Photography
    Replies:
    8
    Views:
    560
    Hans-Georg Michna
    Jul 13, 2005
Loading...

Share This Page