Canon A70 - purple screen problem - no image except now and then

Discussion in 'Digital Photography' started by A. Barnett, Aug 25, 2007.

  1. A. Barnett

    A. Barnett Guest

    Hi,

    Has anyone had any problem with the A70 suddenly not being able to
    photograph (shows a more-or-less purple screen on the LCD, with some
    horizontal lines occasionally), and then once in awhile after being on
    for awhile, the picture finally appears, and then the camera takes
    pictures like it did before. I've also seen one that has a similar
    problem, but is able to photograph despite the purple LCD (although
    the LCD works fine when viewing the images after they're recorded) -
    just has to use the viewfinder.

    It may be power related, but I just put in new batteries, and it still
    took awhile for the camera to be able to take pictures and display the
    real image (my LCD also works fine viewing recorded pictures - the
    camera just doesn't focus or take pictures that I can see until the
    view clears up - also the orange light and manual W/T work fine).

    Could it be the CCD, the processor, or the power supply?

    Thanks!
    Andy
     
    A. Barnett, Aug 25, 2007
    #1
    1. Advertising

  2. A. Barnett

    Bruce. Guest

    "A. Barnett" <> wrote in message
    news:...
    > Has anyone had any problem with the A70 suddenly not being able to
    > photograph (shows a more-or-less purple screen on the LCD, with some
    > horizontal lines occasionally),


    The A70 was one of several models Canon models that used defective Sony CCD
    imagers that went bad over time. The streaky colors are a big sign.

    http://www.usa.canon.com/consumer/c...Act&keycode=2112&fcategoryid=221&modelid=8776

    The problem affected a massive number of models industry wide.

    http://www.imaging-resource.com/badccds.html

    In my case, Canon fixed my A70 for free, including shipping both ways.

    Bruce.
     
    Bruce., Aug 25, 2007
    #2
    1. Advertising

  3. A. Barnett

    A. Barnett Guest

    Thanks for the very helpful response, Bruce! (With our recent round of
    100+ degree weather and frequent high-humidity, perhaps that caused
    the problem.)

    Andy
     
    A. Barnett, Aug 25, 2007
    #3
  4. A. Barnett

    Bruce. Guest

    "A. Barnett" <> wrote in message
    news:...
    > Thanks for the very helpful response, Bruce! (With our recent round of
    > 100+ degree weather and frequent high-humidity, perhaps that caused
    > the problem.)


    You're welcome.

    Bruce.
     
    Bruce., Aug 25, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bill
    Replies:
    13
    Views:
    573
    Sam Smith
    Dec 27, 2003
  2. Dave

    Delayed Response With Canon A70 (and now A20)

    Dave, Jan 5, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    375
    bluestringer
    Jan 6, 2004
  3. mv

    Purple Ring & Purple spot in many pics

    mv, May 10, 2004, in forum: Digital Photography
    Replies:
    3
    Views:
    782
  4. Rick

    Canon A70 Purple fringing

    Rick, Nov 14, 2004, in forum: Digital Photography
    Replies:
    6
    Views:
    334
    Rockin Ronnie
    Nov 15, 2004
  5. Roger Jansson

    ThinkPad screen "blinks" now and then

    Roger Jansson, Dec 19, 2005, in forum: Computer Support
    Replies:
    1
    Views:
    415
    Dave Lear
    Dec 19, 2005
Loading...

Share This Page