Canon A520 won't start up; beeps 7 times

Discussion in 'Digital Photography' started by Tommy Butler, Dec 14, 2006.

  1. Tommy Butler

    Tommy Butler Guest

    My Canon A520 suddenly started failing. When I start it up it shows
    the Cannon startup screen, hangs for 15 seconds then emits seven short
    beeps in fast succession. Then the screen goes black for 15 seconds
    and the unit powers off.

    Any idea what's wrong or how to fix? I'm totally lost.

    Thank you for any help you can provide!

    --
    Tommy Butler
    Tommy Butler, Dec 14, 2006
    #1
    1. Advertising

  2. Tommy Butler <> wrote:
    : My Canon A520 suddenly started failing. When I start it up it shows
    : the Cannon startup screen, hangs for 15 seconds then emits seven short
    : beeps in fast succession. Then the screen goes black for 15 seconds
    : and the unit powers off.

    : Any idea what's wrong or how to fix? I'm totally lost.

    : Thank you for any help you can provide!

    I know that this is probably a "well duh" response but the first thing I
    would check is the batteries. It may even be that a battery that seems to
    be good may be just barely puting out enough power, and once the camera
    turns on the power drops far enough that the auto shutoff takes over.

    I'll leave further possibilities to those with direct experience of this
    camera.

    Randy

    ==========
    Randy Berbaum
    Champaign, IL
    Randy Berbaum, Dec 14, 2006
    #2
    1. Advertising

  3. Tommy Butler

    bugbear Guest

    Tommy Butler wrote:
    > My Canon A520 suddenly started failing. When I start it up it shows
    > the Cannon startup screen, hangs for 15 seconds then emits seven short
    > beeps in fast succession. Then the screen goes black for 15 seconds
    > and the unit powers off.
    >
    > Any idea what's wrong or how to fix? I'm totally lost.


    Are you *sure* the otherwise black screen doesn't say

    E18

    bottom left?

    http://www.bitnet.cx/canon.jpg

    BugBear
    bugbear, Dec 14, 2006
    #3
  4. Tommy Butler

    Tommy Butler Guest

    On Dec 14, 2:27 am, Randy Berbaum <>
    wrote:
    > I know that this is probably a "well duh" response but the first thing I
    > would check is the batteries. It may even be that a battery that seems to
    > be good may be just barely puting out enough power, and once the camera
    > turns on the power drops far enough that the auto shutoff takes over.
    >
    > I'll leave further possibilities to those with direct experience of this
    > camera.


    I have tried multiple batteries, all fully charged (NiMH). All of
    these batteries have worked in the past. I've also tested all of these
    batteries in other electronic devices and verified that they are
    powering the other electronic devices without problems.

    --
    Tommy Butler
    Tommy Butler, Dec 14, 2006
    #4
  5. Tommy Butler

    Tommy Butler Guest

    On Dec 14, 4:26 am, bugbear <bugbear@trim_papermule.co.uk_trim> wrote:
    > Are you *sure* the otherwise black screen doesn't say
    >
    > E18
    >
    > bottom left?
    >
    > http://www.bitnet.cx/canon.jpg


    Yes. I'm sure.

    --
    Tommy Butler
    Tommy Butler, Dec 14, 2006
    #5
  6. Tommy Butler

    bugbear Guest

    Tommy Butler wrote:
    > On Dec 14, 4:26 am, bugbear <bugbear@trim_papermule.co.uk_trim> wrote:
    >
    >>Are you *sure* the otherwise black screen doesn't say
    >>
    >>E18
    >>
    >>bottom left?
    >>
    >>http://www.bitnet.cx/canon.jpg

    >
    >
    > Yes. I'm sure.
    >


    In the light of the difficulty of fixing
    "E18", that's good news.

    BugBear
    bugbear, Dec 14, 2006
    #6
  7. Tommy Butler

    SimonLW Guest

    "Tommy Butler" <> wrote in message
    news:...
    > My Canon A520 suddenly started failing. When I start it up it shows
    > the Cannon startup screen, hangs for 15 seconds then emits seven short
    > beeps in fast succession. Then the screen goes black for 15 seconds
    > and the unit powers off.
    >
    > Any idea what's wrong or how to fix? I'm totally lost.
    >
    > Thank you for any help you can provide!
    >
    > --
    > Tommy Butler
    >

    The number of beeps may have some significance like a computer's POST beep
    codes. Contact Canon support and may be able to offer assistance.
    -S
    SimonLW, Dec 14, 2006
    #7
  8. Tommy Butler

    Tommy Butler Guest

    On Dec 14, 6:22 am, "SimonLW" <> wrote:
    > > Tommy ButlerThe number of beeps may have some significance like a computer's POST beep

    > codes. Contact Canon support and may be able to offer assistance.


    My thought's exactly. Tried it. Like pinning jello to a tree. They
    aren't big on customer service apparently. I'm going back to compusa
    where I bought the camera. I bought a 2 year warranty on it and they
    should honor it. I was just hoping that there was some nifty trick
    that I could do to reset the camera on a low level and perhaps get it
    to 'boot' like new.

    --
    Tommy Butler
    Tommy Butler, Dec 14, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. bux100

    new hard drive - beeps on start up

    bux100, Aug 11, 2004, in forum: Computer Support
    Replies:
    7
    Views:
    4,378
  2. Canon A85 / Canon A520

    , Feb 3, 2005, in forum: Digital Photography
    Replies:
    2
    Views:
    287
    tangwong
    Feb 4, 2005
  3. Canon A85 / Canon A520

    , Feb 3, 2005, in forum: Digital Photography
    Replies:
    1
    Views:
    317
    Harvey
    Feb 3, 2005
  4. Dintoe

    Fujitsu A6120 beeps three times

    Dintoe, May 5, 2010, in forum: Computer Support
    Replies:
    0
    Views:
    663
    Dintoe
    May 5, 2010
  5. john hamilton

    Beeps twice then eight times and no picture

    john hamilton, Nov 30, 2010, in forum: Computer Support
    Replies:
    2
    Views:
    981
    Bucky Breeder
    Nov 30, 2010
Loading...

Share This Page