Canon 300d err99 with Sigma Lens

Discussion in 'Digital Photography' started by Steven Campbell, Feb 3, 2005.

  1. I recently got a Canon 300d and was trying out my lenses from old outfit
    Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    message err99.

    I believe through googling that this is a common problem with non Canon
    lenses but can be overcome with a chip in the lens?!! Anyone managed to get
    Sigma to do this in the UK?

    Steven.
    Steven Campbell, Feb 3, 2005
    #1
    1. Advertising

  2. Steven Campbell

    Big Bill Guest

    On Thu, 3 Feb 2005 21:09:21 -0000, "Steven Campbell"
    <> wrote:

    >I recently got a Canon 300d and was trying out my lenses from old outfit
    >Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    >message err99.
    >
    >I believe through googling that this is a common problem with non Canon
    >lenses but can be overcome with a chip in the lens?!! Anyone managed to get
    >Sigma to do this in the UK?
    >
    >Steven.
    >
    >
    >

    Check with Sigma.
    If the camera is too old (their call), it can't be chipped.
    If it can be chipped, ask them how to get it to them.

    --
    Bill Funk
    Change "g" to "a"
    Big Bill, Feb 3, 2005
    #2
    1. Advertising

  3. "Steven Campbell" <> wrote in message
    news:...
    > I recently got a Canon 300d and was trying out my lenses from old outfit
    > Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    > message err99.
    >
    > I believe through googling that this is a common problem with non Canon
    > lenses but can be overcome with a chip in the lens?!! Anyone managed to

    get
    > Sigma to do this in the UK?


    They used to have a list of re-chippable lenses on their website. Yes, they
    rechipped one lens for me, but not the older one.

    --
    M Stewart
    Milton Keynes, UK
    http://www.megalith.freeserve.co.uk/oddimage.htm
    Malcolm Stewart, Feb 3, 2005
    #3
  4. Steven Campbell

    Vic Guest

    "Big Bill" <> wrote in message
    news:...
    > On Thu, 3 Feb 2005 21:09:21 -0000, "Steven Campbell"
    > <> wrote:
    >
    > >lenses but can be overcome with a chip in the lens?!! Anyone managed to

    get
    > >Sigma to do this in the UK?
    > >

    > Check with Sigma.
    > If the camera is too old (their call), it can't be chipped.
    > If it can be chipped, ask them how to get it to them.
    >

    He means the lens.
    It depends on its age. They wouldn't chip my old 24mm prime - too old.
    Vic, Feb 3, 2005
    #4
  5. Steven Campbell

    traction Guest

    "Steven Campbell" <> wrote in message
    news:...
    >I recently got a Canon 300d and was trying out my lenses from old outfit
    > Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    > message err99.
    >
    > I believe through googling that this is a common problem with non Canon
    > lenses but can be overcome with a chip in the lens?!! Anyone managed to
    > get
    > Sigma to do this in the UK?
    >
    > Steven.

    Yeh Its a lens problem, needs to be rechipped.. They did it for me free,
    inclusive with a lens service, I pay postage to them only- Excellent service
    , although it did take 14 days...All in all hassle free...
    traction, Feb 3, 2005
    #5
  6. Steven Campbell

    Canongirly Guest

    "Steven Campbell" <> wrote in message
    news:...
    >I recently got a Canon 300d and was trying out my lenses from old outfit
    > Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    > message err99.
    >
    > I believe through googling that this is a common problem with non Canon
    > lenses but can be overcome with a chip in the lens?!! Anyone managed to
    > get
    > Sigma to do this in the UK?
    >
    > Steven.

    Yep not only did they re-chip a lens for me they serviced it too.
    Canongirly, Feb 3, 2005
    #6
  7. "Canongirly" <> wrote in message
    news:ctuau7$2gi$...
    >
    > "Steven Campbell" <> wrote in message
    > news:...
    > >I recently got a Canon 300d and was trying out my lenses from old outfit
    > > Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    > > message err99.
    > >
    > > I believe through googling that this is a common problem with non Canon
    > > lenses but can be overcome with a chip in the lens?!! Anyone managed to
    > > get
    > > Sigma to do this in the UK?
    > >
    > > Steven.

    > Yep not only did they re-chip a lens for me they serviced it too.


    Thanks everybody for the advice but does anyone know how I should go about
    it. Is it just a case of emailing them at
    http://www.sigma-imaging-uk.com/a_pages/contact.htm or do they have a
    dedicated web page for this kind of thing. I can't find anything on their
    site about re chipping.

    Steven.
    Steven Campbell, Feb 3, 2005
    #7
  8. Steven Campbell

    Canongirly Guest

    service@[REMOVE-THIS-BEFORE-SENDING]sigma-imaging-uk.com

    service at sigma-imaging-uk.com

    "Steven Campbell" <> wrote in message
    news:...
    > "Canongirly" <> wrote in message
    > news:ctuau7$2gi$...
    >>
    >> "Steven Campbell" <> wrote in message
    >> news:...
    >> >I recently got a Canon 300d and was trying out my lenses from old outfit
    >> > Canon 100 EOS. Unfortunately when the Sigma lens is on I get the error
    >> > message err99.
    >> >
    >> > I believe through googling that this is a common problem with non Canon
    >> > lenses but can be overcome with a chip in the lens?!! Anyone managed
    >> > to
    >> > get
    >> > Sigma to do this in the UK?
    >> >
    >> > Steven.

    >> Yep not only did they re-chip a lens for me they serviced it too.

    >
    > Thanks everybody for the advice but does anyone know how I should go about
    > it. Is it just a case of emailing them at
    > http://www.sigma-imaging-uk.com/a_pages/contact.htm or do they have a
    > dedicated web page for this kind of thing. I can't find anything on their
    > site about re chipping.
    >
    > Steven.
    >
    >
    >
    Canongirly, Feb 4, 2005
    #8
  9. Steven Campbell

    Big Bill Guest

    On Thu, 3 Feb 2005 22:31:16 -0000, "Vic" <> wrote:

    >
    >"Big Bill" <> wrote in message
    >news:...
    >> On Thu, 3 Feb 2005 21:09:21 -0000, "Steven Campbell"
    >> <> wrote:
    >>
    >> >lenses but can be overcome with a chip in the lens?!! Anyone managed to

    >get
    >> >Sigma to do this in the UK?
    >> >

    >> Check with Sigma.
    >> If the camera is too old (their call), it can't be chipped.
    >> If it can be chipped, ask them how to get it to them.
    >>

    >He means the lens.
    >It depends on its age. They wouldn't chip my old 24mm prime - too old.
    >

    You're right, I mistyped. :-(

    --
    Bill Funk
    Change "g" to "a"
    Big Bill, Feb 4, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. No Spam
    Replies:
    24
    Views:
    10,399
  2. Don Gentile

    Sigma SD9 or Canon 300D?

    Don Gentile, Feb 22, 2004, in forum: Digital Photography
    Replies:
    125
    Views:
    2,032
    John Navas
    Mar 7, 2004
  3. Rick

    Rebel err99???

    Rick, May 12, 2004, in forum: Digital Photography
    Replies:
    13
    Views:
    2,281
    Bart van der Wolf
    May 15, 2004
  4. John

    300D and Sigma 70-300 Lens

    John, May 22, 2004, in forum: Digital Photography
    Replies:
    31
    Views:
    1,262
    grant kinsley
    May 25, 2004
  5. Gareth Tuckwell

    canon 18-55 or sigma 18-50 lens for 300d??

    Gareth Tuckwell, Aug 13, 2004, in forum: Digital Photography
    Replies:
    4
    Views:
    4,633
    schuetzen - RKBA!
    Aug 14, 2004
Loading...

Share This Page