Cannot establish connection with ADSL provider

Discussion in 'Cisco' started by John Chajecki, Dec 4, 2005.

  1. Hi,

    I've ytied everything I can think of, but I can't get the ADSL interface to establish a connection with my provider (PIPEX) on my Cisco 837 router. If I use DHCP, then I do not get an IP address assignement. The provider says that I should be using DHCP and confirm that an IP address has in fact be leased. The Cisco dosent seemm to see it though.

    If I use Negotiated, then I do appear get an IP address, but no connectivity. When I run the interface test if fails on something called 'Exit interface'. The options in the suggested fix do not appear to match any options available on the router.

    Here is my config:


    Current configuration : 5811 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname LydiSoft-ADSL
    !
    boot-start-marker
    boot-end-marker
    !
    memory-size iomem 5
    no logging buffered
    enable secret 5 $mysecret
    enable password sh1l0h
    !
    no aaa new-model
    !
    resource policy
    !
    ip subnet-zero
    no ip routing
    !
    !
    no ip dhcp use vrf connected
    !
    !
    ip dhcp update dns both
    no ip cef
    ip domain name mill-corner.ath.cx
    ip name-server 62.241.162.200
    ip name-server 62.241.163.200
    no ip ips deny-action ips-interface
    ip ddns update method sdm_ddns1
    HTTP
    add http://username:p/nic/update?system=dyndns&hostname=<h>&myip=<a>
    remove http://username:p/nic/update?system=dyndns&hostname=<h>&myip=<a>
    !
    !
    no ftp-server write-enable
    !
    crypto pki trustpoint TP-self-signed-2353383044
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2353383044
    revocation-check none
    rsakeypair TP-self-signed-2353383044
    !
    !
    crypto pki certificate chain TP-self-signed-2353383044
    certificate self-signed 01
    ......

    quit
    partition flash 2 10 2
    !
    username admin secret 5 $password
    username jchajecki privilege 15 secret 5 $password
    username chajj001 privilege 15 secret 5 $password
    !
    !
    no crypto isakmp ccm
    !
    !
    !
    interface Ethernet0
    description Internal LAN$ETH-LAN$
    ip address 10.210.210.58 255.255.255.224
    ip access-group 100 in
    ip nat inside
    ip virtual-reassembly
    no ip route-cache
    hold-queue 100 out
    !
    interface Ethernet2
    no ip address
    no ip route-cache
    shutdown
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip route-cache
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    no ip route-cache
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet1
    duplex auto
    speed auto
    !
    interface FastEthernet2
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet3
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet4
    speed auto
    full-duplex
    !
    interface Dialer0
    ip address dhcp client-id Ethernet0
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname
    ppp chap password 0 oongikoo
    ppp pap sent-username password 0 oongikoo
    !
    ip classless
    !
    ip http server
    ip http access-class 1
    ip http secure-server
    !
    ip nat inside source list 2 interface Dialer0 overload
    !
    access-list 1 remark Auto generated by SDM Management Access feature
    access-list 1 remark SDM_ACL Category=1
    access-list 1 permit 10.210.210.64 0.0.0.31
    access-list 1 permit 10.210.210.32 0.0.0.31
    access-list 2 remark INSIDE_IF=Ethernet0
    access-list 2 remark SDM_ACL Category=2
    access-list 2 permit 10.210.210.32 0.0.0.31
    access-list 100 remark Auto generated by SDM Management Access feature
    access-list 100 remark SDM_ACL Category=1
    access-list 100 permit tcp 10.210.210.64 0.0.0.31 host 10.210.210.58 eq 22
    access-list 100 permit tcp 10.210.210.32 0.0.0.31 host 10.210.210.58 eq 22
    access-list 100 permit tcp 10.210.210.64 0.0.0.31 host 10.210.210.58 eq 443
    access-list 100 permit tcp 10.210.210.32 0.0.0.31 host 10.210.210.58 eq 443
    access-list 100 permit tcp 10.210.210.64 0.0.0.31 host 10.210.210.58 eq cmd
    access-list 100 permit tcp 10.210.210.32 0.0.0.31 host 10.210.210.58 eq cmd
    access-list 100 deny tcp any host 10.210.210.58 eq telnet
    access-list 100 deny tcp any host 10.210.210.58 eq 22
    access-list 100 deny tcp any host 10.210.210.58 eq www
    access-list 100 deny tcp any host 10.210.210.58 eq 443
    access-list 100 deny tcp any host 10.210.210.58 eq cmd
    access-list 100 deny udp any host 10.210.210.58 eq snmp
    access-list 100 permit ip any any
    access-list 101 remark Auto generated by SDM Management Access feature
    access-list 101 remark SDM_ACL Category=1
    access-list 101 permit ip 10.210.210.64 0.0.0.31 any
    access-list 101 permit ip 10.210.210.32 0.0.0.31 any
    dialer-list 1 protocol ip permit
    !
    !
    control-plane
    !
    banner login ^CUnauthorised users strictly prohibited! If you are not authorised to log on then please disconnect now.^C
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class 101 in
    password password
    login
    transport input ssh
    !
    scheduler max-task-time 5000
    end

    I am using the SDM (CRWS dosen't work), but I used CLI to bring the Fatsthernet interfaces up before connecting with SDM.
    My supplier requires VC/MUX, ITU G.dmt and PPPoA. IP address delivered by DHCP. VPI/VCI 0,38. Have been playing with this for a few days now trying all sorts of settings but can't get anything to work. Any help or pointers would be greatlt appreciated.

    Thanks in advance.
    John Chajecki, Dec 4, 2005
    #1
    1. Advertising

  2. John Chajecki

    Matty M Guest

    "John Chajecki" <> wrote in message
    news:...
    > Hi,
    >
    > I've ytied everything I can think of, but I can't get the ADSL interface
    > to establish a connection with my provider (PIPEX) on my Cisco 837 router.
    > If I use DHCP, then I do not get an IP address assignement. The provider
    > says that I should be using DHCP and confirm that an IP address has in
    > fact be leased. The Cisco dosent seemm to see it though.
    >
    > If I use Negotiated, then I do appear get an IP address, but no
    > connectivity. When I run the interface test if fails on something called
    > 'Exit interface'. The options in the suggested fix do not appear to match
    > any options available on the router.
    >
    > Here is my config:
    >
    >
    > Current configuration : 5811 bytes
    > !
    > version 12.3
    > no service pad
    > service timestamps debug datetime msec
    > service timestamps log datetime msec
    > no service password-encryption
    > !
    > hostname LydiSoft-ADSL
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > memory-size iomem 5
    > no logging buffered
    > enable secret 5 $mysecret
    > enable password sh1l0h
    > !
    > no aaa new-model
    > !
    > resource policy
    > !
    > ip subnet-zero
    > no ip routing
    > !

    <<SNIPPED>>

    Hi,

    Try adding on your Dialer interface -

    ip address negotiated
    encapsulation ppp
    ppp ipcp dns request
    ppp ipcp wins request

    Cheers

    Matt
    Matty M, Dec 4, 2005
    #2
    1. Advertising

  3. Matt,

    Thanks for your suggestion. I have tried this and now get:

    Checking interface status... UP
    Checking for DNS settings... Successful
    Checking interface IP address... Successful
    Checking exit interface... Failed

    No configured DNS server(s) are routable through the selected interface.

    Select 'Enter IP address or hostname' option or add a 'host specific/network specific/default' route through this interface and retest connection.
    John Chajecki, Dec 5, 2005
    #3
  4. Matt,

    Thanks for your suggestion. I have applied this and now get the following:

    Checking interface status... UP
    Checking for DNS settings... Successful
    Checking interface IP address... Successful
    Checking exit interface... Failed

    No configured DNS server(s) are routable through the selected interface.

    Select 'Enter IP address or hostname' option or add a 'host specific/network specific/default' route through this interface and retest connection.

    I can't find an 'Enter IP address or hostname' option anywhere and I'm not sure how to add a 'host specific/network specific/default' route through this interface. Adding a route of 0.0.0.0 0.0.0.0 to Dialer1 or ATM0.1 does not seem to solve the problem.
    John Chajecki, Dec 5, 2005
    #4
  5. John Chajecki

    Martin Kayes Guest

    Hi John,

    You should try adding these lines to your config to reduce the MTU size,
    Pipex's DSLAM is probably dropping your packets as with the PPP
    encapsulation added they will be oversized.

    interface Ethernet0
    ip tcp adjust-mss 1452
    !
    interface Dialer0
    ip mtu 1492
    ip tcp adjust-mss 1452


    Also, I am not sure why you have a subinterface on the ATM 0, the config
    could be simplified to look like this:

    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1


    Let me know what you get.

    Regards,

    Martin
    Martin Kayes, Dec 5, 2005
    #5
  6. John Chajecki

    nazgulero Guest

    Hello John,

    could you try and take out the statements:

    ip name-server 62.241.162.200
    ip name-server 62.241.163.200

    These should be dynamically assigned by your provider, you will get
    them together with the IP address...

    Regards,

    Naz
    nazgulero, Dec 5, 2005
    #6
  7. John Chajecki

    Bob Goddard Guest

    John Chajecki wrote:

    > Hi,
    >
    > I've ytied everything I can think of, but I can't get the ADSL
    > interface to establish a connection with my provider (PIPEX) on my
    > Cisco 837 router. If I use DHCP, then I do not get an IP address
    > assignement. The provider says that I should be using DHCP and confirm
    > that an IP address has in fact be leased. The Cisco dosent seemm to
    > see it though.
    >
    > If I use Negotiated, then I do appear get an IP address, but no
    > connectivity. When I run the interface test if fails on something
    > called 'Exit interface'. The options in the suggested fix do not
    > appear to match any options available on the router.
    >
    > Here is my config:

    [...]
    > ip subnet-zero
    > no ip routing


    You want
    ip routing

    [...]
    > interface Ethernet2
    > no ip address
    > no ip route-cache
    > shutdown
    > hold-queue 100 out


    How the heck did you get the above interface?

    [...]
    > interface FastEthernet4
    > speed auto
    > full-duplex


    I guess both should be auto or fixed.

    [...]
    > interface Dialer0
    > ip address dhcp client-id Ethernet0


    Change the above to:
    ip address negotiated

    > ip nat outside
    > ip virtual-reassembly
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > ppp authentication chap pap callin
    > ppp chap hostname
    > ppp chap password 0 oongikoo
    > ppp pap sent-username password 0 oongikoo

    [...]
    Bob Goddard, Dec 5, 2005
    #7
  8. [...]
    >> interface Ethernet2
    >> no ip address
    >> no ip route-cache
    >> shutdown
    >> hold-queue 100 out


    Bob Goddard wrote:
    >How the heck did you get the above interface?


    Bob,

    I've no idea. It just appeared after a recent IOS update. I've no idea what it referrs to.

    I will give your settings a try.


    _
    John Chajecki
    John Chajecki, Dec 5, 2005
    #8
  9. Martin,

    > You should try adding these lines to your config to reduce the MTU size,
    > Pipex's DSLAM is probably dropping your packets as with the PPP
    > encapsulation added they will be oversized.


    Never thought about MTU. Will give it a go.

    >Also, I am not sure why you have a subinterface on the ATM 0...


    If you're referring to ATM0.1 then I'm not sure either. Its just how SDM configured it. You can't actually change the ATM0 settings in SDM only ATM0.1, ATM0.2 etc...

    > no ip mroute-cache
    > no atm ilmi-keepalive


    What do these two settings actually do?

    Thanks for your suggestions I will try them out.


    _
    John Chajecki
    John Chajecki, Dec 5, 2005
    #9
  10. Thank you to all who responded. I now have internet access.

    I believe the crucial points were:

    ip address negotiated - thanks Matt

    ip routing
    ip route 0.0.0.0 0.0.0.0 Dialer0 - thanks to Cisco TAC

    You would have thought that the SDM would have put that route in!
    John Chajecki, Dec 7, 2005
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ian Easson
    Replies:
    1
    Views:
    3,625
    Jyri Korhonen
    Jul 8, 2003
  2. PheNiX

    Set SSID to establish a connection

    PheNiX, Mar 22, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    818
    PheNiX
    Mar 22, 2006
  3. Oxford Systems
    Replies:
    7
    Views:
    9,452
    LoneRanger
    Mar 14, 2005
  4. todhunter5
    Replies:
    1
    Views:
    377
    Stephen K. Gielda
    Dec 24, 2003
  5. Carl Rossman
    Replies:
    0
    Views:
    458
    Carl Rossman
    Mar 16, 2007
Loading...

Share This Page