Can someone double check the config

Discussion in 'Cisco' started by Igor Pinchevskiy, Oct 3, 2007.

  1. Hello,

    Below are the configurations from 2 routers that are connected via
    point to point T1 line. Please note hollywood router has 3 serial
    interfaces that connect to other routers via point to point T1 lines
    as well. Can you guys double check the configs to make sure that they
    are correct and doesnt have anything thats not needed and also if you
    guys suggest any improvmenets. These are all connected via private T1
    lines and actually no access lists are needed but they are there from
    the previous guy, I want to make some changes to improve performance
    and stuff. Any advice or suggestions is greatly appreciated!

    Building configuration...

    Current configuration : 1234 bytes
    !
    ! Last configuration change at 17:32:21 UTC Tue Jul 17 2007
    ! NVRAM config last updated at 17:32:33 UTC Tue Jul 17 2007
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Downtown
    !
    enable secret 5 xxxxx
    enable password xxxxx
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip finger
    !
    ip dhcp pool LA
    network 10.1.0.0 255.255.0.0
    default-router 10.1.0.1
    netbios-name-server 10.3.0.254
    !
    ip audit notify log
    ip audit po max-events 100
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 10.1.0.1 255.255.0.0
    no ip mroute-cache
    full-duplex
    arp timeout 60
    no mop enabled
    !
    interface BRI0/0
    no ip address
    no ip mroute-cache
    shutdown
    !
    interface Serial0/0
    ip address 192.168.1.6 255.255.255.252
    encapsulation ppp
    no ip mroute-cache
    !
    interface Ethernet0/1
    ip address 64.171.205.2 255.255.255.248
    ip nat outside
    no ip mroute-cache
    shutdown
    !
    ip nat inside source list 1 interface Ethernet0/1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0
    ip route 10.3.0.0 255.255.0.0 192.168.1.5
    ip http server
    !
    access-list 1 permit 10.1.0.0 0.0.255.255
    !
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password xxxxx
    login
    !
    end

    Downtown#



    Hollywood#sh run
    Building configuration...

    Current configuration : 1807 bytes
    !
    ! Last configuration change at 17:27:20 UTC Tue Jul 17 2007
    ! NVRAM config last updated at 17:28:31 UTC Tue Jul 17 2007
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Hollywood
    !
    logging rate-limit console 10 except errors
    enable secret 5 xxxxx
    enable password xxxxx
    !
    ip subnet-zero
    !
    !
    no ip finger
    !
    ip dhcp pool hollywood
    network 10.3.0.0 255.255.0.0
    netbios-name-server 10.3.0.252
    default-router 10.3.1.1
    lease 0 8
    !
    ip audit notify log
    ip audit po max-events 100
    !
    !
    call rsvp-sync
    !
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0/0
    ip address 10.8.1.1 255.255.0.0
    ip nat inside
    no keepalive
    shutdown
    full-duplex
    arp timeout 60
    !
    interface Serial0/0
    ip address 192.168.1.1 255.255.255.252
    encapsulation ppp
    !
    interface Ethernet0/1
    bandwidth 10000000
    ip address 10.3.0.1 255.255.0.0
    no keepalive
    full-duplex
    arp timeout 60
    !
    interface Serial0/1
    ip address 192.168.1.5 255.255.255.252
    encapsulation ppp
    !
    interface Serial0/2
    ip address 192.168.1.9 255.255.255.252
    encapsulation ppp
    service-module t1 timeslots 1-24
    !
    ip nat inside source list 1 interface Ethernet0/1 overload
    ip nat inside source static 10.3.0.254 64.174.223.75
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.3.1.1
    ip route 10.1.0.0 255.255.0.0 Serial0/1
    ip route 10.2.0.0 255.255.0.0 Serial0/0
    ip route 10.4.0.0 255.255.0.0 Serial0/2
    ip route 10.6.0.0 255.255.0.0 10.3.0.2
    no ip http server
    !
    access-list 1 permit 10.0.0.0 0.255.255.255
    access-list 1 permit 192.168.0.0 0.0.255.255
    snmp-server community public RO
    !
    dial-peer cor custom
    !
    !
    !
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password xxxxx
    login
    !
    no scheduler allocate
    end

    Hollywood#


    Thank you in advance,

    Igor Pinchevskiy
    Igor Pinchevskiy, Oct 3, 2007
    #1
    1. Advertising

  2. Igor Pinchevskiy

    Merv Guest

    Remove the enable password command as it is overrideen by enable
    secret

    I would migrate to a dynamic routing protocol - in your case EIGRP.
    Then I would redistribute default from one router only.

    I would use network 10.x.x.x addressing only and thus would lose the
    192.168.x.x addressing on the serial interfaces
    Merv, Oct 6, 2007
    #2
    1. Advertising

  3. On Oct 6, 2:08 am, Merv <> wrote:
    > Remove the enable password command as it is overrideen by enable
    > secret
    >
    > I would migrate to a dynamic routing protocol - in your case EIGRP.
    > Then I would redistribute default from one router only.
    >
    > I would use network 10.x.x.x addressing only and thus would lose the
    > 192.168.x.x addressing on the serial interfaces


    Thank you Merv!
    Igor Pinchevskiy, Oct 8, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tom Accuosti
    Replies:
    3
    Views:
    488
    Travis Evans
    Sep 27, 2004
  2. Rob Dover
    Replies:
    2
    Views:
    2,324
    Rob Dover
    Dec 22, 2005
  3. The Man With No Name
    Replies:
    3
    Views:
    849
  4. MSB

    PHP double quotes inside double quotes

    MSB, Oct 20, 2006, in forum: Computer Support
    Replies:
    11
    Views:
    1,003
    Beauregard T. Shagnasty
    Oct 21, 2006
  5. Igor Pinchevskiy

    Can someone double check the config

    Igor Pinchevskiy, Oct 3, 2007, in forum: Cisco
    Replies:
    0
    Views:
    418
    Igor Pinchevskiy
    Oct 3, 2007
Loading...

Share This Page