Can not see my home network across router ports, Pt 2

Discussion in 'Cisco' started by Gerald, Apr 29, 2007.

  1. Gerald

    Gerald Guest

    Original Post:
    Hello everyone..

    I have a 3620 router in my home that I am using to study for my CCNA exam.

    I have 1 ethernet port 'ethernet0/1' connected to a 2924 switch, then my pc (192.168.3.2).
    (e0/0 - Ip address 192.168.1.3)

    I have 1 ethernet port 'ethernet0/0' connected to a 2924 switch, then to my home network.
    (e0/1 - Ip address 192.168.3.1)

    I can not 'see' my home network across the router.
    There is a fully configured DNS/WINS server on 192.168.1.0 network
    ( DNS/WINS server = 192.168.1.101 )

    I have a dlink broadband router feeding the internet to my network.
    It's internal IP is 192.168.1.1

    I installed 'Dude, version 2.2' It located the devices on the 192.168.1.0
    side of the router, but only displayed them after I set the preferences to
    allow it to display items with no services. But it didn't find all of them.

    I can not ping across the router to anything on the other side.
    I CAN get to the router from both networks, but not to the other side's interface

    The results I am trying to get are:
    -- I need to share certain devices between the two networks.
    -- 1 network has a network printer, the other has a networked scanner.
    -- the 192.168.1.0 network has the file server on it. Both networks need access to it..
    -- I don't want them to share anything else.

    I am so totally lost. I added the static route to the 1/0 network, I set the default network.
    I just do not get it.

    Can someone please help?
    Thanks!

    ==================================================
    Current configuration : 1045 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname ExtGate
    !
    !
    no ip subnet-zero
    !
    !
    ip cef
    ip domain lookup source-interface Ethernet0/0
    ip name-server 192.168.1.101
    !
    !
    interface Ethernet0/0
    ip address 192.168.1.3 255.255.255.0
    half-duplex
    !
    !
    interface Ethernet0/1
    ip address 192.168.3.1 255.255.255.0
    half-duplex
    !
    router rip
    network 192.168.1.0
    network 192.168.3.0
    !
    ip default-gateway 192.168.1.1
    ip classless
    ip default-network 192.168.1.0
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    ip route 192.168.1.0 255.255.255.0 Ethernet0/0
    !
    !
    snmp-server community public RO
    !
    line con 0
    line aux 0
    line vty 0 4
    line vty 5 15
    !
    !
    end
    ======================
    ExtGate# sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 192.168.1.1 to network 0.0.0.0

    C* 192.168.1.0/24 is directly connected, Ethernet0/0
    C 192.168.3.0/24 is directly connected, Ethernet0/1
    S* 0.0.0.0/0 [1/0] via 192.168.1.1
    ExtGate#
    ============================================
    ExtGate#Show int e0/0
    Ethernet0/0 is up, line protocol is up
    Hardware is AmdP2, address is 0050.731b.ca01 (bia 0050.731b.ca01)
    Internet address is 192.168.1.3/24
    MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:00, output 00:00:00, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 6000 bits/sec, 3 packets/sec
    5 minute output rate 2000 bits/sec, 3 packets/sec
    19234 packets input, 3186361 bytes, 0 no buffer
    Received 2099 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    19985 packets output, 2087678 bytes, 0 underruns
    4 output errors, 16 collisions, 2 interface resets
    0 babbles, 0 late collision, 52 deferred
    4 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
    ExtGate#
    ========================================================
    When logged into the e0/0 interface I get:

    ExtGate>ping 192.168.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
    ExtGate>ping 192.168.3.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    ExtGate>ping 192.168.3.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
    ExtGate>

    >Path: news4.newsguy.com!extra.newsguy.com!postnews.google.com!o5g2000hsb.googlegroups.com!not-for-mail
    >From: Merv <>
    >Newsgroups: comp.dcom.sys.cisco
    >Subject: Re: Can not see my home network across router ports
    >Date: 29 Apr 2007 03:03:08 -0700
    >Organization: http://groups.google.com
    >Lines: 8
    >Message-ID: <>
    >References: <>
    >NNTP-Posting-Host: 72.39.199.83
    >Mime-Version: 1.0
    >Content-Type: text/plain; charset="iso-8859-1"
    >X-Trace: posting.google.com 1177840989 31105 127.0.0.1 (29 Apr 2007 10:03:09 GMT)
    >X-Complaints-To:
    >NNTP-Posting-Date: Sun, 29 Apr 2007 10:03:09 +0000 (UTC)
    >.In-Reply-To: <>>
    >User-Agent: G2/1.0
    >X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.11) Gecko/20070312 Firefox/1.5.0.11,gzip(gfe),gzip(gfe)
    >Complaints-To:
    >Injection-Info: o5g2000hsb.googlegroups.com; posting-host=72.39.199.83;
    > posting-account=VWhwrg0AAABq9d-dYoZZYICoNxMnULHj
    >Xref: news4.newsguy.com comp.dcom.sys.cisco/373665
    >X-Received-Date: Sun, 29 Apr 2007 06:03:09 EDT (beO3)
    >
    >
    > I have a dlink broadband router feeding the internet to my network.
    > It's internal IP is 192.168.1.1
    >
    >
    >have you configured the DLINK router to know that 192.168.3.0/24 is
    >reachable via 192.168.1.3 ???


    My Dlink is a 614+. I see no place to put a static route in that router...BUT...
    - I put this entry in the firewall section :
    Allow 192.168.3.1 WAN,192.168.1.1 LAN,192.168.3.1-192.168.3.254 IP (0),*

    ====

    I understand what you are asking, but do not see where it would help me
    communicate across my Cisco 3620 router ports.

    Gerald
     
    Gerald, Apr 29, 2007
    #1
    1. Advertising

  2. Gerald <> writes:
    >>> I have a dlink broadband router feeding the internet to my network.
    >>> It's internal IP is 192.168.1.1


    >>have you configured the DLINK router to know that 192.168.3.0/24 is
    >>reachable via 192.168.1.3 ???


    >My Dlink is a 614+. I see no place to put a static route in that router...BUT...
    > - I put this entry in the firewall section :
    >Allow 192.168.3.1 WAN,192.168.1.1 LAN,192.168.3.1-192.168.3.254 IP (0),*



    Thats not going to help you, you need to access the static route table
    on the device. If your router is too low-end to deal with it (although
    most tiny consumer ones I've dealt with do have a static route table.)
    you'll have to do something else, one by one on the workstations that
    won't persist across reboots...

    >I understand what you are asking, but do not see where it would help me
    >communicate across my Cisco 3620 router ports.



    Its because of the routing tables in each of the workstations.

    Think about what they have (although a 'route print' will show you,
    its going to be overload at this point).

    They know how to reach 192.168.1.0/24. Thats their connected
    route. Each of them are configured on that network, they know that to
    reach 192.168.1.0/24 by putting out packets out on the Network.

    The other entry that they have is the default route. They're going to
    push every other packet they don't know about up to your
    Dlink.

    There's nothing in there now to know about 192.168.3.0/24. Its totally
    off their radar. You have a 2nd router on your network. The
    workstations have no idea its there. They don't listen to RIP.

    Now, there is a protocol built into TCP/IP that will allow your
    workstations to learn routes like this. ICMP redirects will allow your
    workstations to learn that the 2nd router is there. BUT, something has
    to generate them. The usual thing to do so is going to be your default
    gateway router, your Dlink. Put in a static route there, when a
    workstation pushes a packet up for 192.168.3.0/24 to your dlink, it
    should generate an ICMP redirect packet, and push the packet down to
    your other router. From then on, the workstation should directly
    generate packets heading for 192.168.3.0/24 over to your cisco router.
    It all works pretty well usually.

    Your other choice if the Dlink doesn't support a static route table
    (although again, I haven't seen many that don't) is to add a static
    route into each workstation with the 'route' command from the command
    line.

    Something like
    route add 192.168.3.0 mask 255.255.255.0 192.168.1.3 metric 1

    should work on windows. As I said, this will only work between
    reboots. Once you reboot your workstation, it'll go away.

    This will tell your workstation that all packets for 192.168.3.0/24
    should be handled by 192.168.1.3, your cisco router.

    The static route in the default gateway works much better though.
     
    Doug McIntyre, Apr 29, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RGFya3dhdGVy?=

    Can not see home network

    =?Utf-8?B?RGFya3dhdGVy?=, Jul 15, 2005, in forum: Wireless Networking
    Replies:
    2
    Views:
    483
    Clark
    Jul 15, 2005
  2. Paul Tutle Sr. - OCC
    Replies:
    1
    Views:
    1,455
    Hamman
    Oct 1, 2004
  3. Gerald
    Replies:
    1
    Views:
    441
  4. Gerald
    Replies:
    1
    Views:
    318
    Brian V
    Apr 30, 2007
  5. jjg247
    Replies:
    7
    Views:
    5,150
    Robert L. \(MS-MVP\)
    Jan 21, 2008
Loading...

Share This Page