Calls to an extension result in fast-busy when rolling to UnityExpress voicemail

Discussion in 'Cisco' started by ttripp, Oct 28, 2008.

  1. ttripp

    ttripp Guest

    CME/CUE newbie warning...

    I'm working in a test environment. I have a Cisco 2691 running C2691-
    ADVIPSERVICESK9-M, Version 12.4(21) and CME 3.4, with an AIM module
    running CUE 3.2.2. I have two phones registered, a 7940 and a 7960.

    I can call from one phone to the other. I can also call from a phone
    to the voice-mail system, where I've successfully setup two voice
    mailboxes, and recorded my greetings for two test users. The test
    environment is completely isolated, so there's no PSTN connectivity to
    worry with at this point.

    When I call from one phone to the other and wait for the voice-mail
    system to kick in, I get a fast-busy signal. The Cisco docs I've
    found suggest this can be caused by an incorrect codec, but I've
    double-checked my settings there and found nothing wrong.

    If anyone has any ideas on this, thanks in advance.

    Since there's nothing sacred on either the router or the AIM, here are
    the configs:

    ---------- ROUTER ----------

    Current configuration : 4850 bytes
    !
    ! No configuration change since last restart
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CME-Test-Router
    !
    boot-start-marker
    boot system flash c2691-advipservicesk9-mz.124-21.bin
    boot-end-marker
    !
    enable secret 5 $1$7otI$hiAt2p2G4AzoZoRtm.UWm.
    enable password none
    !
    no aaa new-model
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.10
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp excluded-address 192.168.11.1 192.168.11.10
    !
    ip dhcp pool WAN
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    !
    ip dhcp pool DATA
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    option 150 ip 192.168.10.1
    domain-name domain.test
    dns-server 192.168.10.1
    !
    ip dhcp pool VOICE
    network 192.168.11.0 255.255.255.0
    default-router 192.168.11.1
    option 150 ip 192.168.11.1
    domain-name domain.test
    dns-server 192.168.10.1
    !
    !
    ip host ns.manh.com 192.168.1.1
    ip host CME-Test-Router.domain.test 192.168.10.1
    ip host CME-Test-Switch.domain.test 192.168.10.2
    ip host CME-Test-Router-VM.domain.test 192.168.11.3
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    no mop enabled
    !
    interface FastEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    no cdp enable
    !
    interface Service-Engine0/0
    ip unnumbered FastEthernet0/1.2
    service-module ip address 192.168.11.3 255.255.255.0
    service-module ip default-gateway 192.168.11.1
    !
    interface FastEthernet0/1
    no ip address
    speed 100
    full-duplex
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.10.1 255.255.255.0
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 192.168.11.1 255.255.255.0
    !
    ip forward-protocol nd
    ip route 192.168.11.3 255.255.255.255 Service-Engine0/0
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    tftp-server flash:p00403020214.bin
    tftp-server flash:p00307020200.bin
    tftp-server flash:p00307020200.loads
    tftp-server flash:p00307020200.sb2
    tftp-server flash:p00307020200.sbn
    tftp-server flash:p003-07-4-00.bin
    tftp-server flash:p003-07-4-00.sbn
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    dial-peer voice 1999 voip
    destination-pattern 1999
    session protocol sipv2
    session target ipv4:192.168.11.3
    incoming called-number .
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    !
    dial-peer voice 1998 voip
    destination-pattern 1998
    session protocol sipv2
    session target ipv4:192.168.11.3
    incoming called-number .
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    !
    dial-peer voice 1997 voip
    destination-pattern 1997
    session protocol sipv2
    session target ipv4:192.168.11.3
    incoming called-number .
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    !
    !
    !
    !
    telephony-service
    load 7960-7940 P00307020200
    max-ephones 10
    max-dn 10
    ip source-address 192.168.11.1 port 2000
    auto assign 1 to 10
    url services http://192.168.11.3/voiceview/common/login.do
    url authentication http://192.168.11.3/voiceview/authentication/authenticate.do
    create cnf-files version-stamp 7960 Oct 27 2008 05:25:07
    dialplan-pattern 1 4045551... extension-length 4
    voicemail 1999
    max-conferences 4 gain -6
    moh music-on-hold.au
    transfer-system full-consult
    !
    !
    ephone-dn 1 dual-line
    number 1000
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 2 dual-line
    number 1001
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 3 dual-line
    number 1002
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 4 dual-line
    number 1003
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 5 dual-line
    number 1004
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 6 dual-line
    number 1005
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 7 dual-line
    number 1006
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 8 dual-line
    number 1007
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 9 dual-line
    number 1008
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone-dn 10 dual-line
    number 1009
    call-forward busy 1999
    call-forward noan 1999 timeout 18
    !
    !
    ephone 1
    mac-address 000D.284C.E9C0
    type 7940
    button 1:1
    !
    !
    !
    ephone 2
    mac-address 0003.E363.0B90
    type 7960
    button 1:2
    !
    !
    !
    ephone 3
    !
    !
    !
    ephone 4
    !
    !
    !
    ephone 5
    !
    !
    !
    ephone 6
    !
    !
    !
    ephone 7
    !
    !
    !
    ephone 8
    !
    !
    !
    ephone 9
    !
    !
    !
    ephone 10
    !
    !
    !
    line con 0
    line 26
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output all
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    ntp master 1
    ntp server 192.168.10.1
    !
    end

    ---------- AIM MODULE ----------

    clock timezone America/New_York

    hostname CME-Test-VM

    ip domain-name domain.test

    system language preferred "en_US"

    ntp server 192.168.11.1 prefer

    software download server url "ftp://127.0.0.1/ftp" credentials hidden
    "6u/dKTN/hsEuSAEfw40XlF2eFHnZfyUTSd8ZZNgd
    +Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd
    +Y9J3xlk2B35j0nfGWTYHfmP"
    site name local
    site-hostname 192.168.11.1
    web credentials hidden "c9yem6kD1vJqrOHVxftjAknfGWTYHfmPSd8ZZNgd
    +Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd
    +Y9J3xlk2B35j0nfGWTYHfmP"
    end site

    groupname Administrators create
    groupname Broadcasters create

    username admin create
    username uone create
    username utwo create
    username uone phonenumber "1000"
    username utwo phonenumber "1001"

    groupname Administrators member admin
    groupname Administrators privilege ManagePrompts
    groupname Administrators privilege broadcast
    groupname Administrators privilege local-broadcast
    groupname Administrators privilege ManagePublicList
    groupname Administrators privilege ViewPrivateList
    groupname Administrators privilege vm-imap
    groupname Administrators privilege ViewHistoricalReports
    groupname Administrators privilege ViewRealTimeReports
    groupname Administrators privilege superuser
    groupname Broadcasters privilege broadcast

    restriction msg-notification create
    restriction msg-notification min-digits 1
    restriction msg-notification max-digits 30
    restriction msg-notification dial-string preference 1 pattern *
    allowed

    backup server url "ftp://127.0.0.1/ftp" credentials hidden
    "EWlTygcMhYmjazXhE/
    VNXHCkplVV4KjescbDaLa4fl4WLSPFvv1rWUnfGWTYHfmPSd8ZZNgd
    +Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

    calendar biz-schedule systemschedule
    open day 1 from 00:00 to 24:00
    open day 2 from 00:00 to 24:00
    open day 3 from 00:00 to 24:00
    open day 4 from 00:00 to 24:00
    open day 5 from 00:00 to 24:00
    open day 6 from 00:00 to 24:00
    open day 7 from 00:00 to 24:00
    end schedule

    ccn application autoattendant aa
    description "autoattendant"
    enabled
    maxsessions 6
    script "aa.aef"
    parameter "busClosedPrompt" "AABusinessClosed.wav"
    parameter "holidayPrompt" "AAHolidayPrompt.wav"
    parameter "welcomePrompt" "AAWelcome.wav"
    parameter "disconnectAfterMenu" "false"
    parameter "dialByFirstName" "false"
    parameter "allowExternalTransfers" "false"
    parameter "MaxRetry" "3"
    parameter "dialByExtnAnytime" "false"
    parameter "busOpenPrompt" "AABusinessOpen.wav"
    parameter "businessSchedule" "systemschedule"
    parameter "dialByExtnAnytimeInputLength" "4"
    parameter "operExtn" "0"
    end application

    ccn application ciscomwiapplication aa
    description "ciscomwiapplication"
    enabled
    maxsessions 6
    script "setmwi.aef"
    parameter "CallControlGroupID" "0"
    parameter "strMWI_OFF_DN" "8001"
    parameter "strMWI_ON_DN" "8000"
    end application

    ccn application msgnotification aa
    description "msgnotification"
    enabled
    maxsessions 6
    script "msgnotify.aef"
    parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/
    mbxLogout.jsp"
    parameter "DelayBeforeSendDTMF" "1"
    end application

    ccn application promptmgmt aa
    description "promptmgmt"
    enabled
    maxsessions 1
    script "promptmgmt.aef"
    end application

    ccn application voicemail aa
    description "voicemail"
    enabled
    maxsessions 6
    script "voicebrowser.aef"
    parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/
    mbxLogout.jsp"
    parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
    end application

    ccn engine
    end engine

    ccn reporting historical
    database local
    description "CME-Test-VM"
    end reporting

    ccn subsystem sip
    gateway address "192.168.11.1"
    end subsystem

    ccn trigger http urlname msgnotifytrg
    application "msgnotification"
    enabled
    maxsessions 2
    end trigger

    ccn trigger http urlname mwiapp
    application "ciscomwiapplication"
    enabled
    maxsessions 1
    end trigger

    ccn trigger sip phonenumber 1997
    application "promptmgmt"
    enabled
    locale "en_US"
    maxsessions 1
    end trigger

    ccn trigger sip phonenumber 1998
    application "autoattendant"
    enabled
    locale "en_US"
    maxsessions 6
    end trigger

    ccn trigger sip phonenumber 1999
    application "voicemail"
    enabled
    maxsessions 6
    end trigger

    network location id "1"
    email domain domain.test
    end location

    network local location id 1

    security password lockout policy temp-lock
    security pin lockout policy temp-lock
    service phone-authentication
    end phone-authentication

    service voiceview
    enable
    end voiceview

    voicemail callerid
    voicemail broadcast recording time 300
    voicemail default messagesize 30
    voicemail notification restriction msg-notification
    voicemail mailbox owner "uone" size 120
    description "uone mailbox"
    end mailbox

    voicemail mailbox owner "utwo" size 120
    description "utwo mailbox"
    end mailbox

    end

    ---------- END OF CONFIGS ----------

    I also have a 3500 switch, but there's no problem there so I'm
    skipping its config.

    Everything's basically left at its default settings.
     
    ttripp, Oct 28, 2008
    #1
    1. Advertising

  2. ttripp

    ttripp Guest

    BTW, I noticed the bad DNS entry for the AIM and corrected it, but
    that didn't change anything.
     
    ttripp, Oct 28, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Frankie

    Might aswell get the ball rolling...

    Frankie, Oct 8, 2005, in forum: The Lounge
    Replies:
    14
    Views:
    2,357
    unholy
    Oct 12, 2005
  2. Doom

    OT:Busy Busy

    Doom, Jul 7, 2004, in forum: MCSE
    Replies:
    36
    Views:
    1,445
    TechGeekPro
    Jul 8, 2004
  3. =?Utf-8?B?U3VzaGls?=
    Replies:
    1
    Views:
    744
    Wayne
    Feb 16, 2006
  4. Bob Alan
    Replies:
    1
    Views:
    1,133
    Wolfgang S. Rupprecht
    Sep 28, 2005
  5. Replies:
    0
    Views:
    892
Loading...

Share This Page