cable modem giving private IP

Discussion in 'Cisco' started by ddpant@gmail.com, Aug 10, 2006.

  1. Guest

    hello,
    i have been trying to connect Cisco 1720 router to time-warner cable
    modem for home network. the router has two ethernet ports, fa0 and
    eth0. i want eth0 to be internal and fa0 to connect to modem. i enabled
    dhcp on fa0, but the cable modem always gives a private IP instead of
    public. time warner has no idea how to fix this. their response was
    that for some reason the modem thinks that the router is one of their
    network's nodes.

    i would really appreciate your response.
     
    , Aug 10, 2006
    #1
    1. Advertising

  2. You may also wish to "post" on the cable modem newsgroup:

    comp.dcom.modems.cable

    http://groups.google.com/group/comp.dcom.modems.cable

    Found on Brad's Technical Forum List:

    http://www.bradreese.com/cisco-technical-newsgroups.htm#TECH

    Sincerely,

    Brad Reese
    BradReese.Com - Global Cisco Systems Pre-Sales Support
    http://www.bradreese.com/contact-us.htm#CISCO
    1293 Hendersonville Road, Suite 17
    Asheville, North Carolina USA 28803
    USA & Canada: 877-549-2680
    International: 828-277-7272
    Fax: 775-254-3558
    AIM: R2MGrant
    BradReese.Com - Cisco CraigsList Job Openngs
    http://www.bradreese.com/craigslist-networking-jobs.htm
     
    www.BradReese.Com, Aug 10, 2006
    #2
    1. Advertising

  3. Merv Guest

    Try changing the MAC address on the FA 0 interface so that it does not
    have a Cisco vendor ID in the first 6 characters

    int fa 0
    mac-address EEEE.EE00.0001
    end
     
    Merv, Aug 11, 2006
    #3
  4. On Thu, 10 Aug 2006 12:28:43 -0700, wrote:

    > i have been trying to connect Cisco 1720 router to time-warner cable
    > modem for home network. the router has two ethernet ports, fa0 and
    > eth0. i want eth0 to be internal and fa0 to connect to modem. i enabled
    > dhcp on fa0, but the cable modem always gives a private IP instead of
    > public. time warner has no idea how to fix this. their response was
    > that for some reason the modem thinks that the router is one of their
    > network's nodes.


    How old is your IOS. There was a bug in the DHCP client some time ago
    that did exactly that. One of the option fields was inappropriately filled
    in and made the router look like a cable modem to the DHCP server.

    It seems Google really is our friend:

    The bug ID is CSCdx67972:
    ------------
    A Cisco router running 12.1T or 12.2 IOS will incorrectly set the
    Class ID (Option 60) of a DHCP Discover Packet.

    This only causes a problem when the following is true:

    1) Router is setup to be a DHCP Client.
    2) DHCP Server is looking at Option 60 to assign IP addresses
    3) Router is connected behind a Cable Modem.

    This is a rare problem that does not effect every customer running
    the router as a DHCP Client.
    -----------

    --
    Rgds,
    Martin
     
    Martin Gallagher, Aug 12, 2006
    #4
  5. Guest

    I updated the IOS, and it works fine now.
    Thanks for all your help.
    -DP


    Martin Gallagher wrote:
    > On Thu, 10 Aug 2006 12:28:43 -0700, wrote:
    >
    > > i have been trying to connect Cisco 1720 router to time-warner cable
    > > modem for home network. the router has two ethernet ports, fa0 and
    > > eth0. i want eth0 to be internal and fa0 to connect to modem. i enabled
    > > dhcp on fa0, but the cable modem always gives a private IP instead of
    > > public. time warner has no idea how to fix this. their response was
    > > that for some reason the modem thinks that the router is one of their
    > > network's nodes.

    >
    > How old is your IOS. There was a bug in the DHCP client some time ago
    > that did exactly that. One of the option fields was inappropriately filled
    > in and made the router look like a cable modem to the DHCP server.
    >
    > It seems Google really is our friend:
    >
    > The bug ID is CSCdx67972:
    > ------------
    > A Cisco router running 12.1T or 12.2 IOS will incorrectly set the
    > Class ID (Option 60) of a DHCP Discover Packet.
    >
    > This only causes a problem when the following is true:
    >
    > 1) Router is setup to be a DHCP Client.
    > 2) DHCP Server is looking at Option 60 to assign IP addresses
    > 3) Router is connected behind a Cable Modem.
    >
    > This is a rare problem that does not effect every customer running
    > the router as a DHCP Client.
    > -----------
    >
    > --
    > Rgds,
    > Martin
     
    , Sep 2, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. GS
    Replies:
    3
    Views:
    1,025
    David H. Lipman
    Oct 1, 2005
  2. HMV

    Re: How to keep your private files private

    HMV, Feb 21, 2006, in forum: Computer Support
    Replies:
    0
    Views:
    524
  3. Steve

    Re: How to keep your private files private

    Steve, Feb 21, 2006, in forum: Computer Support
    Replies:
    1
    Views:
    516
  4. John Holmes

    Re: How to keep your private files private

    John Holmes, Feb 21, 2006, in forum: Computer Support
    Replies:
    0
    Views:
    466
    John Holmes
    Feb 21, 2006
  5. Daave

    Re: How to keep your private files private

    Daave, Feb 22, 2006, in forum: Computer Support
    Replies:
    0
    Views:
    440
    Daave
    Feb 22, 2006
Loading...

Share This Page