C876 route-map smtp traffic to one ISP, can you check my config for faults?

Discussion in 'Cisco' started by Steven V.A, Apr 29, 2008.

  1. Steven V.A

    Steven V.A Guest

    Hi Group,


    I' am setting up a Cisco 876 ISDN ADSL router.

    The company has two broadband connections: one ISDN over ADSL
    (currenty by the 876) and one, on an Ethenet cable modem.

    I have read that I can use Cisco's 876 ISDN BRI port as wan port for
    the cable modem. So effectiffly load balancing between the two ISP's

    I did some homework and made a config to balance between the thow
    ISP's.

    Can you check my config for errors? Before I load this in the 876.
    I used the template from:
    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a00808d2b72.shtml

    However there is one thing I coulden't find nicely explaind: I want
    ALL smtp traffic routed trough ISP 2. How can I do that?
    I tried route maps, but I have no idea if I'm doeing thing right.
    Can you help me with that?

    Many thanks in advance.
    picure of the 876:
    http://www.cisco.com/en/US/i/100001-200000/120001-130000/122001-123000/122243.jpg

    Config starts:


    resource policy
    !
    clock timezone BXL 1
    ip subnet-zero
    ip cef
    !
    ! OpenDNS server om dns queries nog te versnellen.
    !
    ip name-server 208.67.222.222
    ip name-server 208.67.220.220
    !!

    ! Het Dual Wan gedeelte begint hieronder.
    !
    !
    track timer interface 5
    !
    ! Configure timers on route tracking
    !
    track 123 rtr 1 reachability
    delay down 15 up 10
    !
    track 345 rtr 2 reachability
    delay down 15 up 10

    !
    ! Use “ip dhcp client route track [number]”
    ! to monitor route on DHCP interfaces
    ! Define ISP-facing interfaces with “ip nat outside”
    !
    ! Deze interface hieronder hangt aan de telenet kabelmodem
    ! This is the iface to the cable modem

    interface BRI0
    ip address dhcp
    ip dhcp client route track 345
    ip nat outside
    ip virtual-reassembly
    mac-address 0050.BFB7.772C
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    !
    ! Define LAN-facing interfaces with “ip nat inside”
    ! This is the Lan iface
    !
    interface Vlan1
    description LAN Interface
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452

    !
    ! Define ISP-facing interfaces with “ip nat outside”
    ! this is the ADSL line to Skynet
    !
    interface ATM0
    description *** DSL line ***
    ip address ****snip******** 255.255.255.192
    ip nat outside
    ip virtual-reassembly
    no atm ilmi-keepalive
    pvc 0/35
    protocol ip *snip******* broadcast
    encapsulation aal5snap
    dsl operating-mode auto
    !

    ip route 0.0.0.0 0.0.0.0 ATM0 track 123
    !
    ! Configure NAT overload (PAT) to use route-maps
    !
    ip nat inside source route-map fixed-nat
    interface ATM0 overload
    ip nat inside source route-map dhcp-nat
    interface BRI0 overload
    !
    ! Configure an OER tracking entry
    ! om de eerste verbinding van de ADSL i-line te monitoren, ATM0
    ! We doen dit door af en toe de DNS van Skynet te pingen.
    !
    ip sla 1
    icmp-echo 195.238.2.21 source-interface ATM0
    timeout 1000
    threshold 40
    frequency 3
    !
    ! Configure a second OER tracking entry
    ! Monitoren van de Telenet verbinding. BRI0
    ! Hierbij pingen we de DNS van Telenet
    !
    ip sla 2
    icmp-echo 195.130.130.11 source-interface BRI0
    timeout 1000
    threshold 40
    frequency 3
    !
    ! Set the SLA schedule and duration
    !
    ip sla schedule 1 life forever start-time now
    ip sla schedule 2 life forever start-time now
    !
    ! Define ACLs for traffic that
    ! will be NATed to the ISP connections
    !

    !!! is is this right ? for smtp traffic
    !access-list 100 permit ip 192.168.0.0 0.0.0.255 any eq smtp

    access-list 110 permit ip 192.168.0.0 0.0.0.255 any



    !
    ! Route-maps associate NAT ACLs with NAT
    ! outside on the ISP-facing interfaces
    !
    route-map fixed-nat permit 10
    match ip address 110
    match interface ATM0
    !
    route-map dhcp-nat permit 10
    match ip address 110
    match interface BRI0

    !!! is is this right ?
    !route-map smtp-static permit 10
    ! match ip address 100
    ! set interface BRI0


    ip dns server
    Steven V.A, Apr 29, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. AM
    Replies:
    3
    Views:
    597
  2. Replies:
    1
    Views:
    5,136
    Barry Margolin
    Aug 13, 2005
  3. Skybuck Flying
    Replies:
    0
    Views:
    4,799
    Skybuck Flying
    Jan 19, 2006
  4. perimere
    Replies:
    0
    Views:
    1,085
    perimere
    Mar 27, 2007
  5. Giuen
    Replies:
    0
    Views:
    690
    Giuen
    Sep 12, 2008
Loading...

Share This Page