C2900XL, two questions

Discussion in 'Cisco' started by 2821 Intergrated mess, Nov 5, 2006.

  1. I have a Cisco C2900XL switch running the
    c2900XL-h2s-mz-112.8.2-SA6.bin. I have two questions regarding this
    switch as I am not that knowledgeable when it comes to cisco.

    1. First off is anytime I plug a serial cable from a windows box into
    the switch, it restarts? Prior to plugging in everything is running
    fine (4 machines plugged into this switch) and then nothing after
    plugging in the serial. So I bring up my hyperterminal and hit enter
    and it boots up.

    2. When I run ping commands from the boxes plugged into the cisco
    switch I get the following results on all boxes.

    # ping google.ca
    PING google.ca (64.233.187.104): 56 data bytes
    64 bytes from 64.233.187.104: icmp_seq=0 ttl=242 time=80.334 ms
    64 bytes from 64.233.187.104: icmp_seq=1 ttl=242 time=80.341 ms
    64 bytes from 64.233.187.104: icmp_seq=2 ttl=242 time=79.818 ms
    64 bytes from 64.233.187.104: icmp_seq=3 ttl=242 time=80.211 ms
    64 bytes from 64.233.187.104: icmp_seq=4 ttl=242 time=79.839 ms
    --- google.ca ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 79.818/80.108/80.341/0.388 ms
    # ping google.ca
    PING google.ca (64.233.161.104): 56 data bytes
    64 bytes from 64.233.161.104: icmp_seq=0 ttl=243 time=73.455 ms
    64 bytes from 64.233.161.104: icmp_seq=1 ttl=243 time=73.334 ms
    64 bytes from 64.233.161.104: icmp_seq=2 ttl=243 time=73.483 ms
    64 bytes from 64.233.161.104: icmp_seq=3 ttl=243 time=73.329 ms
    64 bytes from 64.233.161.104: icmp_seq=4 ttl=243 time=73.612 ms
    --- google.ca ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 73.329/73.442/73.612/0.314 ms
    # ping google.ca
    PING google.ca (66.102.7.104): 56 data bytes
    64 bytes from 66.102.7.104: icmp_seq=0 ttl=246 time=27.236 ms
    64 bytes from 66.102.7.104: icmp_seq=1 ttl=246 time=27.109 ms
    64 bytes from 66.102.7.104: icmp_seq=2 ttl=246 time=27.282 ms
    64 bytes from 66.102.7.104: icmp_seq=3 ttl=246 time=27.091 ms
    64 bytes from 66.102.7.104: icmp_seq=4 ttl=246 time=27.206 ms
    --- google.ca ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 27.091/27.184/27.282/0.221 ms

    Every third attempt is significatly faster. Again this happens on all 4
    boxes with the same results. Does cisco switches just function this
    way? I thought I would include the running config as it is right now.
    FYI this switch is the switch for all machines in the DMZ. It's plugged
    into a BSD firewall.
    I will admit my config is basic as I do not know cisco products that
    well.


    show running-config
    Building configuration...

    Current configuration:
    !
    version 11.2
    no service pad
    no service udp-small-servers
    no service tcp-small-servers
    !
    hostname DMZ
    !
    enable secret 5 blahblahblah
    enable password nothing (this is not my pass)
    !
    ip subnet-zero
    ip name-server 192.168.200.254 (firewall/DNS)
    !
    clock timezone MST -7
    !
    interface VLAN1
    no ip address
    no ip route-cache
    !
    interface FastEthernet0/1 - used (doing 100/full)
    !
    interface FastEthernet0/2 - used (doing 100/full)
    !
    interface FastEthernet0/3 - used (doing 100/full)
    !
    interface FastEthernet0/4- used (doing 100/full)
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12 -(This goes to the firewall)
    keepalive 100
    speed 100
    duplex full
    !
    ip default-gateway 192.168.200.254 (firewall)
    no logging console
    snmp-server community private RW
    snmp-server community public RO
    snmp-server location somewhere
    snmp-server contact me
    snmp-server chassis-id 0x0D
    !
    line con 0
    stopbits 1
    line vty 0 4
    password nothing
    login
    line vty 5 9
    login
    !
    end


    I am sure there are ways to improve the configuration so that
    performance is better, but I need some direction please. This is an old
    switch that I would rather not have to replace.
    2821 Intergrated mess, Nov 5, 2006
    #1
    1. Advertising

  2. 2821 Intergrated mess

    Guest

    Re: C2900XL, two questions

    > PING google.ca (64.233.187.104): 56 data bytes

    > PING google.ca (64.233.161.104): 56 data bytes


    > PING google.ca (66.102.7.104): 56 data bytes



    First, each of the three pings went to a different endpoint IP address.
    It is far more likely that the 66.102.7.104 host is "closer" or
    "faster" relative to you then the other two boxes.

    Another possible explanation is that somewhere between you and
    "google.ca" there is a hop which actually has multiple equal cost
    paths, but each of the paths are loaded differenlty, resulting in
    different RTTs.

    I doubt that the difference is due in anyway to the switch.

    As far as the switch booting when you plug into it, could you capture
    that with hyperterm and post it? That sounds odd. Did you check that
    the power cable is firmly seated in the switch and the outlet?
    , Nov 5, 2006
    #2
    1. Advertising

  3. Re: C2900XL, two questions

    wrote:
    > > PING google.ca (64.233.187.104): 56 data bytes

    >
    > > PING google.ca (64.233.161.104): 56 data bytes

    >
    > > PING google.ca (66.102.7.104): 56 data bytes

    >
    >
    > First, each of the three pings went to a different endpoint IP address.
    > It is far more likely that the 66.102.7.104 host is "closer" or
    > "faster" relative to you then the other two boxes.
    >
    > Another possible explanation is that somewhere between you and
    > "google.ca" there is a hop which actually has multiple equal cost
    > paths, but each of the paths are loaded differenlty, resulting in
    > different RTTs.
    >
    > I doubt that the difference is due in anyway to the switch.
    >
    > As far as the switch booting when you plug into it, could you capture
    > that with hyperterm and post it? That sounds odd. Did you check that
    > the power cable is firmly seated in the switch and the outlet?


    Thanks Angry_Engineer,


    Ya your right the one IP is closer to the my location (stupid on my
    part).

    I will try to capture the reloading of the switch and post it when I
    do.

    Thanks again!
    2821 Intergrated mess, Nov 5, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. gene martinez

    old c2900XL switch

    gene martinez, Apr 24, 2006, in forum: Cisco
    Replies:
    2
    Views:
    529
    gene martinez
    Apr 25, 2006
  2. gene martinez

    old c2900xl switch

    gene martinez, Sep 9, 2006, in forum: Cisco
    Replies:
    5
    Views:
    1,819
  3. paul1537
    Replies:
    0
    Views:
    1,720
    paul1537
    May 15, 2008
  4. Patrick Michael

    Re: Questions....questions....questions

    Patrick Michael, Jun 16, 2004, in forum: A+ Certification
    Replies:
    0
    Views:
    812
    Patrick Michael
    Jun 16, 2004
  5. David Henzler

    c2900XL-h-mz-112.8-SA4

    David Henzler, Apr 21, 2009, in forum: Cisco
    Replies:
    5
    Views:
    645
    hrthrth
    May 30, 2009
Loading...

Share This Page