building a home network around a cisco 1003 router

Discussion in 'Cisco' started by encinomaan, Apr 12, 2007.

  1. encinomaan

    encinomaan Guest

    Greetings everyone,
    I am somewhat inexperienced with routers,but I have collected masses
    of Cisco resource material,have an electronics/communications
    background,and am confident of achieving a successful outcome.
    But,I don't know Cisco and am hoping for advice.My internet is an ISDN
    128kb DVO connection via a modem that connects to a copper pair at its
    U interface,has a USB interface to the PC,has an S bus RJ-45
    interface(is this the same as an S/T interface?),and two analogue
    outputs for two phones.
    I have a Cisco 1003 router with the following setup:
    * 4MB FLASH (SM9FLA4MP320C) Card Installed
    * Cisco IOS Feature Set - SF1005C4-11.1.8
    * Image - c1000-y-mz. 11.2.(3)
    I want to connect NT1+2 modem--->1003 router--->ethernet switch---
    >wireless access point & wired PC.

    Is this feasible?Is there a config that will do this?
    Went to Cisco to find details on feature set,but no longer supported.
    encinomaan, Apr 12, 2007
    #1
    1. Advertising

  2. "encinomaan" <> writes:
    >I am somewhat inexperienced with routers,but I have collected masses
    >of Cisco resource material,have an electronics/communications
    >background,and am confident of achieving a successful outcome.
    >But,I don't know Cisco and am hoping for advice.My internet is an ISDN
    >128kb DVO connection via a modem that connects to a copper pair at its
    >U interface,has a USB interface to the PC,has an S bus RJ-45
    >interface(is this the same as an S/T interface?),and two analogue
    >outputs for two phones.
    >I have a Cisco 1003 router with the following setup:
    >* 4MB FLASH (SM9FLA4MP320C) Card Installed
    >* Cisco IOS Feature Set - SF1005C4-11.1.8
    >* Image - c1000-y-mz. 11.2.(3)
    >I want to connect NT1+2 modem--->1003 router--->ethernet switch---
    >>wireless access point & wired PC.

    >Is this feasible?Is there a config that will do this?
    >Went to Cisco to find details on feature set,but no longer supported.



    Wow, a cisco 1003 eh? I haven't seen those in a long time.

    One thing that you should realize is that in all the true cisco IOS
    based routers, configs are nearly identical across the whole product
    line. You can take your config for one of the smallest old-school
    routers cisco ever made, and if you found one of the largest that
    still took BRI ports, the config would go in with only minor tweaks
    for port numbering scheme differences, and/or config lines that
    changed over time.

    If you dig up an old ISDN config for cisco *something*, it'll most
    likely work fine as long as it doesn't use newer features than what
    your IOS rev has. (one example might be 'ip address dhcp' to obtain an
    IP address via DHCP for an interface. Thats a relatively new feature,
    long after a 1003 would have been out).

    You can dig up all of Cisco's old docs no problem.

    Here's the 1003 router user Guide.

    http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/1000ig/1003_doc/78907.htm

    Chop off a few components of the URL and you'll get some more of the
    1000 series specific docs.

    And you can still get IOS 11.1 docs too.

    http://www.cisco.com/univercd/cc/td/doc/product/software/ios111/index.htm

    As I said, IOS for any cisco router is the same across the whole line.
    The most changes are in the different interfaces each router can have.

    You could also search on cisco's site for ISDN configs, and most
    likely get something just like you want to do.
    Doug McIntyre, Apr 12, 2007
    #2
    1. Advertising

  3. encinomaan

    Brad Guest

    Brad, Apr 12, 2007
    #3
  4. Not sure what's on the other end of your ISDN, here is a config I still had
    around for a 1003 we used. It connected to another Cisco

    The main things we needed to get right was the ISDN Switch Type, SPID Format
    and the number of Digits to dial to get to the other end.

    Hope this help. Need another 1003? How about a 1004, or a 4000 or a 2501
    or? (-;

    Scott<-

    version 11.0
    service slave-log
    no service pad
    service udp-small-servers
    service tcp-small-servers
    !
    hostname chiquita
    !
    !
    username <remote router> password 7 <password>
    isdn switch-type basic-ni1
    !
    interface Ethernet0
    ip address 206.171.20.97 255.255.255.224
    no ip route-cache
    !
    interface BRI0
    ip address 206.170.12.166 255.255.255.252
    encapsulation ppp
    bandwidth 128
    dialer idle-timeout 1200
    ! 23 and 24 are the numbers of the ISDN that we were calling,
    ! We had 2 digit dialing, as we had the ISDN lines in a Centrex
    dialer map ip 206.170.12.165 name rudolph broadcast 23
    dialer map ip 206.170.12.165 name rudolph broadcast 24
    dialer load-threshold 4 either
    dialer-group 2
    ! the 0101 at the end of the number too some time to get. Your ISDN switch
    might be different
    isdn spid1 70743135270101 4313527
    isdn spid2 70743135280101 4313528
    no fair-queue
    compress stac
    ppp multilink
    ppp authentication chap
    !
    ! 206.170.12.165 is the IP address of the Remote sit's BRI
    ip default-gateway 206.170.12.165
    ip name-server 206.13.44.2
    ip name-server 206.13.28.11
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 206.170.12.165
    ip route 206.170.12.165 255.255.255.255 BRI0
    access-list 104 permit ip any any
    dialer-list 2 protocol ip list 199
    !
    line con 0
    line vty 0 4
    exec-timeout 0 0
    login
    !
    end

    "encinomaan" <> wrote in message
    news:...
    > Greetings everyone,
    > I am somewhat inexperienced with routers,but I have collected masses
    > of Cisco resource material,have an electronics/communications
    > background,and am confident of achieving a successful outcome.
    > But,I don't know Cisco and am hoping for advice.My internet is an ISDN
    > 128kb DVO connection via a modem that connects to a copper pair at its
    > U interface,has a USB interface to the PC,has an S bus RJ-45
    > interface(is this the same as an S/T interface?),and two analogue
    > outputs for two phones.
    > I have a Cisco 1003 router with the following setup:
    > * 4MB FLASH (SM9FLA4MP320C) Card Installed
    > * Cisco IOS Feature Set - SF1005C4-11.1.8
    > * Image - c1000-y-mz. 11.2.(3)
    > I want to connect NT1+2 modem--->1003 router--->ethernet switch---
    >>wireless access point & wired PC.

    > Is this feasible?Is there a config that will do this?
    > Went to Cisco to find details on feature set,but no longer supported.
    >
    Scott Townsend, Apr 12, 2007
    #4
  5. encinomaan

    encinomaan Guest

    On Apr 13, 5:58 am, "Scott Townsend" <>
    wrote:
    > Not sure what's on the other end of your ISDN, here is a config I still had
    > around for a 1003 we used. It connected to another Cisco
    >
    > The main things we needed to get right was the ISDN Switch Type, SPID Format
    > and the number of Digits to dial to get to the other end.
    >
    > Hope this help. Need another 1003? How about a 1004, or a 4000 or a 2501
    > or? (-;
    >
    > Scott<-
    >
    > version 11.0
    > service slave-log
    > no service pad
    > service udp-small-servers
    > service tcp-small-servers
    > !
    > hostname chiquita
    > !
    > !
    > username <remote router> password 7 <password>
    > isdn switch-type basic-ni1
    > !
    > interface Ethernet0
    > ip address 206.171.20.97 255.255.255.224
    > no ip route-cache
    > !
    > interface BRI0
    > ip address 206.170.12.166 255.255.255.252
    > encapsulation ppp
    > bandwidth 128
    > dialer idle-timeout 1200
    > ! 23 and 24 are the numbers of the ISDN that we were calling,
    > ! We had 2 digit dialing, as we had the ISDN lines in a Centrex
    > dialer map ip 206.170.12.165 name rudolph broadcast 23
    > dialer map ip 206.170.12.165 name rudolph broadcast 24
    > dialer load-threshold 4 either
    > dialer-group 2
    > ! the 0101 at the end of the number too some time to get. Your ISDN switch
    > might be different
    > isdn spid1 70743135270101 4313527
    > isdn spid2 70743135280101 4313528
    > no fair-queue
    > compress stac
    > ppp multilink
    > ppp authentication chap
    > !
    > ! 206.170.12.165 is the IP address of the Remote sit's BRI
    > ip default-gateway 206.170.12.165
    > ip name-server 206.13.44.2
    > ip name-server 206.13.28.11
    > ip http server
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 206.170.12.165
    > ip route 206.170.12.165 255.255.255.255 BRI0
    > access-list 104 permit ip any any
    > dialer-list 2 protocol ip list 199
    > !
    > line con 0
    > line vty 0 4
    > exec-timeout 0 0
    > login
    > !
    > end
    >
    > "encinomaan" <> wrote in message
    >
    > news:...
    >
    >
    >
    > > Greetings everyone,
    > > I am somewhat inexperienced with routers,but I have collected masses
    > > of Cisco resource material,have an electronics/communications
    > > background,and am confident of achieving a successful outcome.
    > > But,I don't know Cisco and am hoping for advice.My internet is an ISDN
    > > 128kb DVO connection via a modem that connects to a copper pair at its
    > > U interface,has a USB interface to the PC,has an S bus RJ-45
    > > interface(is this the same as an S/T interface?),and two analogue
    > > outputs for two phones.
    > > I have a Cisco 1003 router with the following setup:
    > > * 4MB FLASH (SM9FLA4MP320C) Card Installed
    > > * Cisco IOS Feature Set - SF1005C4-11.1.8
    > > * Image - c1000-y-mz. 11.2.(3)
    > > I want to connect NT1+2 modem--->1003 router--->ethernet switch---
    > >>wireless access point & wired PC.

    > > Is this feasible?Is there a config that will do this?
    > > Went to Cisco to find details on feature set,but no longer supported.- Hide quoted text -

    >
    > - Show quoted text -


    thank you one and all
    encinomaan, Apr 13, 2007
    #5
  6. encinomaan

    Brad Guest


    > The main things we needed to get right was the ISDN Switch Type, SPID Format
    > and the number of Digits to dial to get to the other end.


    The fact that he has a 1003 leads me to believe he's outside the North
    America in which case the SPIDs are irrelevant.
    Brad, Apr 13, 2007
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Patriot

    Building to Building wireless

    Patriot, Nov 4, 2003, in forum: Cisco
    Replies:
    2
    Views:
    516
    Walter Roberson
    Nov 4, 2003
  2. Daniel
    Replies:
    0
    Views:
    399
    Daniel
    Dec 7, 2003
  3. Matthias Fischer
    Replies:
    4
    Views:
    868
    Matthias Fischer
    Jan 21, 2004
  4. Matthias Fischer

    Cisco 1003 - NAT - ISDN and extended ACLs

    Matthias Fischer, Jan 26, 2004, in forum: Cisco
    Replies:
    3
    Views:
    735
    Matthias Fischer
    Jan 26, 2004
  5. Jim
    Replies:
    5
    Views:
    878
    Barb Bowman
    Oct 5, 2007
Loading...

Share This Page