Bridging Ethernet and WLAN with a Cisco 877W

Discussion in 'Cisco' started by Matthias Scheler, Oct 29, 2006.

  1. Hello,

    I'm trying to configure a Cisco 877W to have big LAN which includes
    the ethernet ports and the 802.11g interface. As a first I enabled
    "bridge irb" and assigned VLAN 1 to the bridge:

    bridge irb
    [...]
    interface Vlan1
    no ip address
    bridge-group 1
    bridge-group 1 spanning-disabled
    [...]
    interface BVI1
    ip address 192.168.1.2 255.255.255.0

    That broke network connectivity to the box completely until I used
    this command:

    bridge 1 route ip

    The next thing I tried was getting IPv6 working:

    interface BVI1
    ip address 192.168.1.2 255.255.255.0
    ipv6 address abcd:1234:5678::2/64
    ipv6 enable

    IPv6 connectivity does however not work with this configuration. The
    obvious fix is of course to use "bridge 1 route ipv6". But although that
    command seems to exist(*) my Cisco doesn't accept it. Both IPv4 and IPv6
    work fine if I assign the IP addresses to "Vlan1".

    Any ideas how get this setup working?

    Kind regards

    (*) http://www.ipv6.wanadoo.fr/BB2/viewtopic.php?t=42&highlight=&sid=490578048f510004da89e1d1120a292e

    --
    Matthias Scheler http://zhadum.org.uk/
    Matthias Scheler, Oct 29, 2006
    #1
    1. Advertising

  2. Matthias Scheler

    AN Guest

    Hello,

    I am also working on the same problem but I want to take it a step further.
    Not only do I want to bridge my LAN and wireless into one broadcast domain
    (Vlan) but I want to partition my wireless into more than one ( at least 2)
    wireless vlans so I can set up a guest ssid and keep it logically separate
    from my private ssid. I've been search documentation online and all of it
    that's available online (google) have given information on how to divide the
    wireless domain into separate vlans on a dedicated Access point (ie. Cisco
    Aironet 1200 ) while I'm working with a ISR (Integrated Services Router)
    Cisco device (Cisco 871) which is a router, access point and built-in 4 port
    switch.

    So in the end, I don't know how to do you're trying to do but I ask that when
    you do find out or if anyone out there knows how please let me know.

    Thanks,

    Adil

    On 10/29/2006 4:05:13 PM, wrote:
    > Hello,
    >
    >I'm trying to configure a Cisco 877W to have big LAN which includes
    >the ethernet ports and the 802.11g interface. As a first I enabled
    >"bridge irb" and assigned VLAN 1 to the bridge:
    >
    >bridge irb
    >[...]
    >interface Vlan1
    > no ip address
    > bridge-group 1
    > bridge-group 1 spanning-disabled
    >[...]
    >interface BVI1
    > ip address 192.168.1.2 255.255.255.0
    >
    >That broke network connectivity to the box completely until I used
    >this command:
    >
    >bridge 1 route ip
    >
    >The next thing I tried was getting IPv6 working:
    >
    >interface BVI1
    > ip address 192.168.1.2 255.255.255.0
    > ipv6 address abcd:1234:5678::2/64
    > ipv6 enable
    >
    >IPv6 connectivity does however not work with this configuration. The
    >obvious fix is of course to use "bridge 1 route ipv6". But although that
    >command seems to exist(*) my Cisco doesn't accept it. Both IPv4 and IPv6
    >work fine if I assign the IP addresses to "Vlan1".
    >
    >Any ideas how get this setup working?
    >
    > Kind regards
    >
    >(*) http://www.ipv6.wanadoo.fr/BB2/viewtopic.php?t=42&highlight=&sid=490578048f510004da89e1d1120a292e
    >
    AN, Nov 13, 2006
    #2
    1. Advertising

  3. In re the o.p.'s posting:

    IPv6 over wireless IRB doesn't work yet. CSCej50923.

    In re Adil's desire: configure multiple SSIDs/VLANs on the AP1200. Connect the
    AP's LAN interface to a FastEthernet on you ISR which is configured for dot1q
    trunking. Then you can configure the VLANs on the ISR as desired.

    Aaron

    ---

    ~ Hello,
    ~
    ~ I am also working on the same problem but I want to take it a step further.
    ~ Not only do I want to bridge my LAN and wireless into one broadcast domain
    ~ (Vlan) but I want to partition my wireless into more than one ( at least 2)
    ~ wireless vlans so I can set up a guest ssid and keep it logically separate
    ~ from my private ssid. I've been search documentation online and all of it
    ~ that's available online (google) have given information on how to divide the
    ~ wireless domain into separate vlans on a dedicated Access point (ie. Cisco
    ~ Aironet 1200 ) while I'm working with a ISR (Integrated Services Router)
    ~ Cisco device (Cisco 871) which is a router, access point and built-in 4 port
    ~ switch.
    ~
    ~ So in the end, I don't know how to do you're trying to do but I ask that when
    ~ you do find out or if anyone out there knows how please let me know.
    ~
    ~ Thanks,
    ~
    ~ Adil
    ~
    ~ On 10/29/2006 4:05:13 PM, wrote:
    ~ > Hello,
    ~ >
    ~ >I'm trying to configure a Cisco 877W to have big LAN which includes
    ~ >the ethernet ports and the 802.11g interface. As a first I enabled
    ~ >"bridge irb" and assigned VLAN 1 to the bridge:
    ~ >
    ~ >bridge irb
    ~ >[...]
    ~ >interface Vlan1
    ~ > no ip address
    ~ > bridge-group 1
    ~ > bridge-group 1 spanning-disabled
    ~ >[...]
    ~ >interface BVI1
    ~ > ip address 192.168.1.2 255.255.255.0
    ~ >
    ~ >That broke network connectivity to the box completely until I used
    ~ >this command:
    ~ >
    ~ >bridge 1 route ip
    ~ >
    ~ >The next thing I tried was getting IPv6 working:
    ~ >
    ~ >interface BVI1
    ~ > ip address 192.168.1.2 255.255.255.0
    ~ > ipv6 address abcd:1234:5678::2/64
    ~ > ipv6 enable
    ~ >
    ~ >IPv6 connectivity does however not work with this configuration. The
    ~ >obvious fix is of course to use "bridge 1 route ipv6". But although that
    ~ >command seems to exist(*) my Cisco doesn't accept it. Both IPv4 and IPv6
    ~ >work fine if I assign the IP addresses to "Vlan1".
    ~ >
    ~ >Any ideas how get this setup working?
    ~ >
    ~ > Kind regards
    ~ >
    ~ >(*) http://www.ipv6.wanadoo.fr/BB2/viewtopic.php?t=42&highlight=&sid=490578048f510004da89e1d1120a292e
    ~ >
    Aaron Leonard, Nov 13, 2006
    #3
  4. Matthias Scheler

    AN Guest

    On 11/13/2006 5:07:52 PM, Aaron Leonard wrote:
    >In re the o.p.'s posting:
    >
    >IPv6 over wireless IRB doesn't work yet. CSCej50923.
    >
    >In re Adil's desire: configure multiple SSIDs/VLANs on the AP1200. Connect the
    >AP's LAN interface to a FastEthernet on you ISR which is configured for dot1q
    >trunking. Then you can configure the VLANs on the ISR as desired.
    >
    >Aaron
    >
    >---
    >
    >~ Hello,
    >~
    >~ I am also working on the same problem but I want to take it a step further.
    >~ Not only do I want to bridge my LAN and wireless into one broadcast domain
    >~ (Vlan) but I want to partition my wireless into more than one ( at least 2)
    >~ wireless vlans so I can set up a guest ssid and keep it logically separate
    >~ from my private ssid. I've been search documentation online and all of it
    >~ that's available online (google) have given information on how to divide the
    >~ wireless domain into separate vlans on a dedicated Access point (ie. Cisco
    >~ Aironet 1200 ) while I'm working with a ISR (Integrated Services Router)
    >~ Cisco device (Cisco 871) which is a router, access point and built-in 4 port
    >~ switch.
    >~
    >~ So in the end, I don't know how to do you're trying to do but I ask that when
    >~ you do find out or if anyone out there knows how please let me know.
    >~
    >~ Thanks,
    >~
    >~ Adil
    >~
    >~ On 10/29/2006 4:05:13 PM, wrote:
    >~ > Hello,
    >~ >
    >~ >I'm trying to configure a Cisco 877W to have big LAN which includes
    >~ >the ethernet ports and the 802.11g interface. As a first I enabled
    >~ >"bridge irb" and assigned VLAN 1 to the bridge:
    >~ >
    >~ >bridge irb
    >~ >[...]
    >~ >interface Vlan1
    >~ > no ip address
    >~ > bridge-group 1
    >~ > bridge-group 1 spanning-disabled
    >~ >[...]
    >~ >interface BVI1
    >~ > ip address 192.168.1.2 255.255.255.0
    >~ >
    >~ >That broke network connectivity to the box completely until I used
    >~ >this command:
    >~ >
    >~ >bridge 1 route ip
    >~ >
    >~ >The next thing I tried was getting IPv6 working:
    >~ >
    >~ >interface BVI1
    >~ > ip address 192.168.1.2 255.255.255.0
    >~ > ipv6 address abcd:1234:5678::2/64
    >~ > ipv6 enable
    >~ >
    >~ >IPv6 connectivity does however not work with this configuration. The
    >~ >obvious fix is of course to use "bridge 1 route ipv6". But although that
    >~ >command seems to exist(*) my Cisco doesn't accept it. Both IPv4 and IPv6
    >~ >work fine if I assign the IP addresses to "Vlan1".
    >~ >
    >~ >Any ideas how get this setup working?
    >~ >
    >~ > Kind regards
    >~ >
    >~ >(*) http://www.ipv6.wanadoo.fr/BB2/viewtopic.php?t=42&highlight=&sid=490578048f510004da89e1d1120a292e
    >~ >
    >
    >


    I'm not connecting a dedicated AP to my ISR. I want to configure wireless
    VLAN's on the ISR.
    AN, Nov 15, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Eddy Borg

    Bridging Wireless and Ethernet subnets

    Eddy Borg, Oct 25, 2004, in forum: Wireless Networking
    Replies:
    3
    Views:
    5,686
    =?Utf-8?B?RWRkeSBCb3Jn?=
    Nov 16, 2004
  2. Peter
    Replies:
    2
    Views:
    1,020
  3. Matthias Scheler

    Bridging with a Cisco 877W

    Matthias Scheler, Dec 21, 2006, in forum: Cisco
    Replies:
    2
    Views:
    1,310
  4. mbatiri

    LAn and Wlan Bridging

    mbatiri, May 10, 2010, in forum: Wireless Networking
    Replies:
    0
    Views:
    1,195
    mbatiri
    May 10, 2010
  5. mbatiri

    LAn and Wlan Bridging

    mbatiri, May 10, 2010, in forum: Hardware
    Replies:
    1
    Views:
    1,528
    L8ians
    May 11, 2010
Loading...

Share This Page