Bonding two T1s

Discussion in 'Cisco' started by jhud@osceola.org, May 18, 2005.

  1. Guest

    Hi folks,

    We have a situation where we need to bond two T1s to achieve and
    aggregate of 3meg. The routeres are a 3725 and a 1721. Both have
    available serial ports for the operation.

    I've been looking for an example configuration to help me get it set
    up. So far I've found a couple but I don't really understand how it
    works. The examples I've seen seem to indicate that the bonded link
    won't have IP addresses over the WAN link. Is that correct?

    If someone could post a config with some details I'd really appreciate
    it.

    Thanks.

    Jim
     
    , May 18, 2005
    #1
    1. Advertising

  2. Phil Watkins Guest

    PPP multilink

    <> wrote in message
    news:...
    > Hi folks,
    >
    > We have a situation where we need to bond two T1s to achieve and
    > aggregate of 3meg. The routeres are a 3725 and a 1721. Both have
    > available serial ports for the operation.
    >
    > I've been looking for an example configuration to help me get it set
    > up. So far I've found a couple but I don't really understand how it
    > works. The examples I've seen seem to indicate that the bonded link
    > won't have IP addresses over the WAN link. Is that correct?
    >
    > If someone could post a config with some details I'd really appreciate
    > it.
    >
    > Thanks.
    >
    > Jim
    >
     
    Phil Watkins, May 18, 2005
    #2
    1. Advertising

  3. Guest

    Right, I got that part. What I'm trying to figure out is how the
    configuration should be done. Cisco's site shows a couple of
    configurations, but they don't comment them enough for me to be able to
    determine whether or not they're what I need.
     
    , May 18, 2005
    #3
  4. Phil Watkins Guest

    hmmm, I've forgotten how to do it. I'll have a go now and see if I can
    get it working, if I do I'll post my config.

    <> wrote in message
    news:...
    > Right, I got that part. What I'm trying to figure out is how the
    > configuration should be done. Cisco's site shows a couple of
    > configurations, but they don't comment them enough for me to be able to
    > determine whether or not they're what I need.
    >
     
    Phil Watkins, May 18, 2005
    #4
  5. Guest

    Thanks Phil, I appreciate it.

    Jim
     
    , May 18, 2005
    #5
  6. Phil Watkins Guest

    Phil Watkins, May 18, 2005
    #6
  7. Guest

    I don't have too much of a problem with it bridging I suppose. I'm
    more interested in throughput. We have three remote servers there and
    full BUs have become a W/E long nightmare.

    That link is a better example than I'd found so far.

    One odd thing on the example. Notice that there's a ppp multi
    statement on the "shutdown" isdn int? Seems unnecessary.
     
    , May 18, 2005
    #7
  8. Phil Watkins Guest

    i know this is a cop-out, but why did you decided to load balance this way
    rather than through the routing protocol?
     
    Phil Watkins, May 18, 2005
    #8
  9. Guest

    We don't want to load balance, but rather bond them for an improved
    aggregate throughput. As we understand it (and we may be nuts) bonding
    the Ts in this manner will not load balance them but logically combine
    them as a single pipe.
     
    , May 18, 2005
    #9
  10. Guest

    I have found that multilink PPP does load ballance better than a
    routing protocol will, up to about 3 T1's. Maybe I'm an idiot though.

    Here's my config (using VWIC-2MFT-T1 card)

    interface Multilink1
    ip address 192.168.250.a 255.255.255.252
    ppp multilink
    ppp multilink group 1

    interface Serial0/0:0
    no ip address
    encapsulation ppp
    ppp multilink
    ppp multilink group 1

    interface Serial0/1:0
    no ip address
    encapsulation ppp
    ppp multilink
    ppp multilink group 1

    of course with this card you have to configure the controller...

    controller T1 0/0
    framing esf
    crc-threshold 320
    clock source internal
    linecode b8zs
    channel-group 0 timeslots 1-24 speed 64
    !
    controller T1 0/1
    framing esf
    crc-threshold 320
    clock source internal
    linecode b8zs
    channel-group 0 timeslots 1-24 speed 64

    The physical layer config may vary depending on your hardware
    (WIC-1DSU-T1, WIC-1T, etc.).
     
    , May 18, 2005
    #10
  11. Phil Watkins Guest

    thanks for filling me in on the config. I've read similair things about
    throughput being better with PPP. Would be interested to here how much
    better.


    <> wrote in message
    news:...
    >
    > I have found that multilink PPP does load ballance better than a
    > routing protocol will, up to about 3 T1's. Maybe I'm an idiot though.
    >
    > Here's my config (using VWIC-2MFT-T1 card)
    >
    > interface Multilink1
    > ip address 192.168.250.a 255.255.255.252
    > ppp multilink
    > ppp multilink group 1
    >
    > interface Serial0/0:0
    > no ip address
    > encapsulation ppp
    > ppp multilink
    > ppp multilink group 1
    >
    > interface Serial0/1:0
    > no ip address
    > encapsulation ppp
    > ppp multilink
    > ppp multilink group 1
    >
    > of course with this card you have to configure the controller...
    >
    > controller T1 0/0
    > framing esf
    > crc-threshold 320
    > clock source internal
    > linecode b8zs
    > channel-group 0 timeslots 1-24 speed 64
    > !
    > controller T1 0/1
    > framing esf
    > crc-threshold 320
    > clock source internal
    > linecode b8zs
    > channel-group 0 timeslots 1-24 speed 64
    >
    > The physical layer config may vary depending on your hardware
    > (WIC-1DSU-T1, WIC-1T, etc.).
    >
     
    Phil Watkins, May 18, 2005
    #11
  12. Jonathan Guest

    <> wrote in message
    news:...
    > Hi folks,
    >
    > We have a situation where we need to bond two T1s to achieve and
    > aggregate of 3meg. The routeres are a 3725 and a 1721. Both have
    > available serial ports for the operation.
    >
    > I've been looking for an example configuration to help me get it set
    > up. So far I've found a couple but I don't really understand how it
    > works. The examples I've seen seem to indicate that the bonded link
    > won't have IP addresses over the WAN link. Is that correct?
    >
    > If someone could post a config with some details I'd really appreciate
    > it.
    >


    int multilink 1
    ip add 1.1.1.1 255.255.255.0
    encapsulation ppp
    multilink-group 1
    int s0/0
    encapsulation ppp
    multilink-group 1
    int s0/1
    encapsulation ppp
    multilink-group 1




    Jonathan
     
    Jonathan, May 19, 2005
    #12
  13. Guest

    Hi gents,

    Thanks for all the feedback. I think I've got it now.

    Jim
     
    , May 19, 2005
    #13
  14. Guest

    Hi folks,

    Just got back from putting up the link. Went smooth as silk. Again,
    thanks for all the help.

    Jim
     
    , May 20, 2005
    #14
  15. Tomcat66

    Joined:
    Jul 24, 2007
    Messages:
    1
    consider a hardware solution?

    You might want to consider a redundant Internet access appliance that provides WAN link bonding and load balancing with multiple T1 lines. One vendor I'm aware of is Astrocom; I know their appliances work with Cisco firewalls (they even have a white paper on the topic here, tho you'll have to register for it), so they should work with your routers as well.
     
    Tomcat66, Jul 24, 2007
    #15
  16. zsazsa2011

    Joined:
    Feb 9, 2011
    Messages:
    2
    Looks like you had this under control, but I thought I'd post a late reply anyway.

    Just wanted to make you aware that there is a "new" technology out there called broadband bonding that some companies are offering... no big setup hassle; I think you can pretty much plug and play which makes the whole bonding mess easier.

    Just google "broadband bonding" and you should be able to find them.
     
    zsazsa2011, May 9, 2011
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steve Pfister
    Replies:
    1
    Views:
    692
  2. al

    two T1s

    al, Oct 23, 2003, in forum: Cisco
    Replies:
    2
    Views:
    549
    e-dub
    Oct 25, 2003
  3. Bob Wilson
    Replies:
    8
    Views:
    7,003
    smoove
    Aug 3, 2004
  4. Lars L. Christensen

    Bonding SHDSL lines

    Lars L. Christensen, Jul 20, 2004, in forum: Cisco
    Replies:
    0
    Views:
    558
    Lars L. Christensen
    Jul 20, 2004
  5. Chris
    Replies:
    3
    Views:
    568
    Chris
    Jun 14, 2006
Loading...

Share This Page