Bonded DSL with 2611XM

Discussion in 'Cisco' started by ldw, Sep 11, 2006.

  1. ldw

    ldw Guest

    Does anyone have a working config for a Cisco 2611XM in the UK with
    bonded DSL?

    This is as far as I have got and but its isnt working.

    TIA

    interface Multilink1
    ip address negotiated
    load-interval 30
    keepalive 1
    no cdp enable
    ppp multilink
    ppp multilink fragment delay 10
    ppp multilink interleave
    ppp multilink group 1
    !
    interface ATM0/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    protocol ppp Virtual-Template1
    !
    !
    interface FastEthernet0/0
    ip address x.x.x.17 255.255.255.248
    ip access-group 102 in
    duplex auto
    speed auto
    !
    interface ATM0/1
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    protocol ppp Virtual-Template1
    !
    !
    !
    interface Virtual-Template1
    no ip address
    load-interval 30
    keepalive 1
    ppp authentication chap callin
    ppp chap hostname username
    ppp chap password 7 password
    ppp multilink
    ppp multilink group 1
    ppp multilink multiclass
    !
    ip route 0.0.0.0 0.0.0.0 Multilink1
    !
     
    ldw, Sep 11, 2006
    #1
    1. Advertising

  2. "ldw" <> writes:
    >Does anyone have a working config for a Cisco 2611XM in the UK with
    >bonded DSL?


    This is what I did once for a test on a 2800 in the US for MLPPP/bonded DSL.
    NB: the 26xxXM will run out of steam around 10-14Mbps, its not all
    that fast of a router, but I don't know the speed of your lines.

    interface ATM0/1/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/32
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface ATM0/2/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/32
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface ATM0/3/0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/32
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface Dialer0
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation ppp
    load-interval 30
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp pap sent-username password dsltest
    ppp multilink
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
     
    Doug McIntyre, Sep 11, 2006
    #2
    1. Advertising

  3. ldw

    ldw Guest

    Thanks Doug, this is very similiar to my original config, however the
    issue is that both DSL lines come up and show two default routes
    pointing to Dialer0:

    Any ideas welcome!

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    x.0.0.0/29 is subnetted, 1 subnets
    C x.12.120.16 is directly connected, FastEthernet0/0
    y.y.108.0/32 is subnetted, 1 subnets
    C y.y.108.227 is directly connected, Dialer0
    z.z.5.0/32 is subnetted, 1 subnets
    C z.z.5.10 is directly connected, Dialer0
    S* 0.0.0.0/0 is directly connected, Dialer0

    I have to physically unplug one of the DSL lines to have connectivity
    to the web. If I connect it up again and run debug ppp negotiation, I
    get:

    dslbonded#
    Sep 12 08:26:05.885: %LINK-3-UPDOWN: Interface ATM0/0, changed state to
    up
    Sep 12 08:26:06.886: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    ATM0/0, chp
    Sep 12 08:26:13.201: Vi3 PPP: Phase is DOWN, Setup
    Sep 12 08:26:13.205: %DIALER-6-BIND: Interface Vi3 bound to profile Di0
    Sep 12 08:26:13.209: %LINK-3-UPDOWN: Interface Virtual-Access3, changed
    state tp
    Sep 12 08:26:13.209: Vi3 PPP: Using dialer call direction
    Sep 12 08:26:13.213: Vi3 PPP: Treating connection as a callout
    Sep 12 08:26:13.213: Vi3 PPP: Session handle[41000005] Session id[3]
    Sep 12 08:26:13.213: Vi3 PPP: Phase is ESTABLISHING, Active Open
    Sep 12 08:26:13.213: Vi3 PPP: No remote authentication for call-out
    Sep 12 08:26:13.213: Vi3 LCP: O CONFREQ [Closed] id 1 len 37
    Sep 12 08:26:13.213: Vi3 LCP: MagicNumber 0x0AD036D4
    (0x05060AD036D4)
    Sep 12 08:26:13.213: Vi3 LCP: MRRU 1524 (0x110405F4)
    Sep 12 08:26:13.213: Vi3 LCP: EndpointDisc 1 username
    Sep 12 08:26:13.217: Vi3 LCP: (0x131701676F746164736C2E636F2E756B)
    Sep 12 08:26:13.217: Vi3 LCP: (0x2F6C776562626F)
    Sep 12 08:26:13.481: Vi3 LCP: I CONFREQ [REQsent] id 1 len 15
    Sep 12 08:26:13.485: Vi3 LCP: AuthProto CHAP (0x0305C22305)
    Sep 12 08:26:13.485: Vi3 LCP: MagicNumber 0xBFD777A9
    (0x0506BFD777A9)
    Sep 12 08:26:13.485: Vi3 LCP: O CONFACK [REQsent] id 1 len 15
    Sep 12 08:26:13.485: Vi3 LCP: AuthProto CHAP (0x0305C22305)
    Sep 12 08:26:13.485: Vi3 LCP: MagicNumber 0xBFD777A9
    (0x0506BFD777A9)
    Sep 12 08:26:15.224: Vi3 LCP: Timeout: State ACKsent
    Sep 12 08:26:15.224: Vi3 LCP: O CONFREQ [ACKsent] id 2 len 37
    Sep 12 08:26:15.224: Vi3 LCP: MagicNumber 0x0AD036D4
    (0x05060AD036D4)
    Sep 12 08:26:15.224: Vi3 LCP: MRRU 1524 (0x110405F4)
    Sep 12 08:26:15.224: Vi3 LCP: EndpointDisc 1 username
    Sep 12 08:26:15.224: Vi3 LCP: (0x131701676F746164736C2E636F2E756B)
    Sep 12 08:26:15.224: Vi3 LCP: (0x2F6C776562626F)
    Sep 12 08:26:15.240: Vi3 LCP: I CONFREJ [ACKsent] id 2 len 8
    Sep 12 08:26:15.240: Vi3 LCP: MRRU 1524 (0x110405F4)
    Sep 12 08:26:15.240: Vi3 LCP: O CONFREQ [ACKsent] id 3 len 33
    Sep 12 08:26:15.240: Vi3 LCP: MagicNumber 0x0AD036D4
    (0x05060AD036D4)
    Sep 12 08:26:15.244: Vi3 LCP: EndpointDisc 1 username
    Sep 12 08:26:15.244: Vi3 LCP: (0x131701676F746164736C2E636F2E756B)
    Sep 12 08:26:15.244: Vi3 LCP: (0x2F6C776562626F)
    Sep 12 08:26:15.260: Vi3 LCP: I CONFACK [ACKsent] id 3 len 33
    Sep 12 08:26:15.260: Vi3 LCP: MagicNumber 0x0AD036D4
    (0x05060AD036D4)
    Sep 12 08:26:15.260: Vi3 LCP: EndpointDisc 1 username
    Sep 12 08:26:15.260: Vi3 LCP: (0x131701676F746164736C2E636F2E756B)
    Sep 12 08:26:15.260: Vi3 LCP: (0x2F6C776562626F)
    Sep 12 08:26:15.260: Vi3 LCP: State is Open
    Sep 12 08:26:15.264: Vi3 PPP: Phase is AUTHENTICATING, by the peer
    Sep 12 08:26:15.264: Vi3 CHAP: I CHALLENGE id 1 len 39 from
    "ESR3.Miltonkeynes3"
    Sep 12 08:26:15.268: Vi3 CHAP: Using hostname from interface CHAP
    Sep 12 08:26:15.268: Vi3 CHAP: Using password from interface CHAP
    Sep 12 08:26:15.268: Vi3 CHAP: O RESPONSE id 1 len 47 from "username"
    Sep 12 08:26:15.416: Vi3 LCP: I CONFREQ [Open] id 255 len 19
    Sep 12 08:26:15.416: Vi3 LCP: MRU 32725 (0x01047FD5)
    Sep 12 08:26:15.420: Vi3 LCP: AuthProto CHAP (0x0305C22305)
    Sep 12 08:26:15.420: Vi3 LCP: MagicNumber 0x09581F9D
    (0x050609581F9D)
    Sep 12 08:26:15.420: Vi3 PPP: Sending Acct Event[Reneg] id[5]
    Sep 12 08:26:15.420: Vi3 PPP: Phase is TERMINATING
    Sep 12 08:26:15.420: Vi3 PPP: No remote authentication for call-out
    Sep 12 08:26:15.424: Vi3 PPP: Phase is ESTABLISHING
    Sep 12 08:26:15.424: Vi3 LCP: O CONFREQ [Open] id 4 len 37
    Sep 12 08:26:15.424: Vi3 LCP: MagicNumber 0x0AD03F74
    (0x05060AD03F74)
    Sep 12 08:26:15.424: Vi3 LCP: MRRU 1524 (0x110405F4)
    Sep 12 08:26:15.424: Vi3 LCP: EndpointDisc 1 username
    Sep 12 08:26:15.424: Vi3 LCP: (0x131701676F746164736C2E636F2E756B)
    Sep 12 08:26:15.424: Vi3 LCP: (0x2F6C776562626F)
    Sep 12 08:26:15.428: Vi3 LCP: O CONFACK [Open] id 255 len 19
    Sep 12 08:26:15.428: Vi3 LCP: MRU 32725 (0x01047FD5)
    Sep 12 08:26:15.428: Vi3 LCP: AuthProto CHAP (0x0305C22305)
    Sep 12 08:26:15.428: Vi3 LCP: MagicNumber 0x09581F9D
    (0x050609581F9D)
    Sep 12 08:26:15.452: Vi3 LCP: I CONFREJ [ACKsent] id 4 len 31
    Sep 12 08:26:15.452: Vi3 LCP: MRRU 1524 (0x110405F4)
    Sep 12 08:26:15.452: Vi3 LCP: EndpointDisc 1 username
    Sep 12 08:26:15.452: Vi3 LCP: (0x131701676F746164736C2E636F2E756B)
    Sep 12 08:26:15.456: Vi3 LCP: (0x2F6C776562626F)
    Sep 12 08:26:15.456: Vi3 LCP: O CONFREQ [ACKsent] id 5 len 10
    Sep 12 08:26:15.456: Vi3 LCP: MagicNumber 0x0AD03F74
    (0x05060AD03F74)
    Sep 12 08:26:15.476: Vi3 LCP: I CONFACK [ACKsent] id 5 len 10
    Sep 12 08:26:15.476: Vi3 LCP: MagicNumber 0x0AD03F74
    (0x05060AD03F74)
    Sep 12 08:26:15.476: Vi3 LCP: State is Open
    Sep 12 08:26:15.480: Vi3 PPP: Phase is AUTHENTICATING, by the peer
    Sep 12 08:26:15.480: Vi3 CHAP: I CHALLENGE id 1 len 40 from "standby"
    Sep 12 08:26:15.484: Vi3 CHAP: Using hostname from interface CHAP
    Sep 12 08:26:15.484: Vi3 CHAP: Using password from interface CHAP
    Sep 12 08:26:15.484: Vi3 CHAP: O RESPONSE id 1 len 47 from "username"
    Sep 12 08:26:15.709: Vi3 CHAP: I SUCCESS id 1 len 4
    Sep 12 08:26:15.709: Vi3 PPP: Phase is FORWARDING, Attempting Forward
    Sep 12 08:26:15.709: Vi3 PPP: Phase is ESTABLISHING, Finish LCP
    Sep 12 08:26:15.709: Vi3 PPP: Phase is UP
    Sep 12 08:26:15.713: Vi3 IPCP: O CONFREQ [Closed] id 1 len 10
    Sep 12 08:26:15.713: Vi3 IPCP: Address 0.0.0.0 (0x030600000000)
    Sep 12 08:26:15.713: Vi3 PPP: Process pending ncp packets
    Sep 12 08:26:15.733: Vi3 IPCP: I CONFNAK [REQsent] id 1 len 10
    Sep 12 08:26:15.733: Vi3 IPCP: Address x.x.108.227 (0x0306D5D06CE3)

    Doug McIntyre wrote:

    > "ldw" <> writes:
    > >Does anyone have a working config for a Cisco 2611XM in the UK with
    > >bonded DSL?

    >
    > This is what I did once for a test on a 2800 in the US for MLPPP/bonded DSL.
    > NB: the 26xxXM will run out of steam around 10-14Mbps, its not all
    > that fast of a router, but I don't know the speed of your lines.
    >
    > interface ATM0/1/0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 0/32
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > !
    > interface ATM0/2/0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 0/32
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > !
    > interface ATM0/3/0
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 0/32
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > !
    > interface Dialer0
    > ip address negotiated
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > encapsulation ppp
    > load-interval 30
    > dialer pool 1
    > dialer-group 1
    > ppp authentication pap callin
    > ppp pap sent-username password dsltest
    > ppp multilink
    > !
    > ip route 0.0.0.0 0.0.0.0 Dialer0
    > !
     
    ldw, Sep 12, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Captain
    Replies:
    4
    Views:
    7,048
    mushroom_mover
    Nov 4, 2008
  2. Ken Bettis

    Cisco 6130 with Bonded T1s

    Ken Bettis, Jul 6, 2004, in forum: Cisco
    Replies:
    1
    Views:
    689
    Doug McIntyre
    Jul 7, 2004
  3. Joe Matuscak

    Bonded T1s from different carriers?

    Joe Matuscak, Jan 3, 2006, in forum: Cisco
    Replies:
    0
    Views:
    519
    Joe Matuscak
    Jan 3, 2006
  4. Michael Pelletier

    Has anyone any info on "bonded Sender" DNSBL

    Michael Pelletier, Apr 21, 2005, in forum: Computer Security
    Replies:
    1
    Views:
    431
    Ashley Pride
    Apr 21, 2005
  5. Replies:
    1
    Views:
    1,562
Loading...

Share This Page