BGP won't work over GRE without multihop !

Discussion in 'Cisco' started by b, Nov 7, 2003.

  1. b

    b Guest

    Here is the lab setup :

    [Cisco] <-> [Linux Box with IP forwarding enabled] <-> [Cisco]

    These are the problems I've come accoss :
    - BGP still won't work without an ebgp-multihop config. According to
    the internet searches I've done, this should not be the case ?!?
    - No matter if I put the linux box in single user mode (i.e. eth
    interfaces still "on") or if I turn it off completely, the Ciscos
    don't sem to loose their BGP session ?!?

    I started from a clean router, so I did an "erase nvram" before
    starting and only put in the minimum of commands to get things working
    thereafter.

    =========ROUTER A ============
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    !
    interface Tunnel0
    ip address 10.9.8.7 255.255.255.0
    tunnel source FastEthernet0/1
    tunnel destination 192.168.124.29
    tunnel checksum
    tunnel method gre ip
    !
    interface FastEthernet0/0
    ip address 192.168.199.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.123.28 255.255.255.0
    duplex auto
    speed auto
    !
    router bgp 64525
    no synchronisation
    bgp log-neighbor-changes
    network 192.168.199.0
    neighbor 10.11.12.13 remote-as 64625
    neighbor 10.11.12.13 ebgp-multihop 2
    no auto-summary
    !
    ip classless
    ip route 10.11.12 255.255.255.0 Tunnel0
    ip route 192.168.124.0 255.255.255.0 192.168.123.30
    ip http server
    ip pim bidir-enable
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end
    ====================================
    =========ROUTER B ============
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    !
    interface Tunnel0
    ip address 10.11.12.13 255.255.255.0
    tunnel source FastEthernet0/1
    tunnel destination 192.168.123.28
    tunnel checksum
    tunnel method gre ip
    !
    interface FastEthernet0/0
    ip address 192.168.198.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.124.29 255.255.255.0
    duplex auto
    speed auto
    !
    router bgp 64525
    no synchronisation
    bgp log-neighbor-changes
    network 192.168.198.0
    neighbor 10.9.8.7 remote-as 64525
    neighbor 10.9.8.7 ebgp-multihop 2
    no auto-summary
    !
    ip classless
    ip route 10.9.8.0 255.255.255.0 Tunnel0
    ip route 192.168.123.0 255.255.255.0 192.168.124.254
    ip http server
    ip pim bidir-enable
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    !
    end
    ====================================
     
    b, Nov 7, 2003
    #1
    1. Advertising

  2. b

    Ivan Ostres Guest

    "b" <> wrote in message
    news:...
    > Here is the lab setup :
    >
    > [Cisco] <-> [Linux Box with IP forwarding enabled] <-> [Cisco]
    >
    > These are the problems I've come accoss :
    > - BGP still won't work without an ebgp-multihop config. According to
    > the internet searches I've done, this should not be the case ?!?


    And how would it work without ebgp-multihop? You have one hop between ciscos
    (linux with forwarding enabled acts as a router)....

    Ivan
     
    Ivan Ostres, Nov 7, 2003
    #2
    1. Advertising

  3. b

    b Guest

    And what does an IP GRP tunnel do then Ivan ? ;-)

    Ben

    "Ivan Ostres" <> wrote
    > And how would it work without ebgp-multihop? You have one hop between ciscos
    > (linux with forwarding enabled acts as a router)....
    >
    > Ivan
     
    b, Nov 7, 2003
    #3
  4. b

    Ivan Ostres Guest

    "b" <> wrote in message
    news:...
    > And what does an IP GRP tunnel do then Ivan ? ;-)
    >


    Yeah, I know, it looked stupid even to me :). Try to ping from one bgp
    endpoint to other and debug packet to see difference between starting and
    ending TTL in icmp packets...

    Ivan
     
    Ivan Ostres, Nov 10, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bitoy
    Replies:
    1
    Views:
    1,078
    Ivan Ostres
    Jun 7, 2004
  2. papi
    Replies:
    4
    Views:
    2,270
    theapplebee
    Sep 8, 2009
  3. Kris Amy

    VPDN multihop 12.3

    Kris Amy, Apr 12, 2005, in forum: Cisco
    Replies:
    0
    Views:
    489
    Kris Amy
    Apr 12, 2005
  4. Theo Markettos

    VOIP over VPN over TCP over WAP over 3G

    Theo Markettos, Feb 3, 2008, in forum: UK VOIP
    Replies:
    2
    Views:
    1,028
    Theo Markettos
    Feb 14, 2008
  5. mmark751969

    dual honed ebgp multihop

    mmark751969, Mar 31, 2008, in forum: Cisco
    Replies:
    1
    Views:
    1,420
Loading...

Share This Page