BGP multihoming single site, two isp

Discussion in 'Cisco' started by jan.rockstedt@gmail.com, Apr 4, 2007.

  1. Guest

    Hi all,

    We are soon starting up bgp and multihoming.
    Two ISPs and we have one site.
    We have already PI number and ASN assign to us.
    A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
    is order.
    No full routing table.

    Any sugestion for a config?

    Regards Jan Rockstedt
     
    , Apr 4, 2007
    #1
    1. Advertising

  2. "" <> wrote in
    news::

    > Hi all,
    >
    > We are soon starting up bgp and multihoming.
    > Two ISPs and we have one site.
    > We have already PI number and ASN assign to us.
    > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
    > is order.
    > No full routing table.
    >
    > Any sugestion for a config?
    >
    > Regards Jan Rockstedt
    >
    >


    Hi Jan

    You could do it two ways:

    1. Use one ISP as primary and one as secondary
    2. Use both ISPs and recieve default routes from both ISP along with
    their "own" IPs

    For both ISPs you setup standard BGP settings as described in the
    documentation from Cisco (take a look at CCO and do a search on BGP).

    With option 1 you tag the inbound routes from both ISPs, setting the
    local-preference for 200 on the primary routes and leave the secondary
    ISP with default local-preference (that'll be 100). When you advertise
    your own routes, do a prepend to the routes you advertise to the
    secondary ISP.


    With option 2 you simply accept any routes advertised by the ISP and
    advertise your own routes with default settings.


    If you need further information / help, please respond to this group.

    Cheers,
    Lars Christensen
     
    Lars L. Christensen, Apr 4, 2007
    #2
    1. Advertising

  3. Guest

    On 4 Apr, 18:52, "Lars L. Christensen" <>
    wrote:
    > "" <> wrote innews::
    >
    > > Hi all,

    >
    > > We are soon starting up bgp and multihoming.
    > > Two ISPs and we have one site.
    > > We have already PI number and ASN assign to us.
    > > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
    > > is order.
    > > No full routing table.

    >
    > > Any sugestion for a config?

    >
    > > Regards Jan Rockstedt

    >
    > Hi Jan
    >
    > You could do it two ways:
    >
    > 1. Use one ISP as primary and one as secondary
    > 2. Use both ISPs and recieve default routes from both ISP along with
    > their "own" IPs
    >
    > For both ISPs you setup standard BGP settings as described in the
    > documentation from Cisco (take a look at CCO and do a search on BGP).
    >
    > With option 1 you tag the inbound routes from both ISPs, setting the
    > local-preference for 200 on the primary routes and leave the secondary
    > ISP with default local-preference (that'll be 100). When you advertise
    > your own routes, do a prepend to the routes you advertise to the
    > secondary ISP.
    >
    > With option 2 you simply accept any routes advertised by the ISP and
    > advertise your own routes with default settings.
    >
    > If you need further information / help, please respond to this group.


    Thanks, that is interesting to me too.

    Is it possible to find out how many AS numbers to
    "prepend" to effectively guarantee that one path
    will become primary for all ISPs?

    I have made a stab at 4 relating to 2 connections within a single
    city.
    How many would be needed to guarantee this globally?

    Is there a limit to the number of ASs in a path and
    if so what is a reasonable number to limit our prepends
    to?

    Thanks.
     
    , Apr 4, 2007
    #3
  4. Guest

    On 4 Apr, 19:52, "Lars L. Christensen" <>
    wrote:
    > "" <> wrote innews::
    >
    > > Hi all,

    >
    > > We are soon starting up bgp and multihoming.
    > > Two ISPs and we have one site.
    > > We have already PI number and ASN assign to us.
    > > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
    > > is order.
    > > No full routing table.

    >
    > > Any sugestion for a config?

    >
    > > Regards Jan Rockstedt

    >
    > Hi Jan
    >
    > You could do it two ways:
    >
    > 1. Use one ISP as primary and one as secondary
    > 2. Use both ISPs and recieve default routes from both ISP along with
    > their "own" IPs
    >
    > For both ISPs you setup standard BGP settings as described in the
    > documentation from Cisco (take a look at CCO and do a search on BGP).
    >
    > With option 1 you tag the inbound routes from both ISPs, setting the
    > local-preference for 200 on the primary routes and leave the secondary
    > ISP with default local-preference (that'll be 100). When you advertise
    > your own routes, do a prepend to the routes you advertise to the
    > secondary ISP.
    >
    > With option 2 you simply accept any routes advertised by the ISP and
    > advertise your own routes with default settings.
    >
    > If you need further information / help, please respond to this group.
    >
    > Cheers,
    > Lars Christensen


    Hi Lars,

    Thanks for your respond.

    I have found so many doc on the google.
    Many are old quit .....

    Our primary isp are the link 50 Mbit and our second isp we have a 10
    Mbit.
    So two default routes, one with static 0.0.0.0/0.0.0.0 with default
    100 to the 50 Mbit and one with 0.0.0.0/0.0.0.0 with 200 to the 10
    Mbit
    Redistribute static to bgp?

    router bgp our-ASN
    network 1.0.0.0
    network 2.0.0.0

    neighbor 10.10.10.10 remote-as ISP1-ASN
    neighbor 10.10.10.10 route-map localonly out
    neighbor 20.20.20.20 remote-as IPS2-ASN
    neighbor 20.20.20.20 route-map localonly out

    //Jan
     
    , Apr 5, 2007
    #4
  5. wrote:

    > On 4 Apr, 19:52, "Lars L. Christensen" <>
    > wrote:
    >> "" <> wrote
    >> innews::
    >>
    >> > Hi all,

    >>
    >> > We are soon starting up bgp and multihoming.
    >> > Two ISPs and we have one site.
    >> > We have already PI number and ASN assign to us.
    >> > A Cisco 3825 with 3 ethernet interface with IOS advanced feature pack
    >> > is order.
    >> > No full routing table.

    >>
    >> > Any sugestion for a config?

    >>
    >> > Regards Jan Rockstedt

    >>
    >> Hi Jan
    >>
    >> You could do it two ways:
    >>
    >> 1. Use one ISP as primary and one as secondary
    >> 2. Use both ISPs and recieve default routes from both ISP along with
    >> their "own" IPs
    >>
    >> For both ISPs you setup standard BGP settings as described in the
    >> documentation from Cisco (take a look at CCO and do a search on BGP).
    >>
    >> With option 1 you tag the inbound routes from both ISPs, setting the
    >> local-preference for 200 on the primary routes and leave the secondary
    >> ISP with default local-preference (that'll be 100). When you advertise
    >> your own routes, do a prepend to the routes you advertise to the
    >> secondary ISP.
    >>
    >> With option 2 you simply accept any routes advertised by the ISP and
    >> advertise your own routes with default settings.
    >>
    >> If you need further information / help, please respond to this group.
    >>
    >> Cheers,
    >> Lars Christensen

    >
    > Hi Lars,
    >
    > Thanks for your respond.
    >
    > I have found so many doc on the google.
    > Many are old quit .....
    >
    > Our primary isp are the link 50 Mbit and our second isp we have a 10
    > Mbit.
    > So two default routes, one with static 0.0.0.0/0.0.0.0 with default
    > 100 to the 50 Mbit and one with 0.0.0.0/0.0.0.0 with 200 to the 10
    > Mbit
    > Redistribute static to bgp?
    >
    > router bgp our-ASN
    > network 1.0.0.0
    > network 2.0.0.0
    >
    > neighbor 10.10.10.10 remote-as ISP1-ASN
    > neighbor 10.10.10.10 route-map localonly out
    > neighbor 20.20.20.20 remote-as IPS2-ASN
    > neighbor 20.20.20.20 route-map localonly out
    >
    > //Jan


    A few comments...

    Don't worry about the age of the docs on the web! Not much has changed with
    BGP since version 4 was released last century. If you can track down a copy
    of my book, read the chapter on connecting to an ISP, it still applies.

    As for your proposal, I do not recommend it if your goal is to minimize
    potential for black holes. Rather than using static default routes, have
    your ISPs advertise a default route to you (that way, you only get a
    default route if your link to the ISP is up). There are even better ways to
    protect against problems in your ISP or upstream, but they take more
    effort, as does setting up reasonable load balancing.

    Good luck and have fun!
    --
    Vincent C Jones, Consultant Expert advice and a helping hand
    Networking Unlimited, Inc. for those who want to manage and
    Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    http://www.networkingunlimited.com
     
    Vincent C Jones, Apr 10, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Christian Lox
    Replies:
    4
    Views:
    1,468
    Klaus Thielking-Riechert
    Jul 4, 2004
  2. papi
    Replies:
    4
    Views:
    2,224
    theapplebee
    Sep 8, 2009
  3. papi
    Replies:
    2
    Views:
    1,272
  4. Replies:
    5
    Views:
    7,743
    Vincent C Jones
    Jun 16, 2006
  5. Sinan

    Multihoming with two ISP's

    Sinan, Oct 11, 2007, in forum: Cisco
    Replies:
    0
    Views:
    516
    Sinan
    Oct 11, 2007
Loading...

Share This Page