BGP: Applying map to find origin - help

Discussion in 'Cisco' started by Eli, Sep 8, 2004.

  1. Eli

    Eli Guest

    RTR-A is a foreign (external) router, feeding BGP routes into my
    RTR-B in the DMZ. To further feed those routes into my internal
    network, internal RTR-C maintains a BGP neighbourhood with RTR-B
    through a firewall. Thus my topology is as follows:

    RTR-A (as 65520) --> RTR-B (as 65521) --> FW1 --> RTR-C (as 1)

    When a DEBUG IP BGP is activated in RTR-B, the message " BGP: Applying
    map to find origin " is sent every minute. Is this a point for
    concern?

    The Network numbers whose origin is referred to are defined in RTR-B
    as follows:

    interface Loopback4
    ip address 4.4.4.1 255.255.255.255
    !
    interface Loopback5
    ip address 5.5.5.1 255.255.255.255
    !
    ip route 10.235.0.0 255.255.0.0 Null0

    Here are the BGP configurations and a full bgp debug output:

    RTC-B:
    -----
    router bgp 65521
    no synchronization
    bgp log-neighbor-changes
    network 4.4.4.1 mask 255.255.255.255
    network 5.5.5.1 mask 255.255.255.255
    network 10.235.0.0 mask 255.255.0.0
    network 192.168.2.16 mask 255.255.255.240
    neighbor RTR-A remote-as 65520
    neighbor RTR-C remote-as 1
    neighbor RTR-C ebgp-multihop 255

    router bgp 1
    bgp log-neighbor-changes
    neighbor RTR-B remote-as 65521
    neighbor RTR-B ebgp-multihop 255
    neighbor RTR-B update-source Loopback0
    !



    Cyber-J#
    Sep 8 09:34:10: BGP: RTR-A sending KEEPALIVE (io)
    Sep 8 09:34:12: BGP: RTR-A received KEEPALIVE, length (excl. header)
    0
    Sep 8 09:34:17: BGP: Import timer expired. Walking from 1 to 1
    Sep 8 09:34:32: BGP: Performing BGP general scanning
    Sep 8 09:34:32: BGP(0): scanning IPv4 Unicast routing tables
    Sep 8 09:34:32: BGP: Applying map to find origin for 4.4.4.1/32
    Sep 8 09:34:32: BGP: Applying map to find origin for 5.5.5.1/32
    Sep 8 09:34:32: BGP: Applying map to find origin for 10.235.0.0/16
    Sep 8 09:34:32: BGP: Applying map to find origin for 192.168.2.16/28
    Sep 8 09:34:32: BGP(IPv4 Unicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:34:32: BGP(1): scanning IPv6 Unicast routing tables
    Sep 8 09:34:32: BGP(IPv6 Unicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:34:32: BGP(2): scanning VPNv4 Unicast routing tables
    Sep 8 09:34:32: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:34:32: BGP(3): scanning IPv4 Multicast routing tables
    Sep 8 09:34:32: BGP(IPv4 Multicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:34:43: BGP: RTR-C received KEEPALIVE, length (excl. header)
    0
    Sep 8 09:34:45: BGP: RTR-C sending KEEPALIVE (io)
    Sep 8 09:34:47: BGP: Import timer expired. Walking from 1 to 1
    Sep 8 09:35:02: BGP: Import timer expired. Walking from 1 to 1
    Sep 8 09:35:10: BGP: RTR-A sending KEEPALIVE (io)
    Sep 8 09:35:12: BGP: RTR-A received KEEPALIVE, length (excl. header)
    0
    Sep 8 09:35:17: BGP: Import timer expired. Walking from 1 to 1
    Sep 8 09:35:32: BGP: Performing BGP general scanning
    Sep 8 09:35:32: BGP(0): scanning IPv4 Unicast routing tables
    Sep 8 09:35:32: BGP: Applying map to find origin for 4.4.4.1/32
    Sep 8 09:35:32: BGP: Applying map to find origin for 5.5.5.1/32
    Sep 8 09:35:32: BGP: Applying map to find origin for 10.235.0.0/16
    Sep 8 09:35:32: BGP: Applying map to find origin for 192.168.2.16/28
    Sep 8 09:35:32: BGP(IPv4 Unicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:35:32: BGP(1): scanning IPv6 Unicast routing tables
    Sep 8 09:35:32: BGP(IPv6 Unicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:35:32: BGP(2): scanning VPNv4 Unicast routing tables
    Sep 8 09:35:32: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning
    for general scan
    Sep 8 09:35:32: BGP(3): scanning IPv4 Multicast routing tables
    Sep 8 09:35:32: BGP(IPv4 Multicast): Performing BGP Nexthop scanning
    for general scan
    All possible debugging has been turned off
     
    Eli, Sep 8, 2004
    #1
    1. Advertising

  2. Eli

    JNCIP#0136 Guest

    Re: Applying map to find origin - help

    Hello,
    You redistributed 4.4.4.1/32, 5.5.5.1/32, 10.235.0.0/16 and 192.168.2.16/28
    into BGP and BGP "daemon" needs to "define"/"construct" an ORIGIN attribute
    for these routes before sending (ORIGIN is mandatory attribute so it must be
    "attached" to BGP route). The reason You are seeing it every minute is due
    to well-known BGP scanner process waking up once a minute.
    In a short: these messages are harmless unless the debug is permanently on
    which is bad for CPU utilization.
    HTH,
    Cheers
    Alex

    "Eli" <> wrote in message
    news:...
    > RTR-A is a foreign (external) router, feeding BGP routes into my
    > RTR-B in the DMZ. To further feed those routes into my internal
    > network, internal RTR-C maintains a BGP neighbourhood with RTR-B
    > through a firewall. Thus my topology is as follows:
    >
    > RTR-A (as 65520) --> RTR-B (as 65521) --> FW1 --> RTR-C (as 1)
    >
    > When a DEBUG IP BGP is activated in RTR-B, the message " BGP: Applying
    > map to find origin " is sent every minute. Is this a point for
    > concern?
    >
    > The Network numbers whose origin is referred to are defined in RTR-B
    > as follows:
    >
    > interface Loopback4
    > ip address 4.4.4.1 255.255.255.255
    > !
    > interface Loopback5
    > ip address 5.5.5.1 255.255.255.255
    > !
    > ip route 10.235.0.0 255.255.0.0 Null0
    >
    > Here are the BGP configurations and a full bgp debug output:
    >
    > RTC-B:
    > -----
    > router bgp 65521
    > no synchronization
    > bgp log-neighbor-changes
    > network 4.4.4.1 mask 255.255.255.255
    > network 5.5.5.1 mask 255.255.255.255
    > network 10.235.0.0 mask 255.255.0.0
    > network 192.168.2.16 mask 255.255.255.240
    > neighbor RTR-A remote-as 65520
    > neighbor RTR-C remote-as 1
    > neighbor RTR-C ebgp-multihop 255
    >
    > router bgp 1
    > bgp log-neighbor-changes
    > neighbor RTR-B remote-as 65521
    > neighbor RTR-B ebgp-multihop 255
    > neighbor RTR-B update-source Loopback0
    > !
    >
    >
    >
    > Cyber-J#
    > Sep 8 09:34:10: BGP: RTR-A sending KEEPALIVE (io)
    > Sep 8 09:34:12: BGP: RTR-A received KEEPALIVE, length (excl. header)
    > 0
    > Sep 8 09:34:17: BGP: Import timer expired. Walking from 1 to 1
    > Sep 8 09:34:32: BGP: Performing BGP general scanning
    > Sep 8 09:34:32: BGP(0): scanning IPv4 Unicast routing tables
    > Sep 8 09:34:32: BGP: Applying map to find origin for 4.4.4.1/32
    > Sep 8 09:34:32: BGP: Applying map to find origin for 5.5.5.1/32
    > Sep 8 09:34:32: BGP: Applying map to find origin for 10.235.0.0/16
    > Sep 8 09:34:32: BGP: Applying map to find origin for 192.168.2.16/28
    > Sep 8 09:34:32: BGP(IPv4 Unicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:34:32: BGP(1): scanning IPv6 Unicast routing tables
    > Sep 8 09:34:32: BGP(IPv6 Unicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:34:32: BGP(2): scanning VPNv4 Unicast routing tables
    > Sep 8 09:34:32: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:34:32: BGP(3): scanning IPv4 Multicast routing tables
    > Sep 8 09:34:32: BGP(IPv4 Multicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:34:43: BGP: RTR-C received KEEPALIVE, length (excl. header)
    > 0
    > Sep 8 09:34:45: BGP: RTR-C sending KEEPALIVE (io)
    > Sep 8 09:34:47: BGP: Import timer expired. Walking from 1 to 1
    > Sep 8 09:35:02: BGP: Import timer expired. Walking from 1 to 1
    > Sep 8 09:35:10: BGP: RTR-A sending KEEPALIVE (io)
    > Sep 8 09:35:12: BGP: RTR-A received KEEPALIVE, length (excl. header)
    > 0
    > Sep 8 09:35:17: BGP: Import timer expired. Walking from 1 to 1
    > Sep 8 09:35:32: BGP: Performing BGP general scanning
    > Sep 8 09:35:32: BGP(0): scanning IPv4 Unicast routing tables
    > Sep 8 09:35:32: BGP: Applying map to find origin for 4.4.4.1/32
    > Sep 8 09:35:32: BGP: Applying map to find origin for 5.5.5.1/32
    > Sep 8 09:35:32: BGP: Applying map to find origin for 10.235.0.0/16
    > Sep 8 09:35:32: BGP: Applying map to find origin for 192.168.2.16/28
    > Sep 8 09:35:32: BGP(IPv4 Unicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:35:32: BGP(1): scanning IPv6 Unicast routing tables
    > Sep 8 09:35:32: BGP(IPv6 Unicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:35:32: BGP(2): scanning VPNv4 Unicast routing tables
    > Sep 8 09:35:32: BGP(VPNv4 Unicast): Performing BGP Nexthop scanning
    > for general scan
    > Sep 8 09:35:32: BGP(3): scanning IPv4 Multicast routing tables
    > Sep 8 09:35:32: BGP(IPv4 Multicast): Performing BGP Nexthop scanning
    > for general scan
    > All possible debugging has been turned off
     
    JNCIP#0136, Sep 9, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Daniel Prince
    Replies:
    6
    Views:
    659
    Daniel Prince
    Dec 11, 2004
  2. jmarkotic

    route with EGP origin in BGP table

    jmarkotic, Dec 30, 2003, in forum: Cisco
    Replies:
    5
    Views:
    1,326
    Barry Margolin
    Jan 1, 2004
  3. slumpy
    Replies:
    2
    Views:
    557
    slumpy
    Aug 21, 2003
  4. DVD Verdict
    Replies:
    2
    Views:
    449
    ML-78
    Aug 23, 2003
  5. Geoffrey Sinclair

    Policy map using policy map

    Geoffrey Sinclair, Jul 27, 2009, in forum: Cisco
    Replies:
    1
    Views:
    562
    bod43
    Jul 27, 2009
Loading...

Share This Page