Basic Routing question

Discussion in 'Cisco' started by coffin@isd.net, Dec 5, 2004.

  1. Guest

    I have 2 configs here

    RouterA

    Building configuration...

    Current configuration : 568 bytes
    !
    version 12.2
    service config
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname routerA
    !
    !
    ip subnet-zero
    !
    !
    !
    !
    interface FastEthernet0
    ip address 192.168.1.252 255.255.255.0
    speed auto
    !
    interface Serial0
    ip address 10.53.1.1 255.255.255.252
    encapsulation ppp
    !
    router eigrp 2575
    redistribute static
    network 10.0.0.0
    auto-summary
    no eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.254
    no ip http server
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    no scheduler allocate
    end

    This network has 192.168.1.0 lan behind the ethernet port and a
    gateway (PIX) of 192.168.1.254

    Now for the next config:
    RouterB

    Building configuration...

    Current configuration : 650 bytes
    !
    version 12.1
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname routerB
    !
    !
    !
    !
    !
    !
    memory-size iomem 25
    ip subnet-zero
    !
    !
    !
    !
    interface Serial0
    ip address 10.53.1.2 255.255.255.252
    encapsulation ppp
    no fair-queue
    !
    interface FastEthernet0
    ip address 10.3.1.1 255.255.0.0
    speed auto
    !
    router eigrp 2575
    redistribute static
    network 10.0.0.0
    auto-summary
    no eigrp log-neighbor-changes
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.53.1.1
    no ip http server
    !
    !
    line con 0
    password test
    login
    transport input none
    line aux 0
    line vty 0 4
    password test
    login
    !
    no scheduler allocate
    end

    Basically my problem is this.

    From routerB lan i can ping the internet fine via ip. I cannot however
    ping routerA LAN or any computers on that LAN. How do i route into
    RouterA LAN so that the stuff on RouterB LAN can access the server /
    resources on RouterA LAN?

    It has to be pretty easy but i cant seem to get it. I have a bunch
    other locations via point to point that will be configured the same
    way and needing access to routerA LAN for DNS and server resources in
    the future.

    Im thinking this is a NAT Issue, but am not sure how to resolve it.
    Would i run the NAT at the pix or on my routerA? It would seem that
    my Router A would be the best choice.

    Any input would be apreciated.

    Thanks
     
    , Dec 5, 2004
    #1
    1. Advertising

  2. Toby Guest

    <> wrote in message
    news:...
    >I have 2 configs here
    >
    > RouterA
    >
    > Building configuration...
    >
    > Current configuration : 568 bytes
    > !
    > version 12.2
    > service config
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname routerA
    > !
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > interface FastEthernet0
    > ip address 192.168.1.252 255.255.255.0
    > speed auto
    > !
    > interface Serial0
    > ip address 10.53.1.1 255.255.255.252
    > encapsulation ppp
    > !
    > router eigrp 2575
    > redistribute static
    > network 10.0.0.0
    > auto-summary
    > no eigrp log-neighbor-changes
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.1.254
    > no ip http server
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > !
    > no scheduler allocate
    > end
    >
    > This network has 192.168.1.0 lan behind the ethernet port and a
    > gateway (PIX) of 192.168.1.254
    >
    > Now for the next config:
    > RouterB
    >
    > Building configuration...
    >
    > Current configuration : 650 bytes
    > !
    > version 12.1
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname routerB
    > !
    > !
    > !
    > !
    > !
    > !
    > memory-size iomem 25
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > interface Serial0
    > ip address 10.53.1.2 255.255.255.252
    > encapsulation ppp
    > no fair-queue
    > !
    > interface FastEthernet0
    > ip address 10.3.1.1 255.255.0.0
    > speed auto
    > !
    > router eigrp 2575
    > redistribute static
    > network 10.0.0.0
    > auto-summary
    > no eigrp log-neighbor-changes
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 10.53.1.1
    > no ip http server
    > !
    > !
    > line con 0
    > password test
    > login
    > transport input none
    > line aux 0
    > line vty 0 4
    > password test
    > login
    > !
    > no scheduler allocate
    > end
    >
    > Basically my problem is this.
    >
    > From routerB lan i can ping the internet fine via ip. I cannot however
    > ping routerA LAN or any computers on that LAN. How do i route into
    > RouterA LAN so that the stuff on RouterB LAN can access the server /
    > resources on RouterA LAN?
    >
    > It has to be pretty easy but i cant seem to get it. I have a bunch
    > other locations via point to point that will be configured the same
    > way and needing access to routerA LAN for DNS and server resources in
    > the future.
    >
    > Im thinking this is a NAT Issue, but am not sure how to resolve it.
    > Would i run the NAT at the pix or on my routerA? It would seem that
    > my Router A would be the best choice.
    >
    > Any input would be apreciated.
    >
    > Thanks


    The LAN on Router A is a 192.168.1.0/24 bit address and the only way to
    reach it from Router B is either by a static route or EIGRP.
    Your EIGRP network will not advertise this judging from your current config.
    Try adding the Network statement for 192.168.1.0 on router A. Also if you
    have omited this because you don't want EIGRP to advertise routes over the
    Ethernet port use the passive interface FA0 within your router EIGRP portion
    of the config.

    Regards

    Toby
     
    Toby, Dec 5, 2004
    #2
    1. Advertising

  3. Toby Guest

    <> wrote in message
    news:...
    >I have 2 configs here
    >
    > RouterA
    >
    > Building configuration...
    >
    > Current configuration : 568 bytes
    > !
    > version 12.2
    > service config
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname routerA
    > !
    > !
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > interface FastEthernet0
    > ip address 192.168.1.252 255.255.255.0
    > speed auto
    > !
    > interface Serial0
    > ip address 10.53.1.1 255.255.255.252
    > encapsulation ppp
    > !
    > router eigrp 2575
    > redistribute static
    > network 10.0.0.0
    > auto-summary
    > no eigrp log-neighbor-changes
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 192.168.1.254
    > no ip http server
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > !
    > no scheduler allocate
    > end
    >
    > This network has 192.168.1.0 lan behind the ethernet port and a
    > gateway (PIX) of 192.168.1.254
    >
    > Now for the next config:
    > RouterB
    >
    > Building configuration...
    >
    > Current configuration : 650 bytes
    > !
    > version 12.1
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname routerB
    > !
    > !
    > !
    > !
    > !
    > !
    > memory-size iomem 25
    > ip subnet-zero
    > !
    > !
    > !
    > !
    > interface Serial0
    > ip address 10.53.1.2 255.255.255.252
    > encapsulation ppp
    > no fair-queue
    > !
    > interface FastEthernet0
    > ip address 10.3.1.1 255.255.0.0
    > speed auto
    > !
    > router eigrp 2575
    > redistribute static
    > network 10.0.0.0
    > auto-summary
    > no eigrp log-neighbor-changes
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 10.53.1.1
    > no ip http server
    > !
    > !
    > line con 0
    > password test
    > login
    > transport input none
    > line aux 0
    > line vty 0 4
    > password test
    > login
    > !
    > no scheduler allocate
    > end
    >
    > Basically my problem is this.
    >
    > From routerB lan i can ping the internet fine via ip. I cannot however
    > ping routerA LAN or any computers on that LAN. How do i route into
    > RouterA LAN so that the stuff on RouterB LAN can access the server /
    > resources on RouterA LAN?
    >
    > It has to be pretty easy but i cant seem to get it. I have a bunch
    > other locations via point to point that will be configured the same
    > way and needing access to routerA LAN for DNS and server resources in
    > the future.
    >
    > Im thinking this is a NAT Issue, but am not sure how to resolve it.
    > Would i run the NAT at the pix or on my routerA? It would seem that
    > my Router A would be the best choice.
    >
    > Any input would be apreciated.
    >
    > Thanks


    As for your other question. You should really do the NAT function on the PIX
    so that your LAN off router A is not in the DMZ.

    Toby
     
    Toby, Dec 5, 2004
    #3
  4. In article <>,
    wrote:

    > I have 2 configs here


    How many different threads are you going to start? Pick one thread and
    stick with it, please.

    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
     
    Barry Margolin, Dec 6, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. mgo
    Replies:
    4
    Views:
    767
  2. Jaime
    Replies:
    2
    Views:
    570
    Jaime
    Sep 20, 2003
  3. Jimmy Dean
    Replies:
    3
    Views:
    1,152
    Duane Arnold
    Jul 25, 2005
  4. HandyMan

    Basic routing question

    HandyMan, Jun 18, 2007, in forum: Cisco
    Replies:
    2
    Views:
    392
    HandyMan
    Jun 20, 2007
  5. Sharp Dressed Man

    TurboTax Basic vs. Taxcut Basic?

    Sharp Dressed Man, Jan 10, 2009, in forum: Computer Support
    Replies:
    1
    Views:
    684
    Sharp Dressed Man
    Jan 12, 2009
Loading...

Share This Page