Basic Routing Problem

Discussion in 'Computer Support' started by _Sid, Aug 26, 2003.

  1. _Sid

    _Sid Guest

    I have a Win2K workstation acting as a router with two NIC's - 10.1.1.163
    255.255.255.0 & 10.2.2.14 255.255.255.0

    Each of these NIC's is attached to a different hub.

    On the hub that router NIC 10.1.1.163 links to I have a Win2K workstation :-
    IP 10.1.1.59 255.255.255.0 default gateway 10.1.1.163.

    On the hub that router NIC 10.2.2.14 links to I have another Win2K
    workstaton:-
    IP 10.2.2.238 255.255.255.0 default gateway 10.2.2.14
    and a Redhat 8 box:-
    IP 10.2.2.237 255.255.255.0 gateway 10.2.2.14.

    From the workstation 10.1.1.59, I can ping both of the NIC's in the router
    machine, but neither of the PC's on the other side.

    Similarly from either 10.2.2.237 or 238 I can ping both the NIC's in the
    router machine, but not the PC on the other side.

    I seem to remember with NT4 acting as a two NIC'd router you had to set the
    NIC's properties to 'Enable IP Routing'. I can't seem to find where you
    enable this in Win2K and think this is why my router doesn't work properly?

    Any clues appreciated

    Obliged

    Sid
     
    _Sid, Aug 26, 2003
    #1
    1. Advertising

  2. _Sid

    why? Guest

    On Tue, 26 Aug 2003 18:30:43 +0000 (UTC), _Sid wrote:

    >I have a Win2K workstation acting as a router with two NIC's - 10.1.1.163
    >255.255.255.0 & 10.2.2.14 255.255.255.0
    >
    >Each of these NIC's is attached to a different hub.
    >

    <snip>

    >I seem to remember with NT4 acting as a two NIC'd router you had to set the
    >NIC's properties to 'Enable IP Routing'. I can't seem to find where you


    You remember right, I have not used the same thing in Win 2000 but have
    a look in the help for - Routing and Remote Access. Then again
    www.google.com

    >enable this in Win2K and think this is why my router doesn't work properly?


    Me
     
    why?, Aug 26, 2003
    #2
    1. Advertising

  3. _Sid

    MC Guest

    To enable IP Routing on a Win 2K Server, you have to do it via the registry.
    It's under

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip \Parameters

    Select

    IPEnableRouter: REG_DWORD: 0x0

    and then assign a value of 1


    Now, this may be a similar process for Win2k Pro- have a look.

    HTH







    "_Sid" <> wrote in message
    news:big90j$c0p$...
    > I have a Win2K workstation acting as a router with two NIC's - 10.1.1.163
    > 255.255.255.0 & 10.2.2.14 255.255.255.0
    >
    > Each of these NIC's is attached to a different hub.
    >
    > On the hub that router NIC 10.1.1.163 links to I have a Win2K workstation

    :-
    > IP 10.1.1.59 255.255.255.0 default gateway 10.1.1.163.
    >
    > On the hub that router NIC 10.2.2.14 links to I have another Win2K
    > workstaton:-
    > IP 10.2.2.238 255.255.255.0 default gateway 10.2.2.14
    > and a Redhat 8 box:-
    > IP 10.2.2.237 255.255.255.0 gateway 10.2.2.14.
    >
    > From the workstation 10.1.1.59, I can ping both of the NIC's in the router
    > machine, but neither of the PC's on the other side.
    >
    > Similarly from either 10.2.2.237 or 238 I can ping both the NIC's in the
    > router machine, but not the PC on the other side.
    >
    > I seem to remember with NT4 acting as a two NIC'd router you had to set

    the
    > NIC's properties to 'Enable IP Routing'. I can't seem to find where you
    > enable this in Win2K and think this is why my router doesn't work

    properly?
    >
    > Any clues appreciated
    >
    > Obliged
    >
    > Sid
    >
    >
     
    MC, Aug 26, 2003
    #3
  4. _Sid

    why? Guest

    X-No-Archive: Yes
    On Tue, 26 Aug 2003 20:17:37 GMT, MC wrote:

    >To enable IP Routing on a Win 2K Server, you have to do it via the registry.
    >It's under
    >
    >HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip \Parameters
    >
    >Select
    >
    >IPEnableRouter: REG_DWORD: 0x0
    >
    >and then assign a value of 1


    <snip>

    That is a very user friendly command, it's the best one yet.
    I thought there must be a GUI way to this, except there is not -
    http://www.wown.com/j_helmig/w2kprout.htm
    How daft can MS get? Well the answer is very.

    <snip>

    >"_Sid" <> wrote in message
    >news:big90j$c0p$...
    >> I have a Win2K workstation acting as a router with two NIC's - 10.1.1.163
    >> 255.255.255.0 & 10.2.2.14 255.255.255.0
    >>
    >> Each of these NIC's is attached to a different hub.
    >>
    >> On the hub that router NIC 10.1.1.163 links to I have a Win2K workstation

    >:-
    >> IP 10.1.1.59 255.255.255.0 default gateway 10.1.1.163.


    <snip>

    Me
     
    why?, Aug 26, 2003
    #4
  5. _Sid

    _Sid Guest

    excellent thanks that worked


    "MC" <> wrote in message
    news:BfP2b.5082$...
    > To enable IP Routing on a Win 2K Server, you have to do it via the

    registry.
    > It's under
    >
    > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip \Parameters
    >
    > Select
    >
    > IPEnableRouter: REG_DWORD: 0x0
    >
    > and then assign a value of 1
    >
    >
    > Now, this may be a similar process for Win2k Pro- have a look.
    >
    > HTH
    >
    >
    >
    >
    >
    >
    >
    > "_Sid" <> wrote in message
    > news:big90j$c0p$...
    > > I have a Win2K workstation acting as a router with two NIC's -

    10.1.1.163
    > > 255.255.255.0 & 10.2.2.14 255.255.255.0
    > >
    > > Each of these NIC's is attached to a different hub.
    > >
    > > On the hub that router NIC 10.1.1.163 links to I have a Win2K

    workstation
    > :-
    > > IP 10.1.1.59 255.255.255.0 default gateway 10.1.1.163.
    > >
    > > On the hub that router NIC 10.2.2.14 links to I have another Win2K
    > > workstaton:-
    > > IP 10.2.2.238 255.255.255.0 default gateway 10.2.2.14
    > > and a Redhat 8 box:-
    > > IP 10.2.2.237 255.255.255.0 gateway 10.2.2.14.
    > >
    > > From the workstation 10.1.1.59, I can ping both of the NIC's in the

    router
    > > machine, but neither of the PC's on the other side.
    > >
    > > Similarly from either 10.2.2.237 or 238 I can ping both the NIC's in the
    > > router machine, but not the PC on the other side.
    > >
    > > I seem to remember with NT4 acting as a two NIC'd router you had to set

    > the
    > > NIC's properties to 'Enable IP Routing'. I can't seem to find where you
    > > enable this in Win2K and think this is why my router doesn't work

    > properly?
    > >
    > > Any clues appreciated
    > >
    > > Obliged
    > >
    > > Sid
    > >
    > >

    >
    >
     
    _Sid, Aug 26, 2003
    #5
  6. _Sid

    MC Guest

    You're welcome. Another quality stuff by Microsoft!!


    "_Sid" <> wrote in message
    news:bigick$3rv$...
    > excellent thanks that worked
    >
    >
    > "MC" <> wrote in message
    > news:BfP2b.5082$...
    > > To enable IP Routing on a Win 2K Server, you have to do it via the

    > registry.
    > > It's under
    > >
    > > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip \Parameters
    > >
    > > Select
    > >
    > > IPEnableRouter: REG_DWORD: 0x0
    > >
    > > and then assign a value of 1
    > >
    > >
    > > Now, this may be a similar process for Win2k Pro- have a look.
    > >
    > > HTH
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > > "_Sid" <> wrote in message
    > > news:big90j$c0p$...
    > > > I have a Win2K workstation acting as a router with two NIC's -

    > 10.1.1.163
    > > > 255.255.255.0 & 10.2.2.14 255.255.255.0
    > > >
    > > > Each of these NIC's is attached to a different hub.
    > > >
    > > > On the hub that router NIC 10.1.1.163 links to I have a Win2K

    > workstation
    > > :-
    > > > IP 10.1.1.59 255.255.255.0 default gateway 10.1.1.163.
    > > >
    > > > On the hub that router NIC 10.2.2.14 links to I have another Win2K
    > > > workstaton:-
    > > > IP 10.2.2.238 255.255.255.0 default gateway 10.2.2.14
    > > > and a Redhat 8 box:-
    > > > IP 10.2.2.237 255.255.255.0 gateway 10.2.2.14.
    > > >
    > > > From the workstation 10.1.1.59, I can ping both of the NIC's in the

    > router
    > > > machine, but neither of the PC's on the other side.
    > > >
    > > > Similarly from either 10.2.2.237 or 238 I can ping both the NIC's in

    the
    > > > router machine, but not the PC on the other side.
    > > >
    > > > I seem to remember with NT4 acting as a two NIC'd router you had to

    set
    > > the
    > > > NIC's properties to 'Enable IP Routing'. I can't seem to find where

    you
    > > > enable this in Win2K and think this is why my router doesn't work

    > > properly?
    > > >
    > > > Any clues appreciated
    > > >
    > > > Obliged
    > > >
    > > > Sid
    > > >
    > > >

    > >
    > >

    >
    >
     
    MC, Aug 26, 2003
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. mgo
    Replies:
    4
    Views:
    775
  2. Stuart

    2611XM basic routing problem

    Stuart, Jan 23, 2004, in forum: Cisco
    Replies:
    6
    Views:
    738
    Stuart
    Jan 24, 2004
  3. Jaime
    Replies:
    2
    Views:
    585
    Jaime
    Sep 20, 2003
  4. Jimmy Dean
    Replies:
    3
    Views:
    1,200
    Duane Arnold
    Jul 25, 2005
  5. Hopper
    Replies:
    1
    Views:
    2,227
    slaquer
    Jan 6, 2009
Loading...

Share This Page