Basic Routing Problem (1 router 2 subnets)

Discussion in 'Cisco' started by Hopper, Jan 5, 2009.

  1. Hopper

    Hopper

    Joined:
    Jan 5, 2009
    Messages:
    1
    I know this has been posted before but it didnt help me:

    I am trying to route between the subnets 71.87.16.x /30 and 71.87.16.x /28 on the same router, a cisco 1841.


    the fiber box is set to 71.87.16.101 /30 and interface fa0/0 of the router is set to 71.87.16.102 /30, and the router's default gateway is set to 71.87.16.101

    Fa0/1 of the router is set to 71.87.16.209 /28

    the host is set to 71.87.16.210 /28 with a gateway of 71.87.16.209

    the problem: From the outside interface of the router (FA0/0) i can ping though the fiber box and get to internet successfully pinging a site like google and get a response, but, on the inside interface (FA0/1) and Host i can ping the fiberbox, but not the internet (or im not getting the reply)

    Any help woould be appreciated: (ip routing is enabled)

    [Fiber box] - .101 /30
    =
    =
    =
    [Router] - (FA0/0 .102 /30) (FA0/1 .209 /28) (.101 gateway)
    =
    =
    =
    [Host] - Static Ip .210 /28 gateway .209

    Configuration:
    show run
    Building configuration...

    Current configuration : 704 bytes
    !
    version 12.4
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    ip cef
    !
    !
    interface Loopback0
    no ip address
    !
    interface FastEthernet0/0
    ip address 71.87.16.102 255.255.255.252
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 71.87.16.209 255.255.255.240
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    no ip address
    shutdown
    !
    ip default-gateway 71.87.16.101
    ip route 0.0.0.0 0.0.0.0 71.87.16.101
    no ip http server
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    scheduler allocate 20000 1000
    end
     
    Hopper, Jan 5, 2009
    #1
    1. Advertising

  2. Hopper

    slaquer

    Joined:
    Jan 3, 2009
    Messages:
    9
    You don't need both a default route (the 0.0.0.0) and the ip default-gateway configs. They do the same thing. That's probably not the problem though...

    I would like to see a sh ip route output. Does it show the two subnets correctly pointing to the correct gateways?

    Most definately sounds like a route issue to me.

    Can the two internal subnets ping each other? I know you can ping the fiber box, but can you ping hosts on the other subnet?
     
    slaquer, Jan 6, 2009
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. AlexC
    Replies:
    10
    Views:
    7,606
    reena_ahuja24
    Feb 28, 2009
  2. Shawn
    Replies:
    0
    Views:
    1,149
    Shawn
    May 14, 2004
  3. Jonathan
    Replies:
    13
    Views:
    8,544
    Jonathan
    Jul 26, 2004
  4. Fred
    Replies:
    0
    Views:
    1,388
  5. jfalken@socket.net
    Replies:
    4
    Views:
    1,460
    Trendkill
    Aug 29, 2008
Loading...

Share This Page